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1.0 Class Attendance in MyEducation BC 

Class attendance and Daily attendance are separate functions in MyEducation BC.  An entry 
can be created for individual Classes, and one entry created for a Daily attendance value on a 
given day.  

If a School creates a Daily value for a student in addition to class values, school Preferences 
settings will determine the way a Daily attendance value is created. A Daily value can be 
created by the posting of one or more Class values, or through the Class to Daily Attendance 
Procedure. 

With Class based attendance, MyEducation BC is set up to record one attendance record per 
student per class.   

• The class attendance record stores the date, the code and whether the late, dismissed, 
or excused checkboxes were selected. 

• The arrival and departure times. 

Class Attendance in MyEducation BC can be recorded through the School Office view or 
through the Teacher Staff view: 

• School view > Attendance > Class Office 

• Staff view > Class Attendance 

The School Setup and Staff Class Attendance input vary slightly depending on the method of 
Class Attendance selected.  Detailed instructions for Staff view attendance are found in the Staff 
View Setup and Navigation guide.  

The School Class Office entry is done in the same way regardless of the method of class 
attendance selected.  

Schools must be setup with an active schedule and days assigned if using course sections in 
the calendar. See the School Setup guide for details.  
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2.0 Class Attendance Options 

Class attendance will track which individual classes or course sections your students attended. 
Class attendance can be taken:  

• Once a day by an identified course section 

• Twice a day by identified course section(s)  

• In each course section scheduled in a day  

o Can be taken twice in a course section that is scheduled twice on the same day 

Class attendance can create a Daily attendance value for a student based on School 
Preference settings:  

• The initial posting of one selected period class attendance creates a daily attendance 
value for the student.  After the initial class posting, subsequent changes to the daily 
value can be adjusted by the office as needed.   

• The initial posting of two selected period class attendances creates a daily attendance 
value.  Each period accounts for a partial amount of the day.  After the initial class 
postings, subsequent changes to the daily value can be adjusted by the office as 
needed.   

• Class to Daily attendance procedure creates a daily value for a student based on the 
class value entered in each scheduled class if one is not created through a class 
posting. The daily value for the student will be visible on the following day.  

o This procedure will increase the daily value based on class attendance; it will not 
reduce the daily value based on class attendance.  Reduction to a daily value 
can be adjusted by the office as needed.  

Attendance setup for your school is done from the School top tab > Setup side tab > 
Preferences leaf.  Both the Daily Attendance and Period Attendance dropdowns will have 
preference settings for class attendance. 
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3.0 No Daily Attendance Value created from Class Posting 

 Daily Attendance Preferences 

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic 

• These two settings must be set:Classroom Input Type to Homeroom - This setting 

prevents a daily value from being created by a period class attendance posting. 

• Show Daily Side tab in Staff view to unchecked - Daily values and Class values are 

separate, this should only be checked in schools where the teacher is creating a daily 

value based on students in the homeroom. If the Daily side tab is visible in Staff view a 

Daily value can be posted for the students listed, overwriting any entry made by the 

office.  

 

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > 
Advanced 

For details on Weekend Attendance, see the School Setup guide 

Second Daily Attendance: 

• Second daily attendance – Unchecked 

• AM portion absent – Blank 

• Classroom input type – Homeroom  

• Classroom input period – N/A 

Attendance Activity Tracking: District settings determine if a school can edit these fields 

• Attendance Activity Tracking – Unchecked – not for use in BC 

• Restrict [edit] link in staff view (this setting applies to both class and daily attendance) 
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• Checked: Presents a view only popup in Staff > Attendance 

• Unchecked: Presents an editable popup in Staff > Attendance 

 

 

If the School Office is entering a Daily attendance value, the following Daily Attendance 
preferences can also be set. The Advanced Tab allows for the selection of Weekend 
Attendance if applicable (See School Setup guide for details) and Second Daily Attendance 
settings which are not applicable to this attendance type.   

• Classroom Input Period:  N/A  

• Recent attendance history cut-off – the number of days of attendance 

history shown in the Recent Attendance filter. 

• Allow daily attendance for past dates – N/A  

• Previous day limit – N/A  

• Daily Roster Input Buttons – select the number and type of buttons visible 

in the School > Attendance > Daily Roster side tab if used. 

• Daily Office Input Buttons – select the number and type of buttons visible 

in the School > Attendance > Daily office side tab if used.  

• Staff View Input Buttons – N/A 
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 Class Attendance Preferences 

School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic 

• Post mode - determines if and how many times a teacher may post class attendance 
information to a student record 

o No Post – Attendance will be recorded in the Staff view but will NOT be recorded 
in a student record 

o Post – Attendance can be posted to a student Class attendance record multiple 
times, overwriting the last entry.   

o Post Once – Attendance can be posted to a student Class attendance record 
once, changes made after the initial post will not change the student Class 
attendance record.  

• Allow Date Change – Controls the Date Navigation setting in the Staff view > 
Attendance 

o Checked – Allows date change and attendance adjustment in Staff view (based 
on post mode setting) 

o Unchecked – Changes to Class attendance for previous dates is done only in 
the office via School view 

• Track Class Attendance by Period - Check if the school has double blocked periods 
and would like an attendance record posted for both periods. 

• Display comment column 

o Teachers can enter comments directly on Class Attendance input page for their 
use. 

o For the Comment column to appear, the school must first enable the Display 
comment column preference. 

 

Class Attendance > Advanced tab – N/A 



 

Class Attendance Setup and Management v1.10 Page 9 

 Class to Daily Procedure 

The Class to Daily Procedure can be run for schools taking Class based attendance and not 
creating a Daily value.  

This procedure can be set up to run nightly and will create a Daily Attendance value based on 
the classes absent divided by the total classes scheduled for the day.  The Daily Attendance 
value will be visible the following day.  This procedure will increase the daily value based on 
class attendance; it will not reduce the daily value based on class attendance.  Reduction to a 
daily value can be adjusted by the office as needed. 

The Class to Daily Nightly process only runs for the current date. If you want to capture 
historical attendance Class to Daily entries, you must manually run the procedure. 

 

School view > School top tab > Setup side tab > Details leaf 
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 Staff View Attendance – No Daily Value Created From Class 

In Staff view attendance is accessed through the Today’s Classes widget or the Attendance top 
tab.  

 

 

Class Attendance is taken for all course sections by selecting the corresponding button (A or L 
in the screenshot) on a given date and posted to the student record using the Post button. The 
Post button is active or greyed out depending on the school settings for Post Mode in the Class 
Attendance preferences screen.  No Daily Attendance value is created by the Staff view class 
posting in any course section.   
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4.0 Daily Attendance Value created from one Class Posting 

A Daily Attendance value is created from the initial posting of one selected period Class 
attendance.  Changes to the Daily value after the initial posting can be made through School or 
Staff view depending on preference settings. 

 Daily Attendance Preferences 

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic 

These three settings must be set: 

• Classroom Input Type to Period - This setting allows a daily value to be created by a 

period class attendance posting. 

• Classroom Input Period: Select the period of the day that will create the Daily 

attendance value when the class attendance is posted.  

• Show Daily Side tab in Staff view to unchecked – It is recommended that this only be 

checked in schools where the teacher is creating a daily value based on students in the 

homeroom, not a course section. If the Daily side tab is visible in Staff view a Daily value 

can be posted for the students listed in the staff homeroom, overwriting any entry made 

by the office.  

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > 
Advanced 

For details on Weekend Attendance, see the School Setup guide 

Second Daily Attendance: 

• Second daily attendance – Unchecked 

• AM portion absent – Blank 

• Classroom input type – Homeroom  

• Classroom input period – N/A 

Attendance Activity Tracking: District settings determine if a school can edit these fields 

• Attendance Activity Tracking – Unchecked – not for use in BC 

• Restrict [edit] link in staff view (this setting applies to both class and daily 

attendance) 

o Checked: Presents a view only popup in Staff > Attendance 

o Unchecked: Presents an editable popup in Staff > Attendance 
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If the School Office is entering a Daily attendance value, the following Daily Attendance 
preferences can also be set. The Advanced Tab allows for the selection of Weekend 
Attendance if applicable (See School Setup guide for details) and Second Daily Attendance 
settings which are not applicable to this attendance type.   

• Recent attendance history cut-off – the number of days of attendance history shown in 

the Recent Attendance filter. 

• Allow daily attendance for past dates – N/A  

• Previous day limit – N/A  

• Daily Roster Input Buttons – select the number and type of buttons visible in the School 

> Attendance > Daily Roster side tab if used. 

• Daily Office Input Buttons – select the number and type of buttons visible in the School > 

Attendance > Daily office side tab if used.  

• Staff View Input Buttons – N/A 
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 Class Attendance Preferences 

The first posting of the Class Attendance for the period selected as the Classroom Input Period 
in Daily Attendance preferences will create the Daily Attendance value for the student. 
Subsequent postings (if allowed by school Post Mode preferences below) will update the Class 
attendance value, any changes required to the student Daily Attendance value will be done 
through the office School view.  

School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic 

• Post mode - Determines if and how many times a teacher may post class attendance 
information to a student record.   

o No Post – Attendance will be recorded in the Staff view but will NOT be recorded 
in a student record 

o Post – Attendance can be posted to a student Class attendance record multiple 
times, overwriting the last entry.   

o Post Once – Attendance can be posted to a student Class attendance record 
once, changes made after the initial post will not change the student Class 
attendance record.  

• Allow Date Change – Controls the Date Navigation setting in the Staff view > 
Attendance 

o Checked – Allows date change and attendance adjustment in Staff view (based 
on post mode setting) 

o Unchecked – Changes to Class attendance for previous dates is done only in 
the office via School view 

• Track Class Attendance by Period - Check if the school has double blocked periods 
and would like an attendance record posted for both periods. 

 

Class Attendance > Advanced tab – N/A 
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 Staff View Attendance – Daily Value Created from One Class 
Posting 

In Staff view attendance is accessed through the Today’s Classes widget or the Attendance top 
tab.  

 

 

Class Attendance for all course sections is taken by selecting the corresponding button (A or L 
in the screenshot) on a given date and posted to the student record using the Post button. The 
Post button is active or greyed out depending on the school settings for Post Mode in the Class 
Attendance preferences screen.   

The first posting by the teacher of the Class Attendance for the period creates the Daily 
Attendance value for the student. Subsequent Class Attendance postings for the section (if 
allowed by school Post Mode preferences) will update the Class attendance value, not the 
student Daily Attendance value.  Any changes required to the student Daily Attendance value 
will be done through the office School view. 
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5.0 Daily Attendance Value Created from Two Class 
Postings 

A Daily Attendance value is created from the posting of two selected period Class attendances, 
typically a morning and an afternoon class.  Changes to the Daily value after the initial posting 
can be made through School or Staff view depending on preference settings. 

 Daily Attendance Preferences 

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic 

These settings must be set: 

• Classroom Input Type to Period - This setting allows a daily value to be created by a period 

class attendance posting. 

• Classroom Input Period: Select the period of the day that will create the first or morning 

portion of the student Daily attendance value when the class attendance is posted.  

• Show Daily Side tab in Staff view to unchecked – It is recommended that this only be 

checked in schools where the teacher is creating a daily value based on students in the 

homeroom, not a course section. If the Daily side tab is visible in Staff view a Daily value can be 

posted for the students listed in the staff homeroom, overwriting any entry made by the office.  

 

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > 
Advanced  

• Second daily attendance: checked – This setting allows a portion of the 

daily attendance to be created separately from the first posting 

• AM portion absent – Enter the portion of the day that the morning 

absence counts for (.5 for half of the day) 
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• Classroom input type – Period - This setting allows a daily value to be 

created by a period class attendance posting 

• Classroom input period - Select the period of the day that will create the 

second or afternoon portion of the student Daily attendance value when 

the class attendance is posted.  

Attendance Activity Tracking: District settings determine if a school can edit these fields 

• Attendance Activity Tracking – Unchecked – not for use in BC 

• Restrict [edit] link in staff view (this setting applies to both class and 

daily attendance) 

o Checked: Presents a view only popup in Staff > Attendance 

o Unchecked: Presents an editable popup in Staff > Attendance 

 

If the School Office is entering a Daily attendance value, the following Daily Attendance 
preferences can also be set. The Advanced Tab allows for the selection of Weekend 
Attendance if applicable (See School Setup guide for details).   

• Recent attendance history cut-off – the number of days of attendance history shown in 

the Recent Attendance filter. 

• Allow daily attendance for past dates – N/A  

• Previous day limit – N/A  

• Daily Roster Input Buttons – select the number and type of buttons visible in the School 

> Attendance > Daily Roster side tab if used. 

• Daily Office Input Buttons – select the number and type of buttons visible in the School > 

Attendance > Daily office side tab if used.  

• Staff View Input Buttons – N/A 
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 Class Attendance Preferences 

The first posting of Class Attendance for the periods set as the Classroom Input Periods 
together will create a single Daily Attendance value for the student. Subsequent postings (if 
allowed by school Post Mode preferences below) will update the Class attendance value, any 
changes required to the student Daily Attendance value will be done through the office School 
view.  

School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic 

• Post mode - Determines if and how many times a teacher may post class attendance 
information to a student record.   

o No Post – Attendance will be recorded in the Staff view but will NOT be recorded 
in a student record 

o Post – Attendance can be posted to a student Class attendance record multiple 
times, overwriting the last entry.   

o Post Once – Attendance can be posted to a student Class attendance record 
once changes made after the initial post will not change the student Class 
attendance record.  

• Allow Date Change – Controls the Date Navigation setting in the Staff view > 
Attendance 

o Checked – Allows date change and attendance adjustment in Staff view (based 
on post mode setting) 

o Unchecked – Changes to Class attendance for previous dates is done only in 
the office via School view 

• Track Class Attendance by Period - Check if the school has double blocked periods 
and would like an attendance record posted for both periods. 

 

Class Attendance > Advanced tab – N/A 
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 Staff View Attendance – Daily Value Created from Two Class 
Postings 

In Staff view attendance is accessed through the Today’s Classes widget or the Attendance top 
tab.  

 

 

Class Attendance for all course sections is taken by selecting the corresponding button (A or L 
in the screenshot) on a given date and posted to the student record using the Post button. The 
Post button is active or greyed out depending on the school settings for Post Mode in the Class 
Attendance preferences screen.   

The first posting of Class Attendance by the teacher in the designated periods creates the 
Daily Attendance value for the student. The periods are defined by the preference setting in 
Daily Attendance Preferences > Basic and Advanced. Subsequent Class Attendance postings 
for the course section (if allowed by school Post Mode preferences) will update the Class 
attendance value, not the student Daily Attendance value.  Any changes required to the student 
Daily Attendance value will be done through the office School view. 
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6.0 Taking Attendance – Office 

Each side tab in the Attendance top tab has different action items under the Options menu and 
different reports available in the Reports menu.  

 Creating or Editing a Student Class Attendance Value 

6.1.1 Class Office Side Tab 

School > Attendance > Class Office 

Student Daily Attendance values and Class or Period Attendance values are separate. This 
screen lists all the students in the school and has one column for the Daily code and columns 
for any scheduled periods in your school on the date selected on the top right of the screen.  
Records created for either the Daily or Class attendance values for a student will display in the 
appropriate columns.   

Class attendance entered here will be visible in the Staff view, teachers can edit the record if 
necessary, prior to posting the Staff view attendance. 

Note: Rotating your schedule in the Build View as a part of the Schedule Build process will allow 
this screen to list the course sections in the order they occur on the date selected.  Using the 
Bell Schedule to rotate the school schedule presents this screen in a flat schedule order and the 
user will need to determine which order the periods occur on the date selected.  See Rotations, 
Pattern Library and Pattern Sets reference guide for further details. 

System Filters on the Class Office side tab include:  

• All Records: This contains every student in the school, regardless of whether they have 

an existing attendance record or not.  

Filters to narrow the scope of the list: 

• Attendance Activity: Students with any attendance records assigned to them on the 

given date, regardless of whether they are Daily Attendance or Class Attendance 

records  

• Truant List:  Students that have Absence records assigned in one or more classes 

during the day, but the student Daily Attendance value is empty  

• Course Section = ?: Students scheduled into the selected course section  

• Attendance Discrepancy: Students with a Daily Attendance value of Absent, but have 

no Absent records for any of their classes that day  

• Grade Level =?: Students in a selected grade 

• Group =?: Students in a specified group 

• Homeroom =? Students in a selected homeroom  

• Program =? Students in a specified program 
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6.1.1.1 Attendance Discrepancy - Daily Attendance To Class Attendance Procedure 

School View > Attendance top tab > Class Office side tab > filter = Attendance 
Discrepancy > Options > Attendance Discrepancy - Daily Attendance To Class 
Attendance 

The purpose of this procedure is to push attendance records from the Daily Code column to the 
Period Columns in the Class Office side tab to every scheduled period for a student on a 
specific day avoiding the need to use the chevrons and doing the process one at a time. 

• eliminates the need to push the values out one by one using the chevrons.   

• works only with the Attendance Discrepancy filter.  

• gives users the option of running the procedure from anywhere in the Class Office side 

tab but will only run for records identified in the Attendance Discrepancy filter. 
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Options > Attendance Discrepancy - Daily Attendance To Class Attendance 

 

Selecting Preview produces a pop up providing information about the procedure execution.  

 

Run the Procedure: 

• Refresh the screen (reload the Attendance Discrepancy filter) 
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6.1.2 Taking Class Attendance in the Class Office Side Tab 

If a Daily Attendance record exists, the values can be “pushed out” to all the classes.  In the 
Daily Code column, there will be a Daily Attendance value, followed by two “greater than” 
symbols, like so: >>. Click that symbol and it will copy the A-E code to each of the student’s 
classes. This value will push out to all course sections scheduled that day.  If the absence is for 
a portion of the day only, adjust the class attendance by period as needed.  

When the teacher logs in, it will show that student has been marked absent for that section. 

 

Class Attendance can also be entered for an individual by clicking on the ellipsis in the 
appropriate period column, bringing up a popup. An attendance code and reason can be 
entered for that class only. 
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Any changes you make in this screen will be visible to the teacher when they go to their Staff 
view > Attendance for this course section. 
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6.1.3 Entering Class Attendance for Multiple Students at the Same Time – Two 
process choices 

6.1.3.1 Process 1 - Class Attendance > Multi Add Button  

School users can enter class attendance for several students, for many periods and dates, at 
once. Use the Multi-Add button on the Class Attendance Office Input page to enter the same 
attendance code for several students at once by section, homeroom, group, query, snapshot, or 
selection. This is not a BC Specific process. 

School View > Attendance Top Tab > Class Office Side Tab > Multi Add Button 

 

To enter attendance for several students at a time on the Class Attendance Office Input page: 

• Click Multi-Add Buttton - The Multi-Add Attendance pop-up appears. 

 

 

 

 

 

Class Office Multi-Add Button pop-up 
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6.1.3.2 Students 

Select Students - Section, Homeroom, Group, Query, Snapshot, or Selection.  

Note: If you select Query or Snapshot, the queries and snapshots available are the 
saved queries and snapshots on the Student tab. 

In the pick list, select the section, homeroom, group, query, snapshot, or selection containing 
the students you want to enter the same attendance code for, and then click OK. Review the 
Selected students value to ensure that number matches your expectations. 

6.1.3.3 Duplicate Records 

To determine what you want the system to do if students you include already have an 
attendance record for this date, select Skip or Replace.  

Note: Skip is the default. If a student has an attendance record because, for example, the 
parent called the school to report their absence, then MyEducation BC will skip that student. 
If you select Replace, MyEducation BC overwrites the existing record. 

6.1.3.4 Date 

To enter this attendance record for the selected students for multiple dates, click Multiple Dates. 
The Multi-Add Attendance pop-up displays Start date and End date fields for you to populate. 

In the pop-up, enter the attendance information that applies to all the selected students.  

6.1.3.5 Other Code and Reason Fields 

At the Other code and Reason fields, you can provide an explanation for the absence, such as a 
field trip. Enter any additional information for the records in the Comment field. 

6.1.3.6 Action Items 

Do one of the following: 

Click Preview to view the student class attendance records and, when appropriate, daily 
attendance records that will be created. Then, click Cancel or Save to proceed. 

Click Save to close the pop-up. The attendance records for the students you selected 
appear on the Class Attendance Office Input page. 

Note: If your school has set the Daily Attendance preference Classroom input type to Period, 
then the corresponding daily attendance records will be created. 
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6.1.3.7 Preview Screen 
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6.1.3.8 Process 2 - BC Multi-Add Class Attendance 

School View > Attendance top tab > Class Office side tab > Options > BC Multi-Add Class 
Attendance 

School users can enter class attendance for several students, for many periods and dates, at 
once.  BC Multi-Add Class Attendance was created for BC. A confirmation pop-up will appear 
indicating how many records were updated. 

 

Students to Include – select the students  

Student IDs – opens the Student IDs entry box for entry of pupil numbers 

Current Selection – uses the Current Selection of students on the Class Office Screen. Filter to 
the group of students needed before choosing BC Multi-Add Class Attendance 

Start and End Dates – defaults to the current date, enter the correct date or range of dates for 
the attendance record entry 

Select period(s) – select a single or multiple periods from the picklist 

Attendance code – The code determines the type of Daily Attendance record created, select 
the appropriate code for: 

A – Absent  

AE – Absent Excused  

L - Late 

LE – Late Excused 

AUTH – Authorized 

D – Early Dismissal 
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Time In - available for entry when Attendance code of L - Late or LE - Late Excused is selected. 
Time can be entered as a numeric and will be automatically formatted on the student record - 
HH:MM AM/PM. (10:15 AM) 

Time Out – available for entry when Attendance code of D – Early Dismissal is selected. Time 
can be entered as a numeric and will be automatically formatted on the student record - HH:MM 
AM/PM. (10:15 AM) 

Attendance Reason – select the appropriate Attendance Reason from the picklist per school or 
district policy 

Duplicated Records - provides options for how the system handles a record if one already 
exists for a student on that date. 

Skip – will not overwrite the existing class attendance record 

Replace – will overwrite the existing class attendance record with the new 
information 

Click Run to record these absences. A confirmation pop-up will appear indicating how many 
records were updated. 
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6.1.4 Modifying Class Attendance in the Class Office Side Tab 

Select the date on the top right of the screen and click the blue, hyperlinked Daily Attendance 
record or Class Attendance record to be modified.  Change, add or remove any information as 
required for accuracy, or delete the entire record using Options > Delete.  The Arrivals and 
Departures section can be edited by clicking into the blue hyperlinked details of the entry or 
using the Add or Delete buttons. 
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6.1.5 New Class Roster Side Tab 

This new side tab will allow the school user to post daily, and class attendance based on the 
school settings.  

If the school is set with classroom input type “Homeroom” in preferences, the class attendance 
will be posted from the Class Roster screen. 

If the school is set with classroom input type “Period” in preferences, there will be an option to 
post both Daily and Class attendance from the Class Roster screen. Regardless of the option 
selected, class attendance will be posted respectively. 

 

School View> Attendance (TT)> Class Roster (ST)> Select Course> Take Attendance> Click 
Post button 
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6.1.6 Secondary School Management 

Secondary School Management handles how your school works with Cross-Enrolled students. 
These settings will allow students to show in your All Active Students and All Students filters. 
They also control which school has the ability to create or own a Daily Attendance record. 

School > Setup > Preferences > Secondary School Management  

 

• Secondary Students 

o Checked - will include students with secondary associations to your school in the 
Active Students and related filters along with the student’s primary to your 
school.  This is the recommended setting in BC for full functionality. 

o Unchecked – will not include students with secondary associations to your 
school in the Active Students and related filters.  Secondary students will show in 
All Students. 

• Secondary School Management - pull-down menu determines which school can take 
and manage Daily Attendance.  

o None – Only the Primary School can create and manage the Daily Attendance 
record.  

o Sole – Only the Secondary school can create and manage the Daily Attendance 
record.  

o Shared – Either the Primary or any of the student’s Secondary schools can 
create the Daily record; however, once a record is created on a day only the 
school that created it can modify it at any point.  

 

 

  

Note: This pull-down menu ONLY affects Daily Attendance.  Class attendance for any course 
section can be edited by any one of the students Primary or Secondary schools. 
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6.1.7 Positive Attendance in individual sections 

Positive Attendance is Class Attendance where a student is defaulted to Absent and is marked 
Present if in attendance.  

School view > School top tab > Setup > Preferences > Class Attendance > Advanced 

• Positive attendance in all classes – unchecked 

Set the number and type of attendance input buttons available in the staff view 

  

School > Schedule > Master > Sections 

Add Positive Attendance to your field set: 

  

On the Manage Field Sets menu, highlight a field set you wish to use, and either edit that 
field set, or else make a copy and edit the copy 

 

In the Schedule Master table, highlight Positive Attendance and click the Add button. 
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Select the Field Set and Options > Modify List 

Check the sections using Positive Attendance and check the green save checkbox at the 
top of the column. 
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7.0 Security Roles for Taking Attendance 

To take Attendance, the user will require a security role with Create, Read, Update and Delete 
permissions on the following tables:  

• Daily attendance requires this access Student Attendance table 

• Class Attendance requires this access to the Student Class Attendance table 

School-level staff using the Staff view to take attendance will also require:  

• Create permission on the Gradebook Access Grant table 

• Create permission, and Gradebook Administrator Access permission on the 
Organization table   

Attendance permissions have already been given to the following Baseline Security Roles: 

• Clerical – School Admin Assistant 

• Clerical – SIS Admin 

• School Administrator 

• District Support (Help Desk/Level 1) 

• Teacher (Staff view for all school types) 
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8.0 Attendance Codes 

Student Attendance codes indicate what type of Attendance Record is created for the student.  
These six system codes, combined with optional additional settings, define the type of 
attendance record.  A Reason code may be assigned to indicate why a student was given the 
attendance record per school or district policy. There are several Enterprise level Reason 
Codes outlined in Section 8.1 that are available for District and School users. 

• A (Absent) – Absent Excused or Absent Unexcused 

o Excused – check the excused checkbox or use the A-E dropdown if available  

o Unexcused – leave the checkbox unchecked 

• L (Late) – Late Excused or Late Unexcused 

o Excused – check the Excused checkbox  

o Unexcused – leave the Excused checkbox unchecked 

o Time In – place to record the time the student arrived (per school or district 

policy) defaults to the current time, edit as appropriate 

• D (Dismissal) – Dismissal Excused and Dismissal Unexcused 

o Excused – check the Excused checkbox  

o Unexcused – leave the Excused checkbox unchecked 

o Time Out – place to record the time the student left (per school or district policy) 

defaults to the current time, edit as appropriate  

• AUTH (Authorized) –  

o Absent? – determines if the AUTH code day is counted as an absence for the 

student in summary counts 

▪ Checked will count as an absence for the student 

▪ Unchecked will not count as an absence for the student 

• ISS (In School Suspension) – can be applied as a standard attendance entry and is 

automatically assigned as ISS – Excused to a student given an In School Suspension 

with a date range in the Conduct module.  The record can be edited to uncheck the 

Excused checkbox per school or district policy.  See the Conduct Management guide for 

details. 

• OSS (Out of School Suspension) can be applied as a standard attendance entry and 

is automatically assigned as OSS – Excused to a student given an Out of School 

Suspension with a date range in the Conduct module.  The record can be edited to 

uncheck the Excused checkbox per school or district policy.  See the Conduct 

Management guide for details. 
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 Attendance Reason Codes 

ParentGuardianExcuse 

Illness 

Vacation 

Appointment 

Alternate Program 

Cultural Activity 

Emergency Closure 

Field Trip 

In School Activity 

School Authorized 

School Counsellor 

Principal / VP 

Suspension – In 

Suspension – Out 

Team Activity 

Transport/Bus Issue 

Weather 

Work Experience 
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9.0 Attendance Reports 

 Class Attendance Reports  

School > Attendance > Class Office side tabs 

9.1.1 BC Class Attendance Call Sheet 

 A BC report listing students with an Absent (unexcused) attendance record entered on that day, 
report includes: Name, Grade level, Homeroom, Gender, Attendance Code, and the Name and 
Phone numbers of the two student contacts with highest priority 

o Date 

o Sort results by – select Name, Grade Level or Homeroom from the dropdown 

list 

o Format – select the format to print 

• BC Class Attendance Post Verification – a BC report advising when and if Class 

attendance was posted by a staff user on the selected date. The report can be run for a 

selected course section or for a selected teacher. 

o Start and End Dates - enter the range of dates to include on the report  

o Select class – select a course section from the picklist 

o Select teacher – select a teacher from the picklist 

o Show non-posts only  

▪ Check - to only show classes where attendance was not posted 

▪ Uncheck - to show all classes and if they were posted or not 

o Sort results by – Name or Time posted 

o Format – select the format to print 
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Field Name  Description  

ID This field displays the Staff ID 

Name This is field displays the Staff Name 

Homeroom This displays the staff homeroom number 

Course Description  This field displays the course description  

Course # This field displays the course code with section 

Date and Time This field displays attendance posted date and time  

Post Count This field displays attendance post count by the teacher 

against a course section   

 

• BC Class Attendance Post History – a BC report providing a historical record of 

attendance postings by course section or by teacher 

o Start and End Dates - enter the range of dates to include on the report  

o Select class – select a course section from the picklist 

o Select teacher – select a teacher from the picklist 

o Sort Results by – Date, Post Count or Period 

o Format – select the format to print 

• BC Homeroom List w. Grid – a BC report listing students in a course section with 

fillable column headers in a grid format 

o Column Labels – enter the information to print in the Column Headers 

o Sections to include – select All or select a Term Code, Course Number, 

Section, Schedule Expression or Teacher.  

o Sort results by - select Course or Teacher 

o Format – select the format to print 
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9.1.2 BC Principal’s Attendance Report by Class  

A BC reporting tool allowing schools to review and analyze student Class attendance using a 
parameter form with multiple criteria. The tool will return a list of students that meet the specified 
threshold. If the criteria are to include Absences greater than or equal to 3, the report will 
include students that have 3 or more absences per section but will return a complete listing of 
the student’s attendance in their other sections. 

o Start and End Dates – enter the range of dates to include on the report 

o Students to include – select All, Current Selection or select a YOG, Snapshot, 

Course Section, Combined Classes ID, Grade or Student Program 

o Criteria – enter and combine different criteria to build the report 

▪ Absence Code – use prefilled values or select a code from the dropdown 

▪ Reasons – select from the dropdown  

▪ Operator – select from the dropdown 

▪ Exclude Excused – check to exclude for each criteria line 

▪ Connector – select And or Or to combine criteria lines 

o Sort results by – Name, YOG or Homeroom 

o Group results by – Homeroom, Teacher, Course Section, Period, Combined 

Class Id, Student, Grade 

o Format – select the format to print 

9.1.3 BC Class Attendance Letter 

A BC reporting tool which generates student attendance history i.e. absences, late, dismissals, 
excused, unexcused and prepares letters to send to parents. The tool uses a parameter form 
with multiple selection criteria and returns a list of students that meet the specified threshold. If 
the criteria is to include minimum 3 Attendance (e.g. absence) records (by default the value is 
set to 5), the letter will include students that have 3 or more absences in total for all course 
sections along with other attendance information for the date range selected by the user. The 
letter allows you to use the standard text or customized text which is then printed on the letter.  

Note: The letter can also be printed in French. 

Parameters that can be selected include:  

First Tab – General 

o School – The school’s name will be displayed in a read-only mode 

o Start and End Dates – enter the range of dates to include on the report 

o Students to include – select All, Current Selection, Snapshot, YOG, or 

Homeroom 

o Search Value – enter the value for Snapshot, YOG, and Homeroom  

o Minimum attendance – Enter the number in this field. By default, set to 5 

o Attendance Type – select from the dropdown (Absence, Late, Dismissal, and 

ALL) 

o Excusal Type - select from the dropdown (Excused, Unexcused or Both) 

o Attendance Reason - select from the dropdown 

o Sort results by – Usual Last Name, YOG or Homeroom 

o Format – select the format to print 
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  Second Tab – User Specific Parameters 

o Use Default Letter Body – check this box when you want to use standard text. 

Checked by default 

o Custom Letter Body – uncheck the box “Use Default Letter body” and enter 

customized text. The text will precede the attendance data inserted in the letter 

o Display Box for Principal Signature – check this if you want a box for Principal 

Signature on the letter. Checked by default 

o Print Double-Sided – select this if you want double sided output. Checked by 

default 

o Print in French Language – select this box for French translation of the letter 

 

          Third Tab – Publish 

o Delivery Type – select from Preview or Publish 

o Email subject – include an email subject 

o Email message – use this rich text field to include tables, text etc. 

o Viewing start date – current date (default)  

o Viewing end date – select until when the sent email can be viewed 

o Cleanup date – this date can be modified  
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 Daily Attendance Reports 

School > Attendance > Daily side tabs > Reports 

9.2.1 Absence Letter 

A core report which identifies students with five or more absences and prepares letters to send 

to parents. The report is not customizable by number of absences.  Parameters that can be 

selected include:  

o Start and End Dates – enter the range of dates to include on the report 

o Exclude Excused Absences – check to exclude 

o Include students with previous letters home – check to include  

o Alternate mailings – check to send a letter to parent/guardian designated to 

receive attendance mailing in School > Student > Contacts 

o Sort results by – select Name, YOG or Homeroom from the dropdown list 

o Format – select the format to print 

9.2.2 Attendance Bulletin 

•  A core report listing all students with an attendance record entered that day, report 

includes: Name, YOG, Homeroom, Absence Code and Time (if entered) 

o Date 

o Sort results by – select Name, YOG or Homeroom from the dropdown list 

o Include secondary students – check to include 

o Format – select the format to print 

9.2.3 BC Daily Attendance Call Sheet  

A core report listing students with an attendance record entered on that day, report includes: 
Name, YOG, Homeroom, Gender, Attendance Code, and the Name and Phone numbers of the 
two student contacts with highest priority 

o Date 

o Sort results by – select Name, YOG or Homeroom from the dropdown list 

o Format – select the format to print 

9.2.4 Attendance Classroom Input  

A core report listing the students in a course section with dates for the week selected as column 
headers 

o Week of – select a date to define the date column headers 

o Students to include – select: All or select a Class, Teacher, or Course number 

o Format – select the format to print 
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9.2.5 Attendance Homeroom Input  

A core report listing the students in a homeroom with dates for the week selected as column 
headers 

o Week of – select a date to define the date column headers 

o Students to include – select: All or select a Teacher or Homeroom 

o  Format – select the format to print 

9.2.6 BC Homeroom List w. Design  

A BC report listing students in a homeroom, based on the parameters selected the report can 
include: Name, Pupil #, Gender, Grade, Age, Birthday, Student Services Designation and 
Aboriginal Ancestry indicator 

o Students to include – All or select a Homeroom or Grade 

o Aboriginal Y/N – check to include the Aboriginal Ancestry column in the report 

o Include Exceptionality Type – Defaults to all designations checked 

▪ Checked – an assigned 1701 primary designation program will print  

▪ Unchecked – will not print designations in the column 

o Sort Results by – select Name or Grade 

o Format – select the format to print 

9.2.7 BC Homeroom List w. Grid  

A BC report listing students in a homeroom with fillable column headers in a grid format 

o Column Labels – enter the information to print in the Column Headers 

o Students to include – select All or select a Homeroom or Grade 

o Sort results by - select Name or Grade 

o Format – select the format to print 

9.2.8 Consecutive Absence List   

A core report listing students absent for a selected number of days in a row during the specified 
date range 

o Start and End Dates – enter the range of dates to include on the report 

o Count – enter the minimum consecutive absence records needed to include the 

student on the report 

o Exclude excused – check to exclude  

o Sort results by – select Name, YOG, Homeroom or Count 

o Include secondary students – check to include 

o Format – select the format to print 

9.2.9 Daily Attendance Post Verification   

A core report advising when and if Daily attendance was posted by a staff user on the selected 
date 
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o Date  

o Show non-posts only  

▪ Check - to only show classes where attendance was not posted 

▪ Uncheck - to show all classes and if they were posted or not 

o Sort results by – Name or Time posted 

o Format – select the format to print 

9.2.10 Principal’s Attendance  

A core report tool allowing schools to review and analyze student Daily attendance using a 
parameter form with multiple criteria 

o Start and End Dates – enter the range of dates to include on the report 

o Students to include – select All or select a YOG or Snapshot 

o Criteria – enter and combine different criteria to build the report 

▪ Absence Code – use prefilled values or select a code from the dropdown 

▪ Reasons – select from the dropdown  

▪ Operator – select from the dropdown 

▪ Exclude Excused – check to exclude for each criteria line 

▪ Connector – select And or Or to combine criteria lines 

o Sort results by – Name, YOG or Homeroom 

o Group results by – Homeroom, House Code, Team Code 

o Format – select the format to print 
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 Staff view Attendance Reports 

Staff > Attendance > Reports 

9.3.1 Attendance Bulletin  

A core report listing all students with an attendance record entered that day, report includes: 
Name, YOG, Homeroom, Absence Code and Time (if entered) 

o Date 

o Sort results by – select Name, YOG or Homeroom from the dropdown list 

o Include secondary students – check to include 

o Format – select the format to print 

9.3.2 Attendance Classroom Input  

A core report listing the students in a course section with dates for the week selected as column 

headers 

o Week of – select a date to define the date column headers 

o Students to include – select: All or select a Class, Teacher, or Course number 

o Format – select the format to print 

9.3.3 Attendance Homeroom Input  

A core report listing the students in a homeroom with dates for the week selected as column 

headers 

o Week of – select a date to define the date column headers 

o Students to include – select: All or select a Teacher or Homeroom 

o  Format – select the format to print 

9.3.4 BC Homeroom List w. Grid  

A BC report listing students in a course section with fillable column headers in a grid format 

o Column Labels – enter the information to print in the Column Headers 

o Sections to include – select All or select a Term Code, Course Number, 

Section, Schedule Expression or Teacher.  

o Sort results by - select Course or Teacher 

o Format – select the format to print 

9.3.5 BC Homeroom List w. Desig  

A BC report listing students in a homeroom, based on the parameters selected the report can 

include: Name, Pupil #, Gender, Grade, Age, Birthday, Student Services Designation and 

Aboriginal Ancestry indicator 

o Students to include – All or select a Homeroom or Grade 

o Aboriginal Y/N – check to include the Aboriginal Ancestry column in the report 

o Include Exceptionality Type – Defaults to all designations checked 



 

Class Attendance Setup and Management v1.10 Page 45 

▪ Checked – an assigned 1701 primary designation program will print  

▪ Unchecked – will not print designations in the column 

o Sort Results by – select Name or Grade 

o Format – select the format to print 

9.3.6 Consecutive Absence List  

A core report listing students absent for a selected number of days in a row during the specified 

date range 

o Start and End Dates – enter the range of dates to include on the report 

o Count – enter the minimum consecutive absence records needed to include the 

student on the report 

o Exclude excused – check to exclude  

o Sort results by – select Name, YOG, Homeroom or Count 

o Include secondary students – check to include 

o Format – select the format to print 

 

Staff > Attendance > Class > Details> Input > Reports 

9.3.7 Class Attendance Summary  

A summary of the attendance statistics in a course section by student 

o Start and End Dates – enter the range of dates to include on the report 

o Format – select the format to print 

9.3.8 Class Attendance History  

A listing of the attendance entries for a course section 

o Start and End Dates – enter the range of dates to include on the report 

o Print for – select Current Selection, or All 

o Sort Results by – Name or Date 

o Format – select the format to print 

9.3.9 StrongStart Attendance Summary 

A BC report listing the students in the course section and the number of POS and Absent 

entries in the selected date range 

o Start and End Dates – enter the range of dates to include on the report 

o Format – select the format to print 
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10.0 Attendance Labels 

School View > Student Top Tab > Reports > Labels  

10.1.1 Attendance Label FSS and Attendance Label FSS 5162 

The attendance label report provides school and staff users with an option to generate Daily and 
Class (ATT AM/PM) attendance information for the students selected. These labels can be 
placed on the reports wherever attendance information is required. The daily attendance labels 
when selected, adds separate rows for absences and late daily attendance data and provides 
counts by month including the total count in the reporting period. The class attendance labels 
when selected, adds separate rows for AM absences/late, PM absences/late class attendance 
data by month including the total count in the reporting period.  

Note: The size of the attendance label 5159 format is 1.5” by 4” and prints 14 attendance labels 
per page. The size of the attendance label 5162 format is 1-1/3” by 4” and prints 14 attendance 
labels per page. 

Parameter Screen 

o School – The school’s name will be displayed in a read-only mode 

o Students to include – select All, Current Selection, YOG, or Homeroom 

o Search Value – enter the value for YOG and Homeroom  

o Sort results by – Current sort order, Name, YOG or Homeroom 

o First Name Format – Usual or Legal 

o Last Name Format – Usual or Legal 

o ATT AM/PM Summary – when selected will print class attendance ATT AM/PM 

attendance data by month 

o Print Late – when selected prints a separate row for class/daily attendance late 

information, otherwise, only absences will be displayed 

o Format – select the format to print 
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11.0 Teacher Class Attendance Posting 

GDE that will show teacher's posting of attendance. GDE runs in School View only.  See GDE 
documentation on L1 Information Station for more information. 

School View > Student Top Tab>Options> 

 

GDE includes: 

Data Elements Description 

School Number Unique identifier for school 

School Name Name of the school 

Staff ID Unique identifier for staff 

Employee ID Legal last name 

Teacher Name Course section teacher name 

Course Code Course Code 

Section Number Course section number 

Attendance Date Date of attendance record 

Posting Date Date attendance was posted 

Posting Time Time attendance was posted 

 

 


