
 

 

 

 
 

Student Services 

Competency-

Based Individual 

Education Plans 

Dec 2025 v1.21 



 

 

Version History 

Version Date Description 

1.0 Oct 2018 Initial published version 

1.1 Nov 2018 Clarified the Supplementary Plan district reference table for additional selection items 
and goal entry order 

1.2 Jan 2019 Updated for 5.9 Release: New Filters. 

1.3 Mar 2019 1. New field ‘Type of Goal’ added to competency-based IEP template under 
objectives of curricular competency goals tab (Section 4.1.5).  

2. Type of Goal will be populated on the CB IEP report if selected (Section 9). 

1.4 Apr 2019 Updated PSR IEP Inclusions section. Added hyperlinks to Table of Contents. 

1.5 Jul 2019 Clarification in multiple areas that the Case Manager picklist requires the Staff 
Details to be populated  

1.6 Jul 2019 Added new Release 5.10 features to sections 2.1 and 8 

  Oct 2019 Updated screenshot for new default field set 

1.8 Nov 2019 Updated for 10.0 Printing the Competency Based IEP 

1.9 Apr 2020 Updated the screenshot of student demographic screen to show DOB with format 
hint 

1.10 Aug 2020 Updated screenshot for the support type in the CB IEP report 

1.11 Oct 2020 Updated document from Competency based Inclusive Education Plans to 
Competency Based Individual Education Plans 

1.12 Feb 2021 Updated the document with new screenshot for report, updated screen shots for 
Completing plan section 

1.13 Jul 2021 6.3 New Filter-Next year student on Student TT  
Section 2.5 Staff Inclusive Education Role 

1.14 Aug 2022 Progress Report and Process/Change Management updates for clarification 
Parent Portal visibility, update on where you can run the Competency Based IEP 
report and update PSR Inclusion templates 

1.15 June 2023 Updated information for the new competencies and new report screenshots 

1.16 Mar 2024 Updated screenshots for Plan details and information for Goal Progress Report 
My Learning Profile – added new functionality, separate tabs 

1.17 Dec 2024 Update SPED language to Inclusive Education (IncEd) 

1.18 Dec 2024 Updated screenshot for Progress Report - Competency Based IEP (Section 11) 

1.19 Jan 2025 Updated section 4.1.8 – Updated the screenshots – completing plan 

  



 

 

1.20 Mar 2025 Updated section 4.1.3 –Additional comments field size clarification 

1.21 Dec 2025 Updated sections 4.1.4, 4.1.5, 4.1.6 and 11 - Addition to CB-IEP Goals and 
Objectives tab. 
 Updated Section 10  – Changed ‘IEP Date’ to ‘Plan Date’ on CB-IEP Report and 
Progress Report 

 

Confidentiality 

This document contains information which is proprietary and confidential to Fujitsu Consulting (Canada) Inc. 
(including the information of third parties, including but not limited to, Follett of Canada Inc., submitted with their 
permission). In consideration of receipt of this document, the recipient agrees to treat this information as confidential 
and to not use or reproduce this information for any purpose other than its original intent or disclose this information 
to any other person for any purpose, without the express prior consent of Fujitsu Consulting (Canada) Inc. (and any 
applicable third party.) 



 

 

Table of Contents  

1.0 INTRODUCTION ........................................................................................................................... 5 

2.0 NAVIGATING IN THE  STUDENT SERVICES VIEW .................................................................... 6 

2.1 Filters ......................................................................................................................................... 6 

2.2 Student Top Tab ........................................................................................................................ 8 

2.3 Plan Top Tab ............................................................................................................................ 10 

2.4 Log Top Tab ............................................................................................................................. 11 

2.5 Global Top Tab ........................................................................................................................ 11 

2.6 Staff Top Tab ........................................................................................................................... 12 

3.0 ENROLLING A STUDENT IN STUDENT SERVICES ................................................................. 13 

4.0 STUDENT PLANS ...................................................................................................................... 14 

4.1 Completing a Plan .................................................................................................................... 14 

4.2 Plan Status and Dates .............................................................................................................. 28 

4.3 Plan Status Nightly Update ....................................................................................................... 29 

5.0 RENEWING A PLAN .................................................................................................................. 30 

5.1 Options > Renew Plan.............................................................................................................. 31 

5.2 Options > Renew Plan (Case Manager) ................................................................................... 32 

6.0 DELETING A PLAN .................................................................................................................... 34 

7.0 DISCONTINUE STUDENT SERVICES ....................................................................................... 35 

8.0 BULK EXIT STUDENTS FROM STUDENT SERVICES .............................................................. 36 

9.0 SCHOOL WITHDRAWAL/TRANSFER OF STUDENT SERVICES STUDENTS ......................... 37 

10.0 PRINTING/PUBLISHING THE COMPETENCY BASED IEP ...................................................... 38 

11.0 PRINTING THE PROGRESS REPORT – COMPETENCY BASED IEP ...................................... 44 

12.0 PSR IEP INCLUSIONS ............................................................................................................... 47 

13.0 SECURITY RESTRICTIONS FOR ADDING DOCUMENTS ........................................................ 49 

14.0 STUDENT SERVICES SECURITY .............................................................................................. 53 

14.1 Student Services Security Roles .............................................................................................. 53 

14.2 Staff Details – Inclusive Education and Inclusive Education Role ............................................. 56 



 

Competency-Based Individual Education Plans v1.20 Page 5 

1.0 Introduction  

In MyEducation BC, the Student Services module provides a simple interface that allows users to 
write support plans and review student progress. The module is flexible enough to align with 
district practice while capturing all the required data elements for the Student Plan.  

There are two formats available for the purpose of documenting the services provided to 
students to support their education. The Individual Education Plan format and the Competency 
Based format. Districts, in partnership with their Student Services departments, can choose 
which format will be in use within their district. The form used will be a district wide commitment.  

Submit a Service Request to have the default template set to the Competency based IEP, if that 
is the desired format for the district.  

Important note: If there is an existing plan for a student a user can continue to work on it in its 
current format. Data from one plan format (Individual Education) does not copy into the different 
format (Competency Based) and vice versa. A new plan is created in the format that has been 
defined as the default for the district.  

 

 

  



 

Competency-Based Individual Education Plans v1.20 Page 6 

2.0 Navigating in the  Student Services View 

Users with the role of Student Services – School have access to Student Services – School view 
to manage support plans for students at a defined school. Users with the Student Services - 
District role have access to the Student Services - Organization view and Student Services – 
School view to manage student services for all schools in the district. 

2.1 Filters 

See the Fundamentals Guide for more information about the use of filters and the Advanced 
Filter functionality.   

2.1.1 Standard Filter in the Student Services View 
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2.1.2 Advanced Filter in the Student Services View 

 

 

Filter Results 

All Records Displays all records 

My Cases – Active and Draft Presents a list of students with an Active or Draft plan  

My Cases Presents a list of all students in your case load with an Active, Draft, 
Previous or Discarded plan 

Active Presents a list of students with an Individual Education status of 
Active 

Active-Inactive Enrollment Presents a list of students who have an Enrollment status of 
withdrawn or graduated and an Active plan/status in Student 
Services.  

Not Eligible Not relevant for BC. Filter based on workflow model to set Individual 
Ed status to Ineligible 

Referred Not relevant for BC. Filter based on workflow model to set Individual 
Ed status to Referred 

Exited Presents a list of students with Individual Ed status of Exited. 

Active with Designation (To be Removed)Doesn’t work – shows Active and Exited students 
with designations 

Designated students with Draft IEPs Displays students with a designation and a draft plan 

Designation = ? Query for students with a specific designation 

Next Year Students Presents a list where the student's next year school value is equal to 
the school and the Inclusive Education Status is not empty. 
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2.2 Student Top Tab  

The Student TT provides access to the list of students enrolled in student services. Choose the 
students that you want to work with using the filters provided.  

2.2.1 Details side tab  

The Details ST displays the basic student demographic details. 

 

 

2.2.2 Plans side tab  

The Plans ST displays a list of the student’s plans. Filter the plans to display, using the dictionary 

icon   
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2.2.3 Contacts side tab 

The Contacts ST displays a list of the student’s contacts.  

Contacts with Include on Plan checked and Parent or Guardian? = Y will print on the student 
Plan. 

2.2.4 Remaining side tabs 

The remaining side tabs are the same ones found in School View: 

• Attendance 

• Conduct 

• Academics 

• Transcript 

• Assessments 

• Schedule 

• Membership 

• Transactions 

• Documents 

• Snapshots 

Each of these tabs provides further details on the student. In Student Services view, the data is 
read-only.  
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2.3 Plan Top Tab  

The Plan TT lists the student plans. Filter the types of plans that display by using the Dictionary 

icon.  

Clicking on the student’s name in a given row will open the details of that particular Plan. Choose 
the plans that you want to work with using the filters provided. 

A student services field set is provided which can be modified to include other relevant fields for 
the user.  

 

Filter Results 

My Cases – Active and Draft Presents a list of students with an Active or Draft plan  

My Cases Presents a list of all students in your case load with an Active, Draft, 
Previous or Discarded plan 

Active IEPS Presents a list of students with an Individual Education plan status of 
Active 

Draft IEPS Presents a list of students with an Individual Education plan status of 
Draft 

Previous IEPS Presents a list of students with an Individual Education plan status of 
Previous 

All Records Displays all records 

Grade Level = ?  Presents a list of Plans for students in the requested grade 

Plan Status Presents a list of Plans with the requested status 

Active Student with Active IEPs Presents a list of Students with Active Plans 

2.3.1 Plan Top Tab > Side Tabs 

1. Details Side Tab – Provides the Plan details of the selected record. A Plan in progress can 

be accessed to edit from here. 

2. Forms Side Tab – Provides access to the forms associated with the selected record. These 

are historical records tied to the retired workflows. Users can manually enter information in 

the forms, but it will not print on the report or display in the Plan.  

3. Goals Side Tab – does not work for Competency Based plans. 

4. Progress Side Tab – Allows access to the goal progress reports created for the Plan. 

5. Team Members Side Tab – Shows the identified school-based team members for the Plan. 

6. Access Log Side Tab – Displays those users who have accessed the selected Plan. 



 

Competency-Based Individual Education Plans v1.20 Page 11 

2.4 Log Top Tab 

The Log TT is a place to record interactions between the support team and the student and 
family. 

 

 

• Entry Log – enter information about the interactions with the student and family, 

meetings, and notes from the review. 

• Log History – displays a list of all log entries. Can be sorted, filtered, and printed.  

2.5 Global Top Tab  

The Global TT provides a view to all student records in a variety of categories represented by 
side tabs. This view provides the means to generate reports in pdf or csv formats using the quick 
reports feature.  

 

 

• Goals – Displays a view of all students and their assigned goals. 

• Progress – Shows all students’ Plan goal progress report records. 

• Team Members – Lists the students and team members. These fields can be sorted to 

show the student and all associated team members, or team members and the students 

associated with them. 

• Designations – Lists the students with designations. 

• Goal Bank – Contains the user’s banked goals and associated objectives. This doesn’t 

apply to Competency Based Plans.  Staff Top Tab  
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2.6 Staff Top Tab 

The Staff TT provides a listing of staff members with Student Services checked in their staff 
details.  

 

 

 
 

 
District View and School View > Staff Top Tab > Select teacher > Details Side Tab 
 
Selecting the Inclusive Education check box (and a corresponding Inclusive Education Role) 
will display the Staff member in a pick list in the Student Services Module. This enables staff 
members to appear within the Student Services Module in a pick list to assign them to the School 
Support Team on the CB-IEP. 
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3.0 Enrolling a Student in Student Services 

A student must be enrolled in Student Services before a Plan can be developed for the delivery 
of support services.  

Student Services – District or School view > Student TT > Options > Enroll 

 

 

Student(s) – Use the picklist to select the student or students. Search by name or use the page 
navigation at the top. Only students that are not currently enrolled in Student Services will display 
on the list.  

Case Manager – Select a Case Manager for all students selected (optional). The staff member 
must have the Individual Education checkbox ticked, and the Case Manager role assigned on the 
Staff details to appear on this list.  (School or District view > Staff > Details) 

Start Date – Date of enrollment in Student Services. This date becomes the start date for the 
draft plan. All plans require a start date.  

End Date – Date that the plan will end. This is an optional entry at the time of enrollment, but if 
your district policy is to create a new plan each year then it would be advisable to enter the end 
date now. An existing plan must have an end date before a new plan can be started.  

Plan Name – enter the name of the plan. The standard naming convention is District number–
plan type-other identifiers. For example: 35-IEP-2018-19 or 36-SSP-Grade4. 
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4.0 Student Plans  

The status of a student plan is determined by the start and end date of the plan.  

• Active – the current plan used day-to-day to support the student. 
• Draft – a plan being prepared to support the student in the future. 

• Previous – a plan used to support the student in the past. 

A Draft Plan is created for a student upon enrollment in Student Services. If the start date is a 
current or past date, and the plan has been saved, the Plan will be Active. 

4.1 Completing a Plan 

Student Services – District/School > Student > Plans > Details  

Student Services – District/School > Plan > Details  

 

The Data Dictionary icon  can be used to view Individual Education plans, as well as 
Competency Based plans. 

  

There are eight tabs in the Plan Details screen, as detailed in the following sections. All or a 
portion of the information can be completed as is appropriate for each student.  Information can 
be added in any order, at any point in time. 

 

Note: Student Services – District users have access to the Options menu at the top left of 
the screen, and the ability to delete a Plan when necessary. Use this menu with caution as 
Options > Delete will delete the entire Plan, not the row within the plan.  
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4.1.1 My Personal Profile Tab 

 

• Have the student describe himself/herself in these areas.  If you are unable to obtain 
student input (orally, in writing, or through pictures as appropriate) you may refer to 
parent and teacher input.  

• If there are videos, pictures, or media about the student please indicate where to access 
them and/or include a URL link. 
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4.1.2 My Learning Profile Tab 

 

• Core competencies are sets of Communication, Thinking, Personal and Social 
proficiencies that all students need to develop. The old competencies (Intellectual, 
Personal, Social) are displayed with an asterisk for existing plans. 

• Select which Competency Area each of the Strengths and Stretches are for. 

• The “Thoughts from my team” checkbox is used to indicate that the Learning profile was 
completed by the team members rather than in the student’s own voice. 

• Check the “My Focus Area” checkbox to indicate the competency that the student focus 
is on. Students may need guidance with this, depending on their ability.  
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4.1.3 Support and Plans Tab 

 

• Add the Category, Support Type, and Description. 

• Universal Classroom Supports are supports that could be made available to any student 
to foster greater inclusion in the classroom. List supports here that are particularly helpful 
for this specific student. 

• Essential Supports are identified through psycho-educational and/or medical testing and 
are necessary in order for the student to access the curriculum. They may require the use 
of technology or the direct involvement of specialist support staff. 

• The Supplementary Plans are recorded here but are not attached. Optionally, enter the 
date that the plan was written. Refer to the student’s confidential file to view the additional 
plans. Additional Supplementary Plan types can be added to the District reference table 
for Supplementary Plans by persons with District Support (Help Desk/Level 1) role.  

• Enter Additional Comments as necessary.  Additional comments section can support up 
to 1000 characters.  
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4.1.4 Core Competency Goals Tab 

• Add Core Competency Goals as required. As many goals can be added as required. 

• You may select a goal or personalize it in relation to your student. This should be based 
on the student’s identified focus area and their stretches in the “My Learning Profile” 
section. 

 

• Click the Add button and the following input screen displays: 
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• Identifier (Required) –  

o Enter an identifier for this goal. Goal numbers must be a unique numeric and/or alpha 

identifier. 

o For Core Competency goals preface the goal number with CC. For example: CC2. 

o For Curriculum goals preface the goal number with CR. For example: CR1 

o For Transition goals preface the goal number with TR. For example: TR1 

• Core Competency Area – Select from the list 

• Teacher Responsible – Enter the name of the teacher responsible for this goal. 

• Core Goal – Click the ◀ to expand the Competency Area Bank. Add to or edit the Core 

Goal as required. ▶ will hide the selection screen. 

• Obj., Current Level, Evidence – Create a student-specific measurable objective related 
to the goal.  
(e.g. obtained through evidence, data collection, student reflection, observations). 

• Strategies and Resources - Enter instructional resources, activities and staff that will aid 
the student in achieving the objective and explain how they will be used. 

• Comment – Enter progress comments for the objective. 

• Proficiency – Enter proficiency for the objective. 

• Print – Select to print the goal, objective, Progress proficiency and Progress comments 
on progress report. 
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4.1.5 Curricular Competency Goals Tab 

• Big Ideas – Use the ◀ to expand the Big Ideas Bank.  Select the Area of Learning to 

filter the list. Select the Big Idea. Add to or edit the Big Ideas as required. ▶ will hide the 

selection screen. 

• Curricular Goals – These are the learning standards as identified in the BC Curriculum. 

The following screen displays: 
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Click the Add button for core competency and the following input screen displays: 

 

• Goal Number – Required – Must be unique. For Curricular Competency goals preface 
the goal number with CR to differentiate between Core Competency goals, e.g. CR1. 

• Type of goal – select from the list: Replacement, Supplemental or blank. 

• Person Teacher Responsible – Enter the name of the teacher responsible for this goal. 

• Area of Learning – select from the list.  

• Core Goal – use the ◀ to expand the Learning Standard Bank. Add to or edit the Area 

of Learning as required. ▶ will hide the selection screen. 

• Obj., Current Level, Evidence – create a student-specific measurable objective related 
to the goal.  
(e.g. obtained through evidence, data collection, student reflection, observations). 

• Strategies and Resources – enter instructional resources, activities and staff that will 
aid the student in achieving the objective and explain how they will be used. 

• Comment – enter progress comments for the objective. 

• Proficiency – enter proficiency for the objective. 
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• Print – select to print the goal, objective, Progress proficiency and Progress comments 
on progress report.  
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4.1.6 Progress Report 

• Add Core Competency and Curriculum Goals as required.  

• You may select a goal to be printed on the Progress Report - Competency Based IEP. 

• You can enter Additional Comments / Transition Information to display on the progress 
report - Competency Based IEP. 

• Progress columns will only appear on Progress Report.
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Click the Add button and the following input screen displays: 

 

Please see Section 4.1.4 - Core Competency Goals Tab for field details. 
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Please see Section 4.1.5 Curriculum Competency Goals Tab for field details 
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4.1.7 Student Support Team Tab 

This allows individual team members to be added to the Plan, using the Add button at the 
bottom right, or removed using the Delete button. Names can be selected from the picklist or 
entered free form.  

 

UsualLast – The picklist displays a popup  

Team member type – select the type from the dropdown list and select from the names 
displayed.  Click OK.  

UsualFirst – Displays for the person selected. 

Name – Freeform text field for Name. 

Role – Select a staff member by role. Populates for selected staff when the role is assigned in 
Staff Details, or the role can be entered freeform. 
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4.1.8 Plan Details Tab 

This displays the basic information of every student plan.  All fields other than the student’s name 
and plan status are editable.   

 

• Name – Read Only. 

• Case Manager > Name – Select from picklist, auto-populates if selected during 

Enrollment to Student Services. The staff member must have the Individual Education 

checkbox ticked, and the Case Manager role assigned on the Staff details to appear on 

this list.  (School or District view > Staff > Details). 

• Status – Read Only. 

• Start Date – Required. Select from calendar icon. 

• End Date – Select from calendar icon. 

• Yearly Review Date – Select from calendar icon. 

• Plan Name – used to identify the Plan. Recommended standard is District Number-Plan 

type-other identifiers as per district practice, e.g. 35-IEP-2018. 

• Parent Consulted – Checkbox. Go the LOG file and record the details of the parent 

consultation. 

• Parent Consulted Date – Select from the calendar icon. Competency Based IEP Report 

uses this field for displaying Parent/Guardian Consulted Date  if date entered, otherwise 

display from log details 

• SAVE.  

The plan status will be determined by the start and end dates of the plan, and the plan’s current 
status. 
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4.2 Plan Status and Dates 

The Plan status is determined by the start and end date of the plan. A plan alert is triggered by 
an Active plan status. 

• Active = Current. The plan you are following for the day-to-day support of the student. 
• Draft = Future. A plan that you are preparing for a future implementation. 
• Previous = Past. A plan that was used in the past. 

The following table identifies what the plan status will be based on the dates recorded. A start 
date is a mandatory field.  

Plan Status  Start Date   End Date 

Active Current date Blank 

Active Current date Future Date 

Active Past date Blank 

Active Past date Future date 

Draft  Future date Blank 

Draft  Future date Future Date 

Previous Past date Current date 

Previous Past date Past date 

Discarded = End date = Start date 
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4.3 Plan Status Nightly Update  

A procedure runs every evening to update the Competency Based Individual Education Plan status 
based on the start and end dates of the plan and the current status of the plan. The Plan Alert on 
the student table will be updated accordingly.  

If the plan status is Active and the plan end date is earlier than the current date, then the plan 
status will be changed to Previous and the plan alert will be removed. 

If the plan status is Draft and the plan start date is the current date or earlier, then the plan status 
will be changed to Active and the plan alert will be set. 

If the plan status is Previous or Discarded the record is ignored and no changes are made.  

 

For example: Today’s date is January 3. The Case Manager decides to end the existing plan and 
create a new draft plan. She must enter an end date before the plan can be renewed. The 
overnight procedure runs at 2:00 am on January 4.  

Current Status Start Date End Date Status Change? 

Active Jan 20, 2023 Jan 5, 2024 Previous 

Draft Jan 6, 2024  No change 

 

  

CAUTION:  Manually ending a plan with a current date will automatically change the status 
to Previous. The student must have an Active or Draft plan to be selected for Renewal. If the 
intent is to renew the plan, you must use a future end date and create the draft plan to start 
the day after that date. 
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5.0 Renewing a Plan 

Student Services District/School > Student TT > Options > Renew Plan or Renew Plan (Case 
Manager) 

Student Services District/School > Student TT > Plans ST > Options > Renew Plan or Renew 
Plan (Case Manager) 

Student Services District/School > Plan TT > Options > Renew Plan or Renew Plan (Case 
Manager) 

Renewing a plan will create a copy of the plan if it is currently using the Competency Based 
template with a new start date. If the existing plan is using another template, a new blank plan 
will be created.  A future start date will create a draft plan, and a current start date will create an 
active plan – either of which can be edited to meet the current needs of the student.  

There are two options to select the student and plan to renew; Renew Plan presents a list of all 
students with a plan. Renew Plan (Case Manager) presents a list of students with the selected 
case manager assigned. 
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5.1 Options > Renew Plan  

In the popup:  

• Student – Select the student from the picklist 

• Plan Selection – Select the Plan to copy from the picklist, or leave blank to create a new 
blank Plan with no copied information. Plans can only be copied using the same format. 
Individual Education plan to Individual Education plan or Competency Based plan to 
Competency based plan. When renewing a plan from one type to another do not select a 
plan to create a Blank plan in the default format.  

• Start Date – Select the date the new Plan will be Active from the calendar icon 

• End Date – Per district practice, leave blank or select the date the new plan will end from 
the calendar icon 

• Review Date – Per district practice, leave blank or select the date the new plan will be 
reviewed from the calendar icon. 

• Plan Name – enter the name for the new plan 
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5.2 Options > Renew Plan (Case Manager) 

In the popup:  

• Case Manager – select the case manager from the picklist. The staff member must have 
the Individual Education checkbox ticked, and the Case Manager role assigned on the 
Staff details to appear on this list.  (School or District view > Staff > Details). 

• Student – select the student from the picklist. 

• Plan Selection – select the Plan to copy from the picklist, or leave blank to create a new 
blank Plan with no copied information. Plans can only be copied using the same format. 
Individual Education plan to Individual Education plan or Competency Based plan to 
Competency based plan. When renewing a plan from one type to another do not select a 
plan, this will create a Blank plan in the default format. 

• Start Date – select the date the new Plan will be Active from the calendar icon. 

• End Date – as per district practice; leave blank or select the date the new plan will end 
from the calendar icon. 

• Review Date – as per district practice; leave blank or select the date the new plan will be 
reviewed from the calendar icon. 

• Plan Name – enter the name for the new plan. 

 

 

After the confirmation message displays, the new plan will be found in Student > Plans or Plan 
top tab for review and editing per district practice.  
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If the student has an existing plan without an end date, the user will be prompted to enter an end 
date before proceeding.  
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6.0 Deleting a Plan 

It would be rare for a Student Plan to be deleted. If a Plan is created in error and it is determined 
that the Plan should be deleted, a user with the Student Services – District role has the ability 
to delete a plan. Navigate into the details of the Plan and use Options > Delete.    
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7.0 Discontinue Student Services 

Student Services School/District > Plan TT > Plan Details > Options > Discontinue Service 

Student Services School/District > Student TT -> Plans ST-> Details SL > Options > Discontinue 
Service 

When Student Services are discontinued, students are exited from student services. Plans 
change from Active to Previous or Draft to Discarded.  Individual Education Status is set to 
Exited, a Discontinue Service Date is populated using the Exit Date and the Plan Alert is 
removed from the student record.  The 1701 Designation Program is not end dated and remains 
intact.   

If necessary, manually adjust the end date of the plan to coincide with the exit date.  

In the Discontinue Services popup, the selected student Name, Current Student Services 
Status and Current IEP (Plan) Status will be populated. Fill in the remaining fields below as 
appropriate: 

 

• Exit Date – Select the exit date from the calendar icon 

• Exit Reason – Select the appropriate reason from the dropdown list 

• Comments – Leave blank or enter freeform text per district practice 

 

Discontinue Service Date 

The Discontinue Services date field has no relevance to either CB-IEP or BC-IEP, and cannot be 
manually adjusted. The date is there to indicate that the student was discontinued previously, but 
does not impact current plans. 
 
If a student is discontinued again the new date will overwrite this date, but it is just historical data. 
The field configuration was deliberately made read-only so users cannot delete the value.  
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8.0 Bulk Exit Students from Student Services 

Student Services District > Student TT > Options > Bulk Exit Students from Student Services 

Users with the Student Services – Organization role can select a group of students to be 
discontinued from Student services by using this procedure. The Student Services Status for 
these students changes from Active to Exited and the Plan changes from Active to Previous.  

If a student or group of students is exited in error, they can be manually re-enrolled in Student 
Services. The student Plan remains intact and can be set to active once the student is Active 
again in Student Services. 

 

  



 

Competency-Based Individual Education Plans v1.20 Page 37 

9.0 School Withdrawal/Transfer of Student Services 
Students  

Two processes are available in MyEducation BC for the withdrawal of a student in School or 
District View.  

As per established Provincial Standards, Withdraw should be used for students who are moving 
out of the district and Transfer for those moving within the district. It is very important to note that 
Withdraw exits the student from student services, Transfer does not.  

Please see the Enrollment and Demographics guide for further details on Withdrawal and 
Transfer functionality.  
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10.0  Printing/Publishing the Competency Based IEP 

The Reports button displays a list of reports available in the following areas below: 

10.1.1 Navigation 

• Student Services School/District View > Plan TT > Details ST > Reports > Competency 

Based IEP Report 

• Student Services School/District View > Plan TT > Reports > Competency Based IEP 

Report 

• Student Services School/District View > Student TT > Plans ST > Details > Reports > 

Competency Based IEP Report 

• Staff View > Student TT > Documents ST > Plans SST > Details > Reports > 

Competency Based IEP Report 

• School View > Student TT > Documents ST > Plans SST > Details > Reports > 

Competency Based IEP Report 

 

 

10.1.1.1 Legacy 

Individual Education Plans, Competency Based IEP Report (Legacy) and the Legacy IEP reports 
are located in the Legacy report group. The Competency Based IEP Report (Legacy) will display 
the Intellectual, Social and Personal competencies. 
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10.1.2 Printing/Publishing the Competency Based IEP 

 

 
• Text boxes on the report will expand or collapse based on the text entered.  

• Text boxes without any data in them will not display on the report. 

• The report title will display Individual Education Plan if the students have an active 

designation 

• The report title will display Student Support Plan if the student does not have an active 

designation  

• This report is publishable to the family and student portals.
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• The report title will display Student Support Plan if the student does not have an active 

designation  
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11.0   Printing the Progress Report – Competency Based IEP 

• Student Services School/District View > Plan TT >Details ST >Reports > Progress Report 

- Competency Based IEP 

 

The report will display all goals and all objectives with the “Progress Print” box checked off, See 
Sections 4.1.4 and 4.1.5 for more information. 
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• The report title will display SSP: Progress Report if the student does not have an active 

designation  
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12.0 PSR IEP Inclusions 

Inclusions will appear on the Permanent Student Record (PSR) report.    

If the Grade sub level = HS then the inclusion section will display Homeschooled under the 
Student Record Inclusion on the Permanent Student Record.   

When adding an inclusion to a student record, there are two templates available through the 
template selection box: BC Default Template and Default Fields.  
 
BC Default Template  
In the BC Default Template, the “Inclusion type” field is pre-populated with the word “Inclusion” 
and this field cannot be edited.  
 
Default Fields  

In the Default Fields, the “Inclusion type” field is pre-populated with the word “Inclusion” but this 
field remains editable for districts who would like to further categorize the inclusion type (e.g., 
Inclusion 1, Inclusion 2, Inclusion 3, etc.). 

 

To enter an inclusion for a student: 

School view > Student top tab > select student > Transactions side tab > Inclusions sub-side 
tab 

1. In the Options menu, select Add. 

2. Once the Inclusion page opens, select the template you are using: 
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In the Inclusion date field, type or use the calendar icon to select the effective date of the 
inclusion. 

In the Expiry Date field, type or use the calendar icon to select the expiry date of the inclusion if 
applicable. 

In the School year field, use the icon to select the year the inclusion is recorded for. 

Use the PSR Comment field to record the necessary information. 

 

3. Save. 
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13.0 Security Restrictions for Adding Documents 

Documents saved to Student > Documents have security restrictions applied so that only 
designated users with specific roles can access these.  

This functionality provides opportunity to save sensitive student files such as IEPs from other 
systems to the student record. These files will remain with the student record as the student 
moves through the system. 

13.1.1 Adding Document Type Code 

District View > Admin > Data Dictionary > Document Type Codes > Codes 

1. From the document type Codes, click on Options > Add. 

2. In the template created, under the General sub-top tab, enter the code to identify the 
document type. A description can be added but no other fields need be populated. Save. 

 

 

3. Select the Record Level Security sub-top tab. Set the Role visibility type to Include. 
Use the Multi-Add button to select those roles for access to the documents to be 
identified as IEP. 

Important: Creating a new document type without having the record level security applied 
leaves the document open for anyone with access to the documents side tab (parents, 
teachers, and school and district users) to view it. Proceed with caution. If in doubt, contact 
the service desk for assistance. 
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4. Save the changes. 
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13.1.2 Adding Documents 

Adding documents is done from the Student top tab in any view with access to the student’s 
Documents side tab > Documents sub-side. 

School View > Student > Documents > Documents > Options > Add.  

 

 
Enter a name for the document in the template. 

a. In the Type field select the document type to be uploaded. In this example it will 
be the restricted, IEP document type. 

 

 

 

b. Clicking on the upward facing arrow to the right of the Document field, navigate to, 
and upload the file. Once downloaded the Filename field will display the name of 
the document with the extension. 

c. From the Format drop-down list, select the document format. In the example 
above the document is a pdf so the format of Other was selected. 

Note: Only those users with access to the restricted document type are able 
to see and select it from the drop-down menu. 
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d. Save. 

 

 
 

 

5. Only users with permission to access the document will be able to do so.  

 

 

 

 

  

Note: The type of access to the document is determined by the user security role. Most 
default security roles with access to documents have the ability to create, update and delete. 
One exception is the Teacher role which has read only access to documents.  

Documents may be viewable by Parents in the Family Portal. Access is restricted by 
Document type. 
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14.0 Student Services Security  

14.1 Student Services Security Roles 

There are five security roles in MyEducation BC designed for those needing access to student 
services. These include read-only roles for those who need access to view the information 
without entering or modifying records. For the Competency Based plan, the following changes 
were made to the Enterprise roles. If districts are using custom roles, they may need to make 
similar changes.  

Role Removed Added 

Student Services - District The Workflow side tab LOG TT 

Global TT  > Designation ST and 
Delivery Log ST 

Student Services - School IEP administrative override 

The Workflow side tab 

LOG TT 

Global TT > Designation ST and 
Delivery Log ST 

Student Services: Enroll & Read- 
School  

IEP administrative override 

The Workflow side tab 

Global TT  

LOG TT – History only 

Student Services: Read Only – 
School 

IEP administrative override 

The Workflow side tab 

Global TT 

LOG TT – History only 

Student Services: Read Only – 
District 

IEP administrative override 

The Workflow side tab 

LOG TT – History only 

Publish Add On Role – Student 
Services View 

  

Publish Add On Role – Student 
Services School View 

  

 

Student Services – School 

As the role implies, the school level role is designed with the student support teacher/case 
manager in mind. This role allows for all of the functionality required by the student learning 
support teacher. MyEducation BC functionality allows for  Inclusive Education  teachers who 
work at more than one school to have this role and be assigned to multiple schools. The 
school role may also be applied as an add-on role to other staff members who need access 
to student services data. These other positions might include school administrators, school or 
district counsellors, or school clerical staff that might be responsible for data entry in this 
area. 

• Itinerant student services support teachers that work at multiple schools will need to 
have these schools added to their staff account records. This is done from District View> 
Staff > Schools > Options > Add to add additional schools. 
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Student Services – District  

• The student services district role is designed for the district administrator of student 
services. This role provides access to all schools in the district and all areas of student 
services data. This role allows for the monitoring and management of district records. 
 

• The following processes are limited only to those with the district security role: 
o Change a student’s Individual Education Status 
o Use the Options menu to Exit a student from student services, bypassing the 

workflow process 
o Delete a Plan 
o Change a Plan status 

• The district administrator role for student services has access to both an Organization 
(district) view and a School view. 

 

The organization view provides the user with a district perspective with reference to the 
information provided from the available tabs. The district administrator can view all of the 
special needs students in the district in a single view, as well as run reports for this data. 
This role can also select a school view, select a school and thereby scope only to these 
records. The district administrator has the same top tabs and side tabs as the school 
user. 

 

Student Services: Enroll & Read – School 

• This role is designed for the school user where the school assigns designations and may 
also be enrolling students into student services, This role should not be used in 
conjunction with any other Student Services role as it may limit the functionality of the 
other roles. 

 

Student Services: Read Only – District 

• This role allows read only access at the district level for all areas within Student Services. 
Users with this role have access to both the Organization (district) View and the School 
View with access to all schools within the district.  
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Student Services: Read Only – School 

• This role allows read only access at the school level for all areas within Student Services. 
Users with this role have access to the school or schools to which they have been 
assigned. This role has been developed with school staff needing to monitor students 
receiving support, but who do not manage the records.  

 
1701 Designation Role 
 

• This role allows a user to enter the Ministry designation in the School view for a selected 

student. A user must have this role assigned in order to be able to add the ministry 

designation as a student program. Designations entered in the School view are visible in 

the Student Services view but are not editable.  

 

Teachers 

It is worth noting that teachers with identified special needs students in their classes also have 
access to those students’ Plans. Teachers have read only and print access to these from 
Student > Documents > Plans.  

 

Clerical 

School office staff that have access to the School View and the Student List will also have read 
only access to Documents > Plans. This will provide the same level of access as for a teacher 
outlined above. 

 

Publish Add On Role – Student Services View 

This role is for District Level Student Services Users. It give access to the Student Services 
Organization View This role allows users to Run Publish Add-on definitions at the Student 
Services Organization View. Users with this role can also publish reports to the portal. 

 

Publish Add On Role – Student Services School View 

This role is for School Level Inclusive Education Users. It gives access to the Student Services 
School View. This role allows users to Run Publish Add-on definitions at the Student Services 
School View. Users with this role can also publish Student reports to the portal. 
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14.2 Staff Details – Inclusive Education and Inclusive Education Role 

Student Services 

District/School > Staff > Details 

Staff Detail settings enable a staff member to display in the Student Services view.    

 

Checking Inclusive Education displays the staff member in the team member pick list.  

Selecting an Inclusive Education Role identifies this for the staff member and populates the 
role field in the Student Support Team tab of the Student Plan.  


