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25.1.
Added screenshots for each procedure.

1.2 Aug 2017 Clarified the need for a current year association to the school in Sec 1.

1.3 Aug 2017 Emphasized the Copy Grades and Assignments procedure should only be run
with schools using Single Term Transcript Definitions throughout the document.

14 Apr 2019 Added hyperlinks to Table of Contents

1.5 Jun 2020

1.6 Aug 2021 updated section 2.3 Pre and Post EOYR

1.7 Aug 2024 Updated section 2.5

1.8 Aug 2025 Updated section 2.4
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Confidentiality

This document contains information which is proprietary and confidential to Fujitsu Consulting (Canada)
Inc. (including the information of third parties, including but not limited to, Follett of Canada Inc., submitted
with their permission). In consideration of receipt of this document, the recipient agrees to treat this
information as confidential and to not use or reproduce this information for any purpose other than its
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1.0 Preparation for Continuing Courses Processes

1.
2.
3.

4.

Schools will have an active master schedule in the current year

The same (identical) courses and sections set up in the new school year

Courses will have the Single Term transcript definition in the previous and new school year
before running Copy student grades and assignments

Transcript records to be copied over will have both blank final marks and blank completion
dates

Students will have current year Primary or Secondary Associations to the school*

*Note: The Continuing Courses Procedures assume a student has a current year association to
the school. If a student is part of the Continuing Courses Procedures and does not have a
current year association to the school, there may be issues with student grade management
and reporting.
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2.0 Continuing Courses Procedures

2.1 What is the purpose of these procedures?

The Continuing Courses procedure provides a method for carrying courses, course dates, term
mark and comments forward to the next school year for students that are continuing their
studies. The procedures will run for students with transcript records where the final mark and
completion date are both blank in the previous year.

The procedure is broken into four distinct steps, across two different parameter screens.

Grades top tab > Transcript side tab > Options > Continuing Courses Procedure — Steps 1-3

Continuing Courses Procedure — Steps 1-3

This procedure is only used for continuing courses from one school year to the next.

After each step, verify the data prior to running the next step.

Step 1: Copy transcripts: This will copy transcript records from the previous school year
without a final mark and completion date.

Step 2: Copy student schedules: This will copy the student’s schedules forward based on the
transcripts that were copied. Note: the sections must be identical to the one in the previous
year.

Step 3: Copy student grades and assignments: Optional. This will copy the teacher’s
gradebook forward from the previous year. Note: the courses must have a single term transcript
definition for this to work.

School eSchool23

Select a step hd

Continuing Courses Procedure — Step 4

Continuing Courses Procedure — Step 4

This procedure is only used for deleting previous year's transcript records which have been
copied forward
NOTE: Only run this procedure once data has been verified, and steps 1-3 have been
completed. There is NO undo.

School eSchool23

Preview Mode

o
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2.2 What do the procedures do?

Step 1: Copy transcripts will create a new transcript record in the current year where a
student has the same course and section from the previous year, and the final mark and
completion date are blank. The Active date, Actual start date, Percent complete, Term
mark and comment will be copied into the new transcript record. This record is created in
the Student top tab > Transcript side tab. Comment only courses will not be copied
forward.

Step 2: Copy student schedules procedure will add the course that was not
completed in the previous year to the student’s current year timetable in Student top tab
> Schedule side tab. For this to happen, the school must have created a master
timetable in the school with course codes and section numbers that exactly match the
previous year course.

Step 3: Copy Student grades and assignments procedure will copy the gradebook
assignments with marks; the assignment start and due dates will be advanced by one
year. This procedure is designed to work with courses that have a single term transcript
definition in both the previous and current years. Do not run this procedure if the
transcript definitions on any courses are not single term.
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2.3 Steps Before and After EOYR

Before EOYR
e Set Build Year context ( next school year)
e Copy School Catalogue
e Copy Current Schedule (Build View)

e Ensure that students that have completed, have completed, have a FINAL MARK and
have a COMPLETION DATE in their transcript

o Confirm Next Year Students
After EOYR
e Create course sections
o Commit your School Schedule (From Build View)
o Manually create or adjust sections

¢ Review the records to be copied forward using the School view > Grades top tab >
Transcript side tab > Transcripts to Copy filter (enter in the previous year when
prompted)

¢ Run School view > Grades top tab > Transcript side tab > Options > Continuing Courses
Procedure steps 1-3, verifying data between each step.

e Prepare Grade Input (do not replace columns)

It may look like the columns are there, but this needs to be run to ensure they exist properly in
the new year.
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2.4 Running the Copy Transcripts procedure

The procedure can only be run Post EOYR. Prior to running the procedure, ensure that the
matching courses and sections have been created at the school. You can assign the Transcript
definition to the courses after the procedure has completed.

Continuing Courses Procedure — Step 1-3

This procedure is only used for continuing courses from one school year to the next.

After each step, verify the data prior to running the next step.

Step 1: Copy transcripts: This will copy transcript records from the previous school year without a
final mark and completion date.

Step 2: Copy student schedules: This will copy the student's schedules forward based on the
transcripts that were copied. Note: the sections must be identical to the one in the previous year.
Step 3: Copy student grades and assignments: Optional. This will copy the teacher’s gradebook
forward from the previous year. Note: the courses must have a single term transcript definition for
this to work.

School 2ag'amnik School

Select a step ~

2. Copy student schedules

3. Copy student grades and assignments

To run the Copy Transcripts Procedure:

In the School view, select the Grades top tab.
Click the Transcripts side tab.

In the Options menu, select 1: Copy transcripts.
Select Run.

o~

When complete, a pop-up message will identify the records that were created and the total
number of records updated, as well as the one’s that could not be created and the reason
that they were skipped.

2.4.1 What follow-up is required after the procedure is run?

If you are choosing to NOT run the Copy Student Grades and Assignments procedure, you
will need to update the Grade input records with the Active dates, to ensure that future
posting of grades does not overwrite the Active dates with a blank value.

If you planning to run the Copy Student Grades and Assignments procedure you DO NOT
need to run this process, as the Active dates will be populated in the Gradebook and the
Transcript record.
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To Update Gradebook (school is not running Copy Student Grades and Assignments

procedure):

In the School view, select the Grades top tab.
Click the Transcripts side tab.

Choose the Transcript records to update.
Click OK.

o0k wh=

In the Options menu, select Update Gradebooks
Choose Active date from the list of available fields to update

Update Gradebooks from Transcript

Column Active DateQ

Transcript Definition Single Term 10-12 2023 English %-LG

Update For
Current selection: 1049

() CurrentYear
() All Transcripts

D D
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2.5 Running the Schedule Students procedure

The procedure can only be run Post EOYR. Prior to running the procedure, ensure that the
matching courses and sections have been created at the school. Teachers may be assigned to
the sections prior to running the procedure but it is not necessary.

Continuing Courses Procedure — Step 1-3

This procedure is only used for continuing courses from one school year to the next.

After each step, verify the data prior to running the next step.

Step 1: Copy transcripts: This will copy transcript records from the previous school year without a
final mark and completion date.

Step 2: Copy student schedules: This will copy the student's schedules forward based on the
transcripts that were copied. Mote: the sections must be identical to the one in the previous year.
Step 3: Copy student grades and assignments: Optional. This will copy the teacher’s gradebook
forward from the previous year. Mote: the courses must have a single term transcript definition for
this to work.

School Anchor Academy (DL)

Select a step w

2. Copy student schedules

3. Copy student grades and assignments

To run the Schedule student Procedure:

In the School view, select the Grades top tab.

Click the Transcripts side tab.

In the Options menu, select Continuing Courses Procedure — Step 1-3.
In the pop-up window, check the 2. Copy Student Schedules option

N =

When complete, a pop-up message will identify the records that were created and the total
number of records updated, as well as the one’s that could not be created and the reason
that they were skipped.
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251 What follow-up is required after the procedure is run?
Run the process to Recalculate Enrollment Totals after the students have been scheduled into
the sections:

1. Inthe School view, select the Schedule top tab.
2. In the Options menu, select Recalculate Enroliment Totals.

Page 11
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2.6 Copy Student Grades and Assignments procedure

NOTE: Do not run this procedure unless both the previous and current year courses all have the
same Single Term Transcript Definitions.

Procedure is not designed to be run multiple times.

This procedure will allow the teacher created assignments and marks from a last-year course
section to be copied into the current year course section.

Continuing Courses Procedure — Step 1-3

This procedure is only used for continuing courses from one school year to the next.

After each step, verify the data prior to running the next step.

Step 1: Copy transcripts: This will copy transcript records from the previous school year without a
final mark and completion date.

Step 2: Copy student schedules: This will copy the student's schedules forward based on the
transcripts that were copied. Note: the sections must be identical to the one in the previous year.
Step 3: Copy student grades and assignments: Optional. This will copy the teacher’s gradebook
forward from the previous year. Mote: the courses must have a single term transcript definition for
this to work.

School Anchor Academy (DL)

Select a step L

1. Copy transcripts

2. Copy student schedules

3. Copy student grades and assignments

To run the Copy Student Grades and Assignments Procedure:

1. Inthe School view, select the Grades top tab.

2. Click the Transcripts side tab.

3. In the Options menu, select Continuing Courses Procedure Step 1-3.

4. In the pop-up window, check the Copy Student Grades and Assignments option

2.6.1 What follow-up is required after the procedure is run?

Teachers can continue to work in the Gradebook with the assignment marks that were copied
forward. It is important to note that only the gradebooks with students that are continuing in the
course from the previous year will be copied forward.

Teachers can add additional assignments to the gradebook if necessary.
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3.0 Delete Last-Year Transcripts procedure

This procedure is only used for deleting previous year’s transcript records which have been
copied forward

NOTE: Only run this procedure once data has been verified, and steps 1-3 have been
completed. There is NO undo.

Important Note: Before running this procedure ensure that you are confident that the transcript
records that were carried forward are correct. You can run this procedure in Preview Mode

School View>Grades Top Tab>Options>Continued Courses Procedure Step 4

Continuing Courses Procedure — Step 4

This procedure is only used for deleting previous year's transcript records which have been copied
forward

NOTE: Only run this procedure once data has been verified, and steps 1-3 have been completed.
There is NO undo.

School Anchor Academy (DL)

Preview Mode
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