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1.0 School Setup Tips for DL and CE Schools 

In a distributed learning or continuing education school, the school setup tasks outlined in the 
School Setup document should be completed.  Some additional information is provided below in 
the context of DL and CE schools.   

1.1 School Type 

Determines the format of the extract and the options available on the parameter pop-up window.  

• School type determines how some Ministry exports and reports are produced. 

• Regular and DL for all schools except Summer Schools 

• Summer School for Summer Schools only 

1.2 School Visibility When Selecting Schools 

Select School(s):  Select the school the extract is being run for.   

• School users will only have the option to select schools they are connected to.   

• District users will have the option to select multiple schools. 

Grades:  Use the drop-down menu to select the grades to be included in the extract.  

1.3 Distributed Learning – Active Course Date 

If the school type is a distributed learning or continuing education school, populate the 
appropriate Active Course Date for this 1701 reporting period (the first calendar day after the 
last funding snapshot date). 

• Active Date Preference Setting: School TT> Setup > Preferences > Grade category. 
This setting will define how the recording of the Active Date is managed at the school.  

 

Active Date is enabled by: 

• Disable – no automatic population of the Active date. Active date may be manually 
entered. 

• By Multiple Assignments – enables a flag on the Assignment detail default template 
allowing a teacher to indicate one or multiple assignments as being the trigger for the 
Active date to automatically populate. If the Active date flag is set for multiple 
assignments then ALL assignments with the flag set must have a mark entered for the 
Active date to automatically populate.  

• By First Assignment Mark only – the Active date is automatically populated when the 
first assignment mark is entered.  
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1.4 Calendars 

Calendars: School top tab > Calendars side tab (School Setup guide) 

• Ensure the school calendar has a name of Standard.   

• Calendars should still be assigned to the primary students in the school, even if 
attendance is not being taken.   

• Secondary students (cross-enrolled students) will have a calendar value assigned by 
their primary school.  This cannot be changed by the secondary school.   

 

1.5 Grade Terms, Schedule, Courses and Sections 

• Grade Terms: Grades top tab > Grade Terms side tab (School Setup or Grade 
Management guide) 

o Grade terms are required set up. If the DL or CE school issues report cards three 

times a year for elementary grades and four times a year for secondary level 

grades, then the K-12 grade term model may be appropriate. 

o For DL and CE schools that are not using MyEducation BC for regularly issued 

report cards, grade input may be prepared for only the final grade term (Q4 or Tri 3) 

so the final mark column appears for entry and posting to the transcript.  This 

assumes all courses are running in a Full-Year schedule term model. 

• Schedule Structure: Schedule top tab > Structure side tab 

o DL and CE schools commonly have a master schedule that has one full-year 

schedule term, one day and one period with all sections scheduled into the same 

period. Additional periods can be defined, if desired. 

• Courses: Schedule top tab > Courses side tab (School Setup guide or Elementary 
Scheduling guide) 

o Courses need to be set up with the appropriate transcript definitions 

o Single Term transcript definition must be used if the Continuing Courses Processes 

will be used in the school (Continuing Courses guide) 

• Sections:  Schedule top tab > Schedule Attributes side tab > Course Attributes sub-
side tab (Elementary Scheduling guide) 

o Most DL and CE schools will have one section of each course to assign to students; 

however, master schedules can be built for whatever model the school operates in. 

• Course Sections:  Schedule top tab > Master side tab > Sections sub-side tab 
(Elementary Scheduling guide) 

1. Assign teachers, schedule terms, schedule expression (period/day) and max 

enrollments.   

2. For DL and CE schools, all the sections need to be scheduled, but can be 

scheduled into the same day and period. 

 



 

DL & CE School Setup and Processes  v3.5 Page 6 

2.0 District Online School (DOLS) and Provincial Online 
School (POLS) 

There are two types of online learning schools identified by the Ministry:  

 

1. District Online Learning School (DOLS)  

• Catchment area boundaries are enforced 

• If a student’s postal code is outside the catchment area determined by the Ministry, the 

DL school will not be able to: 

a. Enroll the student to the school 

b. Cross-enroll the student from a primary school 

c. Schedule a student into courses in the DL school 

2. Provincial Online Learning School (POLS) 

• Catchment area boundaries are not enforced 

• The POLS school will be able to: 

a. Enroll any student in BC to the school 

b. Cross-enroll any student in BC from a primary school 

c. Schedule any student in BC into courses in the POLS 
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2.1 DOLS Catchment Area Boundary Enforcement 

2.1.1 Enrolling a student 

If a DOLS attempts to register a student who has a postal code outside of the catchment area 
boundaries for the school the following message will display: 
 

 

2.1.2 Cross-enrolling a student (creating a secondary school association) 

If a DOLS attempts to cross-enroll a student who has a postal code outside of the catchment 
area boundaries for the school the following message will display: 
 

 

2.1.3 Scheduling a student 

If a DOLS attempts to schedule a student into courses in a DL who has a postal code outside of 
the catchment area boundaries for the school the following message will display: 
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2.2 Setting a School to DOLS 

District View > District top tab > Schools side tab > Select the School Details  

or by adding the “District Online Learning School” field to a field set and then going to:   
District View > District top tab > Schools side tab > Options > Modify List   

 

 

 

School View > School top tab > Setup > Details.  Set the flag to Y.  
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2.3 Students Exempt from Catchment Area Boundary Rules 

If a student lives outside the catchment area for a District Online School, and the school 
chooses to accept the student to the school, there is a flag that must be set to complete the 
student registration. 

Notes:   

1. Refer to Ministry guidelines regarding funding for registered students living outside the 

catchment boundary for a school.  

2. Online Registration – accepting students outside catchment area boundaries: 

Refer to section 4.5.4.1 DOLS District Online Schools: Students Outside of Catchment 

Area Boundaries) in the Online Registration document for instructions on accepting a 

student registration when the student’s postal code is outside the catchment area 

boundary for a DOLS. 

 

School View > Student top tab > Details side tab > Address sub top tab > DOLS 
Exemption 

 

An Exempt from Catchment Reason should be entered if the student is exempt from the 
catchment boundary rules.  There is a limit of 25 characters in the field. 
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2.4  Identifying Students Outside of Catchment Area Boundaries 

School View > Student tt > Filter = DOLS Students Outside Catchment > Field Set = 
DOLS -Outside of District Postal Code 

The filter will display students in the current school who have the Exempt from Catchment flag 
set on the student record. 

• The filter can be run for: 

• All Active Students  

• Next Year Students 

• The default school = current school.  (Note: Do not change the name of the school in the 

filter parameters) 
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2.5 Students Outside DOLS Catchment Area Report 

The report identifies students in a DOLS who have been flagged as Exempt from Catchment 
and the Exempt from Catchment reason. It is run at both the District and School view. 

 

District View > Student top tab > Reports > Students Outside DOLS Catchment Area 

School View > Student top tab > Reports > Students Outside DOLS Catchment Area 

 

 

 

 

Only schools with the DOLS flag will display in the magnifying glass in the District View.  

In School View, the current school will display only if it has the DOLS flag set. If the report is run 
for a school where the DOLS flag has not been set, the results will be empty. 

 

 



 

DL & CE School Setup and Processes  v3.5 Page 12 

 



 

DL & CE School Setup and Processes  v3.5 Page 13 
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3.0 Scheduling Students into Courses 

Students can be scheduled into courses in two areas of the application: 

• Schedule top tab > Master side tab > select section > Roster leaf 

• Student top tab > Schedule side tab > Workspace sub-side tab 

3.1 Scheduling Multiple Students into the Same Course Section 

1. In the School view, select the Schedule top tab.  

2. Click on the Master side tab. This will open to the Sections sub-side tab.  

3. Click the Roster leaf.   

4. In the Options menu, select Add. The Multi-Add Students pop-up window will appear. 

5. Schedule Mode field can be left at Pull. 

6. In the Students section, click the Selection radio button. This will present a pop-up list of 
students to select. Use the search field to find the students and check the box beside 
their name as they appear. Multiple students can be selected at the same time.   

7. Click OK. 

8. In the Multi-Add Students pop-up window, ensure the Selected students count 
represents the correct number of students.   

9. Click OK.  The roster will now display the names of the students added to the section.  
The student schedule will also display the classes as scheduled.   

3.2 Scheduling an Individual Student into One or More Course 
Sections 

When scheduling students in DL and CE schools, users will likely find the List view best. The 
reason for this is that the common scheduling setup for these schools is to have all courses 
scheduled into the same day and period. A Matrix view is based on students’ classes being 
scheduled into multiple periods and/or days and therefore its functionality may be confusing to 
users. Step 3 below explains how to change to the list view if the screen is in matrix view when 
entered. 

1. In the School view, select the Student top tab.  

2. Check the box beside the student requiring a schedule. Click the Schedule side tab. 

3. Select the Workspace sub-side tab. For DL schools, List view is the best view for 
scheduling students. If, upon entering the screen, there is a grid with days and periods 
displayed on the right hand side, look in the upper right corner of the schedule screen for 
the blue hyperlink that says << List view. Click it to display the workspace in the list view, 
as below: 
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Note that this screen may have a Pending Schedule Changes section in between the 
two sections displayed below if the school has the preference set to Allow Future 
Adds/Drops enabled in School top tab > Setup side tab > Preferences > Category = 
Schedule.  This section can be ignored when scheduling a student into sections. 

4. To add a specific course section to a student, click the Select button in the Student 
Schedule area.     

 

This will present the Schedule Master Pick List pop-up window.   

• If the course pick list is empty, this can be due to courses not having schedule 
expressions, or courses having reached their maximum enrollment.  A user may 
uncheck the Valid sections only box to the upper right of the picklist so all 
sections are displayed. 

• DL and CE schools with all sections scheduled into the same day/period will 
want to check the Allow conflicts checkbox to the upper right of the picklist to 
allow multiple sections with the same schedule expression to be selected.   
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5. Use the search window to find the course sections required for the student schedule.  
Check the box beside the desired section.  Multiple sections can be selected in the same 
window.   

• If the selected course has reached is maximum, but approval has been given to 
exceed the maximum, the user can check the Allow all over max box above the 
picklist to the right.  This will let the student into the selected sections.    

 

 

6. Click OK.  This will return you to the main student schedule window, with the sections 
displayed.   

7. Click Post to make the schedule changes permanent.   

8. Go to the Course Requests section and click the Update button.  If course sections are 
accidentally dropped from the student schedule, this section will preserve the courses 
that were selected.  Note that this is a course request screen and will not show the 
section the student was scheduled into, only the courses.   

Note:  The Change History sub-side tab within the Schedule side tab will display any changes 
made to the student schedule within the current year, as well as the date the change was made 
and the user who made the change.  
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3.3 Scheduling Course Sections for Students for Future Dates 

This function is available both on the class roster for multiple students, or in the student 
workspace for an individual student.   It requires that the school preference has been set to 
Allow future add/drop.   

To use this function to schedule multiple students into a roster for a future date: 

1. In the School view, select the Schedule top tab.  

2. Click on the Master side tab.  This will open to the Sections sub-side tab.  

3. Click the Roster leaf.  A field will appear at the top called Effective Date =.  

4. Populate the date field with the date that the students to be selected should be added to 
the roster.   

5. Follow the steps above to schedule multiple students into the same course section. 

6. The student will display on the roster and the student schedule screen will indicate a 
pending change. 
 

To use this function to schedule an individual student into a roster for a future date: 

1. In the School view, select the Student top tab.  

2. Check the box beside the student requiring a schedule.  Click the Schedule side tab. 

3. Select the Workspace sub-side tab.  A field will appear at the top called View and make 
changes as of. 

4. Populate the date field with the date that the subsequently selected sections should be 
added to the student schedule.   

5. Follow the steps above to schedule an individual student into one or more course 
sections. 

6. When the student schedule is posted, the future change will appear in the student 
schedule in bold type and the Pending Student Schedule Changes section will display 
the section that will become permanent on the student section on the specified date. 

7. In the Pending Student Schedule Changes section, the user can click the 

 button to have the schedule reflect the section as immediately active 
on the student schedule.   Alternatively, checking the box beside the Add in this section 

and clicking  will remove the change from the student schedule. 
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4.0 Grade Management 

DL and CE schools will prepare grade input for terms and dates using the same process as 
regular schools.  This will present the columns for entering term grades and dates as necessary.  
Instructions for both of these processes are provided in the Grade Management guide and 
Grade Management checklist.     

Grade entry and posting, as well as course date entry and posting can be done by office admin 
staff or through the teacher gradebook functions outlined in the Grade Management guide.    

Note:  Active Dates and Completion Dates 

Depending on the School Preference settings, the entry of a selected assignment(s) mark by a 
teacher will trigger an Active Date to be populated for that student for that particular course or 
the date can be manually populated into the Grade Input or Gradebook > Scores screen.  When 
course dates are posted, this will populate the student transcript record and appear in the 1701 
and SADE extracts.  Similarly, the entry of a final mark for a course by either a teacher or office 
admin staff will automatically populate a completion date. When dates are posted the 
completion date will populate the student transcript record and appear in the 1701 and SADE 
extracts, DVR and School Transcript reports.  Completion Dates are also required for some 
funding situations with adult students. 


