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1.0 Annual Instructional Plan 

Annual Instructional Plans (AIP) are developed and implemented by specialist 
English Language Learning (ELL) educators. Specialist educators work collaboratively 
to identify, plan and provide services and integrated instruction to ELL students. 
Ongoing ELL assessment and review is used to report student progress towards their 
ELL goals. 

The MyEducation BC Annual Instructional Plan provides functionality within the student 
record for School and District ELL specialists to plot a student’s language proficiency in 
one of the provincial proficiency levels based on assessment and observation of the 
student’s language proficiency in domains of speaking, listening, reading, and writing. 
The AIP allows a user to apply a set of supports and objectives based on the proficiency 
levels across a group of students and create custom goals for individual student needs. 

• Identifies language and literacy goals 

• Provides link between assessment, instruction, and reporting 

• Identifies instructional strategies, adaptations, and resources 

• Specifies the nature of support 

 

1.1 District Process 

 

  

Who will be creating 
and maintaining 
AIP’s

Who
Where will they be 
doing the work 
from?

District View

School View

Student Services 
View

Staff View

Where How do you want to 
run the Copy AIP 
procedure or get 
your users to create 
new individual 
ones?

How will you give 
the Teacher access 
to the students ie 
Scheduling a class 
or homeroom?

How
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1.2 Security Roles  

1.2.1 Base Roles 

The following roles have access to create, update, and delete an AIP: 

• District View: District Support (Help Desk/Level 1) 

• School View: Clerical - SIS Admin, School Administrator, Clerical - SIS Clerk 

• Student Services School View: Student Services – School, Student Services: Enroll & 

Read - School – this role cannot print report, but can create and update AIP 

 

The ability to run the Copy AIP Procedures is defined in their specific sections. 

1.2.2 Add On Role for Staff View 

 

AIP Add-On - Staff

 

 

Teacher Role 

• By default, the enterprise Teacher role has the ability to read AIP plans. To create, 

update, and delete an AIP they will also need the AIP Add-On – Staff role. The ability to 

run the Copy AIP Procedures is defined in their specific sections. 

• If a District is using custom roles, staff using Staff View will need the add-on role to 

create, update, and delete an AIP. The ability to run the Copy AIP Procedures is defined 

in their specific sections. 

• This role only grants the user the ability to add an assessment (Student Top Tab > 

Assessment Side Tab) already attached to the student record, to the AIP in the 

Language Assessment Information Sub Top Tab within the AIP (Student Top Tab > 

Documents Side Tab > Ed. Plans) 

• A teacher must be attached to a course and section with students assigned to have 

access to the student’s AIP in Staff View. 

  



 

ELL Annual Instructional Plan v1.9 Page 6 

1.2.3 Add On Role for School View 

School view users with this security add-on role have permission to create, read, update, print, 
and publish AIPs from the “Documents” side tab. This change is expected to help schools where 
a non-enrolling English Language Learner (ELL) specialist prepares AIPs for the whole school.  

 

AIP Add-On - School 

 

School View Role 

• This role only grants the user the ability to add an assessment (Student Top Tab > 

Assessment Side Tab) already attached to the student record, to the AIP in the 

Language Assessment Information Sub Top Tab within the AIP (Student Top Tab > 

Documents Side Tab > Ed. Plans) 

 

AIP Creation 

AIP plans are created the same way in District, School, Staff and Student Services view from 
the following paths.  

District View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select Dictionary: 
Annual Instructional Plan > Add 

School View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select Dictionary: 
Annual Instructional Plan > Add 

Staff View: Student Top tab > Documents Side Tab > Ed Plans Lea f> Select Dictionary: 
Annual Instructional Plan > Add 

Student Services View: Student Top Tab > Documents Side Tab > Ed Plans Leaf > Select 
Dictionary: Annual Instructional Plan > Add 
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1.3 AIP Creation Business Rules 

The AIP plans are created based on the following Business Rules 

• One Active status AIP for a student in the current year 

• Multiple Draft status AIP are possible for a student in the current year  

• Copy procedure business rules are defined in their specific sections 
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2.0 Create an Annual Instructional Plan 

The Annual Instructional Plan is created in the same way at District and School View. Following 
are the components of the process for an ELL specialist to create an AIP. 

1. Select Student information 

2. Add English Language Assessment Information  

3. Add Language and Literacy Goals 

4. Add Support Plans for Language Development  

5. Add Language Development Support Strategies  

 

 

 

2.1 Annual Instruction Plan Icon 

 

The Annual Instructional Plan Icon on the student demographics displays when: 

• The plan Status field = “Active” 

• Effective date field Is not empty. 

 

  

Saving often in plans is highly recommended. 
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2.2 Annual Instruction Plan Icon Details 

 
The user can click on the AIP Icon to see the plan information. AIP Icons display the summary 
of the annual instructional plan attached to the student. 

  

Field Description 

AIP Developer  Displays the Staff/AIP Developer Name 

Case Manger Displays the case manager name 

Language Overall Level Beginning, Developing, Expanding, Consolidating, Bridging 

AIP Developed On Beginning, Developing, Expanding, Consolidating, Bridging 

Effective Date Display date the Plan is effective   If Status = Active and the Effective 
Date field is filled then AIP icon will show for student 

End Date Display the date the Plan will end 

Listening & Speaking Level Beginning, Developing, Expanding, Consolidating, Bridging  

Reading Level Beginning, Developing, Expanding, Consolidating, Bridging 

Writing Level Beginning, Developing, Expanding, Consolidating, Bridging 

Language Development 
Support Strategies 

Displays the Language Development Support Strategies against the AIP 
for the student 
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2.3 Create an Annual Instructional Plan  

1. Click Student top tab > Documents side tab > Ed Plans leaf 

2. Click on Dictionary > Annual Instructional Plan 

 

Field Description 

Extended Dictionary Name Annual Instruction Plan  

Status  Default = Draft 

Select plan status as appropriate from the dropdown list:  

Draft, Active, Previous, Rejected, Discarded 

If Status = Active then AIP icon will show for student 

School Year This field will populate entered school year  

Language Overall Level Beginning, Developing, Expanding, Consolidating, Bridging 

Listening & Speaking Level Beginning, Developing, Expanding, Consolidating, Bridging  

Reading Level Beginning, Developing, Expanding, Consolidating, Bridging 
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Field Description 

Writing Level Beginning, Developing, Expanding, Consolidating, Bridging 

Staff>Name This field will display the Case Manager Name.  In District view it will 
only show TOC’s as they are owned at the District level not the School 
level. 

Effective Date Display date the Plan is effective 

End Date Display the date the Plan will end 

3. Click Options > Add 

4. If you have not selected a definition in the Dictionary icon, you will get the following error 

message 

 

 

Fill in the Annual Instructional Plan using the top tabs of the plan: 
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2.4 Student Details Tab 

1. Select the Student Details tab and enter required details for Student Information (see 

below for field details).  This tab has required fields (shown with a red asterisk * ) that 

must be populated to save the plan. 

2. When complete, click Save before moving to the next tab 

 

Field Description 

Type (Required) Default = ELL 

Select appropriate type from the dropdown  

ELL, FLL 

Status (Required) Default = Draft 

Select plan status as appropriate from the dropdown list:  

Draft, Active, Previous, Rejected, Discarded 

If Status = Active and the Effect Date field is filled, then AIP icon will show 
for student 

AIP Developer (Required) Select the Developer name from the picklist.  Pulls from the Staff list of 
Active school 

Case Manager 
(Required) 

Select the Case Manager name from the picklist. Pulls form the Staff list of 
Active School 

Language Overall Level Default = Blank  

Select the appropriate overall level for the student from the dropdown list:  

Beginning, Developing, Expanding, Consolidating, Bridging 
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Field Description 

School Year (Required) This field will populate with the current school year  

AIP Developed On 
(Required) 

This field will populate with the current date (Today’s date)  

Effective Date (Required) Enter date the Plan is effective  

End Date Enter the date the Plan will end 

Review Date 1 This field is available to track the review Date of the plan 

Review Date 2 This field is available to track the review Date of the plan 

Review Date 3 This field is available to track the review Date of the plan 

Review Date 4 This field is available to track the review Date of the plan 

Years of ELL This is a read only field and will display the Years of ELL count 

Listening & Speaking 
Level 

Default = Blank  

Select the appropriate overall level for the student from the dropdown list:  

Beginning, Developing, Expanding, Consolidating, Bridging 

Reading Level Default = Blank  

Select the appropriate overall level for the student from the dropdown list:  

Beginning, Developing, Expanding, Consolidating, Bridging 

Writing Level Default = Blank  

Select the appropriate overall level for the student from the dropdown list:  

Beginning, Developing, Expanding, Consolidating, Bridging 

Additional Comments  This Rich Text field is for creating comments, adding tables, adding 
images etc. 

Note: If pasting text into this field, copy from the source as plain text. 
Format within the existing text editor in the AIP. 
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2.5 Language Assessment Information Tab  

Add student assessments to student Annual Plan at District/School View.  Three sections are 
available for each area of assessment in this tab: 

• Listening and Speaking  

• Reading 

• Writing  

2.5.1 AIP Assessments 

Users can view and create student assessment records in MyEducation BC in multiple screens.   

2.5.1.1 Assessment Top Tab > Student Assessments Side Tab > Assessment 
History/Entry Sub Side Tabs in District, School and/or Staff view.   

Student assessment records display and can be created for individual or multiple students.  

Select an Assessment Definition from the magnifying glass. 

 

Click Options > Add 
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Select the student from the picklist and complete the form. 

Note: Only Assessments with Type = District will populate on an AIP.  You can see the  
Type =? in School View > Assessment Top Tab > Assessment Definitions Side Tab 

When you create an assessment at the district level it will automatically give it Type = District. 

 

2.5.1.2 Student Top Tab > Assessments Side Tab in District, School, and Staff view.  

Student assessment records display individually and can be created individually.  

Select an Assessment Definition from the magnifying glass. 
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Select the student from the picklist and complete the form. 

Note: Only Assessments with Type = District will populate on an AIP.  You can see the  
Type =? in School View > Assessment Top Tab > Assessment Definitions Side Tab 

When you create an assessment at the district level it will automatically give it Type = District. 

 

2.5.2 Multi-Add button 

Multi-Add button will only show existing assessments that have been added to the student 
record. 

 

In each section, use the Multi-Add button to select one or more student assessments for each 
area. 

1. Click Multi-Add button in each section (one by one) 

2. In the pop up, select one or more assessments for that section and click OK 

3. Select the Level for the section 

4. Click Save at the bottom of the screen 

Move to the next area of assessment section and repeat the steps  
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2.6 Language and Literacy Goals Tab 

Add Language and Literacy Goals to student Annual Plan at District/School View.  Three 
sections are available for each area of assessment in this tab: 

• Listening and Speaking  

• Reading 

• Writing  

The top of the screen displays the student Levels entered for each area that were entered in 
the Student Details tab of the plan for quick reference.   

In each section, use the Add button to select one or more student goals for each area. 

 

To Add Goals for each section: 

1. Click Add  

2. In the pop-up enter the fields from the table below and click OK   

Field Description 

Sequence No. (Required)  Sequence No. sets the order for comments displayed on both 
the screen and the AIP report. Sequence Number – sorts 
them based on the sequential number, starts at 0, 0 would be 
the first one 

Comment Bank – Category (Required) Select the Comment Bank – Category from the dropdown:  

Intermediate, Secondary, Kindergarten, Primary  

Comment Bank – Subcategory 
(Required) 

Select the Comment Bank – Subcategory from the dropdown:  

Beginning, Bridging, Consolidating, Developing, 
Establishing, Expanding, Pre-Stage 

Listening and Speaking Goals 
(Required) 

Select the appropriate student goals for the area by clicking 
on the goal at the right.  
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Note: Collapse or expand the Goal bank using the black arrow at the top right of the Goals 
section.   

Note:  Freeform text goals can be entered in the Goals section for customization and can be 
combined with goals from the goal bank.  

 

Click OK in the pop up, the Goals will then display on the screen  

 

Click Save at the bottom of the screen and proceed to the next Goal section. 
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2.7 Nature of Support Tab 

Add Support Plans to student Annual Plan at District/School View.   

1. Click Add 

 

 

In the pop-up Enter the sequence number and Plan from the bank 

1. In the pop-up Enter the Sequence Number 

2. Click on the Black Triangle to expand the bank section 

3. Select Category: EN Plans 

4. Select one or more Support Plans from the comment bank 

5. Click OK 

6. Click Save 

 

Note: Collapse or expand the Goal bank using the black arrow at the top right of the Goals 
section.   

Note:  Freeform text goals can be entered in the Goals section for customization and can be 
combined with goals from the goal bank.  
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2.8 Language Development Support Strategies Tab 

Add Language Development Support Strategies to student Annual Plan at District/School 
View.   

 

 

Following are the Steps to Add Language Development Support Strategies 

1. Click Add 

In the pop-up Enter the sequence number and Plan from the banks 

1. In the pop-up Enter the Sequence Number 

2. Click on the Black Triangle to expand the bank section 

3. Select the Strategies Category for this support item 

• EN Listening, EN Reading, EN Speaking or EN Writing 

4. Select Category: 

• Listening, Reading, Speaking or Writing  

5. Select one or more Language Development Support Strategies from the comment 

bank  

6. Click OK 

7. Click Save 

Note: Collapse or expand the Goal bank using the black arrow at the top right of the Goals 
section.   

Note:  Freeform text goals can be entered in the Goals section for customization and can be 
combined with goals from the goal bank.  
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3.0 Annual Instructional Plan Report  

The Annual Instructional Plan report is available in the District, School and Staff view, and users 
with publish rights can publish the AIP to the Student and Family Portal from District and School 
view. The Report prints for those students who have an AIP. The Report contains the 
information sections available in the AIP screen: 

▪ Student Information 

▪ English Language Assessment Information  

▪ Language and Literacy Goals 

▪ Support Plans for Language Development  

▪ Language Development Support Strategies  

 

3.1 Print/Publish the Annual Instructional Plan Report  

Staff/School/District view > Student top tab > Reports > Annual Instructional Plan 

A pop-up parameter screen displays the options available when running the report:  
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Fill in the fields of the parameter form  

Field Description 

Organization District Name 

School(s) In School view: School Name 

In District View: Select one or more of the schools in the district 

School Year Default = Current School Year, select previous years with the picklist 

Students to Include Default = Current selection 

Select the appropriate value from the drop down: 

Current Selection, All, YOG or Snapshot 

Staff View: Students to Include = Current Selection 

Sort Results By Default = Name 

Select the appropriate value from the drop down:   

Name, YOG, Homeroom 

Status Default = Active  

Select the AIP Status for the report(s) as appropriate from the drop 
down:  

This dropdown is set to Active by default, but it contains the 
following options 

Draft, Active, Previous, Rejected or Discarded  

Name to be printed Default = Usual Name.  
Option to select Legal Name or Cultural/Traditional Name 

Print in French Language  Checked: Produces the report in French  

Un-Checked: Un-checked by default, produces the report in 
English 

Print Double sided Default = Checked 

Format Default = Adobe Acrobat (PDF)  

Select the Format of the report from the dropdown list:  

Adobe Acrobat (PDF), Webpage (HTML), Microsoft Excel (XLS), 
Comma-separated values (CSV) 

Publish – tab (see below) To publish the report to the Student and Family Portal:  

Select the Delivery type: (Publish or Preview) and fill in the email 
subject and body that will notify the students and parents the report 
is available in the Portal for download.   
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Fields Descriptions 

Delivery 
Type 

Publish or Preview  

Previewing a report does everything except send a notification email and put the report 
into the Published Reports widget. 

The current roles that allow the user to see and use the Publish tab are: 

• Clerical - SIS Admin 

• School Administrator 

• Publish Add On Role – School View 

• Publish Add On Role – Staff View 

• Core Report Delivery Job Create=yes  

Email 
Message 

A default email message appears. Edit the text if needed. 

 

Viewing Start 
Date 

 

Viewing End 
Date 

This is the date that you want the report to appear in the Published Reports widget. 
Default value is today. Edit if needed. 

 

This is the date that you want the report to disappear from the Published Reports 
widget. Default value is two weeks from today. Edit if needed. 

 

Note: All published reports must have a viewing end date. They can not display 
in the widget indefinitely. 

 

Cleanup 
Date 

This is the date that the report and publish log are completely removed from the 
system. Default value is one week after the viewing end date. Edit if needed. 
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3.2 Sample Annual Instructional Plan Report:  
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4.0 Copy AIP Procedures 

4.1 Copy Validations 

When copying an AIP there are the following rules for the effective and end date fields 

• The effective date must be within the school year selected 

• The effective date must be before the end date 

• The effective date and end date must be different dates 

These rules are in the following procedures 

• Copy Active AIP to Selected Year for Multiple Students 

• Copy AIP to Selected Year 

• Copy Annual Instructional Plan From Selected Student 

4.2 Copy AIP from Selected Student Procedure 

The Copy Annual Instructional Plan procedure will copy a previously created student plan to all 
the students in a selected snapshot, regardless of enrollment in an ELL program.  
Snapshots can be created at the District, School and Staff view, and the level determines the 
ownership of the snapshot.   

Create a snapshot:  

1. Staff, School, or District view > Student top tab > Select the students to include > 

Options > Show Selected. 

2. Confirm the students in the list are correct 

3. Options > Snapshots 

4. In the pop-up Click the New button, name the snapshot, select the owner and ensure 

the records to include is set to Current List 

Note: In Staff view the students in a snapshot are limited to the students the teacher has access 
to e.g., students also available in the ‘Students in My Classes’ and ‘Students in My Homeroom’ 
filters.   A snapshot is different from a filter. Where a filter is dynamic and always returns the 
latest data, a snapshot is a static list. It always displays the same records unless it is manually 
edited. Only the user who created the snapshot can add or remove students from it. 

Details on Snapshots are found in the Snapshots section of the Fundamentals guide located 
on the MyEducationBC.info site.  

In Staff View Copy AIP Procedure will copy the students where the teacher is the Primary 
Teacher.  This is set up in School View>Schedule Top Tab 

4.2.1 Security Roles 

Only the Security Roles defined in the following subsections have access for running the Copy 
Annual Instructional Plan from Selected Student Procedure. 
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4.2.1.1 Base Roles 

The following roles have access to run the Copy Annual Instructional Plan From Selected 
Student Procedure:  

• District View: District Support (Help Desk/Level 1)  

• School View: Clerical - SIS Admin, School Administrator, Clerical - SIS Clerk  

4.2.1.2 Add On Role for Staff View 

If your District is using custom roles, staff using Staff View will need the following add-on role to 
run the Copy Annual Instructional Plan From Selected Student Procedure. 

 

4.3 AIP Add-On – Staff Role 

 

Teacher Role 

• By default, the enterprise Teacher role has the ability to read AIP plans. To run the Copy 

Annual Instructional Plan From Selected Student Procedure, they will also need the AIP 

Add-On – Staff role 

4.3.1 Navigation: Copy Annual Instructional Plan From Selected Student 
Procedure 

The Copy Annual Instructional Plan From Selected Student Procedure is run the same way 
in District, School, and Staff views from the following paths.  

District View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into 
an existing Annual Instructional Plan for a student > Options > Copy Annual Instructional Plan 
From Selected Student  

School View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into 
an existing Annual Instructional Plan for a student > Options > Copy Annual Instructional Plan 
From Selected Student  

Staff View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into an 
existing Annual Instructional Plan for a student > Options > Copy Annual Instructional Plan 
From Selected Student  
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4.3.2 AIP Creation Business Rules 

In addition to the business rules noted above for creating AIP plans, the copied AIP plans have 
the following additional Business Rules 

• Copy Annual Instructional Plan From Selected Student procedure when run at the School view 
applies to Primary Active students in the School  

• Copy Annual Instructional Plan From Selected Student procedure when run at the District 
applies to Primary Active students in the District  

• Copy Annual Instructional Plan From Selected Student procedure will skip a student with an 
existing Active status AIP in the current year 

 

Following are the steps to copy a procedure from school view 

1. Click Student top tab > Select a Student > Documents side tab > Plans > Ed Plans 

2. Click into the Annual Instructional Plan for the selected student  

3. Options > Copy Annual Instructional Plan from Selected Student 

 

 

In the pop up, fill in the parameters for the copy procedure 

 

Note: Snapshot ownership determines which users can see which snapshots. E.g. a District 
user can use snapshots created with ownership for District and School but the school user can 
only use snapshots that have ownership at school level.  

Only Use Copy Annual Instructional Plan from Selected Student  
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Field Description 

Snapshot of students to 
copy to  

Select the student snapshot (created above).  The snapshot contains the 
students that will receive a copy of this AIP in their Ed. Plans side tab. 

School Year Default = Current School Year,  

To create a next year plan, select the next school year with the picklist 

Status Default = Active  

Select one of the following statuses from the dropdown list  

Active, Draft 

Note: The value selected from this dropdown will be the status on all 
of the new student plans  

Effective Date Enter the Effective Date, this date identifies the start of the Plan delivery, 
and determines when the AIP icon is active.  

Note: The date entered will be the Effective Date on all of the new 
student plans 

End Date Enter the End Date this date identifies the end of the Plan delivery, and 
determines when the AIP icon is active.  

Note: The date entered will be the End Date on all of the new student 
plans 

Preview  Checked: It will be checked by default and provides the opportunity to 
confirm the settings in the parameter screen are correct. Results 
message is displayed giving the user information to adjust the settings or 
snapshot. 

Un-Checked: Runs the copy procedure and creates AIPs for the 
students in the snapshot 

Note: It is highly recommended to run the copy procedure in Preview 
mode first to confirm details before creating multiple Plans  

When the Procedure is run in either Preview or copy mode, a results message pop up displays 
to confirm the details of the run.    

Note: It is highly recommended to run the copy procedure in Preview mode first to confirm 
details and results before creating multiple Plans. 

4.3.3 Copy Annual Instructional Plan From Selected Student Procedure Results  

Here is a sample log message and the list of Business Rules that apply to the Copy AIP 
Procedure. 
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Log Message 
 

 
 

List of Business Rules and Error Messages 

No. Business Rule Error Message 

1.  If student has an active AIP – skip student Student already has Active AIP Plan 

 

2.  If Student does not have an active enrollment 
status – skip student  

Student does not have Active status 

 

3.  If student is not primary at the School running 
the procedure – skip student 

Student is not primary to the selected school 

 

4.  If student is not primary at the District running 
the procedure – skip student 

Student is not primary to the selected district 

 

5.  Staff View – If students included in the 
snapshot selected are not in a section or 
homeroom taught by the teacher – skip student 

The remainder of the skipped students are 
not in a class or homeroom taught by this 
teacher 

 

 
Note: In Staff view the students in a results file are limited to the students the teacher has 
access to e.g. students also available in the ‘Students in My Classes’ and ‘Students in My 
Homeroom’ filters.    
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4.4 Copy AIP to Selected Year Procedure 

The Copy AIP to Selected Year procedure will copy existing Annual Instruction Plans forward 
to the School Year selected by the user. The copy forward functionality will be for a single 
student only. The user is able to select existing AIPs having any status – e.g., ‘Draft’, ‘Active’, 
‘Previous’, ‘Rejected’, ‘Discarded’ – and the next year AIP will be created in ‘Draft’ status. 

For the copy forward functionality, all details from all tabs in the current year AIP will be exactly 
duplicated to the next year AIP. The user does, however, have the option to Include Language 
Assessments in the copy forward Procedure. Deselecting the Include Language Assessment 
checkbox leaves the Language Assessment Information tab blank. 

4.4.1 Security Roles 

4.4.1.1 Base Roles 

The following roles have access to run the Copy AIP for Selected Year Procedure:  

• District View:  District Support (Help Desk/Level 1)  

• School View:  School Administrator, Clerical – School Admin Assistant, Clerical - SIS Admin, 
Clerical - SIS Clerk  

4.4.1.2 Add On Role for Staff View 

If your District is using custom roles, staff using Staff View will need the following add-on role to 
run the Copy AIP to Selected Year Procedure. 

AIP Add-On – Staff 

 

Teacher Role 

• By default, the enterprise Teacher role has the ability to read AIP plans. To run the Copy 

AIP to Selected Year Procedure, they will also need the AIP Add-On – Staff role 

4.4.1.3 Add On Role for School View  

School view users with the security add-on role of AIP Add-On - School will have permission to 
run the Copy AIP to Selected Year Procedure. 
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School View Role  

• This role grants the user the ability to run the Copy AIP to Selected Year Procedure. 

4.4.2 Navigation: Copy AIP to Selected Year Procedure 

The Copy AIP to Selected Year Procedure is run the same way in District, School, Staff and 
Student Services views from the following paths.  

District View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into 
an existing Annual Instructional Plan for a student > Options > Copy AIP to Selected Year  

School View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into 
an existing Annual Instructional Plan for a student> Options > Copy AIP to Selected Year 

Staff View: Student Top tab > Documents Side Tab > Ed Plans Leaf > Select and click into an 
existing Annual Instructional Plan for a student > Options > Copy AIP to Selected Year 

4.4.3 AIP Creation Business Rules 

In addition to the business rules noted in section 1.3 for creating AIP plans, the copied AIP 
plans have the following additional Business Rules 

• Copy AIP for Selected Year procedure when run at the School view applies to Primary Active 
students in the School  

• Copy AIP for Selected Year procedure when run at the District view applies to Primary Active 
students in the District  

4.4.4 Copy AIP to Selected Year process  

Following are the steps to copy a procedure from school view: 

1. Click Student top tab > Select a Student > Documents side tab > Plans > Ed Plans  

2. Click into the Annual Instructional Plan for the selected student  

3. Options > Copy AIP to Selected Year  

  

 

In the pop-up fill in the parameters for the copy procedure 



 

ELL Annual Instructional Plan v1.9 Page 33 

  

Field Description 

Copy to School year Select the school year for copying the AIP to – i.e. Next Year. 

 

Click the magnifying glass to open the list of values, search for and 
select a school year then click the [OK] button. 

 

School year is a required field. 

Effective Date Enter/ select Effective Date for populating to the newly created AIP 
document. Effective Date is an optional field. 

Leave blank to have Effective Date auto-populate with start date of 
selected school year. 

End Date Enter/ select End Date for populating to the newly created AIP 
document. End Date is an optional field. 

Leave blank to have End Date auto-populate with start date of selected 
school year. 

Include Language 
Assessments 

Select/check the Include Language Assessments checkbox to copy 
data in the Language Assessment Information tab from the current year 
AIP to the Selected Year AIP. 

 

Include Language Assessment checkbox is mandatory and is 
selected/checked by default. 
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4.4.5 Copy AIP to Selected Year Results  

Here is a sample log message and the list of Business Rules that apply to the Copy AIP 
Procedure.  

Log Message  

 

 

 

List of Business Rules and Error Messages  

No. Business Rule Error Message 

1.  If the student status is not active Cannot create AIP as the student enrollment status 
is not active 

2.  If the current School is not a primary 
School 

Cannot create AIP as the student is not primary to 
this school 

3.  If the current District is not the primary 
District 

Cannot create AIP as the student is not primary to 
this district 
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5.0 AIP Status Update Procedure 

The purpose of BC AIP Status Update Procedure is to update the “Status” of annual 
instructional plans attached to the student based on the plan effective and end date. One 
Student can have one “Active” AIP plan at one time. There might be multiple AIP’s attached to a 
student in a “Draft” or “Previous” status. The Procedure is available at district and school views. 

5.1 BC AIP Status Update Procedure 

Following are the steps to run the procedure from school view 

1. Click Student top tab > Select a Student > Documents side tab > Plans > Ed Plans 

2. Click into the Annual Instructional Plan for the selected student  

3. Options > BC AIP Status Update Procedure 

 
 
 

 
 

Note: If you run this procedure from school view, only current school is selected in the 
“school(s)” pick list. When the procedure runs from the district view, list of all the schools in the 
current district appears and the user can select multiple schools from the picklist. 
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Field Description 

Organization Displays the district name 

School(s) Displays the School ID  

Preview  Checked: It will be checked by default and provides the opportunity to confirm the 
settings in the parameter screen are correct. Results message is displayed giving 
the user information to adjust the settings 

Un-Checked: Runs the BC AIP Status Update Procedure which updates the AIPs 
for the students in the school 

Note: It is highly recommended to run the procedure in Preview mode first to 
confirm details before updating multiple plans 

 

5.2 AIP Status Update Procedure Results  

Here is a sample log message and the list of Business Rules that apply to the BC AIP Status 
Update Procedure. 

Log Message 

 

List of Business Rules 

No. Business Rule 

1.  One AIP can be in Active status at one time with one student 

2.  If the end date of the plan is equal to or greater than today’s date and the plan current status is “Active” 
it will update the plan status to “Previous” 

3.  If the effective end date of the plan is less than today’s date and the plan current status is “Draft” it will 
update the plan status to “Active” 

4.  Any Plan with “Previous” status won’t be processed/updated 

5.  If a student with more than one plan has same “Effective Date” with a “Draft status”, the most recently 
updated plan will be processed and the status will be updated from “Draft” to “Active” once the 
procedure runs 
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6.0 Comment Banks for District and School Users 

District and school ELL specialists can add their own comments in the Provincial Annual 
Instructional Plan comments banks. Following are the comment banks used for Annual 
Instructional Plan: 

• AIP Goals – Listening and Speaking 

• AIP Goals – Reading 

• AIP Goals – Writing  

• AIP Plans 

• AIP Strategies 

To add district and school specific comments please refer to document “School-Setup” and 
section 7.0 for school specific comments and “District Setup” and section 6.0 for adding 
district specific comments in the comment banks 

District View > Admin Top Tab > Data Dictionary Side Tab > Comments Sub Side Tab > 
Filter = All records > Select AIP Comment Bank > Codes Sub Side Tab 

 

1. Click into AIP Comment Bank 

2. Code Sub Side Tab 

3. Filter = All Codes 

4. Options Add 

• Defaults the owner of that code to the district created 

• ID has to be unique from previously created 

• Comment Preview – what is displayed 

• Comment – What goes on the plan 

 


