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1.0 Purpose 

The purpose of this document is to provide information and instruction for setting up a next year 
master schedule for elementary schools. 

 

2.0 Preparing for Build 

Next year setup for students, teachers and courses will be done in the Build view.  There are 
some tasks that will need to be completed so the necessary information is available in the Build 
view. 

2.1 Security 

School users that will be accessing the Build view will require the following security role: 

• Schedule Builder 

2.2 School Details 

To use the Build view, the Build Year Context must be set to the appropriate year in the school’s 
details.  

 To set the Build Year Context: 

1. In the School view, select the School top tab.  

2. Click the Setup side tab. 

3. Select the Details leaf. 

Prepare for 
Build

Workspace  
and loading 

students 

After EOYR 
commit 

schedule
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4. In the Build Year Context > School year field, click the  and select the school year 

representing next year.   

5. Click Save. 
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2.3 Student Next School Assignments 

Placing students into sections will be optional for elementary schools.  However, to see students 
in the Build view, they will require a next year school assignment.  It will also be necessary to 
assign next school values to students who have been pre-registered for the next school year.   

Typically, the grade 6 or 7 students will be directed to a middle or high school, while grades K 
through 5 or 6 will be directed back to this year's primary school.  Strongstart students, when 
they are old enough, will be directed to a Kindergarten.  

 To assign a next school to students: 

1. In the School view, select the Student top tab. 

2. Use the  icon to select Primary Active Students. 

3. Use the  icon to select the Pre-Transition field set.  The NextSkl > Name field 

appears.   

4. Populate the NextSkl > Name field using one of the following methods: 

Option 1: 

a. In the Options menu, select Modify List.   

b. Click the  icon to activate the NextSkl > Name fields beside each student. 

c. Use the  to select the next school value for the student, or begin typing the 

school name in the field.  

d. When all values have been assigned, click the  icon to save the records. 
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Option 2: 

Select the student records that will have the same next school value.   

a. In the Options menu, select Mass Update.   

b. Use the drop down menu to select the Field value of Next School. 

c. Use the  to select the next school value for these records.  

d. Click the Update button to update the records.  

 

 To View Next Year Students 

1. In the School view, select the Student top tab. 

2. Use the  icon to select Next Year Students. 

3. Use the  icon to select the Pre-Transition field set.  The NextSkl > Name field 

appears. 
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2.4 Staff in the School View 

The Build view will look at the existing staff records in the School view > Staff top tab.  If 
additional staff are required for next year course sections, they can be added to the staff list in 
the school view.  Users may need to refer to their district policy for managing staff records in 
MyEducation BC (whether this is a school task or a district task).   

 To View School Staff Only 

1. In the School view, select the Staff top tab. 

2. Use the  icon to select Primary Active Staff. 

3. This will show you only the staff active in your school. 

2.5 Staff Secondary School Associations 

School view roles do not have permissions to add Staff Secondary School Associations. 

 

There are two scenarios where a school may want to review the secondary school associations 
attached to staff. 

1. Staff who teach at more than one school and this school is the secondary school. If 

these staff members need to be attached to classes for next year in the Build view, they 

will require a secondary school association for the next school year. 

2. Staff who teach at a different school in the current year but are required in this school to 

assign classes for in next year. Once the new school year has begun, the school can set 

the appropriate primary school on the staff details and remove or end the secondary 

school association. 

Ensuring that appropriate staff secondary school associations are in place will make these staff 
members visible in the Build view to assign to classes. 

• These staff members can be given a secondary school association to the new school by 

personnel with the appropriate security roles.   

 Rollover Secondary School Association Process 

Only a District User or L1 can do the Rollover secondary school Association for the staff with the 
existing secondary school association from the School View.  
 
School View>Staff TT> Options >Rollover staff School  
 
This functionality will create the next school year association only for the staff who are primary 
to school from where this procedure is run.  
To assign next year secondary school associations for all existing secondary staff: 

1. In the School view, select the Staff top tab. 

2. In the Options menu, select Rollover Staff Schools. 

3. Click OK. 
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2.6 Courses 

 District Course Catalogue 

The district course catalogue must be created for the next school year so schools can copy or 
create their course catalogues for the next year.  Ensure the required elementary-level courses 
are in the district catalogue, including the ATT—AM and ATT—PM courses for elementary 
attendance, if using the period attendance method for elementary schools.  The XAT—EL 
course should also be available for districts with StrongStart Centres. 

Please refer to Scheduling Module 2 Course Catalogues, Student and Staff setup, on the 
www.myeducationbc.info website under Resources > School Scheduler Resources. 

 School Course Catalogue 

School course catalogues need to be copied to the next year.  

Please refer to Scheduling Module 2 Course Catalogues, Student and Staff setup, on the 
www.myeducationbc.info website under Resources > School Scheduler Resources. 

 Copying the School Course Catalogue  

School course catalogues can be copied forward from one year to the next. In order to do so, 
the course must first exist in the district course catalogue. 

1. Log on to the School View 

2. Click the Schedule top tab 

3. Click the Courses Side tab 

4. Go to Options and select, Copy Course Catalog 

5. From the popup window: 

a. Select the year to copy from and the year to copy to 

b. Note the option to “Replace existing”  

6. Select to Copy all, copy a Selection, or copy from a Snapshot. 
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2.7 Rooms 

Rooms that are currently in the school will appear in the Build view when a scenario is created.  

To review room information: 

1. In the School view, select the Schedule top tab.  

2. Click on the Rooms side tab.  Review the rooms available.  

3. In the Options menu, select Add to create additional rooms, if necessary. 

a. Number:  Enter the room identifier. 

b. Include in scheduling:  Check this box if the room needs to be available for 

selection when creating or modifying the information on a course section.  

c. All other fields are optional. 
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3.0 The Build View 

The Build view is the area in MyEducation BC where schools can prepare their schedule 
structure and setup for their next school year.   This view contains information on students, staff, 
courses and rooms.   

In the context of an Elementary school, or any school (Secondary, Middle, DL, CE, etc,) the 
Build View can be used to create the next year course sections. This can be done by copying 
the current year structure and schedule into the Build view, or by creating a new structure. 

To access the Build view: 

1. In the School view, select Change View on the Settings Bar. 

2. Select Build. 

 

 

• Ensure the school name at the top shows the next school year.   

• Notice the application background colour has changed to purple and the Build view is 
indicated in the upper right corner below the Settings bar.  

• Note that top tab selections are different from the School view. 

 

3.1 Creating a Scenario 

Build view > Scenario top tab 

Scenarios define the structure of the master schedule.   

To create a scenario as a copy of the current schedule: 

1. In the Build view, select the Scenario top tab.   

2. In the Options menu, select Copy Active Schedule. 

3. Populate the fields as follows: 

a. New scenario name:  give the scenario a name that makes sense to the user. 

b. Items to include:  Master Schedule:  check this box to copy the master 

schedule and all sections from the current year.   
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4. Click OK.  The scenario will now appear in the list.   

 

 

5. Click into the Scenario Details. 

6. Click SAVE. 
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 Terms 

Build View>Scenario top tab > Select scenario > Terms side tab 

Confirm that there is one full year schedule term in this screen.   

 

 Days 

Build View>Scenario top tab > Select scenario > Days side tab 

Elementary schools that are using the period-based attendance model with the ATT—AM and 
ATT—PM courses will require days in the school.   

• If the school is currently using period-based attendance in the current year and has 

created the scenario by copying the current active schedule, then the Day value will 

have been copied over.  Confirm that it is in place.  

• If the school is not currently using period-based attendance in the current year, but 

intends to use it next year, then add 1 day to this screen.  Using the Options menu, 

select Add and enter the required value. 
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 Periods 

Build View>Scenario top tab > Select scenario > Periods side tab 

Elementary schools that are using the period-based attendance model with the ATT—AM and 
ATT—PM courses will require 2 periods in the school.   

• If the school is currently using period-based attendance in the current year and has 

created the scenario by copying the current active schedule, then the Period value(s) 

will have been copied over.  Confirm that they are correct. 

• If the school is not currently using period-based attendance in the current year, but 

intends to use it next year, then add the required periods to this screen.  Using the 

Options menu, select Add and enter the required values. 
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3.2 Courses 

Build view > Courses Top tab 

Courses that have been added to the school course catalogue through the Build Year in the 
school view will appear in this list.  The following sub-sections include information on adding and 
removing courses for the Build view and their attributes.  

 Adding and Removing Courses from the Build View 

The course list should be reviewed to ensure all courses are in the list for use.  Common 
scenarios are listed in the table below if a user identifies courses that are not showing in the list. 

Problem Resolution Path 

Course is in the School 
view list under Build Year, 
but does not show in the 
Build View > Courses list 

1. Check if the course is marked 
to “Include in scheduling” 

 

 

 

 

 

2. Refresh the course list in the 
Build view 

1. Build view > Courses top tab 

• Set filter to All Records 

• Set field set to Required Crs Fields 

• Check the Schd? Field.  If set to N, 
click into the detail of the course and 
check the box for “Include in 
Scheduling” 

2. Build view > Courses top tab 

• Options > Refresh 

Course was added to the 
Build view > Courses in 
error and cannot be 
deleted. 

Courses can be added to the Build 
view, but must be deleted through 
the School view. 

School view > Schedule top tab 

• Courses side tab > set filter to Build 
Year 

• Check the box beside the course to be 
deleted.   

• Options > Delete 

 Course Attributes in the Build View 

Build view > Courses side tab > Elementary Required Fields field set 

The only fields that are necessary for elementary schedule building are: 

• Include in scheduling:  This should be checked by default when the current active 

schedule was copied in the scenario.  Double-check this field if the course is required for 

scheduling but is not appearing in the list. 

• Section enrollment max:  This is optional and will not be observed when using group 

scheduling functions.  However, when enrolling additional students throughout the 

school year, setting this maximum would warn the user that the section is already full. 

These fields can be updated from the course list screen using either Mass Update or Modify List 
options.   
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3.3 Staff in the Build View 

Build view > Staff top tab 

Staff members cannot be added or deleted in the Build view.  

The Staff top tab will display staff members who were in the School, when the scenario was 
created.   

If staff do not appear, refresh the list. 

To refresh list: 

1. Build view >Staff top tab.  

2. Set the filter to All Records.  

a. Check if the staff member now appears, but has their Schd? Field set to “N”.  

Click into the detail of the staff record and check the box for Include in 

scheduling. 

b. If the staff member still does not appear, proceed to Step 3 below. 

3. In the Options menu, select Refresh. 

 

 Staff Attributes in the Build View 

The only fields that are necessary for elementary schedule building are: 
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• Include in scheduling:  check this box if this staff member needs to be in the list to 

assign to a course section.  

• Classroom > Number:  this field is optional, but if a classroom is assigned to a specific 

teacher, it can be assigned here. 

These fields can be updated from the staff list screen using either Mass Update or Modify List 
options.   
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3.4 Students 

Build view > Student top tab 

The Student top tab in the Build view will show the students available for next year scheduling.  
If the correct number of students does not display, go to the Options menu and select Refresh.  
This will refresh the list with the latest information of students with next school values for this 
school. 

The following filters and field sets have been created to assist with grouping students and 
viewing the appropriate fields.   

• Elem – with Hrm info – Field Set 

• Elem – Current Hrm Contains ?  - Filter 

• Elem – Nxt Hrm Contains ? – Filter 

 Student Attributes in the Build View 

• Include in scheduling:  check this box if this student needs to be in the list to assign to 

a course section.  

• Next Homeroom:  this field is optional but can be populated for the purposes of 

organizing next year students.  If the field is populated in the Build view, it will appear 

automatically in the School view and vice-versa.   The end of year rollover process will 

automatically copy the contents of the Next Homeroom into the Homeroom field. 

NOTE: Changing the Homeroom value in Build will change the student’s CURRENT homeroom 
in School View.
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4.0 Using the Workspace 

The Workspace top tab displays the sections and section information that was copied over 
when the scenario was created, from the current year active schedule.   

This is where the school can add or remove sections and modify the information on sections.   

The following filters and field sets have been created to assist with viewing and updating 
records in the workspace.  

• Elem – Section Detail – Field Set 

• Elem – Section # = ? - Filter 

 Modifying information on sections 

Modify List or Mass Update functions can be used on these fields to make necessary 
adjustments: 

• SecNo:  The section number can be adjusted, if necessary. 

• PrimaryStaff > Name:  Staff member assigned to the section can be adjusted as 

necessary. 

• PrimaryRoom > Num:  A room can be assigned as appropriate.  This is optional. 

• ScheduleTerm > Code:  all sections should have a term code of FY for elementary 

schools.   

• Schedule:  A schedule expression is only necessary for courses in which attendance is 

being recorded (ATT—AM and/or ATT—PM).  

• Platoon:  If platoons are being used for group scheduling, the values can be updated 

here.  This is not necessary if the school is not using platoon codes for Group 

Scheduling.  

• Team: If teams are being used for group scheduling, the values can be updated here. 

NOTE: For more information on setting up Teams, Platoons and House see Elementary 
Scheduling. 
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 Adding a section 

Build view > Workspace top tab > Sections side tab 

If additional sections are required for a course, they can be added here: 

1. In the Options menu, select Add. 

2. In the Number field, use the  to select the course code that requires the new section.  

3. Populate the Section number field with the desired value. 

4. Use the  in the Staff > Name field to select the staff member for the section. 

5. Use the  in the SchoolRoom > Number field to select the room for the section. 

6. Use the  in the Schedule Term > Code field to select the FY term code for the 

section. 

7. Click the Edit Schedule hyperlink on the Schedule field only if attendance will be taken 

on this course. 

8. The Platoon field is optional and could be selected, if the school is using the Group 

Scheduling function.  

9. Click Save. 

 

 Deleting a section 

Build view > Workspace top tab > Sections side tab 

If sections have been created that are not required for the next school year, they can be deleted 
here: 

1. Check the box beside the section(s) to be deleted.  

2. In the Options menu, select Delete.  

3. Read the pop-up window and click Continue to confirm the deletion or Cancel to stop 

the deletion. 
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5.0 Loading Students into Sections 

There are different options for loading students into sections of their courses for the next school 
year.  Since elementary students stay in the same classroom with the same teacher for the full 
year, it is not necessary to load them into all the sections of all of their courses before the year 
rolls over.   Group Scheduling or Homeroom Snapshot options can be used in the School View 
to load students as a school start-up task.   

If the school really wants to load students into a section in the Build view, it is suggested that 
only one class is loaded (perhaps an ATT—AM section or an XAT homeroom section).  If 
there is a change to the student roster, only one class would then need to be maintained.  When 
the school year is rolled over, students could then be loaded into the rest of their courses using 
Group Scheduling or homeroom snapshot options defined in the Elementary Scheduling Guide.   

Consider the following: 

• How stable is the school population and how much adjustment would be made to 

students between different classes? 

o If the school population is highly transitional, the school may want to wait until the 
year rolls over and then assign new homerooms to students in the new school 
year.  

o If the population is quite stable and little movement of students between classes 
is expected, the school could use the Next Homeroom field to group students for 
next year classes.   

• Create Next Homeroom snapshots in the student top tab.  This would enable you to load 

students into all their courses by snapshot when the year has rolled over and the student 

population is more settled.  Keep in mind that snapshots are static lists, so new students 

would need the appropriate snapshot added to their record and students withdrawing 

would need the appropriate snapshot deleted from their record. 

• Create Platoon snapshots 

• Loading students in the Build view would provide a way to generate class lists prior to 

the school year rollover. 
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5.1 To load students in the Build View 

Build view > Workspace top tab > Sections side tab  

1. Select the section to add students to by checking the box beside the section.  

2. Click the Roster leaf.  

3. In the Options menu, select Add. 

4. Set the Schedule Mode drop-down menu to Pull. 

5. In the Students area, select the method to use to select the students for this section: 

a. Selection:  allows the user to select multiple students, one by one.  

b. Snapshots:  can be used if a snapshot has been created to group students for 

loading into classes.  

6. Click OK.   The students will now appear in the roster list for the selected section.  
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6.0 Generating Class Lists 

Build view > Workspace top tab > Sections side tab 

If students have been loaded into a section of a course in the Build view, class lists can be 
generated for each teacher.  Note:  Class lists will only be generated for classes that have 
students in them.  Empty sections will not generate a blank list. 

1. In the Reports menu, select Students and click on Class Lists. 

2. Use the Sections to include drop-down menu to select which sections class lists are 

being generated for.  If anything other than Current Selection is chosen, the user will be 

required to enter the Search Value exactly as the selected detail on the class is entered. 

3. Use Sort results by to choose what order the report will be generated in.   

4. Click Run.  

  

7.0 K-12 Considerations 

K-12 schools that are scheduling the secondary grade levels, using the full functionality of the 
Build and Load, should submit a ticket, requesting one-on-one district support session to 
determine their individual requirements.  
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8.0 Reports 

8.1 BC Master Schedule 

Build View>Workspace Top Tab>Reports>Scheduling Reports>BC Master Schedule 
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8.2 Class Lists 

Build View>Workspace Top Tab>Reports>Class Lists 
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9.0 Commit Schedule 

After the End of Year Rollover (EOYR) process is complete, one Scenario from the Build view 
must be Committed – this will then become the Active Schedule. 

9.1 Commit Schedule 

In the Build view: 

1. Click the Scenario tab. 

2. Select the Scenario that you would like to commit, to go into the Details. 

3. Click Options > Commit Schedule… … The Commit Schedule dialog box appears: 

 

4. Select the appropriate option, Replace the active schedule or Update the active 

schedule (if you have already committed the schedule, made changes and want to only 

re-commit the changes. 

 

 

Note:  This topic will be covered further, as part of End of Year Rollover (EOYR) and 
School Start-up Learning Events. 


