
 

 

 

 
 

Elementary Scheduling 

September 2023 v4.9 



 

Version History 

Version Date Description 

1.0 May 2014 Initial document 

1.1 Jun 2014 Addition of Individual Student Platoon Scheduling 

2.0 Jul 20114 Prepare Grade Input added 

3.0 Sep 2014 Addition of pushing homeroom into course roster. Update of course list 

3.1 Oct 2014 Addition of XTC term comment reporting course 

4.0 Feb 2015 Updated Course Catalogue in Appendix B 

4.1 Mar 2015 Updated 6.4 to include Days In Session filter use 

Updated BC Department codes section to add codes.  Removed reference 
to disabling codes.  

Corrected Assigning Student Homerooms section 

Updated Defining course details with Report Card Field Set reference 

4.2 Jun 2015 Minor updates to Defining Section Details to include mass update of 
Schedule Term. 

4.3 Aug 2019 Update to Appendix C to run report homeroom distribution. 

Removed Appendix B – Enterprise Course catalogue.  Users should refer 
to the BC Ministry of Education Course Registry website. 

4.4 Aug 2020 Release 6.1, Appendix A updates 
Updated Section 1.0 Set Default Transcript Definition 

 

4.5 Sep 2021 Updated screen captures, some formatting.  Added Section 6.5 and 6.6 
Adding Bell Schedule 

4.6  Oct 2022 Transcript Visibility in Portal added section 15 

4.7 Mar 2023 Updated Section 15 Hide in Portal Field set 

Updated screen captures, some formatting. 

4.8 Sep 2023 Screenshots added to reflect 2023 Reporting Order – transcripts and 
Rubrics 

4.9 Sep 2023 Screenshots with 6.6 upgrades 

 

 

Confidentiality 

This document contains information which is proprietary and confidential to Fujitsu Consulting (Canada) 
Inc. (including the information of third parties, including but not limited to, Follett of Canada Inc., submitted 
with their permission). In consideration of receipt of this document, the recipient agrees to treat this 
information as confidential and to not use or reproduce this information for any purpose other than its 
original intent or any other person for any purpose, without the express prior consent of Fujitsu Consulting 
(Canada) Inc. (and any applicable third party.) 

 



 

Table of Contents 

1.0 ELEMENTARY SCHEDULING ACTIVITIES .................................................................... 5 

2.0 SET DEFAULT TRANSCRIPT DEFINITION .................................................................... 5 

3.0 SET SCHOOL SCHEDULE PREFERENCES .................................................................. 6 

4.0 CREATE SCHOOL SCHEDULE AND/OR SET ACTIVE SCHEDULE ............................. 6 

5.0 SET/ADJUST SCHOOL CALENDAR .............................................................................. 7 

6.0 PREPARE GRADE TERMS ............................................................................................. 8 

7.0 CREATE A SCHEDULE STRUCTURE ............................................................................ 9 

7.1 Define Full Year Schedule Term ................................................................................... 9 

7.2 Set up School Schedule Day ........................................................................................10 

7.3 Set Up Two Periods for Attendance .............................................................................11 

7.4 Define Bell Schedules ..................................................................................................12 

7.5 Assign Day to Calendar. ..............................................................................................12 

7.6 Assign Bell Schedule to Calendar ................................................................................13 

8.0 DEFINE BC DEPARTMENT CODES (OPTIONAL) ........................................................14 

8.1 Add BC Department Codes at the School Level ...........................................................14 

9.0 ASSIGN HOMEROOMS TO STAFF ...............................................................................15 

10.0 ASSIGN STUDENT HOMEROOMS ................................................................................16 

10.1 Assign Homerooms to Individual Students: ..................................................................16 

10.2 Mass Assign Homerooms to Students..........................................................................16 

11.0 CREATE SCHOOL COURSE CATALOGUE ..................................................................18 

11.1 Create the School Course Catalogue ...........................................................................18 

11.2 Define Course Details ..................................................................................................19 

12.0 CREATE COURSE SECTIONS ......................................................................................22 

12.1 Assign the Number of Sections to Courses ..................................................................22 

12.2 Initialize Sections .........................................................................................................23 

12.3 Define Section Details ..................................................................................................23 

12.4 Assign a Schedule Expression to Attendance Courses ................................................24 

12.5 Create Additional Sections ...........................................................................................25 

13.0 GROUP SCHEDULING...................................................................................................25 



 

Elementary Scheduling v4.9  

13.1 Use Homeroom Snapshots for Mass Scheduling Students ..........................................26 

13.2 Create the Homeroom Snapshot ..................................................................................26 

13.3 Schedule Students Using a Snapshot ..........................................................................28 

13.4 Use Platoons for Group Scheduling .............................................................................30 

13.5 Set up Platoon Codes for Group Scheduling ................................................................30 

13.6 Confirm Setup ..............................................................................................................31 

13.7 Group Scheduling Non-blended Classes ......................................................................31 

13.8 Group Scheduling Blended Classes .............................................................................32 

14.0 INDIVIDUAL STUDENT SCHEDULING ..........................................................................33 

14.1 Homeroom Assignment ................................................................................................33 

14.2 Schedule the Individual Student ...................................................................................33 

15.0 PREPARE GRADE INPUT FOR ALL CLASSES ............................................................38 

16.0 TRANSCRIPT VISIBILITY IN PORTAL ..........................................................................39 

APPENDIX A – TRANSCRIPT, REPORT CARDS & RUBRIC DEFINITIONS ..........................41 

APPENDIX B – DETERMINING SECTIONS ............................................................................42 

APPENDIX C – SCHEDULING BLENDED CLASSES USING PLATOONS ............................44 

 

 

 



 

Elementary Scheduling  v4.9 Page 5 

1.0 Elementary Scheduling Activities 

This document relies on these activities having been completed at the District level: 

• District calendar has been initialized, which pushes calendar dates down to the 

individual schools.  

• Elementary courses have been brought into the District course catalogue for use in the 

School course catalogue. 

• District and School Start-up Tasks Checklist has been completed (on 

MyEducationBC.info site). 

All activities below are done in the School View and is relevant specifically to scheduling 
elementary students. 

2.0 Set Default Transcript Definition 

This may already have been completed but should be reviewed prior to beginning elementary 
scheduling activities.   

1. Go to the School top tab. 

2. Click on the Setup side tab and choose the Details leaf. 

3. Set the Default Transcript Definition > Name field as appropriate.  

Note:  This is only a default that will be assigned to courses when you bring them into your 
school.  This choice should represent the majority of the courses in your school.   
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3.0 Set School Schedule Preferences 

This may already have been completed but should be reviewed prior to beginning elementary 
scheduling activities.   

1. Go to the School top tab. 

2. Click on the Setup side tab and choose the Preferences leaf. 

3. In the Category drop down (upper right), choose Schedule. 

4. Ensure the Schedule Mode field is set to Secondary. 

  
 

4.0 Create School Schedule and/or Set Active Schedule 

The school must define a schedule with the start and end dates of the school year.  These dates 
are the “shell” for the schedule terms and grade terms.  The school calendar dates should be 
equal to or less than these dates.   

1. Go to the School top tab. 

2. Click on the Schedules side tab.  Set the filter to All Records. 

3. If you see the schedule year already created, click the blue link and confirm the start 

and end dates are correct for your school.   

4. If you do not see a current year schedule: 

a. Click Options. 

b. Select Add.  

c. Populate the Name, Start Date and End Date. 

d. Click Save. 
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e. Click Options and choose Set Active Schedule. 

f. Click OK to confirm setting the schedule as the active schedule.  

 

 

5.0 Set/Adjust School Calendar 

1. Go to the School top tab. 

2. Click on the Calendars side tab. 

3. Select the checkbox beside the calendar year you want. 

4. Click the Dates leaf.  

5. Review the in-session and non-session dates in your calendar  

a. To modify a date, click on the blue link, select or deselect the Is school in 

session checkbox as appropriate.  Click Save. 

Note:  School calendar dates are populated when the district initializes a calendar.  If no 
dates appear for your school, contact your district support to ask if the district calendar has 
been initialized for the year.  If the district calendar has been initialized and the dates do not 
display in the school calendar, you can use the Initialize Calendar function in the School 
Setup document to populate the dates for your school.   
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6.0 Prepare Grade Terms 

Grade Terms must be entered for all schools in your district. In the School view, each school 
will define the dates for each grade term.  A sample is shown below: 

 

Trimester Start Date End Date 

Tri 1 September 3  December 10 

Tri 2 December 11 March 10 

Tri 3 March 11 June 27 

To create grade terms: 

1. Go to the Grades top tab. 

2. Click on the Grade Terms side tab. 

3. Click Options on the menu bar and select Add. 

4. In the Term ID field, begin typing Tri and select Tri 1, or use the    to select Tri 1 

from the picklist.  

5. Define the Start date and End date for the trimester.   

6. Click Save.  

7. Repeat the above steps for Tri 2 and Tri 3. Click the Grade Terms side tab.  All three 

trimesters should be represented in the list. 
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7.0 Create a Schedule Structure 

7.1 Define Full Year Schedule Term 

Schedule terms are different from grade terms. Grade terms are dates that represent milestones 
during the year when you report academic progress. Schedule terms are the date ranges during 
which courses can begin and end.  Elementary schools would typically only have one full year 
schedule term as their courses run all year. 

To create your school’s Schedule Term: 

1. Go to the Schedule top tab. 

2. Click on the Structure side tab, then click the Terms sub-side tab. 

3. Click Options on the menu bar and select Add. 

4. In the Code field, select FY for a full year schedule term.  

5. In the Name field, type Full Year. 

6. Enter 1 in the Base terms per year field and click the Set button.  A Term map box 

will populate.   

7. Check the Term map box.  Two date fields will appear below Term Date Ranges 

8. Enter the Start date and the End date for the full year term.  (As this is a full year 

term, your Start and End date fields will be the first and last day of school). 

9. Three check boxes should appear in the Grade term cover map area.  All three 

boxes should be checked to tell the system that you will be preparing for three 

reporting terms.  Click Save.  
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7.2 Set up School Schedule Day 

For schools following the recommended approach to record attendance using the ATT-AM and 
ATT-PM courses, one day and two periods will need to be created in the schedule structure.   

1. Click the Schedule top tab 

2. Click the Structure side tab and select the Days sub-side tab. 

3. If there are no records, click the Options menu and select Add. 

 

When the pop-up menu appears, enter 1 into the Day count field, and tab out of that area. 
This will give you your section for filling in the information for this Day.   

 

4. Put in the value of 1 for Identifier and Name fields. 

5. Click the Save button. 

6. This will create a single Day for your school.  
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7.3 Set Up Two Periods for Attendance 

For schools following the recommended approach to record attendance using the ATT-AM and 
ATT-PM courses, one day and two periods will need to be created in the schedule structure.   

1. Click the Schedule top tab. 

2. Click the Structure side tab and select the Periods sub-side tab. 

3. If there are no records, click the Options menu and select Add. 

 

When the pop-up menu appears, enter 2 into the Period count field, and tab out of that 

area. This will give you two rows for filling in the period information. To make it easy to 

identify these as attendance periods, you may want to consider using AM and PM as in the 

screen shot below. 
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7.4 Define Bell Schedules 

1. Click the Schedule top tab. 

2. Click the Structure side tab and select the Bell Schedules sub side tab. 

3. If there are no records, click the Options menu and select Add. 

 

4. Give bell schedule Identifier a name like:  Regular 

5. Give bell schedule a name like:  Regular Daily 

6. Select the Include in Scheduling? Checkbox if you are using Build in your district. 

7. For each period (AM & PM), define start time and duration for morning period and the 
afternoon period. Eg.  Bell Period Number = 1, Bell Period Identifier = AM Start time = 
8:36 AM Duration (Minutes) = 296 

8. Click Save 

 

7.5 Assign Day to Calendar. 

1. From the School top tab, click the Calendars side tab,  

2. Click the Dates leaf. 

3. Use the  icon to filter the list to Days in Session. 
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4. In the Options menu, select Mass Update. 

5. Select Schedule day number from the drop-down selection list for Field. 

6. In the Value field, enter 1. 

7. Click the Update button.  All in-session dates should now display a 1 in the DayNum 

field. 

7.6 Assign Bell Schedule to Calendar 

1. Select School top tab > Calendars side tab > Dates leaf 

2. Filter = Days in Session 

3. Options > Mass Update > Field = Schedule Bell, use Pick list to pick Value > and then 

Update 

4. Bell > Name field should now be filled with newly created Bell Schedule 
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8.0 Define BC Department Codes (Optional) 

Departments are a way of categorizing courses when you bring them into your school. Districts 
may choose to manage these, or they may set the District > Preferences > Schedule for 
department codes to be managed at the school level. Check with your district support staff to 
determine if the schools can manage the department codes and if there are district standards 
for categorizing courses.  Then customize the reference table to suit the district or school 
standards.  

  

8.1 Add BC Department Codes at the School Level 

1. Go to the Admin top tab. 

2. Click the Reference side tab. 

3. Find the BC Departments table in the list.  Check the box beside the name. 

4. Click the Codes leaf.   

5. In the Options menu, select Add. 

6. In the Code field, type the name of the department being added.  

7. In the Description field, type the name of the department being added. 

 

 

 

  



 

Elementary Scheduling  v4.9 Page 15 

9.0 Assign Homerooms to Staff 

In MyEducation BC, homeroom numbers are assigned to teachers through the School view > 
Staff top tab.  Homerooms can be assigned to an individual teacher by selecting the staff 
member and entering the homeroom value into their details or en masse by using Modify List. 
Students can then be assigned to the homeroom number associated to their teacher. 

To assign homeroom numbers to staff:      

1. Click the Staff top tab. 

2. Click Options in the menu bar. 

3. Select Modify List. 

4. Click the icon in the Homeroom column. 

5. Enter the Homeroom value for each Teacher in the list.  

6. Click the  icon to save your entries.  

7. Click Options in the menu bar and select Modify List or click on the Staff top tab to 

shut the function off. 
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10.0 Assign Student Homerooms 

A homeroom can be assigned to an individual student by selecting the student and entering the 
homeroom value into their Details.  Homerooms can also be assigned “en masse” by using 
either Modify List or Mass Update. 

10.1 Assign Homerooms to Individual Students: 

1. Click the Student top tab. 

2. Check the box beside the student name and click the Details side tab, or click the 

blue link of the student name.  

3. In the Homeroom field on the Demographics sub-top tab, bottom of the page, use 

the  icon to select the homeroom for the student, or begin typing the homeroom 

name and let the field populate. 

4. Click Save. 

 

 

10.2 Mass Assign Homerooms to Students 

10.2.1 Option 1:  Modify List 

1. Click the Student top tab.  (You may wish to sort the grade column by clicking the 

Grade column header, or use the  icon to select Grade level = ? to narrow 

the list of students). 

2. Click Options in the menu bar. 

3. Select Modify List. 

4. Click the  icon in the Homeroom field. 

5. Use the  icon to select the homeroom for the student, or begin typing the 

homeroom name and let the field populate. 

6. Click the  icon to save the entries.  

7. Click Options in the menu bar and select Modify List to shut the function off. 

10.2.2 Option 2:  Mass Update 

1. Click the Student top tab.  (You may wish to sort the grade column by clicking the 

Grade column header, or use the  icon to select Grade level = ? to narrow 

the list of students). 
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2. Place a check in the box beside each name to be assigned to the same homeroom.  

3. Click Options in the menu bar and select Show Selected.  The list of students 

selected appears for confirmation.   

4. Click Options in the menu bar and select Mass Update. 

5. In the Mass Update pop-up window, set the Field value to Homeroom using the 

drop-down menu.  

6. In the Value field, type the homeroom to be assigned to all of the students selected.   

7. Click Update.  Accept the confirmations.  

8. A Mass-Updated validation window will pop up.  Click OK. 

9. Change the  icon from Custom Selection back to All Active Students. 

10. Repeat the process until all students are assigned to the appropriate homeroom. 
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11.0 Create School Course Catalogue 

The district course catalogue will need to be reviewed and adjusted as necessary for the needs 
of the district.  Elementary courses need to be brought into the district level before they will be 
available for the school.  This document assumes the district course catalogue contains the 
necessary elementary courses.   

Appendix B contains a list of all elementary courses available at the Enterprise level. 

11.1 Create the School Course Catalogue 

1. Go to the Schedule top tab. 

2. Select the Courses side tab. 

3. On the Options menu, select Add. 

a. Ensure the Course Catalogue field is set to the current year. 

b. The following tools can be used to select courses: 

• School Level may be used to filter courses to the ones appropriate to 

your school.  K-5  courses are assigned a school level of Elementary.  

Grades 6 to 8 courses are assigned a school level of Middle.  Select All 

K-5 courses, click OK to add them to the catalogue before switching the 

filter to Middle for selecting grades 6-8 courses that may be needed.   

•  Ctrl F helps to search for courses and the selections will be retained as 

you check the boxes beside the ones you want. 

4. Check the box beside all the courses required in the school. 

5. Click OK.  
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11.2 Define Course Details 

You can view and edit courses one-by-one, but most fields on these screens are mass-
updateable and it will save time to use the mass update functions to adjust them, where the 
same value will be assigned to multiple courses in your course catalogue.   It may be helpful to 
use the Report Card Field Set so all applicable fields are visible in the list. 

1. On the Schedule top tab, click the Courses side tab.  

2. Click on the blue link to view the details of the course.   

a. On the General sub-top tab, the Department and Bank name can be populated.  

However, you may prefer to use Mass Update functions for these fields.  Other 

fields on this screen do not need to be populated for implementation scheduling. 

Consult your district on department standards. 

3. Click Save. 

 

4. On the Grading sub-top tab, review the settings for the following fields: 

a. Term grades term map:  all boxes should be checked. 

b. Progress grades term map:  all boxes should be checked. 

c. Transcript Definition > Name:  should be populated with the appropriate 

transcript definition for the course.  You may prefer to use Mass Update functions 

for this field if the transcript definition is different from the default school setting.  

(See instructions below screenshot). 

d. Rubric Definition > Name:  should be populated with the appropriate rubric 

definition for the course.  You may prefer to use Mass Update functions for this 

field.  (See instructions below screenshot). 

e. Hide from grade input:  should be unchecked if you want to enter student 

grades for the course.   
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f. Hide on report card:  should be unchecked if you want the course to display on 

the report card. You may prefer to use Mass Update functions for this field.  (See 

instructions below screenshot). 

g. Disable text comments:  should be unchecked if you want to enter comments 

on courses for report cards. 

h. Disable reference comments:  should be unchecked.  

i. Disable non-rubric grades:  should be unchecked.  

j. Click Save. 

 

To mass update a transcript definition: 

1. Go to the Schedule top tab. 

2. Select the Courses side tab and filter to Report Card Field Set. 

3. Check the box beside all courses that will have the same transcript definition (ex. all 

kindergarten courses) 

4. On the Options menu, select Show Selected 

5. On the Options menu, select Mass Update.  

6. Using the drop-down options, set the Field value to Transcript Definition. 

7. Using the icon, set the Value field to the appropriate transcript definition.   

8. Click Update.  Read and respond to the confirmation messages.   
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To mass update a rubric definition: 

1. Go to the Schedule top tab. 

2. Select the Courses side tab and filter to Report Card Field Set. 

3. Check the box beside all courses that will have the same rubric definition (ex. all 

primary courses) 

4. On the Options menu, select Show Selected 

5. On the Options menu, select Mass Update.  

6. Using the drop-down options, set the Field value to Rubric Definition. 

7. Using the icon, set the Value field to the appropriate rubric definition.   

8. Click Update.  Read and respond to the confirmation messages.   

To mass update Department: 

1. Go to the Schedule top tab. 

2. Select the Courses side tab and filter to Report Card Field Set. 

3. Check the box beside all courses that will have the same department (example:  all 

Language Arts courses).   

4. On the Options menu, select Show Selected. 

5. On the Options menu, select Mass Update.  

6. Using the drop-down options, set the Field value to Department. 

7. Using the icon, set the Value field to the appropriate department.   

8. Click Update.  Read and respond to the confirmation messages.   

To mass update Bank name: 

1. Go to the Schedule top tab. 

2. Select the Courses side tab and filter to Report Card Field Set. 

3. Check the box beside all courses that will have the same comment bank. 

4. On the Options menu, select Show Selected. 

5. On the Options menu, select Mass Update.  

6. Using the drop-down options, set the Field value to Comment Bank Table. 

7. Using the icon, set the Value field to the appropriate comment bank.   

8. Click Update.  Read and respond to the confirmation messages.   

To mass update Hide on report card: 

1. Go to the Schedule top tab.  

2. Select the Courses side tab and filter to Report Card Field Set. 

3. Check the box beside all courses. 

4. On the Options menu, select Show Selected. 

5. On the Options menu, select Mass Update.  

6. Using the drop-down options, set the Field value to Hide on report card. 

7. Set the Value box to unchecked.   

8. Click Update.  Read and respond to the confirmation messages.   

  



 

Elementary Scheduling  v4.9 Page 22 

12.0 Create Course Sections 

Once the school course catalogue has been created and the attributes defined, you will need to 
determine how many “sections” of each course you will need.  For example, if you have two full 
grade one classes, you will need two sections of each grade 1 course.  Another example would 
be if you have two full grade 4 classes and a blended grade 4/5 class, you will need three 
sections of each grade 4 course. 

12.1 Assign the Number of Sections to Courses 

MyEducation BC has a function for creating sections for you, once you have identified how 
many sections of each course you will need.   

To define the number of sections: 

See Appendix C for a sample table for determining the required number of sections for split 
classes. 

1. Go to the Schedule top tab and select the Schedule Attributes side tab (turns into 

Course Attributes sub-side tab). If no courses are visible, go to Options > Refresh 

to generate the current course list for attributes. 

2. On the Options menu, select Modify List. 

3. Click the   icon in the Sections column to activate the fields.   

4. Enter the number of sections you require for each course. The number of sections 

becomes significant if there are split grade classes (see Appendix C). 

5. Click the icon to save your entries.   
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12.2 Initialize Sections 

1. Go to the Schedule top tab and select Master side tab (turns into Sections sub-side 

tab). 

2. On the Options menu, select Initialize Sections.  This creates all the sections 

indicated as required in Schedule Attributes. 

 

12.3 Define Section Details 

Section details need to be defined, such as: Teachers, Schedule Terms, Schedule Expressions 
and Platoons to sections.   

You will need to define section details once the sections have been initialized.  If you plan to use 
Platoons for Group Scheduling this can also be assigned at this time (see Setting up Platoon 
Codes for Group Scheduling below).  

To update information on sections: 

1. Go to the Schedule top tab and select Master side tab (turns into Sections sub-side 

tab). 

2. In the field set menu, select the Primary Teacher field set. 

3. On the Options menu, select Modify List.  

4. Click the   icon in the Primary Staff > Name column to activate the fields. 

5. Use the  icon to choose the teacher name, or begin typing the name in the field. 

6. Click the icon to save your entries. 

7. Repeat the above process to populate the Platoon fields only if the school is using 

platoon codes for group scheduling.  Platoons should be the same as the teacher 

homeroom number for the students to be placed in that section. 
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8. Repeat the process for the Max field – assigning an appropriate class maximum for 

each section. 

9. In the Options menu, select Mass Update.   

10. In the Field drop-down, select Schedule Term. 

11. In the Value field, use the  icon to select the Full Year schedule term. 

12. Click Update.  This will set the FY schedule term for all courses and sections. 

To modify information for an individual section: 

1. Go to the Schedule top tab and select Master side tab (turns into Sections sub-side 

tab). 

2. Click on the blue Course link to open each section.   

3. Adjust the section details as required.   

4. Save. 

12.4 Assign a Schedule Expression to Attendance Courses 

If the school is using the ATT--AM and ATT—PM courses for attendance, these courses will 
need a day and period assigned to them.   

1. Go to the Schedule top tab and select Master side tab (turns into Sections sub-side 

tab). 

2. Select all sections of the ATT—AM and ATT—PM courses.  In the Options menu, 

select Show Selected. 

3. Click on the blue hyperlink of the first section in the list.  This will take you to the 

sections details.  

4. Click the blue Edit Schedule hyperlink.  A matrix will display.   

5. If the section is an AM section, click the box beside AM.  The box will change colour.  

Click OK.  The Schedule field on the course section will now display the AM period 

and the day behind it in brackets.   

6. Repeat this process for each section of the AM and PM courses, selecting the AM or 

PM box in the matrix as appropriate. 
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12.5 Create Additional Sections 

If additional sections of a course are required, they can be created in this screen.   

To create additional sections: 

1. On the Options menu, select Add. 

2. Use the  icon to choose a Course Code. 

3. Type in the Section number you need.  

4. Use the  icon to populate the Primary Staff > Name, Primary Room > Number, 

and Schedule Term > Code. 

5. Use the drop-down menu to select the appropriate Platoon, if you use platoon codes 

to group schedule students. 

6. Populate the Enrollment maximum field with a value appropriate to how many 

students can be scheduled into the section.  

7. Check the Is section closed at max enrollment? checkbox if the system is to 

restrict the section from additional students when it has reached the maximum. 

 

13.0 Group Scheduling 

Group scheduling allows you to take a group of students in a homeroom and mass load them 
into all sections of all courses assigned to a specific teacher. There are two methods of group 
scheduling for elementary schools: 

 

Option 1:  Create a snapshot to “push” students into their courses.  It is important to remember 
that the snapshot is not dynamic and will not automatically add students who have entered the 
school after the snapshot has been created.  Also, for blended homerooms (more than one 
grade), a separate snapshot must be created for each grade in the homeroom to be used for 
scheduling purposes. 

 

Option 2:  Use the platoon function.  This requires a platoon reference table in which the 
platoon codes exactly match the homeroom values assigned to teachers and students.  These 
platoon codes are then assigned to course sections and the group scheduling function is used 
to find all the students in the matching homeroom/grade and place them in the class. 

  



 

Elementary Scheduling  v4.9 Page 26 

13.1 Use Homeroom Snapshots for Mass Scheduling Students 

Student homerooms can be captured in a snapshot and then “pushed” out into the courses or 
sections of those courses that these students should be assigned. For split classes, users will 
have to capture each grade grouping within a homeroom for scheduling. 

 

13.2 Create the Homeroom Snapshot 

Once students have been assigned a homeroom, they can be filtered based on this.  
Remember that snapshots are “static” and will not automatically update when new students 
enter the school or are added to classes.   

1. On the Student top tab, click the  icon and 

choose the Homeroom =?  

2. In the pop-up window, enter the desired homeroom. 

3. Click Submit.  You will be presented with a list of 

students in the homeroom selected. 

4. Ensure that all of the students are in the same grade.  

If there are students from more than one grade, you 

will need to select records from one of the grades by 

checking the box beside their name.   Then in the 

Options menu, select Show Selected.  

5. Once the homeroom group has been filtered, go to 

the Options menu and select Snapshot. 
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In the pop-up window, click the New button.  

 

Give your snapshot a name that represents the homeroom.  There is an option to save the 
snapshot as a filter, but you probably do not want these in the filters. 

6. Click Save. 

7. Repeat the process for all homerooms so you have a snapshot for each homeroom.   

• For blended classes, you will have a snapshot for each grade in the homeroom.  
For example, for a grade 4/5 class, you might have a snapshot called HR 101-
Grade 4 and a snapshot called HR 101 – Grade 5.  This way, the appropriate 
snapshot can be used to ensure only grade 4 students are going into grade 4 
courses.   
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13.3 Schedule Students Using a Snapshot 

Once snapshots have been created for homerooms and course sections have been created to 
match homeroom groupings, the students can be assigned to these.  

1. In the Schedule top tab, select the Master side tab. 

2. Click the Roster leaf. There is no need to select a course, and the course name that 
appears for the roster does not matter; this is just a means to access the function. As 
in the screenshot below, the Sciences humaines course has no bearing on the 
process about to be carried out. 

 

 

3. In the Options menu, select Add.  

4. In the pop-up window, set the Schedule Mode to Push.  

5. In the Students block, select Snapshots. The snapshots pick list popup window will 
open for the user to choose from. 

6. Select the snapshot to use and click OK. 
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7. The multi-add students window will now display the number of students identified 
from the snapshot.  

8. In the Add to the following sections: field, click the Select button. A list of course 
sections appears.   

9. Select the course sections to add the students from the snapshot into. Multiple 
sections can be selected and you can use the Ctrl + F function to search the list and 
select records. 

 

 

10. When the selection is complete, click OK.  The sections will appear in a string in the 
Add to the following sections:  field.  

11. Click OK in the multi-add window to “push” the selected students into the course 
sections selected.  

12. Click the Sections sub-side tab.  You will see the Total column is populated with the 
number 
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13.4 Use Platoons for Group Scheduling 

Platoons are a method of flagging courses that can be used with matching homerooms as a 
means of group scheduling. This is where the match of the homeroom value between the 
teacher, the student and the platoon becomes critical.   

Example:   

• Teacher A has been assigned a homeroom value of HR 01 in his/her staff record.  

• 24 students have been assigned the homeroom value of HR 01 in their student record. 

• A Platoon table has been created with a code of HR 01 to match the staff homeroom.  

• A Platoon of HR 01 has been attached to Section 1 of all grade 3 classes assigned to 

Teacher A.  (MENS—03-001, MENR—03-001, MENW—03-001, MMA—03-001, MSC—

03-01, MSS—03-01, etc.) 

In the above example, the group scheduling feature will assign all 24 students to Section 1 of all 
the grade 3 classes assigned to Teacher A.   

Where the students in HR 01 are in different grades (ie. a blended 2/3 classroom), group 
scheduling will need to be run twice to place the students into the appropriate grade level of 
courses within the homeroom.   

Before beginning, you do a quick check to ensure your teachers and students have homerooms 
and that matching platoons exist on your sections.   

13.5 Set up Platoon Codes for Group Scheduling 

Platoons are a way of grouping students by their homeroom value so they can be easily 
scheduled into courses. The first step in this process is to create the Platoon Code reference 
table.   

To create the Platoon Code reference table: 

When using platoon codes for elementary group scheduling, the key to success is to have the 
homeroom value on the staff record, the homeroom value on the student record and the platoon 
code reference table match exactly.  For example, if the homeroom assigned to the teacher is 
HR 10, the student record must show a homeroom assignment of HR10 and the Platoon code 
created must be HR10 – no extra spaces, dashes, capitals, etc.   

1. Go to the Admin top tab. 

2. Click the Reference side tab. 

3. Find the Platoon Code table in the list.   

4. Check the box beside Platoon Code and click the Codes leaf.  

 
5. If you see items in the list already, click on their detail. 
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• Check the box beside the record.  

• Click the Options menu, select Delete.   

6. On the Options menu, select Add 

7. Populate the Code and Description fields to match the homerooms assigned to the 

school staff (homerooms can be assigned prior to the creation of platoon codes).  

The values must be an exact match to the homeroom values on the staff and student 

records. 

8. Click Save. 

 

9. Repeat until you have all the codes you need (match the homeroom numbers you 

will give to your teachers and students below) 

 

13.6 Confirm Setup 

1. Staff top tab > Staff List – review values in Homeroom column.  

2. Student top tab > Student List – filter students based on a given homeroom or sort 

by clicking the Homeroom column header.  The homeroom value must match the 

homeroom attached to the teacher.   

3. Schedule top tab > Master side tab (turns into Sections side-sub tab) – ensure 

Platoon values assigned to sections match the homeroom values assigned to 

teachers and students. 

13.7 Group Scheduling Non-blended Classes 

1. Go to the Schedule top tab and select the Master side tab (turns into Sections sub-

side tab). 
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2. Use Platoon = ? filter to select the sections that have a platoon and homeroom 

match.   

3. On the Options menu, choose Group scheduling. 

4. In the Load Students by Group pop-up window:   

a. Leave Student field selection value at Homeroom. 

b. The Section can be left at Current selection. 

c. The Students can be left at all. 

5. Click OK.  This will populate the identified course sections for all students as long as 

their homeroom matches the teacher homeroom and the platoon assigned to the 

section.   

13.8 Group Scheduling Blended Classes 

1. Go to the Schedule top tab and select the Master side tab (turns into Sections sub-

side tab). 

2. Use Platoon = ? filter to select the sections that have a platoon and homeroom 

match.  You should see courses with different grade levels in the results.   

3. Check the box beside all the courses in the filtered platoon that have the same grade 

level.   

4. On the Options menu, choose Show Selected. 

5. On the Options menu, choose Group scheduling. 

6. In the Load Students by Group pop-up window:   

d. Leave Student field selection value at Homeroom. 

e. The Section can be left at Current selection and should show the number of 

sections you selected in Step 4. 

7. In the Students section, click the Grade level radio button and select the appropriate 

grade level from the pop-up picklist.  Note that 

even though the Selected students: may show 

the total number of students in that grade, only 

the ones with the matching homeroom and 

platoon codes will be loaded into the selected 

sections. 

8. Click OK.  This will populate the identified 

course sections for all students as long as their 

homeroom matches the teacher homeroom and 

the platoon assigned to the section.   

9. Filter for your platoon again and repeat steps 3 

through 8 for the other grade level in the 

blended class.   
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14.0 Individual Student Scheduling 

14.1 Homeroom Assignment  

14.1.1 Assigning Homeroom on Registration  

Upon the registration of a new student to the school, Step 2 of the process provides the 
opportunity to assign the homeroom. 

 

 

 

14.1.2 Assigning the Homeroom for the Registered Student 

1. Click on the Student top tab. Navigate to the new student (you can use Ctrl-F to search 

for the student). 

2. Click on the blue link for the student name to enter the student details screen. Enter the 

desired homeroom by clicking the         and choosing from the pick list. 

3. Click Save. 

 

14.2 Schedule the Individual Student 

Scheduling individual students can be done in a variety of ways: using the homeroom/roster 
method, using platoons, or through the Student top tab, Schedules side tab.  
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14.2.1 Using Student top tab, Schedule side tab 

For the scheduling of an individual student, the user can access the student workspace and 
assign course sections. To do so: 

1. From the Student top tab, select the student 

2. Go to the Schedule side tab > Workspace sub-side tab 

 

3. From within the workspace in either list view or matrix view under Student Schedule, 
click Select. 

4. The Schedule Master Pick List window will open. Be sure to uncheck the Valid Sections 
Only check box. 

5. Make use of the wildcard feature for Course selection. An asterisk (*) can be used as a 
wildcard example *01-001 is entered in the Course field as I want all grade one (01), 
section one (001) courses. OR you can use the Platoon field and choose the appropriate 
platoon. 

6. Select the course sections and appropriate grade level for split homerooms for 
scheduling and click OK 

7. Once back in the Workspace click Post. The student will now be scheduled. 
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14.2.2 Using the course section roster method to schedule a student 

1. Go to the Schedule top tab. 

2. Select the Master side tab 

3. Click the Roster leaf.  

4. In the Options menu, select Add 

5. In the Multi-Add Students pop-up window, set the Schedule Mode field to Push.  

6. In the Students block select Selection. From the Selection popup window, select the 

student for scheduling.  

 

 

7. In the Add to the following sections: field, click the Select button. Click on the Platoon 
or SecNo column header to sort, then select the appropriate course sections for 
scheduling. 

8. Click OK. 
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14.2.3 Using Platoons to schedule Individual students 

1. On the Schedule top tab, select the Master side tab.  

2. Click on the  icon and select Platoon = ? and select the code matching the new 
student’s homeroom. The remaining list of course sections should be those to assign to 
the student.  For multi-grade classes, it may be necessary to check the box beside the 
course sections for the appropriate grade and do Options > Show Selected before 
proceeding. 

3. In the Options menu, select Group Scheduling. This will generate a pop-up window.  
Leave the Student field selection value set to Homeroom. 

4. In the Students field choose Selection. 

5. In the Student pick list window, locate the student to be scheduled. 

6. Click OK to select the student. 

7. Click OK in the field selection window. This will run the procedure to schedule the 
student into the required course sections with the matching homeroom/platoon code. 
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15.0 Prepare Grade Input for All Classes 

This process requires that the following steps have been completed: 

1. Courses have transcript definitions attached 

2. Courses have rubric definitions attached (if applicable) 

3. Course sections are created 

4. Students are scheduled into course sections 

 

Note:  Course sections that do not have students will not appear in the list of course sections 
for which you can prepare grade input.   

 

To prepare Grade Input: 

1. Log in to School view. 
2. Click on Grades top tab. 
3. Click the Grade Input side tab.  
4. In the Options menu, select Prepare Grade Input.  This launches the Prepare Grade 

Input wizard. 
5. In Step 1 – Select Sections - of the Wizard 

• Select an option to Prepare for:  
▪ Current Selection:  will show all sections unless you selected sections on the 

Classes list and went to Options > Show Selected. 
▪ Selected Sections:  gives you the opportunity to select specific sections from 

a pop-up window. 
▪ All Sections:  allows you to prepare all sections of all classes with students in 

them. 

• Click Next. 
6. In Step 2 – Select Columns - of the Wizard: 

• From the Report Type dropdown, select Term. 
▪ Term:    end-of-term mark for report cards. 
▪ Progress:  interim report. MyEducation BC allows you to create grade input 

for one additional interim report per term without needing to create additional 
grade terms. 

▪ Course:  used by DL schools to create columns for recording their Active 
Date, Start Date, etc.   

Select the correct term from the Grade Term dropdown. 

• Do not select Replace Existing Columns checkbox. This is only used on very 
rare occasions when errors have been made in entering grades for an entire class.  
This option will wipe out all existing data entered for that term (marks, comments, 
work habits, etc.) 

7. Step 3 – Set Posting Parameters - of the Wizard. 

• Enter the Start Date and End Date for the grading window to be open.  The 
window will be open until midnight of the end date. This controls when teachers 
can access the term for entering marks.   

• Allow Posting for “All Students. 

• Click Next. 



 

Elementary Scheduling  v4.9 Page 39 

8. Step 4 – Confirmation - of the Wizard 

• This is a confirmation screen.   

• Click Finish to complete the Prepare Grade Input process.   
 

You can view the post controls that were created: 
1. Click on the Grades top tab  

2. Click on the Grade Post Controls side tab. 

3. Check the box beside the Grade Term ID you wish to view.   

4. Click on the Details leaf to edit the window dates.  

 

16.0 Transcript Visibility in Portal 

Student grades posted from Staff View or from School View are not automatically visible in the 
family or student portals.  

“Hide in Portal” = Y is the default setting on all current year transcript records to avoid the marks 
and comments being visible in the family or student portal before the school is ready.   

Follow district or school process to update the flag from “Y” to “N” before publishing report cards 
to the Family and Student Portals. 

School View > Schedule top tab > Master Schedule side tab  

To update the flag for Hide in Portal, select the “Hide in Portal” FieldSet from the list (the Hide in 
Portal is list and mass updateable). 
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Note: The Hide in Portal flag is visible in the School View > Grades top tab > Transcript side tab 
but is not updateable in this location.  The Hide in Portal flag must be updated from the 
Schedule top tab > Master Schedule side tab. 

  



 

Elementary Scheduling  v4.9 Page 41 

Appendix A – Transcript, Report Cards & Rubric Definitions 

Transcript Definitions:  These define the columns created for grade entry at the school.  The 
process of grade input looks at the transcript definition to determine what columns to create for 
report card grade entry (example:  a column for the performance scale or letter grade, a column 
for a text comment, etc.) 

Rubric Definitions:  These define the available curricular competencies for teachers to apply in 
assignments.   

Learning Update: What are your districts reporting policies?  

For detailed information on Transcript Definitions, Rubric Definitions and the Learning Update, 
refer to the spreadsheet: Transcript Definitions Explained on the L1 Info Station under Support 
Resources > Transcript Definitions and Report Cards. 
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Appendix B – Determining sections  

Teacher (Primary Staff > 
Name) Homeroom KF 01 02 03 04 05 06 Platoon 

Austen, Jane HR 01 18             HR 01 

Dickens, Charles HR 02 19             HR 02 

Franklin, Ben HR 03 6 16           HR 03 - K 

Gabaldon, Diana HR 04   24           HR 04 

Leacock, Stephen HR 05   12 10         HR 05 

Montgomery, Lucy HR 06     15 8       HR 06 

Davies, Robertson HR 07     13 9       HR 07 

Mowat, Farley HR 08     14 7       HR 08 

Munro, Alice HR 09       23       HR 09 

Atwood, Margaret HR 10         26     HR 10 

Einstein, Albert HR 11         12 16   HR 11 

Bronte, Charlotte HR 12           25   HR 12 

Dumas, Alexander HR 13           6 18 HR 13 

Shields, Carol HR 14             26 HR 14 

No. of Sections Required 
for each course:   3 3 4 4 2 3 2   
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The following report in MyEducation BC may be helpful in this task.   

1. In the School view, select the School top tab. 

2. Click on Reports in the menu bar.  

3. Select Enrollment Breakdown 

a. In the Date field, enter or select the appropriate date.  

b. In the Calculate Totals by field, use the  icon to select Home Room or Home 

Room Teacher 

c. Leave all other settings at default.  

4. Click Run. 
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Appendix C – Scheduling Blended Classes using Platoons 

Recommendations: 

• Be familiar with using filters 

• Map out your blended homerooms, grades and courses on a whiteboard or spreadsheet 

before you begin working in MyEducation BC. 

 

Two scenarios are provided below. 

Scenario 1: Students homeroom teacher teaches all courses 

Homeroom > 45A, Grades > 4/5, Teacher > Sian Espey 

Homeroom > 45B, Grades > 4/5, Teacher > Vivian Gilbertson 

 

   Gr-4   MEN04-01  (Platoon 45A)       Ms. Espey 

Hmrm 45A                Lang. Arts 
   Gr-5   MEN05-01 (Platoon 45A)       

 

 

   Gr-4   MEN04-02 (Platoon 45B)        Ms. Gilbertson 

Hmrm 45B                Lang. Arts 

   Gr-5   MEN05-02 (Platoon 45B)       

 

Create 
Platoon 

Codes with 
Homeroom 

Values

Assign 
Homerooms 
to Teachers

Assign 
Homerooms 
to Students

Assign 
Teacher & 
Platoon to 
Sections

Group 
Schedule



 

Elementary Scheduling  v4.9 Page 45 

Scenario 2: Students homeroom teacher differs from course teachers 

Homeroom > 45A, Grades > 4/5, Teacher > Sian Espey 

Homeroom > 45B, Grades > 4/5, Teacher > Vivian Gilbertson 

 

   Gr-4   MEN04-01  (Platoon 45A) 

Hmrm 45A               Ms. Espey 
   Gr-5   MEN04-02 (Platoon 45B)      Gr. 4 Lang. Arts 

 

 

   Gr-4   MEN05-01 (Platoon 45A) 

Hmrm 45B               Ms. Gilbertson 

   Gr-5   MEN05-02 (Platoon 45B)      Gr. 5 Lang. Arts 

 

Note:  

Homeroom 45A must match the corresponding platoon - 45A, section 01 

Homeroom 45B must match the corresponding platoon – 45B, section 02 

 

Grades will be assigned to their corresponding grade level/platoon/section 

 


