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1.0 Enrollment in MyEducation BC 

Enrollment Management encompasses student registrations, withdrawals, secondary 
associations, and transfers. Enrollment enables the smooth movement of student records from 
school to school or from district to district within British Columbia and the Yukon. This Document 
provides step by step instructions on how to register a student, withdraw a student, manage 
secondary associations, outlines how and when student transfers take place and which security 
roles are required to perform these tasks.   

2.0 Registering Students 

Most students in BC will be found within the MyEducation BC database or in the Student 
Archive environment if the student has been out of school for a while. See the Registering a 
Student from the Archive Environment section for details on archive criteria. 

The first step of the Registration Wizard queries for an existing student record in MyEducation 
BC, if the search does not return a student, then a search of the Archive should be done.  If no 
record is found in either the query or the archive, and the student Legal Last Name, DOB and 
Gender are confirmed to be accurate based on the student identification, then a new student 
record can be created.   

The MyEducation BC Standards Manual provides guidelines for acceptable identification 
documentation and name formatting.  Following the Ministry guidelines will help reduce the 
number of duplicate students created within the district. The MyEducation BC Standards Manual 
is found on the MyEducationBC.info site > School User Resources 
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2.1 Registration Wizard Step 1 - Query 

In School view > Student top tab > Set Filter to All Active Students   

• Options > Registration > Register Student 

• Using the information on the legal identification enter: 

o Legal Last Name 

o Gender 

o Date of Birth 

➢  Spelling out the month allows the system to automatically format the 
date to match the user locale preference settings.  This reduces the 
chance of entry error in day/month formatting, which will reduce 
duplicate student records.   

If this student has a family member in the school or district, click the “New family member” 
checkbox, otherwise leave it blank. If this is a family member, see the Registering Related 
Students section.  

• Click Next 

2.1.1 If a Student Match is Found in the Query  

A number of possible scenarios will result from a search including: 

• Possible match(es) will display who is a match for the data elements being queried. 

• Possible match(es) will display who is not a match for the data elements being queried. 

• No match displays for data elements being queried but the student is archived. 

• No match displays for data elements being queried but the student is NOT archived. 

• A confidential flag message will appear indicating that the data elements being queried 

are associated with a student who has their confidential flag set. 

An overlay will appear in the Registration Wizard with a reminder to verify the student 
identification information before making a selection.  Use the scroll bar to scroll right and see 
more information on the student, including Enrolment Status and Current School Name.  
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• Scrolling over in the list, reveals existing school Information for the student being 

registered including (phone number and email).  Clicking the school’s name in the 

Contact information, opens an email to the school if an email address has been entered 

in the School Details (refer to School Setup documentation for details). 
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o Activate Existing Student Record   

▪ If the selected student is currently active in a school, clicking OK will 
return to step 1 of the registration wizard.  A message will appear ‘The 
selected student is already active.’ The current school and district 
information is provided for contacting the school to withdraw the student. 
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▪ If the selected student is not active in another school, the student 
information will populate step 2 of the registration wizard. 

 

 

If the flag hasn’t been set, you will receive an error message and must 
contact the existing school of record for the student 

o Create a New Student – If the student(s) returned by the Restricted Query is not 
a match, this option may be selected.  It will move to step 2 of the registration 
wizard and create a new student record.  A search of the Archive Database 
should be done prior to creating any new student record.   

▪ Click the Options menu, and select Flag Student for Retrieval, enter the 
student PEN - or – Legal First Name, Legal Last Name, Gender and 
DOB.  See the Registering a Student from the Archive Environment 
section for details. 

• Note:  If the student is being registered to a DOLS (catchment area, boundaries are 
enforced), the student’s postal code is outside of the catchment area boundary, and the 
student is exempt from the catchment area boundary rules, the flag and reason must be 
set before saving the registration. 

Note: A DOLS school will be unable to register a student outside of the catchment area 
boundary for the school unless the Exempt from Catchment Rules and Exempt from 
Catchment Reason flags are set. 
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o Go Back to Registration Wizard Step 1 – If the student(s) returned by the 
Restricted Query does not include the registering student and the user would like 
to run the query again after checking the student documentation, this option will 
return to the query screen. 

 

This message may appear after the query if a student has been flagged as a confidential 
student based on the guidelines in the MyEducation BC Standards Manual.  Contact the 
previous school to withdraw the student.  Once withdrawn, the confidential flag is removed, and 
the student will be found in the query.  When the student is registered, the flag may be set again 
based on district practices.   

 

 

2.1.2 If a Student Match is Not Found in the Query  

Step 2 of the Registration Wizard shows in the pop up.  A search of the Archive Environment 
should be done prior to entering a new student record every time a search returns no results. 
Click the Options menu, and select Flag Student for Retrieval, enter the student PEN - or – 
Legal First Name, Legal Last Name, Gender, and DOB.  See the Registering a Student from 
the Archive Environment section for details.   

Only when there are no results in a regular query and the Archive retrieval do you proceed to 
step 2 of the registration wizard. 
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2.2 Registration Wizard Step 2 – Student Demographics 

If the student was found in the Step 1 Query and selected, the existing demographic information 
will automatically populate into the fields.  The demographic information can be updated with 
any new information in this screen.  If a new student record is being created, the student 
demographic information can be entered in this screen.  Follow the Ministry guidelines for 
acceptable identification documentation and name formatting found in the MyEducation BC 
Standards Manual.  Required fields are identified with an (*) and any optional information not 
entered in the wizard can be entered in the student details. 

 

• Legal first name – The legal first name found on the student’s identification 

• Legal middle name - The legal middle name found on the student’s identification 

• Legal last name - The legal last name found on the student’s identification 

• Suffix – A dropdown list to select the legal name suffix if one appears on the student’s 
identification 

Enter the usual name fields only if the student has a usual name that is different from the legal 
name.  

• Usual first name – The first name the student uses to identify themselves. 
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• Usual last name – The last name the student uses to identify themselves. 

• Gender – Gender as it appears on the student’s identification 

• Gender Identity– The gender a student uses to identify themselves. (See the 
MyEducation BC Standards Guide for more information) 

• Date of birth – The birthdate as it appears on the student’s identification 

• Home phone – The student’s home phone number 

• Work phone – The student’s work phone number  

• Cell phone – The student’s cell phone number 

• Home Language – The primary language spoken in the student’s home 

• Homeroom - The student’s homeroom identifier 

• Grade sub level – TRAX and 1701 use subgrades to identify students with situations 

that are not met by the standard EL-12 grade levels.  

Subgrades used by TRAX with the Adult Diploma: AD, AN and HS: 

KH - A half day Kindergarten student has the YOG for KF and the subgrade KH 

EU and SU - When the school determines a student is not in a specific grade, the 

student YOG is related to the student age and SU (secondary ungraded) or EU 

(elementary ungraded) as the subgrade.  

HS - A student registered at a school as a home-school student has a YOG related to 

the age and HS as the subgrade. 

AD and AN - A student older than school age as defined by the Ministry of Education 

and has the Adult Diploma primary program of study will have a YOG for grade 12 and 

AN or AD as the subgrade.  

GA - A student older than school age as defined by the Ministry of Education and has 
previously earned a diploma will have a YOG for grade 12 and the subgrade GA. Click 
the Address tab to display the address fields – See Student Demographics – Addresses 
section for more details. 

• Calendar – The student calendar is required for attendance, select from the picklist. 

Physical Address: 

• Street address – The street number and name of the student’s residence  

• RR Number/PO Box – Rural Route or Post Office Box information 

• City Prov PC – Municipality, Province and Postal Code of the student’s residence 

Mailing Address:  

• Is identical – Check this box if the mailing and physical address fields are the same, the 
fields will auto populate.  

• Street address – If different than the physical address, enter the information here 
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• RR Number/PO Box – if different than the physical address, enter the information here 

• City Prov PC - if different than the physical address, enter the information here 

Click Next 
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2.3 Registration Wizard Step 3 – Enrollment 

Information relating to the student in the school are in this screen.  Required fields are marked 
with an (*) and any optional information not entered in the wizard can be entered in the student 
details.    

• Year of Graduation – the Year of Graduation (YOG) determines the grade level of the 

student.  Grade level will fill in automatically once YOG has been selected. 

• Enrollment Status – When registering a student, the status will be Active or PreReg 

o Active – The student is active in the school  

o PreReg – The student will be active in the school at a future time.  

▪  Pre Registering a student allows for future course section scheduling and 

reporting. The school will change the Enrollment Status to Active when 

the student arrives, or the status change will be done automatically over 

End of Year Rollover if the student is preregistering for the next school 

year.  When Pre Registering a student, using the current date in this 

screen will allow the school to adjust the record as needed.  Using a 

future date will cause complications with the student enrolment records 

and potential inaccuracies in the student PSR. This is not the date the 

student becomes active in the school.  It is the date the student became 

pre-registered in the school and therefore is best represented by the 

current date.  Each student’s active date is populated en masse during 

the EOYR processing of student records. 

▪ Withdrawing a Pre-Reg cannot be done with Registration Wizard.  

Withdraw needs to be done in the Students Record>Membership Side 

Tab.  Options>Registration>Withdraw Student>Code = No Show 

• PSR Grade – Grade when enrolled for the PSR card 

• Date -  The date of registration 

• Code – Select the appropriate registration code from the picklist.   
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2.4 Registration Wizard Step 4 – Confirmation 

Confirm and select the Finish button or return to previous screens to edit information if required. 

Update the student demographics in the Student top tab > Details side tab screen for any 
additional changes to the student information.  For more about the information on the Student 
Details page, see the section Student Demographics.  

2.4.1 Registering a Student from the Archive Environment 

The archive process moves eligible student records from Production into the Archive database.  
The student may be retrieved from the Archive database and returned to Production through an 
overnight process that is similar to the PEN request.   

 
Retrieving a student from the Archive environment and returning their record to Production is a 
part of the standard registration process.  An additional step of Flag Student for Retrieval 
should be done if the student is not found with the restricted query in Production and the student 
fits the archive criteria.  Student archive criteria are:  more than 6 years of age -and- withdrawn 
(inactive) for more than 4 years.   

• Search for the student using the instructions in the section: Registration Wizard Step 1 - 

Query 

•  If the student is not found using the registration query and the student meets the archive 
criteria: 

o In Options > Flag Student for Retrieval Enter the student PEN - OR – 
Legal First Name, Legal Last Name, Gender and DOB. 
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If a student match is found, the record will be flagged for retrieval.  When the student is 
flagged for retrieval, the overnight process will bring the student back into Production in 
the same state they were when archived.  The following day the school will find the 
student in Step 1 – Query of the registration wizard.  

If no student match is found a message will return “No students found in the archive 
database for the passed criteria.” the school can then create a new student record in 
Step 2 – Student Demographics of the registration wizard. 

2.4.2 Registering Related Students/Siblings 

In Step 1 – Query of the registration wizard, there is a checkbox available Search for related 
student.  Searching for related student will populate some of the student demographic fields 
(home phone number, address, contacts) if a new student record is being created.  If the 
student record is found with the query it will keep the information that is currently in the record. 

• In Step 1 – Query  

o Check the search for related student

 

The Student Pick List appears. Find the related student and click OK. Then, 
select the Relationship to the student registering (such as sibling). 

 

If this is a new registration, it will copy some of the demographic information (phone number, 
address, contacts) from their existing sibling. If the student record is found with the query it will 
keep the information that is currently in the record.  
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3.0 Cross-Enrolling Students 

Students taking courses from more than one school at a time are cross enrolled from the 
primary (school of record) to a secondary school or schools. 

3.1 Creating Secondary School Associations 

To associate a student with a secondary school: 

School view, click the Student top tab. 

• Options > Create Secondary School Associations 

• Select the top tab 

o Push – Primarily used for Summer School, this will create secondary school 
associations for groups of students who are primary to the school for a different 
school.   

▪ Secondary school – select the school the students need secondary 
associations to.  

▪ District year - select the school year 

▪ Start Date – The date the secondary association will start 

▪ End Date – The date the secondary association will end 

▪ Students:  

- Selection – select individual students from a list 

- Snapshot – use a snapshot of students  

▪ Click OK – a message will appear showing how many secondary 
associations were created and how many skipped 
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o Pull – Create secondary school associations for students coming to the school, 
this is the standard method used for a single student.  

▪ Secondary School – the current school 

▪ District year – select the correct year 

▪ Start Date – The date the secondary association will start 

▪ End Date – The date the secondary association will end 

▪ Legal first name – student legal first name (optional) 

▪ Legal last name – student legal last name 

▪ Gender – Gender as appears on student identification documentation 

▪ Date of Birth – Date of Birth as it appears on student identification 
documentation 

Click Search – a confirmation message will state the association was created or 
that no matching results were found 

 

 

The student(s) should now appear in the Student list under the All Active Students filter with a 

Cross-Enrollment icon (   ) in the Alerts column. See the exception to this in Future Cross 
Enrollments below for future dated students. 

Note:  A student being Cross-Enrolled to a DOLS (District Online Learning School) who is 
outside of the catchment area boundaries for the school, and is exempt from the catchment 
area boundary rules, must have the flag set on the student record indicating the exemption and 
reason by the primary school or the student cross-enrollment cannot happen.  



 

Enrollment and Demographics v4.13 Page 19 

3.1.1 Setting Attendance Management Type for Secondary Students 

Depending on the school preference setting for Secondary School Management, the 
Attendance management type for secondary students may need to be set.  

 

Option 1 – Setting attendance management type for an individual student 

• School view > Student top tab.  

• Select the student and click the Membership side tab > Schools sub side tab.  

The student’s list of former and secondary school associations will appear.   

• Click the blue hyperlink for the record representing the school.   

• Set the Attendance management type field as appropriate. 

Option 2 - Setting attendance management type for multiple students 

• School view > Global top tab > Favorite side tab > Student School Association table.  

• Use the filter called:  Secondary Students to filter to the students who are secondary 
students at the school.  Check the School>Name field to ensure all records are for the 
school.  

• Review the AttMag Type field and update using mass update or modify list functions.  

 

3.1.2 Future Cross Enrollments 

When cross enrolling a student during the current school year using a future date, follow the 
same steps as above, entering a future date for the secondary school association.   

The cross-enrollment icon will display on the start date of the Secondary School Association 
and the student will show in the All Active Students filter. The Future cross-enrollments filter will 
display all secondary students in the school with a start date after today’s date, and the student 
will show in the All Secondary Students and All Students filters. 
 

See note above re DOLS 

 

 

  

Note: Future cross-enrollments only refers to students who will be attending at a future 
date in this current school year. Students who will be cross-enrolled after the end of the 
school year are found in the Build view. 
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3.1.3 Ending Secondary School Associations 

Please see the sections:  

• Withdraw Student Wizard – Students with an Active status that are Secondary to the 

school 

• Withdraw Student Wizard – Students with an Active no Primary status that are 

Secondary to the school 

 

If a student moves to another district mid-school year and has a secondary school association 

that is being end-dated, the student may still be included in some filtered lists at the former 

district, until after EOYR. To ensure the student does not appear in lists at the former district, go 

to Student TT > Membership ST > Schools, and change the Type on the secondary school 

association record from "secondary" to "former." 
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4.0 Transferring Students 

4.1 Transferring a Student from One School to Another 

The Transfer Student function allows one school to pull a student in from another school in the 
province, without taking each individual step of withdrawing them and enrolling them at the new 
school during the current school year.  

The MyEducation BC Standards Manual states that students moving between districts should 
be withdrawn from the sending school and registered to the receiving school.  Transfer function 
should only be used within districts in BC.  

The Transfer function is only currently available in the enterprise security roles:  District Support 
(Help Desk/Level 1) and Registrar roles.  In order to add this function to a role, add Transfer 
students in the Other column on the Student table see the Security Management guide for 
details. 

Note:  If a student is being transferred to a DOLS (District Online Learning School) and has an 
address outside of the catchment area boundaries for the school, but is exempt from the 
catchment area boundary rules, the Exempt from Catchment Rules and the Exempt from 
Catchment Reason flags must be set on the student record indicating the exemption and reason 
by the primary school prior to initiating the transfer or the DOLS will not be able to accept the 
transfer. 

 

To perform a Transfer of a student from one school to another: 

The sending school initiates the process: 

School or District view > Student top tab > Details  

• Transfer pending – check the checkbox  
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• Transfer School > Name - Select the receiving school using the magnifying glass 
picklist and click OK

 

 Click the Save button on the student details page.  

The student is now ready for the Receiving School to accept the transfer. 

 

The receiving school: 

School or District view > Student top tab 

• Options > Registration > Transfer Student. 

In the Transfer Student pop up window:  

• Select the student using the magnifying glass pick list.  The list presented are students 
that sending schools have tagged as transfers for the receiving school.   

 

• Withdrawal – creates the Membership > Enrolment W record for the sending (current) 
school 

o Current school – auto populates the sending school 

o Date – date of withdrawal  

o Code – the withdraw code for the sending school record 

o Reason – not required, use per district practice 
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• Entry – creates the Membership > Enrolment E record for the receiving (destination)  
school 

o Current school – auto populates the receiving school 

o Date – date of enrollment (for enrollment record and PSR consistency it is 
recommended that the withdrawal date and enrolment date are not the same 
day) 

o Code – the enrollment code for the sending school record 

o Reason – not required, use per district practice 

o PSR Grade – mandatory entry by the receiving school for a transfer 

The student Membership > Enrollment record will be populated using the values entered above:  

 

To adjust the other fields, click into the details of the record 

• Select the template for Default Fields + BC. 

• Change record details as necessary for accuracy. 

• Save 
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4.2 Primary School Transfer 

A Primary School Transfer occurs when a student needs to swap their Primary and Secondary 
Schools. To perform this task, we will make use of the Transfer function. See Transferring a 
Student from One School to Another for details.   

There are six parts to performing a Primary School Transfer in MyEducation BC:  

1. Take a screenshot of the student’s schedule. 

2. Set the transfer of the student from the original primary to the original secondary school 
(which will now make it the primary). 

3. End the secondary association at the original secondary school. 

4. Complete the transfer; and cross-enroll the student back to the original primary school 
(which makes it now the secondary).   

5. Recreate the student schedule. 

 

Screenshot of student schedule: (school A) 

School or District view > Student > Schedule 

o Take a screenshot of the student schedule for use later 

 

Set the transfer at the primary school: (school A) 

(For complete details see Transferring a Student from One School to Another) 

School or District view > Student top tab > Details  

o Transfer pending – check the checkbox  

o Transfer School > Name - Select the receiving school using the magnifying 
glass picklist and click OK 

o Click the Save button in the student details page.  

 

End the Secondary Association: (school B) 

School > Student > Membership > Schools >  

o Click into the details of the secondary association and enter or edit the end date 
to the day prior to the transfer.  Using the current date will overlap the secondary 
associations with the primary associations for one day, while confusing to view it 
will clear up the next day. 

 

Complete the Transfer: (school B) 

(For complete details see Transferring a Student from One School to Another) 

The receiving school: 

School or District view > Student top tab 

o Options > Registration > Transfer Student. 
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In the Transfer Student pop up window:  

o Select the student using the magnifying glass pick list.  The list presented are 
students that sending schools have tagged as transfers for the receiving school.  
Fill in the Withdrawal and Entry sections.  

o Adjust the Membership > Enrolment records as necessary 

 

Create Secondary Association: (school A) 

See the section Creating Secondary School Associations for the steps to create the secondary 
association for school (A) 

 

Recreate the student schedule using the screenshot taken: (school A) 

School > Student > Schedule > Workspace  

• Add the courses back to the student schedule.  All marks and attendance will be 
restored. 
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4.3 Review Student Enrollment Information 

All enrollment information is located in the Membership side tab. 

Student top tab > select student > Membership side tab. 

4.3.1 View Current and Past Primary Enrollments 

Existing and historical Primary School enrollments, status change and YOG change records are 
found in the Enrollment side tab.  See the sections on: Changing a Student’s Enrollment Status 
and Changing a Student’s Year of Graduation for details. 

Edits to the details of a record for a primary student can be made by clicking into the details of 
the record. 

 

 

 

4.3.2 View Current and Past Cross-Enrollments 

Current secondary school association, historical secondary school associations and former 
primary school associations are found in the Schools sub side tab.   

Secondary and Former school associations allow the school to view student details, pull 
necessary reports and edit course records attached to their school as required. 

For details on creating Former school associations, see section Withdraw Student Wizard – 
Step 1 – Students with an Active status who are Primary to the school for details.   

For details on Secondary Associations, see the section Creating Secondary School 
Associations. 
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4.4 Change a Student Enrollment Status 

When a manual change to a student status is required, these can be made in the registration 
set of the options menu.  Enrollment changes can be made for Active and PreReg students. 

Primarily this is used to update a student with the status of Pre Reg to Active during the current 
school year.  (End of Year Rollover will set all Pre Reg students to Active for the following 
school year)  

School or District view > Student top tab > Select the student 

• Options > Registration > Change Student Status 

o Name – populates if the student was selected, or the student can be 
selected using the magnifying glass picklist. 

o Current Primary School – will populate the current primary school 

o Date – the date the change will take place 

o Reason – optional use per district policy 

o Status – select the appropriate status  

▪ Active – will be active in the school  

▪ Withdrawn – will be withdrawn from the school 

• Click Save 

 

The change made is visible in the following location: 

Student top tab > select student > Membership side tab > Enrollment sub-side tab. 

All changes to Enrollment Status will be indicated with a S. 

 

Click into the details of the S record for more information on the Enrollment Status change: 
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4.5 Change a Student Year of Graduation 

The Year of Graduation (YOG) can only be changed for an Active student. See Changing a 
Student’s Registration Status for details on how to change a student Status to Active, and then 
change them back to their proper status once the YOG has been updated.  

 

To change a YOG for a student: 

School or District view > Student top tab 

School View>Student top tab>Membership side tab> 

1. Select the checkbox by the name of the student. 

2. From the Options menu, select Registration > Promote/Demote Student. 
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3. This will bring up the Promote/Demote Wizard  

▪ Date: when this change is to take place 

▪ Reason: Double promote = advance the grade, Repeat = go back a grade or blank 

▪ Year of Graduation Picklist or enter year.  This will calculate the Grade Level based on 
the current school year 

 
 

4. Click the OK button to make the changes. 

View the change in the Student top tab > select student > Membership side tab > Enrollment 
sub-side tab. 

All changes to Year of Graduation will be indicated with a Y. 

 

Click into the details of the records for more information, PSR Entry/Exit Grade is not applicable 
here and can be left blank. 

 

PSR Grade field can only be edited for an E or W membership record   
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5.0 Demographics 

Student Demographics are the fields of identifying information for a student.  The fields include 
the date of birth, contact information, parent/guardian and sibling information, grade level, 
programs, alerts, citizenship, diploma information and schools they attend.  

5.1 Student Demographics 

The registration wizard populates the legal and usual name, gender, gender identity, date of 
birth, Year of Graduation, PSR grade, telephone number(s), address(es), homeroom and home 
language.  Additional demographic fields can be populated after the wizard completes. 

5.1.1 Main Demographics Page 

School or District view > Student top tab > select student > Details side tab. 

The bulk of the information for a student is stored here, and along the top are several Sub-tabs 
where more information can be collected and stored.  The information entered in the enrollment 
wizard will populate to the Details page. Additional information can be entered after the wizard 
completes. 

In addition to basic student demographic information, the Demographics sub-top tab contains 
fields for populating additional school-level information, such as calendars, homerooms, and 
lockers.   

 

5.1.1.1 Cultural and Traditional Names field 

 

5.1.1.2 Formatting of Phone Numbers 

Formatting of Phone Numbers in MyEducation BC follow a very specific format: 

XXX-XXX-XXXX 

Auto formatting occurs when no spaces are entered. 

5.1.1.3 Updating Homeroom Information 

Homeroom assignments can be handled for individual students by using the magnifying glass 
on the Demographics sub-side tab > Homeroom field to select the appropriate homeroom.  
Alternatively, homerooms can be assigned by selecting a group of students and using the Mass 
Update or Modify List functions in MyEducation BC.   

If the School Schedule preference Homeroom – Require room for homeroom fields on Staff is 
selected, homeroom can only be selected using the magnifying glass pick list. With this 
preference turned on the Next homeroom field cannot be used. 

If the School Schedule preference Homeroom – Require room for homeroom fields on Staff is 
not selected, homeroom can be selected using the magnifying glass pick list or homeroom can 
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be typed as free text. With this preference turned off the user can enter a free text value into the 
next homeroom field. 

5.1.1.4 Parent/Guardian Information 

The Contacts side tab contains the parent/guardian information. For more information, see the 
Contacts section. 

5.1.1.5 Locker Assignment 

Locker setup for the school is covered in the School Setup documentation. Lockers can be 
assigned to students through the Student top tab: 

• The locker field can be added to a field set in order to use Modify List functionality for populating 
multiple students.  

• Click into the Detail side tab of a student and use the magnifying glass to populate the Locker field 
on the student’s Demographics sub-top tab. 

5.1.2 Addresses 

In the Addresses sub-top tab, both the Physical address and Mailing address for a student can 
be entered. If the Mailing address is the same as the Physical one, check the is identical 
checkbox beside the Mailing Address field and it will auto populate the physical address 
information. The Mailing Address field populates mailing reports and is searchable using a 
Query. 

Note: The User validated checkbox should ONLY be used if the system validation fails on 
addresses entered correctly. Address discrepancies with exports and reports can occur with 
addresses validated with the User validated option.    

The Proof of address field can be populated per district practice.   

5.1.2.1 Formatting of Addresses 

Addresses in MyEducation BC are actually concatenated smaller fields that must fit a specific 
format. When saving the address, a validation procedure will be run, and will prevent saving the 
information if the address does not match this format.  

Canada Post conventions for street types have been applied to the validation of addresses, so 
abbreviations must be used when entering a street type. The validation tool provides a selection 
list for valid street types, if required. 
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Address Component User enters . . . 

Apt/Unit/Complex Only the number or letter of the apartment, unit or complex. Do not preface the 
letter or number with Apt, Unit, etc. 

Street number The street number of the building 

Street prefix Street prefix if there is one. 

Street name Name of the street, without the street type 

Street type Street type as per Canada Post abbreviation conventions.  Example:  Rd, St, etc. 

Street post direction Street direction that comes after the street name, if there is one.  This value should 
be the abbreviated street direction.  Example:  Gordon St SE 

Street pre direction Street direction that comes before the street name, if there is one.  This value 
should be the abbreviated street direction.   Example:  N Gordon St 

 

The second set of fields will be for RR Number or PO Box.  
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Address component User enters . . . 

RR Number/PO Box This field may contain:  RR, PO BOX, LOT, CONC or GD information.  When entering 
data, these fields should be entered in block caps as follows: 

• RR  

• PO BOX 

• LOT 

• CONC 

• GD 

The last set of fields in the address will be City, Province and Postal Code. 
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Address Component User enters . . . 

City Name of the city, town, etc. 

Province 2-Digit Provincial code, i.e., BC or YK 

Postal code Postal code in Canada Post convention format A1A 1A1 

 

5.1.2.2 Entering Addresses in MyEducation BC 

1. Type the address into the fields given. 

2. Click on the  icon at the end of the address field to open the validation window. 

3. In the pop-up validation window: 

a.  Uncheck the User Validated checkbox.  

b. Verify that the address components appear in the correct fields, by clicking the 
Validate button. 

 

4. If a validation warning is received on entering this window, verify the address 
components appear in the correct fields.  

a. The User validated override checkbox may be used if the address does not 
validate correctly. This will open the address fields to be populated manually. 

 

b. Type the address components into the appropriate fields. 
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c. Press Format after entering components.  Select the appropriate format for 
addresses with Apt/Unit/Complex numbers using the dropdown selection.  

i. CA – Civic Address 1 – Apt/Unit/Complex number at the end (e.g. 2614 
Koby Ave 26A)  

ii. CA – Civic Address 2 – Apt/Unit/Complex number at the beginning with a 
dash (e.g. 26A-2614 Koby Ave) 

d. Click OK, then the Save button. 

Note: The User validated checkbox should ONLY be used if the system validation fails on 
addresses entered correctly.  Address discrepancies with exports and reports can occur with 
addresses validated with the User validated option.    

Shared Addresses 

If an address is already in MyEducation BC, attached to a sibling or contact, the address can be 
selected from the magnifying glass picklist. Autofill suggestions may appear as the address is 
typed. When selected, this will automatically populate the entire address and identify it as a 
shared address between the student and the sibling or the selected contact. Subsequent 
changes to this shared address will prompt the user to choose if they want to update the 
address for any or all records attached to the shared address. 

 

The “Shared Address” icon will then appear. 
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5.1.3 Alerts 

On the Alerts sub-top tab, there are three Alert categories. Student alerts are important bits of 
information about a student that are represented by an icon next to the student's name on 
student pages. These icons alert users to information they should know about a student. The 
information entered about each alert will be visible to any user who has Read access to the 
Alerts table in their Security Role. Note: Alert icons and associated text may be visible in the 
Portal to users with a Parent role.  

 

 

• Identify the category for the Alert (see category details below) 

• Click the Add button below the category 

• In the popup window enter a sequence number to sort the alerts within the 

category if applicable 

• Enter the Description per district policy, this information will display to the user 

when the student Alert icon is clicked.   

• Enter the start date 

• Enter the end date 

• Check ‘Disabled’ check box to disable the alert before the end date is reached 

• Select the icon from the picklist for Other Alerts 

• Click the OK button 

• Click Save in the student details when the popup window closes 
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5.1.3.1 Legal Alerts 

Legal alerts  can inform users about certain legal situations they should be aware of. These 
are most often used for child custody, safety or legal issues surrounding the student’s family 
situation. Some court documentation is typically on file at the school for these students. While 
the Legal Alert is active by date, the student PSR will display a checked Legal Alert box on the 
student PSR. A permanent inclusion record for the PSR can be created using the instructions in 
the Inclusions section of this guide 

If the Legal Alert is active by date, the student PSR will display a checked Legal Alert box on the 
student PSR. 

 

5.1.3.2 Medical Alerts 

Medical alerts can inform users about a student’s life-threatening medical condition. 
While the life-threatening Medical Alert is active by date, the student PSR will display a checked 
Medical Alert box on the student PSR. A permanent inclusion record for the PSR can be created 
using the instructions in the Inclusions section of this guide. (Other health conditions that are not 
considered life-threatening will be stored in the Other Alerts category using Health Alert).  

If the life-threatening Medical Alert is active by date, the student PSR will display a checked 
Medical Alert box on the student PSR.  

5.1.3.3 Other Alerts 

Other alerts can inform users about any other important information staff members should 
know about a student, such as Health Alerts, Family Alerts, Information Alerts.  

The Health Alert   is used for non-life-threatening medical conditions.  

The Family Alert icon is most often used to note information on a student’s family 
situation that is not related to safety or legal matters for that student. 

The Information Alert would be used for any other informational alert that users may 
need to know about the student. 

5.1.4 Citizenship 

The Citizenship sub-top tab contains information about a student’s Country of Birth, Country of 
Citizenship and corresponding Citizenship code. This page will also contain information for 
international students, such as Length of Stay, Visa Status and Expiration Date.  Country of 
Citizen and Citizenship Code are used in 1701 and TRAX and should be filled in. The other 
fields are optional based on district practice. 
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5.1.5 Children and Youth In Care and Youth Agreement 

Children and Youth in Care (CYIC) and Youth Agreement (YAG) fields are available to aid 
administrators and district and school staff in ensuring the health, safety, and educational 
achievement of vulnerable children. In MyEducation BC, CYIC fields are in the Student 
Demographic information (Student top tab).  

These fields are NOT visible in the Family or Student Portal. 

5.1.5.1  

District and School View > Student top tab > Details leaf > Demographics Sub top tab 

 

There are 3 fields available to record CYIC and YAG information: 

1. Who has custody? 

2. CYIC or YAG  

3. Agreement or Order 
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5.1.5.2 Accessing CYIC and YAG Student Data  

There are specific filters available in the District, School and Staff Views to identify and report on 
CYIC and YAG student records. 

5.1.5.2.1 District and School View Filters 

Administrators and school staff can filter a list of students at the district or school level who have 
data in either CYIC or YAG or Agreement or Order. 

The CYIC or YAG Student filter is available in the District View, School View and Staff View. 

District View > Student top tab > Filter = CYIC or YAG Students 
School View > Student top tab > Filter = CYIC or YAG Students 
Staff View > Student top tab > Filter = CYIC or YAG Students 

 

5.1.5.2.2 Attendance Filters for CYIC and YAG Student Data 

School View > Attendance top tab > Daily History side tab > Filter = CYIC or YAG 
Students recent attendance 

Administrators and school staff can filter on attendance data to list and run the daily attendance 
report for any students in the school who have data in either CYIC or YAG or Agreement or 
Order. 
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School View > Attendance top tab > Class office Select Filter = CYIC or YAG Students 

Administrators and school staff can filter on attendance data to list and run the class attendance 
report for any students in that school who have data in either CYIC or YAG or Agreement or 
Order. 

5.1.5.3 Viewing Student Data using the CYIC or YAG Field Set 

District View > Student top tab > Field Set = CYIC or YAG  

School View > Student top tab > Field Set = CYIC or YAG  

Staff View > Student top tab > Field Set = CYIC or YAG  

 

The Field Set is available in the District View, School View and Staff View and displays the 
following CYIC or YAG Student information: Custody, CYIC or YAG, and Agreement or Order.  
These columns of information are both mass updateable and list updateable under the Options 
menu. 
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5.1.6 General Student Programs 

The Membership side tab Programs sub-side tab is where General Student Programs are 
assigned. If a student is assigned a program, it will be done here, and other users may view 
what programs a student is assigned to.  A variety of BC templates are available for General 
Student Programs, the templates provide program specific fields that can be populated per 
district policy.  

To assign a program to a student:  

• Set the data dictionary  to General Programs  

• Options > Add to bring up the Student Program pop-up.  

• Select the appropriate template for the program type (ELL, Ab Program, Career 

Program) 

• Choose the Program code using a pick list.  

• Assign the program school 

• Enter the start date and end date (per district practice).  

To modify existing general program assignments, click the blue, hyperlinked name of the 
program and update the information in the fields as required. 

Programs are also visible on the Student > Details > Programs sub top tab. The second part of 
this Programs page is the Years of ELL section.  

The Years of ELL is loaded by the Ministry of Education each year. It is recommended that 
districts not adjust the Ministry provided information in this field.  Contact the Ministry of 
Education if there are concerns with the Years of ELL value loaded by the Ministry. 

Considerations:  

• Students with active Enterprise ELL Programs will display the ELL Alert icon 

• District Created funded and non-funded ELL Programs can also be set up to display the 

ELL Alert icon (see District Setup guide for instructions)  

5.1.6.1 School View > Student Top Tab > Options > Assign Student Programs 

You can mass assign a Student Program to: Current selection, All, YOG or Homeroom 
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5.1.6.2 School View > Global Top Tab > Favorite Side Tab>Student Program Participation 

Global Tables to view all students who have a Student Program.  In this table you can sort by 
column headers, Modify list (Program, Prog Sch, Start, End), Mass Update (Start Date, End 
Date, Program Code). 

 

5.1.7 Student Services 1701 Designation Programs 

The 1701 Designation is managed through the School View > Student top tab > Membership 
side tab > Programs and is restricted by an add-on security role.   

To assign a 1701 Designation Program: 

• School or District View > Student top tab > Select the Student > Membership side tab > 
Programs.    

• Set the Dictionary Menu to Student Designations and the Field Set to Default Fields 
(Student Designations) 
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• Options > Add  

o Select the Student Designations template in the upper right corner 

    

o Select the appropriate Designation from the pick list 

o If this is the Primary Designation, check the Primary designation check box 

o Enter the Start Date 

o End Date may be entered or may be left blank per district standards 

o Save 

• School View>Global Top Tab>Favorite Side Tab>Student Program Participation to see 
all students program information. 

Considerations 

• Students with an active 1701 Designation Program will display an Other Alert identifying 
the student has a designation on file. 

• Students may have multiple designation programs assigned, if they are applicable, but 
only the primary designation will populate the 1701 Designation field.   

• The Primary Designation is identified by the Primary Designation check box in the 
Program Screen.  Only one Designation may be the Primary Designation.   

• When a new Primary Designation is created, the previous primary designation will 
automatically end date.  The end date may be removed if applicable.   

5.1.8 Update Designation/ELL Tallies 

If a student’s Primary Designation or ELL (ESL) program participation is added, deleted, or 
changed, there is a procedure to update the class composition. 

When the procedure is run (or is scheduled to be run) at the District level, it will update all 
students and all course sections, given the parameters selected. This procedure is available in 
the following locations: 

School view:  Student > Select a student > Membership > Programs > Options > Update 
Designation/ELL Tallies. 
 
District view:  Student > Select a student > Membership > Programs > Options > Update 
Designation/ELL Tallies. 
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Tools > Jobs > Options > Add…> 

1. Select a Tool = Procedure 
2. Procedure = Update Designation/ELL Tallies 

3. Input parameters > Select All Active Schools or an individual school 

Build view 

Workspace top tab > Master side tab > Options > Update Designation/ELL Tallies – Build > 
Choose a Scenario. 

5.1.9 Permissions 

The Permission sub-top tab indicates which permissions that parents, or guardians have given 
for student information. The fields that appear on this tab include Send Email & Autodialer 
Calls, Release of Info/Photos Outside of District, Permission to Walk Home, Allow 
Internet Access, Field Trip Permission, and Release of info to PAC. 

These fields are strictly informational and do not have functionality outside of this page; if Send 
Email is set to “No”, it will not remove the parent from the email list when emails are sent using 
bulk-send to all parents/contacts from the system. 

5.1.10 Language & Culture 

The Language & Culture top tab contains two sections.  The left side indicates the language 
spoken in the home, which language the student uses most and the first language of the 
student. Home Language is used in 1701 reporting and should be filled. 

The right side of the screen provides fields for Aboriginal Ancestry reporting, populate these 
fields as applicable for the student and per district policy.  

• Aboriginal Ancestry - provides a dropdown selection list  

• Band of Origin - the band the student originates from  

• Band of Residence - the band where the student currently resides 

• Status Card Number - freeform field 

Band of Residence is the field used for Nominal Roll reporting, identifying where the student 
currently resides for educational reporting and funding purposes. 
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5.2 Student Contacts 

MyEducation BC stores information about a student’s contacts and related students. This data 
can be shared between other students, as can their addresses and other contact information.  
Updating existing contacts with different demographic information will change the existing 
Person Record across the province, do not update existing contact fields with information for a 
different person.  

Parents/Guardians/Other Contacts 

School or District view > Student top tab > Contacts side tab 

The Contacts side tab lists the student contacts in a customizable field set.  Click into the 
details of the record to make changes if required.  

In the screenshot below, the outlined fields belong to this student contact relationship. Changes 
to the outlined fields are limited to this screen for this student only.    

The remaining fields, including the address tab, is demographic information that belongs to the 
contact’s person record.  If the person record fields are changed, they will be changed for the 
person everywhere they appear in MyEducation.  Note: Updating existing contacts with different 
demographic information will change the person’s demographic information across the province, 
Do Not update existing contact records with information for a different person. 
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Primary District field has been introduced on this template. This will facilitate the school users to 
identify the ownership of the student contact before updating it. Contacts are sorted by 
Emergency Priority.  Each contact requires a different number to print correctly on student 
information reports and exports as well as requiring specific contact type and/or checkboxes 
selected.  The MyEducation Standards Manual provides a complete listing of Contact Related 
Standards including assigning Emergency Priority. 

5.2.1.1 Add a Contact That Already Exists in MyEducation BC 

Select the contact through the picklist to avoid creating duplicate person records. Each contact 
record should identify a single person. Click the magnifying glass at the end of the surname 
when inputting a new contact and it will attempt to match the surname or next closest surname. 
If the contact cannot be located see the section for Adding a New Contact in MyEducation BC.  

There are three filter options in Selection Type:  

• Related Contacts – a list of contacts connected to a related student (if available) 

• All Contacts – a list of contacts in the district 

• All People – a list of contacts, staff and students in the district  

If there are multiple people with the same first and last name, match the person using the 
physical address.  
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Once a contact is shared, the Shared Contact icon will appear at the end of the surname.  

  

 

When a shared contact is selected the existing person demographic fields will auto-populate.  
Demographic fields for a contact include Title, Legal first and Legal last name, Suffix, Usual first 
and Usual last name, gender, Home (or primary) phone number, Cell phone, email addresses, 
place of employment, Work phone and extension, pager and addresses on the address tab.  

The Address sub-top tab will indicate if the contact has a shared address. This may not mean 
that the contact has the same address as the student; the contact could have a shared address 
with another student or another contact that they are attached to. 
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5.2.1.2 Add a New Contact in MyEducation BC 

Before adding a new contact, please refer to district policy on creating new records. To add a 
contact that has never existed in MyEducation BC, go to the Contacts side tab, click Add from 
the Options menu:  

In the New Contact page, enter the demographic information for that contact.  

Demographic fields for a contact include Title, Legal first and Legal last name, Suffix, Usual first 
and Usual last name, gender, Home (or primary) phone number, Cell phone, email addresses, 
place of employment, Work phone and extension, pager and addresses on the address tab.  

Fields in the context of the relationship to the student include Emergency Priority, Relationship, 
Type of contact, the contact’s Language details, and several check boxes, some with system 
functionality and others for information only:  

• Parental Authority or Guardian – used with BC demographic reports  

• Contact can pick up – information only  

• Contact lives with student – information only  

• Contact has family portal access – used with Portal account creation 

• Volunteer – information only  

• Receive grade mailing – used with staff view email functions 

• Receive conduct mailing – information only 

• Receive other mailing – information only 

• Receive email – used with email functions 

• Include on IEP – used with IEP report 

• Prevent Autodialing – used with BC AutoDialer export 

 

 

 

Enter or select the address on the Addresses sub-top tab.   

If the contact address is the same address as the student, connect this address with the 
student’s address. Autofill suggestions may appear when enough of the address is typed to 
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trigger a match in the system. Clicking the autofill suggestion will fill in the rest of the fields and 
display a “Shared Address” icon when saved:  

 

 

Clicking the magnifying glass at the end of the Street address field will bring up a pop-up with a 
list of addresses that match the entered address, and an “owner” field indicating who lives there. 
If none appear, the address may exist differently in the system. Selecting one and clicking OK 
will autofill all fields and display the “Shared Address” icon. 

 

If the contact does not have a shared address with another person in the system, simply fill out 
the remaining fields and click the Save button. There will be a “Not-Shared Address” icon 
displayed at the end of the Street address field: 

 

5.2.1.3 Delete a Contact 

If a contact is no longer applicable to the student, the contact can be deleted, this will remove 
the connection to the student.  

Once deleted, the record for the contact will still be available to select for another student in the 
pick list as shown in the Section– Adding a Contact That Already Exists in MyEducation BC. 

To delete a contact, check the box beside their name in the Contacts side tab, and then select 
Delete from the Options menu. 
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5.2.2 Related Students 

This screen displays the relationship between students.  The student relationships must display 
both sides of the relationship to function correctly on reports and searches: Student A must 
connect to Student B, and then Student B will connect to Student A. 

Related students with a two-way connection will print on the Student Information Verification 
form in the Sibling Information area. 

When a student is enrolled through the registration wizard as a sibling (see the Section – 
Registering related students), the relationship from one student to another will appear in the 
Contacts side tab > Related Students sub-side tab. Related students can also be added from 
this location. 

5.2.2.1 Create a related student record for two students in the system. 

Student top tab > select the student A > Contacts side tab > Related Students sub-side tab > 
Options > Add. 

 

In the New Related Student screen select the related student from the Name picklist then click 
OK in the popup.  Assign the relationship (Sibling is the recommended relationship) from the 
dropdown list and click Save.  

This step also has to be done in the Student B demographic screen 

This creates a relationship from the enrolling student to the existing student.  Without this 
relationship you will not see the information on Student Information Verification report. 
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The Name picklist popup contains a list of students in the district with an enrollment status of 
Active.  Students with a Pre-Reg status can have related students added when they become 
Active. 

 

 

 

5.2.2.2 Delete a related student 

To delete a relationship between two students, click into the details of the record then use 

Options > Delete.  Or check the checkbox next to the record in the field set and use Options > 

Delete.    

Note: Two students who are not in the same district can be connected as related students, 
this can be done by the Fujitsu Service Desk at the Enterprise level. 
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5.3 Primary Program of Study 

Programs of Study do not automatically populate in MyEducation BC, they are required for 
TRAX and the Graduation Reports.  This field can be populated as part of the registration 
process.  Refer to Graduation Reports Documentation for more information on Programs of 
Study. 

5.3.1 Add a Program of Study to an Individual Student 

School > Student > Transcript > Programs of Study 

1. In the Options menu, select Add.  A new window appears to enter the graduation 

program information.  

2. Click the  to open the Graduation Program Pick List window.   

 

3. Click the radio button to select the appropriate graduation program in the list.   

4. Click OK to close the pop-up window.  The selected program will now appear in the 

Name field.  The Total credit, Diploma type, and Description fields will auto-populate. 

5. Check the box for Primary program study. 

6. Click Save. 
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5.3.2 Add a Program of Study to Multiple Students Without a Program of Study  

This will add a Program of Study to students that currently do not have a Program of Study.  It 
will not change a Program of Study if a student already has one assigned. 

1. School view, Student top tab 

2. Options, Program of Study Creator – Primary 

3. Select the Program of Study to assign from the Pick List 

4. Select the group of students from the drop down selection 

5. Check or uncheck the ‘Active Students Only’ checkbox as appropriate 

6. Set the Start and End Grade if you want to limit the process to specific grade levels 

5.3.3 Locating Students in a Specific Program of Study Using Filter 

For a list of students in a particular program of study, use the “Program of Study = ?” filter and 
in the pop-up choose the program of study and what the search is based on. 
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5.3.4 Add or Change a Program of Study for Multiple Students  

In the School view, click the Global top tab.  

7. Click the Favorite side tab.  

8. Click the blue hyperlink on the Graduation Student Program table.  

9. Update student graduation program values using modify list or mass update functions. 

5.4 Updating Diploma/SCCP Granted Dates 

Diploma/SCCP met dates may be updated prior to End of Year Rollover (EOYR) to confirm 
students who are graduating.  It may also be necessary to update Diploma met dates for 
students who did not meet graduation requirements before EOYR, but have completed summer 
school courses to complete their programs.   

5.4.1 Enter Diploma/SCCP Granted Date for an Individual Student 

1. In the School view, click the Student top tab.  

2. Click the Details sub-side tab and select the Demographics sub-top tab.  

3. Use the date selector icon or type in the Diploma Granted Date that reflects the effective 

date on which the student fulfilled graduation requirements. 

5.4.2 Enter Diploma/SCCP Granted Date for Multiple Students 

1. In the School view, click the Global top tab.  

2. Click the Student side tab.  

3. Click the blue hyperlink on the Student table.  

4. Select the field set called Diploma Granted.     

5. Update Diploma granted date values using Modify List or Mass Update functions. 

Or, use the Pre transition field set as outlined in the EOYR reference guide. 

 

  

Note: If using Mass Update, ensure that the only students in the list are ones intended to 
update.  There is no way to mass update date fields back to a blank value. 
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5.5 Inclusions 

Inclusions will appear on the Permanent Student Record (PSR) report.    

If the Grade sub level = HS then the inclusion section will display Homeschooled under the 
Student Record Inclusion on the Permanent Student Record.   

If you have included an end date, and the end date is expired, a procedure needs to run 
in order to find the records and act on the date. It is not real time. There will be a nightly 
procedure in prod that will do this. 

 

To enter an inclusion for a student: 

1. In the School view, click on the Student top tab. 

2. Find the student requiring an inclusion record and check the box beside their name. 

3. Click the Transactions side tab. 

4. Click the Inclusions sub-side tab.  

5. In the Options menu, select Add. 

6. The New Inclusion page opens: 

 

a. In the Inclusion date field, type or use the calendar icon to select the effective 
date of the inclusion. 

b. In the Expiry Date field, type or use the calendar icon to select the expiry date of 
the inclusion if applicable. 

c. In the Inclusion type field, indicate the type of inclusion being recorded, this field 
is read only and will auto fill with the word: Inclusion. To update the Inclusion 
Type you can use Modify List in Student TT > Transactions ST > Inclusions SST.  
The type must be contain the word: Inclusion and then the number sequence 
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(01, 02, 03). The word Inclusion and the sequence number will determine if and 
in what order the inclusion prints on the PSR. 

d. In the School year field, use the icon to select the year for the inclusion to be 
recorded. The list of values is sorted in descending order with the latest school 
year listed first. 

e. Use the PSR Comment field to record the necessary information. 

7. Click Save. 

If the Legal Alert is active by date, the student PSR will display a checked Legal Alert 
box on the student PSR.  

If the life-threatening Medical Alert is active by date, the student PSR will display a 
checked Medical Alert box on the student PSR. 

 

 

  

Note: Guidelines on Student Record Inclusions for the Student Permanent Record can be 
found on the Ministry of Education website at as per the Ministry of Education instructions at 
http://www.bced.gov.bc.ca/classroom_assessment/psr_instruct.htm 

http://www.bced.gov.bc.ca/classroom_assessment/psr_instruct.htm
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5.6 Import Documents 

The school level procedure to Import the same document to all school students has been 
enhanced.  The name of the procedure has been changed to “Import Document to All Students”, 
and a new specific security role titled "Import Students Documents" has been created to control 
access to the functionality. This has been done to improve security and clarity for the “Import 
Students Documents” functionality. 

5.6.1 Import Documents for All Students 

New Add-On Role needed for this Procedure: 

 Import Students Documents 

 
To import a document for a group of students: 

1. Log on to School view. 

2. Click the Student top tab. 

3. Search for and select the students that you want to associate with the document. Or, you 
can select them from the pop-up in the next step. 

4. Select Options > Imports > Import Document To All Students. The following pop-up 
appears. 

 

5. Use the following table to enter information in the fields: 

Field Description 

School School name will be filled in. 

Students to 
include 

Current celection appears.  Click the drop-down to select All students or 
students by their YOG or Homeroom. 

 

NOTE:  If you select students from the list and then specify YOG or Homeroom 
here, the document will be attached to all students that meet the YOG or 
Homeroom criteria (not just those selected from the student list). 
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Search 
value 

If you selected YOG or Homeroom at Students to include, enter the YOG or 
homeroom here. 

File Click Browse and then select the file to associate with the students. 

6. Click Run.  The import might take some time for a large file and / or number of students.   
When it is done, a pop-up displays the umber of records that were matched, updated, 
inserted and/or skipped. 

 

5.6.2 Add Document to a Student 

You can attach files such as Microsoft Word and Excel documents to student records.  These 
files are easy to retrieve and view. 

To attach a file to a student: 
1. Log on to school view. 

2. Select the student and click the Documents side tab. 

3. On the documents side tab, click Documents. 

4. Select Options > Add.  The new Document page appears. 

 
5. Enter the information in the fields and import the document. 

6. Click Save. 

7. To view the document, Click the Documents side ab. 

8. Click the name of the document you want to view. 

9. Click Download.  
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6.0 Withdrawing Students 

The Withdraw Student Wizard presents options based on the student status within the school. 
Using the Withdraw Student Wizard with secondary students is advised for accuracy in the 
student enrolment records. Students should be removed from Groups, Snapshots and 
Homerooms prior to withdrawing.  Students can move schools during EOYR by entering the 
new school in the Next School field, see the End of Year Rollover guide for more information. 

6.1 Withdraw Student Wizard  

The Withdraw Wizard is used for individual students: 

• Individual students with an Active status who are Primary to the school.   

• Individual students with an Active no Primary status that are Secondary to the school.   

• Individual students with and Active status who are Secondary to the school 

6.1.1 Students With an Active Status Who Are Primary to the School 

In School view > Student top tab  

• Select the student  

• Options > Registration > Withdraw Student 

• (if the student was not selected prior to opening the wizard)  

o Withdraw student that is: Primary  

o Name – select the student from the picklist 

• Date - Enter the date of withdrawal 

• Code – select from the pick list 

• Reason - Optional, use per district practices 

• Status – Select the correct status from the picklist 

o Withdrawn – primary student with no open secondary school associations 

o Active no Primary – primary student no longer active in this school, with open 
secondary school associations and it has been determined this school will remain 
the school of record with the Ministry of Education for TRAX.  

o Graduate – primary student that has satisfied graduation requirements and has 
completed schooling 

o Keep student in special education- Select to withdraw the student and keep 
the student Active in Student Services Note: BC Standards are to Exit students 
from Student Services when the student is moving out of District. This 
functionality should not be used for students moving out of District.  

o Disable related user accounts – select if the student user account is to be 
disabled.  Before selecting this option be sure to check with secondary schools to 
determine whether to disable portal accounts. 
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o Create former school association – select if the school wants the ability to 
view, print report cards, PSR or other reports and edit course related information 
after withdrawal.  The student will be visible when using the Former Student filter.  
A former school association will remain until the end of the current school year.    

o PSR grade – Mandatory Field - Select the PSR grade that will show as the exit 
grade on the Permanent Student Record in the Record of Schooling section. 

• Click Ok 

 

Exceptions: 

If the student has attendance records recorded after the withdraw date there will be a pop-up 
asking if the records should be deleted.  Select yes to delete or no to leave the records and 
adjust them manually after the withdrawal. 

 

If the student has open secondary school associations, the wizard will set the Status to Active 
no Primary and give a message that the status cannot be adjusted due to open secondary 
school associations.  Active no Primary means the student is no longer active in the school, 
but this school will remain the school of record with the Ministry of Education for TRAX.  If Active 
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no Primary will not be the appropriate status for the student, contact the secondary school to 
determine if the student should be withdrawn from the school and registered as a primary 
student in the school where courses are active.  

 

 

If the ‘Keep student in special education’ option is selected, a confirmation pop-up displays: 

 

If the student is moving out of District, select No (per BC Standards) and return to the wizard to 
remove the selection.  See District policy for students remaining in the District. 

 

Sometimes a student has special circumstances and is marked confidential to hide their 
demographic information from other schools in the district and province. See the MyEducation 
BC Standards Manual for details.  Withdrawing a student marked confidential presents the 
following pop-up: 

 

Proceeding with the withdrawal will present a confirmation:  
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If the student is cross enrolled to another school, the student will remain confidential at that 
school.  
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6.1.2 Students With an Active No Primary Status that are Secondary to the 
School. 

Using the withdraw student wizard for students secondary to the school that have a status of 
Active no Primary will allow the student enrollment details to complete with the correct final 
withdrawal reason.   

 

Confirm the student is secondary to the school and has a status of Active no Primary.   

Check the School > Student > Membership > Enrollment and view the withdraw code from the 
primary school.   

 

 

In School view > Student top tab  

• Select the student  

• Options > Registration > Withdraw Student 

• (if the student was not selected prior to opening the wizard)  

o Withdraw student that is: Secondary  

o Name – select the student from the picklist 

The wizard will return a message: ‘This is the student’s last active cross-enrollment record. 
Select the appropriate withdrawal status and indicate if related user accounts should be 
disabled.’    

• Date - Enter the date of withdrawal 

• Code – select from the pick list 

• Reason - Optional, use per district practices 

• Status – Select the correct status from the picklist based on the withdrawal record of the 
primary school.  Contact the school if further information is needed. 

o Withdrawn – student has withdrawn from school  

o Graduate – student that has satisfied graduation requirements and has 
completed schooling 
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• Keep student in special education- Select to Withdraw the student and keep the 

student Active in Student Services. Note: Do not use this functionality when withdrawing 

Secondary students. The determination to keep a student active in student services 

should only be made by the Primary School/District. 

• Disable related user accounts – select if the student user account should be disabled 

• PSR grade – Leave blank.  Not applicable to a secondary association  

• Click Ok 

 

The Student > Membership > Enrollment tab will show the primary school withdraw record and 
the reason of Graduate or Withdrawn depending on the status chosen. 

 

6.1.3 Students with an Active Status that are Secondary to the School. 

In School view > Student top tab  

• Select the student  

• Options > Registration > Withdraw Student 

• (if the student was not selected prior to opening the wizard)  

o Withdraw student that is: Secondary  

o Name – select the student from the picklist 

The wizard will return a message: ‘The student’s enrollment status cannot be adjusted due to 
one or more active enrollments.’    

• Date – The current date will be entered 

• Status – will not be able to change, it will remain the status at the primary school 
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• Keep student in special education - Select to Withdraw the student and keep the 

student Active in Student Services. Note: Do not use this functionality when withdrawing 

Secondary students. The determination to keep a student active in student services 

should only be made by the Primary School/District. 

• PSR grade – Leave blank.  Not applicable to a secondary association 

• Click Ok 

The secondary association will be end dated using the current date.  

6.2    
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6.3 Withdraw Students over EOYR 

Students can be withdrawn, or withdrawn and transferred to a new school over EOYR using 
settings in the Pre transition field set. Please see the End of Year Rollover Guide for details.  

6.4  Withdrawn Students and Archiving 

Students that are inactive (withdrawn) for more than four years and that are over six years of 
age are eligible for archive.  The annual archive process moves eligible student records from 
Production into the Archive environment.  The student may be retrieved from the Archive 
environment and returned to Production through an overnight process similar to the PEN 
request.  There are a few items to consider that relate to the Archive process.  

• Once a Student is archived: 
o Students cannot be removed from a shared address until they are retrieved from 

archive. 
o Shared contact information will be updated if the student is retrieved. 
o The students’ addresses in District > Addresses may appear to be orphaned (no 

associated person connected to them).  If these records are deleted, when the student is 
retrieved, they won’t have an address. 

o The students’ contacts in District > Contacts may appear to be orphaned (no associated 
student connected to them).  If these records are deleted, when the student is retrieved, 
they won’t have this contact. 

• The shared contact icon still displays with non-archived students.  When a user clicks on a 
shared contact icon, however, it will indicate that the contact is unshared (since the student 
is archived). 

• Students should be removed from Groups and Snapshots prior to archiving, ideally at the 
time of Withdraw process.  Students that were not removed from groups and snapshots prior 
to being archived can be removed after retrieval. 

• User accounts remain intact through archive.  Accounts can be managed according to 
District policy, e.g., disabled, by selecting the option through the Withdraw wizard.   
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7.0  Security Roles 

There are several baseline Security Roles that have the ability to enroll, cross enroll and 
withdraw students: 

• Clerical – School Admin Assistant 

• Clerical – SIS Admin 

• Clerical – SIS Clerk 

• District Support (Level 1) 

• Registrar 

• School Administrator 

District Support (level 1) and Registrar also have the ability to perform a Home School Transfer, 
see more in the Home School Transfer Section 4.2 in this document. 

7.1   District Registrar 

In order for the Centralized registrar to be able to access all schools they will be associated to 
all schools in the district and have an enabled User Account created for them with one of the 
baseline security roles above. 

Refer to Maintaining Secondary School associations for staff in the Security Management 
document for steps on how to associate a staff member with all schools (or a group of schools) 
within the School District. 

Students are registered in the school view.  A district user selects the School View, then the 
school from the picklist in the Select School menu item: 

7.2     School Registrar 

Registration duties at a School are done from the Student top tab. Enroll, Withdraw, Transfer, 
Cross-Enroll, Change Enrollment Status or Change Year of Graduation (YOG) are all found on 
the Student top tab. 

Security Roles for a School-level person can be any of the baseline roles at the beginning of the 
section. 
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Appendix A: Enrollment Reports 

Enrollment Activity  

School view > School top tab > Reports menu > Enrollment Activity report 
School or District view > Student top tab > Reports menu > Enrollment Activity report 

The Enrollment Activity report shows Enrollments, Withdrawals, Status changes and YOG changes 
between defined dates within a school year. The user can choose to sort the results by Date, Name, 
YOG, School (if done by District) and Type (i.e., display all Enrollments first, then all Status Changes, 
etc.). 

The final report displays all of the sort fields, as well as any Code and/or Reason that may be entered 
when the enrollments were done. 

 

 

Enrollment Types: 
E=Enrolled 
W=Withdrawn 
S=Status Change (i.e., PreReg to Active) 
Y=Year Of Graduation change (change to a student grade level) 
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Enrollment Breakdown 

 

School view > School top tab > Reports menu > Enrollment Breakdown report 
District view > District top tab > Reports menu > Enrollment Breakdown report 
District view > District top tab > Schools side tab > Reports menu > Enrollment Breakdown report 

The Enrollment Breakdown report will produce a report that provides the breakdown of students in a 
school or district. The report will run from the beginning of the school year until the date specified, and 
then calculate by a selected field on the Student table.  

• See below for selections.  Enrollment Breakdown and Enrollment Breakdown for All Schools 
Report have the same choices. 
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Enrollment Breakdown for All Schools 

District view > District top tab > Reports menu > Enrollment Breakdown for All Schools 
District view > District top tab > Schools side tab > Reports menu > Enrollment Breakdown for All 
Schoolst 

The Enrollment Breakdown for All Schools report will produce a report that provides the breakdown 
across the Grade Level or Age for all schools in your district. The report will run from the beginning of the 
school year until the date specified, and then calculate by a selected field on the Student table.  

For example, calculate totals by: Aboriginal Ancestry will display the number of Inuit, Metis, Non-Status 
and Status-Off Reserve you have per each grade in the school, with totals at the end. 

Multiple selections on the parameter screen allow users to: 

Date 

• run from the beginning of the school year until the date specified 

Next Year School  

• Checking the Next Year School will include students identified in the Next Year Students filter 
(Student top tab > Filter = Next Year Students) 

Calculate Totals by 

• Required 

• Suggestions would be: Grade Level, Homeroom 

• For example, calculate totals by: Aboriginal Ancestry will display the number of Inuit, Metis, Non-
Status and Status-Off Reserve you have per each grade in the school, with totals at the end. 

Organize Total By  

• Grade level or Age 

Break Totals by Gender 

• Checked means yes 

Active Students Only 

• Checked - Exclude Active no Primary Students 

Include Secondary Students 

• Checked - Include students with Secondary School Associations 

Format 

• PDF, HTML, XLS, CSV 

 

The Enrollment Breakdown For All Schools report is restricted to users having District Level access. 

Title of the Printed Report – currently Enrollment Statistics 
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District Enrollment 

District view > District top tab > Reports menu > District Enrollment  

 
The District Enrollment report provides a breakdown of the enrollment statistics for the district by school 
and by grade level with totals for the district by grade level. This report can be run by Student Type: 
Active Primary students, Fee Paying students or can be run for Both to include all students in a single 
report.  Active no Primary students are excluded from the enrollment counts on this report.     
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Appendix B: Demographic Reports 

Both the custom BC Demographic reports and a variety of core demographic reports are available on the 
Student top tab > Reports in both the School and District view, reports that scope a single student can be 
run in Details > Reports and/or from some side tabs (i.e. the Student Contacts report can be run from 
Student > Contacts > Reports).  

Permanent Student Record 

School or District view > Student top tab > Reports menu > Permanent Student Record 

See Appendix D section 

BC Student Information Verification Form 

School or District view > Student top tab > Reports menu > BC Student Information Verification Form 

See Appendix C section  

BC Homeroom List w/Grid 

School or District view > Student top tab > Reports menu > BC Homeroom List w/Grid  

The BC Homeroom List w/Grid provides a list of students by homeroom with columns that can be typed 
in or left blank. 

BC Class List w/Designation 

School view > Student top tab > Reports menu > BC Class Lists  > BC Class List w/Desig 

The BC Class List w/Designation provides a list of students by course section with totals by 
Grade/Gender/Designation. The report lists the schedule and block for each section.  Options in the 
parameter screen allow the user to print Aboriginal and student services designations. 

BC Student Information with Photo 

School or District view > Student top tab > Reports menu >BC Student Information with Photo 

The BC Student Information with Photo provides a single sheet per student report that includes 
Demographic, Student Contacts, Custody, Alerts and Medical contact information.  

BC Student Withdraw Form 

School or District view > Student top tab > Reports menu >BC Student Withdraw Form 

The BC Student Withdraw Form provides a form for schools to use when a student withdraws from the 
school. The report includes the Usual Name, Pupil number, Gender, Grade, Homeroom, Courses listed 
by section and fields for Withdraw reason, Outstanding Resources and Sign-off sections for a variety 
of departments and teachers.     

Student Alerts 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Alerts 

The Student Alerts report will allow you to print out a summary of Student Alerts for a selection of 
students. The report will give a list of all Alerts for all students that were chosen in the Input screen, along 
with the descriptions for each Alert. 
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Student Contacts 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Contacts 

The Student Contacts report prints out a page for each student which displays the student’s Name, Pupil 
# and Homeroom, along with all contacts associated with that student. The contacts will list the 
Emergency Priority number, Name, Relationship and two phone numbers for each contact. 

Student Address Labels 

School or District view > Student top tab > Reports menu > Labels > Student Address Labels – 5161 and 
5960 

Student Address Label reports (5161 and 5960) displays the Mailing Address information for the student, 
regardless of whether the “Street Address” information is populated. 

Both reports have the “Active students only” checkbox defaulted to checked. This option will only print 
students who have an enrolment status of either “Active” or “Active No Primary”. If this option is un-
checked then the report will include all enrolment statuses. 

Address labels will print for both students currently enrolled in the school and also students that will be 
enrolled for ‘Next School Year’. 

There are two sizes of Student Address Labels available in MyEducation BC: Ones that are formatted 
1” x 4” for Avery 5161 and 1” x 2.63” for Avery 5960 labels. 

Birthday List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Birthday List 

The Birthday List report will print out a list of birthdays for the selected students.  The list can be sorted 
by Date or Name. 

Homeroom List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Homeroom List 

The Homeroom List is a summary of the rosters of each homeroom in your school.  

Locker Assignments 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Locker Assignments 

Locker Assignments is a breakdown of the lockers assigned to which students.  

Refer to the School Setup reference guide for information about assigning lockers to students. 

Student List 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student List 

The Student List This report will display the Pupil #, Name, YOG, Gender and Homeroom for each 
student selected. 

 

Student Directory 

School or District view > Student top tab > Reports menu > Other Jurisdiction > Student Directory 

The Student Directory report prints out a list of each student selected, one student per line and provides 
YOG, Homeroom, Gender, DOB, Phone, Parent/Guardian, Address, City and Postal Code.  
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Appendix C: Student Information Verification Form 

BC Student Information Verification Form 

School or District view > Student top tab > Reports menu > BC Student Information Verification 
Form 

School or District view > Student top tab > Student detail > Reports menu > BC Student 
Information Verification Form 

The BC Student Information Verification Form provides the student’s demographic and contact 
information and can be sent home with the student for a Parent/Guardian to enter or confirm 
existing information on the student. You have the option of printing or publishing the form with 
the student’s information, or a blank form can be printed for the Parent/Guardian to fill in. 

 

 

Emergency and Incident Messages Reference table 

Schools and Districts have the option of adding custom messages to print under the emergency 
contact section and/or under the school declaration section of the form. 

This can be done using the reference tables. 

Districts and/or Schools:  Admin top tab > Data Dictionary side tab > Reference > Emergency 
and Incident Messages > Codes - Select Emergency and Incident Messages Template> 
Options > Add > Select Emergency and Incident Messages Template. 
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Text entered in Emergency Contact Information Message prints under the Emergency Contact 
Information heading in the Student Information Verification Report. 

 

  

Text entered in the School Act Declaration Message prints under the declaration section in the 
Student Information Verification report. 
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If a School Reference Table record does not exist, the report will display the District Reference 
Table record.  

If a District Reference Table record does not exist nothing will print in that section on the report. 

 

Related School Aged Siblings 

 

The Related School Aged Siblings section is intended as a space for parents/guardians to enter 
sibling information for all school aged siblings currently enrolled in MyEducation BC. 
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Emergency Contact Information Section 

 
 
Emergency Contact Information 

• contacted if parents can't be reached, listed in the order they are to be called. 

• contact Pick Up Checkbox allows clarity for who is allowed to pick up the child.  
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Appendix D - Permanent Student Record 

School or District view > Student top tab > Reports menu > Permanent Student Record 

School or District view > Student top tab > Student detail > Reports menu > Permanent 
Student Record 

The Permanent Student Record report is used to document the history of a student’s 
education program. The report will track a student’s enrollment information, inclusions, 
attendance and achievements. 

MyEducation BC prints Permanent Student Record (PSR) cards in the Ministry required format 
(form 1704). 

7.2.1 Program of Study missing? 

When running the PSR if you receive the following error, please make sure that all students 
have a program of study assigned. 

"An exception occurred while running the job. Contact your system administrator if this 
problem persists." 

To identify students with no program of study assigned: 

• Global TT > Favorite ST > Graduation Student Program  

• Sort the list by ProgramStudies > Name and the student with the missing program of 

study should appear at the top of the list. Once their program of study has been added 

in, the PSR should run. 

7.2.2 Printing PSR 

Reminder – “Current selection” will print all of the students if you did not use the “Show 
Selected” functionality before going into Reports> Permanent Student Record 

Inclusions on PSR 

Legal Alert 

If the Legal Alert is active by date, the student PSR 
will display a checked Legal Alert box on the student 
PSR. 

 

 

 

7.2.3 Medical Alert 

If the life-threatening Medical Alert is active by date, the student PSR will display a checked 
Medical Alert box on the student PSR and if you have included an end date, and the end date is 
expired, a procedure needs to run in order to find the records and act on the date. It is not real 
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time. There will be nightly procedure in prod that will do this. In SDTest it needs to be run 
manually. 

7.2.4 HomeSchool 

If the Grade sub level = HS then the inclusion section will display Homeschooled under the 
Student Record Inclusion on the Permanent Student Record.   

Record of Schooling is attached to the Membership Record 

PSR Grade on Membership Record 

7.2.5 Adding an Inclusion 

See Inclusion section of this guide 

7.2.6 Attendance numbers 

 

Days Absent Abs  is calculated From Daily Attendance 

Use the Class to Daily Attendance Procedure if you are missing Daily Attendance records. 

• School Top Tab> Set Up Side Tab to turn on nightly procedure 

• Attendance Top Tab>Options>Class to Daily Attendance for a specific time period 


