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1.0 Introduction 

MYEDBC provides a flexible system for recording fees, such as sporting equipment, art supplies 
and field trips.  You can create fees, record payments and print receipts. 

Note: fees and fines are treated the same – they are both charges assigned to a user. 

1.1 Access 

1.1.1 Security Roles 

Clerical-School Admin and Administrator roles can access the Cashiers Office Side tab and 
School View 

1.1.2 Navigation 

The Cashiers Office is only available in the: 

District View>District Top Tab>Cashiers Side Tab 

School View>School Top Tab>Cashiers Office Side Tab 
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2.0 Fees 

Fees setup is done at the school level.  Once fee types are created, fees can be assigned to 
individual students or to a group of students.  Payments can be made to individual student fee 
records. 

2.1 Creating Fee Types 

To add a new fee type to your school: 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Fee Types sub-side tab.  

4. In the Options menu, select Add. 
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5. The New Reference Code – Common page appears: 

 

 

 

6. Use the following table to complete the fields:  

Field Description 

Code Type the name of the fee as it will appear in the Code column on the Fee Types 
page. 

Description Type a brief description of the fee type. 

Default Amount Type the fee amount as it will appear by default.  The default fee can be 
modified when assigning a fee to a student. 

Default Quantity Type the quantity as it will appear by default.  The default quantity can be 
modified when adding a fee.  

GL Account Type Click this drop-down to select the accounting ledger for the fee. This field has no 
accounting functionality.  Used for categorizing and tracking. New GL Account 
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Field Description 

Types can be added in School or District View Admin Top Tab>Reference Side 
Tab>General Ledger Account Type 

Owner* Click the  to select the school name if not automatically populated.  The fee 
type will be added to the Fees and Fines reference table for the school 
indicated.  

Is a category? This box can be checked if the fee is a category.  For example, the school may 
have an overall Grad Fees category that contains a $25.00 fee for dinner, a 
$60.00 fee for cap and gown and a $40.00 fee for Dry Grad. 

Category This drop-down will populate if a previous fee type has been identified as a 
category.  Any new fee type can then be identified as part of the category.  For 
example, the Fee Type of Grad Fees was created as a category.  Then the fee 
type of Cap and Gown could be created and the Category of Grad Fees 
selected.  

The “Is a category?” and “Category” field would not both be used on the same 
fee type.   

The Default Amount field can be left blank on a category, if desired, as the fees 
within the category will usually have the amount assigned to them.  

7. Click Save. 
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2.2 Deleting a Fee Type 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Fee Types sub-side tab.  

4. Check the box beside the fee for deletion. 

5. On the Options menu, select Delete. 

• Click OK to confirm the deletion.

 

2.3 Deleting a Category 

If a fee type has been created as a category, the fee types within the category should be 
deleted first.  Then, to delete the category: 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Fee Types sub-side tab.  

4. Click on the blue hyperlink of the category fee type to be deleted. 

5. Uncheck the Is a Category? box.   

6. Click Save. 

7. On the Options menu, select Delete. 

8. Click OK to confirm the deletion. 
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2.4 Assigning a Fee to an Individual Student 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. In the Name/ID field, type the name of the student receiving the fee and click the  

button, or use the  button to select a student from the Student Pick List pop-up 

window and click OK.   

 

4. You will be presented with a fee assignment pop-up window.  Ensure the student 

selected is correct.   

5. In the Outstanding Fees section, click the  button.   
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6. In the Cashier’s Entry pop-up window, click the  icon to select a fee from the list, or 

start typing the fee code in the Fee type field.  In the Itemized Fees section, you will see 

the fee added to the student.  

 

• To edit the amount or quantity, click on the blue hyperlink of the fee name.  Once 

the fee is created, you will need to click into it’s detail in the Cashier’s Office and 

click Save to have the changed amount reflected properly in the record.   

• Note: 

▪ If you adjust the quantity, you will also have to update the amount owing.  

This does not automatically update. 



 

Fees Management  v2.3 Page 11 

▪ The adjusted values also do not appear automatically on the main screen 

in the Cashier’s Office side tab.  To save adjusted values (quantity and 

amount), you must click into the details of the record in question, click to 

SAVE; the values will display properly. 

• The Comment field can be used to add additional details, if required.  

7. Click OK.   

 
8. Confirm you have the correct fee assigned.  If not, click the box beside the student name 

and use the Options menu to select Delete. 

9. Click Save.  
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Once fees have been assigned to students, the Account Statement report can be run from the 
Cashier’s Office side tab > Reports menu. 
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2.5 Assigning Multiple Fees to an Individual Student 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. In the Name/ID field, type the name of the student receiving the fee and click the  

button, or use the  button to select a student from the Student Pick List pop-up 

window and click OK.   

 

4. You will be presented with a fee assignment pop-up window.  Ensure the student 

selected is correct.   

5. In the Outstanding Fees section, click the  button.   
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In the Cashier’s Entry pop-up window, click the  icon to select a fee from the list, or 

start typing the fee code in the Fee type field.  In the Itemized Fees section, you will see 

the fee added to the student.  

6. Click OK.   

7. In the Outstanding Fees section, click the  button again.  Select the next fee to 

assign.  Click OK.  This fee will also appear in the window below the first one.   

8. Repeat until all fees have been assigned.   

9. Click Save.  An individual record will appear in the cashier’s window for each fee 

assigned to the student.  
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2.6 Assigning Fees to Multiple Students 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. In the Name/ID field, click the  button.  

4. In the pop-up window, select how you want to mass assign the fee: 

• Section:  assigns by course section. Multiple course sections can be queried and 

selected at once.   

• Homeroom:  requires that Staff have homeroom assignments in the Staff List 

and those homerooms are also attached to students.  

• Group:  assigns to all students who are members of a group created by the 

school.  Only groups who have members will appear in the selection list.  

• Query:  presents a variety of queries to identify a group of students for assigning 

the fee.  

• Snapshot:  assigns to all students who are members of a snapshot created by 

the school.  Only snapshots containing members will appear in the selection list.  

• Selection:  allows the user to select multiple, random students for the fee 

assignment.  

 

5. Check the Selected students count to ensure the number is correct.  
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6. In the Fee Type field, type or use the  icon to select the fee you want to assign to the 

selected students. 

7. Confirm the date and fee details.  

8. Click Save 
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2.7 Mass Assign Student Fees  

Create Batch Fees – Mass Assign Student Fees  

Use this to mass assign fees to students multiple times, with fees only posting to those accounts 
that did not have the fee assigned previously in the current year. 

Selection is by student, courses or schedule terms for the current school year. 

School top tab > Cashier’s Office > Options > Create Batch Fees – Mass Assign Student Fees 

In the pop-up window, select the students and the fee type/s to be mass assigned 

On the first tab ALWAYS select the fee type/s to be mass assigned   

1. Student Selection top tab – Optionally select student group by YOG or Grade level 

AND select the Fee Type(s) 

• Students to Include: YOG (or use other tabs to select students) 

• Fee Type: Required Select the fee type/s using the magnifying glass picklist 

 

• Student Grade Level Selection top tab – to assign a fee by grade level, select 

the grade from the picklist 

                   

• Student Course Selection top tab – to assign a fee type/s selected on first tab 

to students by course section 

▪ Schedule Term: Single or multiple Schedule Terms can be selected from 

the picklist  

▪ Course: Single or multiple course sections can be selected from the 

picklist.   



 

Fees Management  v2.3 Page 18 

 

 
 

• Student Program Selection top tab – to assign fee type/s selected on the first 

tab to primary students in an active program defined by program start and end 

date. Note: No fees will be assigned if the group is created by Snapshot. 

 

• Student Group Selection: Single or multiple student groups can be selected 

from the picklist.  Groups must be open, defined by a start and end date, and 

membership in the group created by Grade Level or individual student selection.  

Note: No fees will be assigned if the group is created by Snapshot. 
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9. Click Run 
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2.8 Voiding a Fee 

Fees may be voided if a student is not expected to pay the fee or if the student is leaving the 
school. Fees can only be voided if no payments have been made on them and there is no ability 
to void only a portion of a fee.  

 In the case where a partial payment was made and there is still an outstanding balance on the 
fee, schools will need to either make a payment with a notation that the balance was voided or 
delete the fee and re-enter it with the fee amount and payment being the same amount so there 
is no outstanding balance 

To void an assigned fee: 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Fees sub side tab. 

4. Click on the blue hyperlink of the student’s name and fee to be voided.  This will present 

the details of the fee.   

5. In the Options menu, select Void Fee.  In the Itemized Fees section, a new row will 

automatically appear, voiding the entire fee amount.   

6. Click Save. 

Voided fees will not appear on a student’s account statement. 

2.9 Making a Payment on a Student Fee 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Payments sub side tab. 

4. Go to the Options menu and select Add. 

5. From the pop-up pick list window, select the student making the payment.  Click OK. 

6. In the pop-up window for the student, record the details of the payment.  

7. Click Save. 

8. If multiple fees have been assigned to the student, you will have the opportunity to adjust 

the payment distribution as required.  You can do this by clicking on the blue hyperlink of 

the payment and adjusting the amount in the Payment distribution area. 

 



 

Fees Management  v2.3 Page 21 

 

9. In the Reports menu, select Payment Receipts - Letter to generate a receipt, if 

necessary. 

2.10 Deleting a Payment 

If a payment has been recorded on the wrong student in error, it can be deleted from the record.   

To delete a payment: 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click on the Payments sub side tab. 

4. Click on the blue hyperlink of the payment that requires deletion so you are viewing the 

detail of the payment.  

5. In the Options menu, select Delete Payment.   

2.10.1 Tracking Deleted Payments 

The Cashier’s Office side tab will still show deleted payment records, but the amount returns 
to $0.00 and the Amount paid on the fee(s) becomes $0.00.  This is the system’s way of 
tracking all activity on an account.  In the Reports menu, run the Deleted Payments report 
to see all deleted payments.   

To remove these records permanently: 

1. Click on the School top tab. 

2. Click on the Cashier’s Office side tab. 

3. Click the blue hyperlink of the payment record to delete. This will open the payment 

detail.   

4. In the Options menu, select Delete.  Payment records deleted here will not appear on 

the Deleted Payments report.   

2.11 Refunding a Payment 

Refunds can be made on payments for fees.  To refund a payment: 

1. In the School top tab, click on the Cashier`s Office side tab.  

2. Click on the Payments sub-side tab.  

3. Check the blue hyperlink on the date beside the payment record to be refunded.  This 

will open the payment detail.   

4. If there is more than one payment record in the Payment distribution section of the 

payment detail screen, check the box beside the fee that the refund is being applied to. 

5. In the Options menu, select Create Refund.  A row in the Payment distribution section 

will appear, with the total amount of the fee showing.  This amount may be adjusted as 

necessary if only a partial refund is being applied. 

6. Click Save.   
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2.12 Fees & Withdrawing Students 

Outstanding fees remain attached to a student when they withdraw from a school.  If the student 
attends a different school, these outstanding fees will remain on the student record and appear 
on the account statements at the new school.    

• The new school will not be able to make payment or remove the fee from the student 

record.   

• The original school that assigned the fee will be able to delete or void the fee from the 

student record, even after they have moved to the new school.  

Schools using fees in MyEducation BC may want to add deleting or voiding outstanding fee 
balances for students to their withdraw procedures.   
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Reports 

The following is a brief description of the Fees reports currently available in MyEducation BC.   

2.12.1 Cashier’s Office side tab 

• Account Statement:   student report that reports all account activity.  One page per 

student.  

• Deleted Payments:  displays all payments deleted from the Payments sub-side tab 

unless they were permanently deleted from the Cashier’s side tab as well.  

• Outstanding Balance Report:  school report that reports all outstanding balances for all 

fees for all students. 

• BC Student Payment Distribution Detail:  school report that details payments made 

on all fees and displays the method of payment. 

 

• BC Outstanding Balance by Homeroom:  Student report that reports outstanding 

balances sorted by homeroom. One page per student. 
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2.12.2 Fees sub-side tab: 

Account Statement, Outstanding Balance Report and Student Payment Distribution Detail are 
also available under the Reports menu when the Fees sub-side tab is selected.  

2.12.3 Payments sub-side tab 

Deleted Payments and Student Payment Distribution Detail are also available under the 
Reports menu when the Payments sub-side tab is selected.   In addition, the report below 
appears in this sub-side tab.  

• Transaction Detail:  school report that details fee payments and balances due by 

account type. 
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2.13 Filter to notify the parents for assigned fee 

User can use the filter under Student TT> Filter> Select Filter ‘Outstanding Fees – From Date’ 
or ‘Outstanding Fees – From/To Dates’ to list the student in that school with outstanding fee 
to/from the date selected in the filter. 

 
  
Once the list is generated, parent can be send email using ‘Send Email’ functionality under 
options 

  
 
User can select the student or contact to send out the email.  

 
 
PS- ‘Receive Email’ checkbox should be checked under Contact>Details, for parents to receive 
the email.   
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3.0 Appendix A 

3.1 Setup schools for the Online Payment 

For directions for the Online Payment refer to the following documentation 

• Online Payments Setup 

• Online Payments 

3.2 Family Portal View 

Family Portal>Family Top Tab>Transactions Side Tab 

 

3.3 BC Student Payment Distribution Detail 

This report can be found in: School View > School > Cashier Office Detail> Report > BC 
Student Payment Distribution Detail. This detailed report, available to users with school level 
view roles includes the following fields; payment method, GL code, description, date, reference 
number, and amount. 

 

 

 



 

Fees Management  v2.3 Page 27 

3.4 BC Outstanding Balance by Homeroom 

This report can be found in: School View > School > Cashier Office Detail> Report > BC 
Student Outstanding Balance by Homeroom Report. The report, available to users with school 
level view roles includes information such as; date, fee type, comment, total due, amount paid, 
and balance. 

 


