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1.0 Fundamentals  

1.1 Logging In 

Individuals will receive their login name (username) and temporary password from their school 
or district support staff.  On initial log in, users will be required to change the temporary 
password before they can proceed.  Passwords must meet the following criteria:  

• Minimum length is 8 

• At least one number 

• At least one capital and lowercase letter 

• At least one symbol that isn’t a letter or number 

• Cannot contain ‘password’, login name, first name, middle name, last name, date of 

birth, personal id, or only sequential letters or numbers. 

 

Go to https://www.myeducation.gov.bc.ca/aspen/logon.do 

Enter the username and temporary password in the Login screen, and click Log On:  

 

The Log in using BC Services Card is only for students and/or parents. For more information 
please contact your school district. 

 

https://www.myeducation.gov.bc.ca/aspen/logon.do
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Enter the following information in the Change Password pop-up that displays next: 

 

• Current Password – enter the assigned temporary password 

• New Password – enter the new user created password 

• Confirm New Password – enter the new user created password a second time 

 

Click OK. 

The Security Preferences Update pop-up window opens next. Setting security preferences will 
make it possible for a user to use the I forgot my password option that displays on the login 
screen. Enter the following information: 

• Primary email - confirm or enter the user email that will be used for password recovery 

• Security question – select a question from the dropdown list 

• Security answer – enter the answer to the selected question 

• Confirm answer – enter the answer to the selected security question a second time 
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• Click Submit 

Alternatively, select Later and the Security Preferences Update pop-up window will display 
again on the next login. 

2.0 Managing User Preferences 

2.1 Security 

The level of access each individual has in MyEducation BC, i.e., what data elements and menu 
items they can see, etc., is determined by the security role(s) assigned to their user account by 
their district or school.   

2.2 Settings Bar 

The settings bar is the first level of navigation in MyEducation BC.  The options visible to the 
user are determined by the security access granted by the district. Select School, for example, 
will only appear if the user has access to more than one school.   

All users see Set Preferences, in the drop-down menu under their name, and Log Off. 

 

 View Navigation 

The View that individuals see when they login, e.g., District, School, Staff, etc., is the default 
view for the security role assigned to their user account. If a user has several roles assigned, 
the preferred View can be set as default under user preferences. Users with access to multiple 
views, as illustrated below, have a dropdown selection for view navigation. Selecting a different 
view from the dropdown changes the way the information is displayed and scopes the 
information to the selected view.  The example below shows the options typically available to a 
District level user.   
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To change views: 

1. Click the drop-down menu under the current View on the settings bar 

2. Select a view.   

 Select School 

If the user account has access to more than one school, the Select School option will appear on 
the settings bar menu.  

To select a school: 

1. Click Select School on the settings bar.    

2. In the pop-up window that displays, click the radio button beside the appropriate school.  

3. Click OK.  
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 Set Preferences 

This option on the settings bar allows users to personalize MyEducation BC. The preferences 
that display in the pop up are specific based on the roles assigned to the user account and 
depend on the view the user is in, e.g., District view is different from School view.  

2.2.3.1 General 

The settings under the General tab determine the default presentation of screens for the user – 
i.e., the default view and school as well other options of a general nature. A user with a Teacher 
Security Role you will be also see Gradebook Top Tab. See the table following the screenshot 
for a definition of each of these fields. 
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Field Description 

Default Locale Default Locale determines the Language and Date format for each individual 
user.  French (Canada) displays French text and report options, while Canada 
will display English text and report options. 

 

This selection also affects the display of dates in MyEducation BC:  

Canada: Dates appear as date/month/year 

French (Canada): Dates appear as year/month/date 

US: Dates appear as month/date/year 

 

Note: A Default Locale must be set to prevent exception errors when 
saving preferences, including the Gradebook Preference Settings. 

Default View Click this drop-down to select the default view when logging on to MyEducation 
BC if the user has more than one view. 

Default School Click the  to select the default school when accessing the School view if the 
user has more than one school.  

Auto-save interval 
(minutes) 

Type the number of minutes to lapse before the system automatically saves the 
information entered on a detail page. The system displays a message to the right 
of the Save and Cancel buttons on detail pages, alerting the user of the time of 
the last auto-save, or why the auto-save failed. 

Disable User-defined Help This disables the user-defined help icon  for fields.  This icon gives brief “tip” 
information on what is expected in that field. 

Records per page This determines how many records display on the screen in a list before moving 
to the next page to see more. Set at the Enterprise level, the maximum records 
per page is 35.  

Show lower page controls Page controls display at the top of a page where the number of records in the list 
exceeds one page.  To display the page controls at the bottom of all list pages, 
select this checkbox.   

 

Warn on save Check this box to display a warning when the user clicks Save on a list page 
after using the Modify List option.  This is specific to the Modify List function and 
does not affect the user prompts to save when changing screens or tabs in the 
application.   
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2.2.3.2 Home 

The Home top tab in Set Preferences has one 
setting used in BC.  The Tasks checkbox allows 
the user access to the Tasks widget on the user 
home page.  The Tasks widget is used with the 
Student Self Assessment and Online Forms 
functionality.  Check the Tasks box to display the 
Tasks widget. 

  

 

2.2.3.3 Security 

The Security sub-top tab in Set Preferences records the user’s email address, and the security 
question and answer, that are required to enable the I forgot my password functionality on the 
login screen. User Passwords can be changed here by clicking the blue hyperlink Change then 
entering the current password and new password in the pop-up screen. 
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Field Description 

Primary email Type the primary email address. The system sends the password to this address 
when the 'I forgot my password' link on the logon page is used. 

Note: This is the address that displays in the From field when using the Send 
Email option. 

Alternate email If an alternate email address is entered, that address displays.  This has no 
functionality in MyEducation BC. 

Google Docs email This has no functionality in MyEducation BC. 

Security question Click this drop-down to select the security question to be used for the “I forgot my 
password” function. 

Security answer Type the answer for the security question.  This will be case-sensitive.  

Confirm answer Type the security answer again. 

Password Click Change to change a user password.  Password requirements can be 
viewed by clicking Click to view. 
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 Gradebook 

Grade book only appears if you are in the Staff View. Teachers can also set their preferences 
on the Scores page and the Class List page by clicking on the gear icon  

 

 Communication 

The communication tab holds Forum Options, where you can set the number of Forum posts 
per page.  Setting used in the student portal. 

 Log Off 

Use the Log Off button in the top right hand corner of the Settings Bar to exit MyEducation BC.  
This will properly terminate the session.  
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3.0 Save Functionality 

As with any software, users should ensure that they are saving often to avoid loss of 
work.  Save buttons are available at the top and bottom of screens throughout the application. 

 

3.1 Auto-Save 

In addition to the save buttons, many screens in MyEdBC have an Auto-Save feature.  While 
this is handy functionality, users should not rely on it as a means of saving their work. Regular 
use of the save buttons should ALWAYS be the primary method for saving.  See the separate 
Fundamentals Appendix: Auto-Save Statistics for a list of screens that provide the Auto-Save 
functionality as a back-up measure. 

Note: The auto-save interval (number of minutes before a screen is auto-saved) is determined 
by the user preference settings as outlined in the Preferences - General section above.   

3.2 Gradebook and Grade Input Scores Save Functionality 

Staff > Gradebook > Scores 

School > Grades > Grade Input > Input Grid 

The grade entry screens in School and Staff view have a save-as-you-go functionality.  When a 
score is entered and the user moves out of the cell, the message: Saving, Please Wait…. 
displays above the score grid and the cell will turn yellow.  The mark column entry is saved 
when both the message and the yellow cell colour have cleared the screen.  To avoid loss of 
work, do not begin entering information into the next cell until both the message and the yellow 
colour are no longer displayed on the screen, indicating the save has completed.  

3.3 Removing Browser Buttons (F11) 

Browser buttons for back and forward and cancel should not be used to navigate the 
application.  Navigating with the browser buttons can generate application errors or browser out 
of synch errors.  

F11 will hide the browser menu, removing the back, forward and cancel browser navigation.  
This is a toggle function; pressing F11 again will return the browser buttons.  
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4.0 Navigation Tools & Selecting Records 

4.1 Top Tabs and Side Tabs 

Top tabs represent functional areas of MyEducation BC.  These are scoped to the user view 
and role so a user will only see what they have been given access to view and work with.  The 
top tab that is highlighted indicates where the user is in the application.  
 

Side tabs provide access to additional details of the top tab functional area. 

 

4.2 Sub-side Tabs, Sub-top Tabs and Leaves 

Side tabs usually contain sub-side tabs, leaves and sub-top tabs. 
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Sub-top tabs display at the top of a list, when a side tab is selected.   

 

4.3 Page selector 

This navigation tool allows the user to select a range of records.  The tool displays by default at 
the top of the list of data, and will display at the bottom of the list as well if the preference to 
Show lower page controls has been set.  

Use the drop-down arrow to select a page in the list, or the back and forth arrows at either side 
to move through the pages consecutively. 

 

In the drop down menu, the first record on each page is indicated.  The number of records that 
display on each page is determined by the user preference setting Records per page. 
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4.4 Record Navigation Bar 

The Record Navigation Bar can be used to change the record being viewed.   

 

For example, if the user is in the Student top tab > Details side tab, only one student is 
displayed.  The user can: 

• Use the  in the record navigation bar to search for a new student without returning 

to the student list.   

• Use the forward and back arrows on the record navigation bar to move to the next 

consecutive record.  

• Use the first and last record buttons to move to the first record in the page selector or to 

the last record in the page selector. 

4.5 Search Tool 

The search tool is present throughout the application to provide the ability to search the values 
in a field set or pop-up list.  The user can enter the search criteria.  The search is conducted on 
the first column of information in the field set, or the column of data that represents the primary 
sort.  Clicking on a column header will sort the data on that column, and the search function will 
work on the selected column.  The Search tool indicates which column the search is using with 
a Search on … prompt before text is entered in the field.  

Filters determine the students included in the search.  For example, if the filter is set to Primary 
Active Students in the student list, the search will not return results for a student who is a 
secondary student.  For details on Filters see the Filters section. 

Results are returned with the closest match the system can make.  The closest match record 
will be selected in the list.   

1. Enter the value to search for in the search field.   

2. Click the magnifying glass or the enter key to execute the search.  

 

4.6 Finding and Selecting a Student by Name 

There are four ways to find that student on the Student List: 

• Type the name in the Search box , and then click . 

• Use the Find pop-up (CTRL+F). 

• Use the Page drop-down . 

• Press CTRL+I to search for a student by initials. 
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If you are on a student details page (Student > Details) and want to look for a different student, 

click  on the record navigation bar and search through the student pick list. 

 

Depending on your district's Student preferences, the Student Search icon  appears in the 

record navigation bar (in place of ). To search for a different student, click . A pop-up 
appears: 
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4.7 Hyperlinks 

Hyperlinks are in blue lettering and an underscore displays when the user hovers over them 
with a mouse.  Clicking on a hyperlink will take the user to the details of that particular record. 

 

 

4.8 Breadcrumbs 

When a user has selected a record and is viewing the details, a breadcrumb trail will appear at 
the top of the list to indicate the path used to arrive at that location.  The breadcrumb presents 
with blue hyperlinks, clicking on any of the hyperlinks within the breadcrumb will return the user 
to that location.  

In the example below, the user is viewing student transcript record for a sample student in the 
School view.   

The user arrived at this screen by following this path: Student > Transcript > Details.  The 
steps to follow the path are: 

• Click the Student top tab 

• Select the checkbox next to the student name in the Student List  

• Click the Transcript side tab 

• Click the Details leaf (or click into the blue hyperlink on the transcript record) 

The user can return to the Student Details by clicking on the Student Name in the breadcrumb 
trail, or return to the Student List by clicking on Student List in the breadcrumb trail. 
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4.9 Checkboxes vs Radio Buttons 

There are many selection lists throughout MyEducation BC.  If a list shows round radio buttons, 
it indicates that only one record can be selected.  If a list shows square checkboxes, then 
multiple records can be selected.   

 Checkboxes 

A sample of the Checkboxes are found on the Student list: 

• More than one student can be selected at a time using the checkboxes in front of their 

names.  Checking the checkbox at the top of the list will select all of the records visible 

on the page. 
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 Radio Buttons 

A sample of Radio Buttons is found in Student > Options menu > Snapshots:  

• Only one snapshot can be selected because there are radio buttons in front of them.   

 

 

4.10 Clearing Record Selections 

When multiple records have been selected in a list, a user may clear them using one of the 
following options: 

• Manually uncheck the box in front of a record.  This will de-select an individual record.  

• Use the  icon at the top of the list of selected records.  This will clear ALL selections. 

• Changing the filter to generate a new list. 

• Leaving the top tab to navigate to another area of the application.  This is only true if the 

user is on the main list and has not performed an Options > Show Selected on the 

records.   

• Logging out of MyEducation BC. 
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5.0 Icons and Alerts 

MyEducation BC will display a number of icons throughout the application to indicate additional 
information or alert information.  Hovering over these icons will provide a tool tip that displays 
what type of information the icon contains.  Clicking on the icon will generate additional 
information.  These icons include: 

• Medical and health alerts:     

• Legal alerts:   

• Other alerts:      

• Quick Status for locating a student:  

• Student Services alerts:     

• Family alerts:   

Information on maintaining student alerts is included in the Enrollment Management and 
Student Demographics and Student Services documentation.    
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6.0 Menu Bar Buttons 

The menu bar buttons display just below the top tabs in MyEducation BC.  The menu bar 
buttons are the same regardless of the top tab the user selects, and the list of items in the list 
display based on the screen.   

 

The items displayed in the dropdowns of the menu will change, depending on the top tab and 
side tab the user has selected. 

 

The various tools in the menu bar are described in the following sections. 

6.1 Options 

The Options menu is an action centre where a user can initiate actions on the data that is 
displayed on the screen.  The Options list may include items with an arrow, indicating a fly out 
menu with additional options.  
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6.2 Reports- Print and Publish 

The Reports button displays a list of reports available.  This list is based on the top tab, side tab 
and leaf currently selected.  For example: When in School > Student > List the Reports button 
provides a number of reports related to student demographics which can be printed for multiple 
students.  When in School > Schedule > Master > Sections the Reports button provides a list of 
reports related to scheduling and course sections.  The Reports list may include items with an 
arrow, indicating a fly out menu with additional reports. 

Selecting a 
report brings up a parameter form with items to select before running the report.  Reports with 
publish functionality will display an additional tab for the outgoing message sent to 
parents/students when the report is published to the Family or Student Portal. To use the 
publish functionality the user must have a Security Role to see the Publish Sub Top Tab.   
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Fields Descriptions 

Publish 

Preview 

Previewing a report does everything except send a notification email and put 
the report into the Published Reports widget. 

Email 
Subject 

Type a subject for your email message.  Limit of 100 characters. 

Email 
Message 

Enter the desired content for your report. 

 

Viewing Start 
Date 

 

Viewing End 
Date 

This is the date that you want the report to appear in the Published Reports 
widget. Default value is today. Edit if needed. 

 

This is the date that you want the report to disappear from the Published 
Reports widget. Default value is two weeks from today. Edit if needed. 

Note: All published reports must have a viewing end date. They cannot 
display in the widget indefinitely. 

 

Cleanup 
Date 

This is the date that the report and publish log are completely removed from the 
system. Default value is one week after the viewing end date. Edit if needed. 

 

The My Job Queue item in the Reports list will present a window that shows reports the user 
has run and the report status.   It is not necessary to wait for a report to finish once Run has 
been selected.  The report can be retrieved later from My Job Queue. 
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Helpful Tip:   
 
If a school realizes they published the wrong data, a Service Request (using template Change 
Report Viewing Dates) can be submitted through HEAT by the District L1 and the Service Desk 
can roll back the dates, which removes the report from the parent portal. This can only be done 
for the entire report card run and not for an individual student. 

 

6.3 Help 

The Help button provides several options for online instructions and tools that are core to the 

Follett product.  The Help list may include items with an arrow, indicating a fly out menu with 

additional tools.   

 

Note: The tools in the Help menu are not customized for MyEducation BC and may reference 

options or functions that are not available to District and School Users due to BC specific 

standards and configuration.   

 

 
The About MyEducation BC item provides information about the server to which the user’s 

session is connected.  This will display below the copyright information and can be useful 
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information for the service desk if users are experiencing problems with performance or report 

running in MyEducation BC.  Example:  vaspnapprd5 indicates that the user is on server 5.  

 
 

 Online Help 

Help for this Page and Help Center open in a new window and provide a variety of ways to 
search for information.   

The Help for this Page functionality identifies where the user is, and directs them to information 
related to that top and side tab. For example, if the user is in School > Student > Membership 
and selects the Help for this Page option, they are directed to Working With Student Enrollment 
Information in the online guide. In addition, Help topic(s) are listed to the left of the screen. 

The Help Center functionality displays a screen with a search bar, results page and topic icons 
to assist with navigation. 
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If the user enters a specific search term, a results page will display related results and to the left 
of the screen Help topics will be listed. If the user selects a topic icon, a drop-down of related 
topics will display for selection. Once selected, the specific topic page will display and Help 
topics will list on the left of the screen. 

 

The information in the On-line help is not customized for MyEducation BC and may reference 
options or functions that are not available to District and School Users due to BC standards and 
configuration 

 Release Notes 

Release notes will provide information about the latest changes to the software product.  This 
information refers to the Follett application as a whole; it is not customized for MyEducation BC.  
The release notes will reference options or functions that are not available to District and School 
Users based on BC standards and configuration.    

 User Guides 

User guides open up as documents with hyperlinks in the table of contents. These guides are 
not customized for MyEducation BC.     
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7.0 Queries 

A query is dynamic. A query performs a new search and displays current information each time 
the query is run. For example, the list of students assigned to a homeroom may be different 
today than it was yesterday because a new student enrolled and was assigned to the 
homeroom. 

7.1 Creating a Simple Query 

1. In the Options menu, select Query.  

2. In the New Query window, use the following table to select appropriate fields: 

 

Fields Descriptions 

Tables Select the table where the search information resides. The selected table determines the 
selections in the Fields area. 

For example, if the Student table is selected, fields in the student details appear. 

Fields At Fields, select the field to be included in the search criteria. 

Note: Fields within each reference table are listed from most commonly used to least commonly 

used. To change this order to alphabetical, click the Alpha Sort button  

Operator Select an appropriate operator. 

For example, if the search is for students with a specific year of graduation, select Year of 
graduation in the Fields box, and select the Equals operator. 

Value Enter the search value.  In some cases, this may be a pick list or drop down menu. 

 

3. Click Add to add the criteria to the Search criteria box.  To add other criteria, select 
the Table, Field, and Operator, and enter the Value, if appropriate. 

4. Click And or Or to determine if the students should meet the first criteria, the second 
criteria, or both to be included in the search. 

5. Confirm the correct search criteria are displayed in the Search criteria box.  To delete 
the criteria from this search, highlight it in the Search criteria box and click Delete. 

6. In the Search based on field, use the drop-down to select which students should be 
included in the search.   

7. Click the Search button to execute the search.  
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Once a query has been executed, the records matching the search criteria will be displayed on 
the screen.   The upper right corner of the screen, above the list, will indicate that the records 

displayed are a custom selection.  Use the  icon to return the list to all records or 
another selection.  
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7.2 Saving a Query 

If a query will be used frequently, it can be saved for quick retrieval. 

1. Create a query using the instructions above.   

2. Click Save as. . .  The Save as dialogue box displays.   

a. Name:  Give the query a name that will make sense later.  If it will be saved as a 

filter, it is best to keep the name concise.   

b. Owner type:  Click the drop-down to select one of the following: 

• User: to give an individual user access to the query. 

• School: to give users at a school access to the query.  User must have 

access to the school view to use this option.  

• District: to give all users in a district access to the query.  User must have 

access to the district view to use this option. 

c. Owner Name:  click the magnifying glass to change the owner of the query.  The 

owner can edit a saved query.  

d. Save as filter:  Select this checkbox to have this query automatically appear on 

the  menu for all users who have access to it.  If this checkbox is 

selected, the next three fields are accessible.   

e. Filter Owner type:  Click the drop-down to select the owner type as appropriate.  

These options are defined the same as the Query Owner Type options. 

f. Filter Owner name:  click the magnifying glass to change the owner of the 

query.  The owner can edit a saved filter.  

g. Move to the top of my list:  Checking this box will place the query at the top of 

the  menu.  If a query is first on the filter menu, it becomes the default 

filter for that screen.   

3. Click Save. 
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7.3 Editing a Query 

Users must have the appropriate permissions to edit the query.   

1. In the Options menu, select Query.  

2. In the New Query pop-up window, click the Select button.  A list will pop up with all the 

queries.  

3. Click the radio button beside the query to be edited.   

4. Click Edit.  

5. Adjust the Name and Owner fields, if necessary.  

6. Click Save. 

7. Ensure the query is still selected and click Use. 

8. Adjust search criteria as necessary.  

9. Click Save. 
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7.4 Copying a Query 

Users can copy a query that contains elements they want and adjust it to suit their need. 

 

1. In the Options menu, select Query.  

2. In the New Query pop-up window, click the Select button.  A list will pop up with all the 

queries.  

3. Click the radio button beside the query to be copied.   

4. Click Copy.  

5. Give the new query a Name and Owner type.  

6. Click Save. 

7. Ensure the query is still selected and click Use. 

8. Adjust search criteria as necessary.  

9. Click Save. 

7.5 Deleting a Query 

If a query has become obsolete, it can be deleted  

1. In the Options menu, select Query.  

2. In the New Query pop-up window, click the Select button.  A list of queries will pop up.  

3. Click the radio button beside the query to be deleted.   

4. Click Delete.  

5. Click Cancel to close the query list popup.   

6. Click Cancel to close the New Query window. 
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8.0 Snapshots 

A snapshot is different from a filter.  Where a filter is dynamic and always returns the latest data, 
a snapshot is a static list.  It always displays the same records unless it is manually edited.  
Only the user who created the snapshot can add or remove students from it. 

8.1 Creating and Deleting Snapshots 

 Creating a Snapshot 

1. In the School view, click the Student top tab.  Select the records to be included in the 
snapshot.  

2. If records have been manually selected in a large list, be sure to go to the 

Options menu and click Show Selected.  Users can also use a filter or query to isolate 

the records for a snapshot. Snapshots will include any records that appear on the 

current list. 

3. In the Options menu, select Snapshots.  

4. In the pop-up window, click the New button. 

a. Name:  Give the snapshot a name that represents the data in the snapshot. 

b. Owner:  Who will see and use this snapshot?  If the user has district or school 

access, they have the ability to set this to all users with those views.  If the user 

sees no other option, they are creating a user snapshot. 

c. Save as filter:  If this is selected, the snapshot will appear in the filter menu 

under the  icon. 

d. Move to the top of my list:  If this is selected the snapshot will appear as the 
first item in the filter menu and will become the default filter for that screen. 

5. In the Records to Include box, select one of the following: 

a. Current List:  includes records selected on the list page.  

b. Snapshot Combination:  this will combine two existing snapshots and is only 
available if two or more snapshots have already been defined.  This provides 3 
options:   

i. Union:  Any records that appear in the first snapshot selected or the 
second snapshot selected. For example, for a snapshot of students who 
are in grade 12 or have a program of study, select Union. 

ii. Intersection:  Only records that appear in both the first and the 
second snapshots selected. For example, for a snapshot of students who 
are both in grade 12 and have a program of study, select Intersection. 

iii. Difference:  Any record that displays in the first snapshot selected, but 
not in the second. For example, for a snapshot of students who are in 
grade 12 but do not have a program of study, select Difference. 

6. Click Save.  
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 Removing a Snapshot from the Filter Menu 

If a snapshot was saved as a filter in error, or is no longer needed as a filter, it can be removed 
from the filter menu.   

1. Click on the  icon and select Manage Filters. 

2. In the Manage Filters window, click on the snapshot so it is highlighted. 

3. Click the Delete button.   

4. Click Close.  

Note:  Deleting the filter does not delete the snapshot behind it.  The filter can be restored 
by creating a new filter and selecting the snapshot.   

 Deleting a Snapshot 

If a snapshot has become obsolete, it can be deleted from the snapshot menu.   

1. In the Options menu, select Snapshots.  

2. Select the snapshot to be deleted.  

3. Click Delete.  Note that it warns the user that any filter associated with the snapshot will 

be deleted. 

4. Click OK.     
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8.2 Add a Snapshot to a Student 

Snapshots are static lists and will not update automatically when a new student meets the 
criteria the snapshot was based on.   

 Adding a Snapshot to a Student 

1. In the Student top tab, select the student to be included in the snapshot. 

2. Click the Snapshots side tab.  

3. In the Options menu, select Add. 

4. Select the snapshot from the list.  

5. Click OK. 

 

8.3 Removing a Snapshot from a Student 

If a student no longer meets the criteria for the snapshot, a user may want to delete them from 
that snapshot.  

 To remove a snapshot from a student. 

1. In the Options menu, select Snapshots. 

2. Select the snapshot to be modified.  Click Use.  The list of students in the snapshot will 

appear.   

3. Check the box beside the student(s) to be removed from the snapshot. 

4. Click the Snapshots side tab.  

5. In the Options menu, select Delete. 

6. Click OK. 
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9.0 Menu Bar Tools 

The menu bar provides several tools for filtering, displaying, sorting and exporting data in 
MyEducation BC.  The menu tools are the same regardless of the top tab the user has selected, 
with the exception of the quick letter function on the Student top tab.  The options that display 
when using these tools will vary depending on the top tab and side tabs selected.    

 

9.1 Filters and Advanced Filter mode  

The Filter functionality is used to determine the records that display on a page.  Selecting the 
Filter icon displays a list of filters currently available to the user.  This list is based on the top 
tab, side tab and leaf currently selected, as well as the security role(s) assigned to the user.  

Filters are built from queries that provide a real time list of the students meeting the criteria 
defined in the query.  For example: The Filter Homeroom = ? returns all the current students 
with the selected homeroom assigned.  If a new student is assigned to the selected homeroom, 
they will immediately display in the filter list. 

Filters can be created at the District, School or individual user level.  

System Filter Description 

All Active Students Primary Active, Active No Primary and Secondary Active Students 

Primary Active Students Primary students with a status of Active or Active No Primary. 

All Primary Students All Primary students for which this school is or was the last school of record, 
regardless of the current student Enrollment Status.   

All Secondary Students Students that have a secondary school association to this school, with a status of 
Active or Active No Primary. 

All Students All Primary students for which this school is or was the last school of record, 
regardless of the current student Enrollment Status, Active No Primary and 
Secondary students.  

Current Members All students with current admission dates, including students with secondary 
school associations that have a current start date.  This filter does not include 
students with a future admission date, or students with future secondary school 
association start dates. 

Former Students Students who were withdrawn, but have a former school association to this 
school.  If this association record is deleted, the student will no longer appear in 
the filter. 
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System Filter Description 

Next Year Students Students with a Next School value field populated with the name of this school.   

The filters that appear in the list have been created at the system, enterprise or district level. 

Click the  icon and select Manage Filters. In the Manage Filters pop-up window, users 
see the following in brackets beside the name of the filters: 

a. System:  these filters are part of the core application.  They can be hidden or 

moved up or down in the list, but cannot be modified. 

b. Enterprise:  these filters have been created at the enterprise level and display 

for all districts and schools.  They can be hidden or moved up or down in the list, 

but cannot be modified. 

c. District:  these filters have been created at the district level for the district level 

views. They can be hidden or moved up or down in the list, but cannot be 

modified unless the user has access to the District view. 

d. School:  these filters have been created either by a school user, or by a district 

user in the school view. They are visible to all users with access to the School 

view.  These filters can only be modified or deleted by a school user or a district 

user with school view access. 

e. User:  these filters have been created by an individual user.  They will only show 

in the list for the user who created them and therefore can only be modified or 

deleted by the user who created them.  
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 Moving a Filter 

A user can set the filter they use most often as the default for that screen by moving it to the top 
of the list. 

1. Click the   icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click on the name of the filter to be moved.  It will 

be highlighted.  

3. Click the  or  buttons to position the filter in the list.  The filter at the very top of 

the list is the default filter when entering that screen. 

4. Several filters can be moved at once by using Shift + click and using the  or  

buttons.   

5. Click Close. 
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 Hiding a Filter 

1. Click the  icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click on the name of the filter to be hidden.  It will 

be highlighted.  

3. Click the  button.  If the Show All box is checked, the filter will still appear 

here, but is now greyed out.  This means the filter will no longer appear in the list when 

the  icon is clicked.  The item can be restored at any time by clicking the 

 button to put it back in the list.   If the Show All box is not checked, the 

filters which have been hidden will no longer be visible.  This checkbox will need to be 

enabled in order to restore a hidden filter. 

4. Click Close. 

 Creating a New Filter 

Filters are connected to queries and snapshots.  Users can access those queries and create 
them as a filter by using the New button in the Manage Filters window. 

1. Click the  icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click the  button. A list of available queries will 

appear.   

a. Filter Type:  This allows a filter to be created from an existing query or snapshot.  

Changing this selection will change the list of options below.   

b. Owner:  Who will see and use this filter?  If the user has district or school 

access, they will have the ability to set this filter for all users with those views.  If 

the user sees no other selection, they are creating a User filter. 

c. Name:  Give the filter a name that makes sense for its function.   

3. Click the radio button beside the query or snapshot in the list that the filter will be based 

on.   

4. Click OK.  The filter will now appear in the Manage Filters window and in the list below 

the  icon for this screen. 

5. Click Close on the Manage Filters window. 
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 Editing a Filter 

A user can only edit a filter that exists at the level of their user role view.  In other words, a 
district user who has access to both district and school views can edit a District or School filter.  
A school user can edit a School filter because they have school view access.  A user with staff 
view will only be able to edit their own User filters. 

1. Click the  icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click the   button. 

3. In the pop-up window: 

a. Filter Type:  This allows a filter to be changed from its current query or snapshot, 

to a new query or snapshot.  Changing this selection will change the list of 

options below.   

b. Owner:  Who will see and use this filter?  If the user has district or school 

access, they will have the ability to set this filter for all users with those views.  If 

the user sees no other selection, they are creating a User filter. 

c. Name:  Give the filter a name that makes sense for its function. 

4. Click OK. 

5. Click Close on the Manage Filters window. 
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 Copying a Filter 

Because a filter is connected to a query or a snapshot, there are few reasons to copy a filter.  A 
user may decide to copy a filter in order to rename it to something that is more meaningful.  

1. Click the  icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click on the name of the filter to be copied. It will 

be highlighted. Click on the   button. 

3. In the pop-up window: 

a. Name:  Give the filter a name that makes sense for its function. 

b. Owner:  Who will see and use this filter?  If the user has district or school 

access, they will have the ability to set this filter for all users with those views.  If 

the user sees no other selection, they are creating a User filter. 

4. Click Save.  

5. Click Close on the Manage Filters window. 

If a filter has been copied, it may be practical to hide or delete the original to avoid confusion. 
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 Deleting a Filter 

A user can only delete a filter that exists at the level of their user role view.  In other words, a 
district user who has access to both district and school views can delete a District or School 
filter.  A school user can delete a School filter because they have school view access.  A user 
with staff view will only be able to delete their own User filters. 

1. Click the  icon and select Manage Filters . . .  

2. In the Manage Filters pop-up window, click on the name of the filter to be deleted.  It will 

be highlighted.  

3. Click the  button.   

4. Click Close on the Manage Filters window. 

Deleting a filter does not delete the query behind it.  If a filter is deleted in error, it can be 
restored by using the Add button.   
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 Advanced Filter Mode 

Some list pages now have an Advanced  Filter mode. Use this mode to filter the list of records 
before Aspen loads data to the page. This saves time on pages with many records. Click the 
Advanced Filter mode toggle switch to turn it on or off. The system remembers your choice of 
whether to display the Advanced Filter on each list. 

 

When the Advanced Filter mode is on, an overlay appears. The overlap displays the fields for 
that page's field set. 

Enter values in the fields, and then click Search. MYEDBC displays the filtered records. See the 
Help topic " Use the Advanced Filter Mode" for more information. 
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9.2 Field Sets   

Field sets display information in a list.  By selecting a different field set, the user is choosing to 
display different columns of information for the same records in the list.  Field sets are useful for 
grouping commonly used sets of information and then extracting those into a spreadsheet for 
analysis or manipulation.  

The field sets that display in the list have been created at the Enterprise level or have been 
created by district users who may have created them for their schools.  

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, users may see the following in brackets 

beside the name of the field sets: 

a. System:  these field sets are part of the core application.  They can be hidden or 

moved up or down in the list, but cannot be modified. 

b. Enterprise:  these field sets have been created at the enterprise level and 

display for all districts and schools.  They can be hidden or moved up or down in 

the list, but cannot be modified. 

c. District:  these field sets have been created at the district level for the district 

level views. They can be hidden or moved up or down in the list, but cannot be 

modified unless the user has access to the District view. 

d. School:  these field sets have been created either by a school user, or been 

created by a district user in the school view.  They will be visible to all users who 

have access to the School view.  These field sets can only be modified or deleted 

by a school user or a district user with school view access. 

e. User:  these field sets have been created by an individual user. 
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 Moving a Field set 

A user can set a field set they use the most as the default in that screen by moving it to the top 
of the list. 

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click on the name of the field set to be moved.  

It will be highlighted.  

3. Click the  or  buttons to position the field set in the list.  Any field set placed at 

the very top of the list will become the default field set when entering the screen. 

4. Several field sets can be moved at once by using Shift + click and using the  or 

 buttons.   

5. Click Close. 

 Hiding a Field Set 

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click on the name of the field set to be hidden.  

It will be highlighted.  

3. Click the  button.  If the Show All box is checked, the field set will still 

display here, but is now greyed out.  This means the field set will no longer appear in the 

list when the  icon is clicked.  The item can be restored at any time by clicking 

the  button to put it back in the list.   If the Show All box is not checked, the 

field sets which have been hidden will no longer be visible.  This checkbox will need to 

be enabled in order to restore a hidden field set. 

4. Click Close. 

 Creating a New Field Set 

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click the  button. 

3. In the pop-up window: 

a. Name:  Give the field set a name that makes sense for its data set. 

b. Owner:  Who will see and use this field set?  If the user has district or school 

access, they will have the ability to set this field set for all users with those views.  

If the user sees no other option, they are creating a User field set. 

c. In the Available Fields window, use the drop-down menu to select the table from 

containing the desired data fields.   These are listed in the order most frequently 

used.  If the user is having trouble finding a field, use the  button to sort 

them into alphabetical order.   

d. Click on the desired field to select so it is highlighted in the list.   
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e. Click the  button.  This will move the field into the Selected Fields 

window.   

Note:  Multiple fields from multiple tables can be selected for the same field set.   

4. Once all fields have been selected, click Save.  

5. Click Close on the Manage Field Sets window.  The field set will now appear in the list 

for selection.   

 

 Editing a Field Set 

A user can only edit a field set that exists at the level of their user role view.  In other words, a 
district user who has access to both district and school views can edit a District or School field 
set.  A school user can edit a School field set because they have school view access.  A user 
that only has staff view will only be able to edit their own User field sets. 

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click on the name of the field set to be edited.  

It will be highlighted. 

3. Click the   button. 

4. In the pop-up window: 

a. Name:  Enter the new name for the field set, if appropriate. 

b. Owner:  Who will see and use this field set?  If the user has district or school 

access, they will have the ability to set this field set for all users with those views.  

If the user sees no other selection, they are creating a User field set. 
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5. In the Available Fields window, click the fields of information to add to the field set.  Click 

the  button.  Alternatively, in the Selected Fields window, click the fields of 

information to be removed from the field set.  Click the  button. 

6. Click Save. 

7. Click Close on the Manage Field sets window. 

 

 Copying a Field Set 

A user may see a field set in the list that suits their needs, but would like to add or remove some 
information from it.  If the user does not own the field set, a copy can be made and adjusted to 
suit the need.  

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click on the name of the field set to be copied.  

It will be highlighted. 

3. Click the   button. 

4. In the pop-up window: 

a. Name:  Give the field set a name that makes sense for its data set. 

b. Owner:  Who will see and use this field set?  If the user has district or school 

access, they will have the ability to set this field set for all users with those views.  

If the user sees no other selection, they are creating a User field set. 

5. Click Save.  

6. Click Close on the Manage Field sets window. 
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If a field set has been copied, the user may want to consider hiding or deleting the original to 
avoid confusion or duplication in the field set list. 

 

 Deleting a Field Set 

A user can only delete a field set that exists at the level of their user role view.  In other words, a 
district user who has access to both district and school views can delete a District or School 
field set.  A school user can delete a School field set because they have school view access.  A 
user that only has staff view will only be able to delete their own User field sets. 

1. Click the  icon and select Manage Field Sets . . .  

2. In the Manage Field Sets pop-up window, click on the name of the field set to be 

deleted.  It will be highlighted.  

3. Click the  button.   

4. Click Close on the Manage Field Sets window.  
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9.3 Sorts   

There are different ways to sort data in a field set, which are defined below.  The options for 
sorting data in a field set are: 

• Click the header of a column of data, a triangle displays pointing up or down in the 

column header to indicate the sort column and order.  The field set sorts by the data in 

that column, opposite to its original sort order. Clicking the header again sorts the data 

back to its original order.  This function can be used for multi-level sorts of up to 3 

columns of data at a time.  For example:  clicking the Gender column in the Student top 

tab, then clicking the Pupil # column, then the Grade column, the grade would be the 

primary sort.  Data displayed will be in order by Grade, then by Pupil #, then by Gender. 

 

• Use the  icon, which simply sorts the data in the field set by the list value chosen for 

the sort.  The sort icon can also be used to set any sort back to the default.   

The field sets that appear in the list already have been created at the Enterprise level or by 
district users who may have created field sets for their own schools.  

1. Click the  icon and select Manage Sort Orders. . .  

2. In the Manage Sort Orders pop-up window, the following will appear in brackets beside 

the name of the field sets: 

a. System:  these sort orders are part of the core application.  They can be hidden 

or moved up or down in the list, but cannot be modified. 

b. Enterprise: these sort orders have been created at the enterprise level and 

appear for all districts and schools.  They can be hidden or moved up or down in 

the list, but cannot be modified. 

c. District:  these sort orders have been created at the district level for the district 

level views. They can be hidden or moved up or down in the list, but cannot be 

modified unless the user has access to the District view. 

d. School:  these sort orders have been created either by a school user, or been 

created by a district user in the school view.  They will be visible to all users who 

have access to the School view.  These sort orders can only be modified or 

deleted by a school user or a district user with school view access. 
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 Moving a Sort Order 

A user can set the sort order they use the most as the default in that screen by moving it to the 
top of the list. Users can also create custom sorts.   

1. Click the  icon and select Manage Sort Orders . . .  

2. In the Manage Sort Orders pop-up window, click on the name of the sort order to be 

moved.  It will be highlighted.  

3. Click the  or  buttons to position the field set in the list.  Any sort order placed 

at the very top of the list will become the default sort order when entering the screen. 

4. Several sort orders can be moved at once by using Shift + click and using the  or 

 buttons.   

5. Click Close. 

 Hiding a Sort Order 

1. Click the  icon and select Manage Sort orders . . .  

2. In the Manage Sort orders pop-up window, click on the name of the sort order to be 

hidden.  It will be highlighted.  

3. Click the  button.  If the Show All box is checked, the sort order will still 

appear here, but is now greyed out.  This means the sort order will no longer appear in 

the list when the  icon is clicked.  The item can be restored at any time by clicking 

the  button to put it back in the list.   If the Show All box is not checked, the 

sort orders which have been hidden will no longer be visible.  This checkbox will need to 

be enabled in order to restore a hidden sort order. 

4. Click Close. 
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 Creating a New Sort Order 

1. Click the  icon and select Manage Sort Orders . . .  

2. In the Manage Sort Orders pop-up window, click the  button. 

3. In the pop-up window: 

a. Name:  Give the sort a name that makes sense for its function. 

b. Owner:  Who will see and use this sort?  If the user has district or school access, 

they will have the ability to set this sort for all users with those views.  If the user 

sees no other selection, they are creating a User sort. 

c. In the Available Fields window, use the drop-down menu to select the table from 

which to sort fields.   These are listed in the order most frequently used.  To help 

find a field, use the  button to sort them into alphabetical order.   

d. Click on the field to select it.  It will be highlighted in the list.  Click the  

button.  This will move the field into the Selected Fields window.   

Note:  Multiple fields from multiple tables can be selected or the same field set.   

4. Once all fields have been selected, click Save.  

5. Use the  and  buttons to arrange the fields in the desired sort order.  The 

 button will cause (desc) to appear beside the field highlighted when clicked.  

This means the data in that field will be sorted in reverse (descending) order when this 

new sort is applied to a field set. 

6. Click Close on the Manage Sort Orders window.  The sort order will now display in the 

list for selection.   

 

 

 Editing a Sort Order 

A user can only edit a sort order that exists at the level of their user role view.  In other words, a 
district user who has access to both district and school views can edit a District or School sort 
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order.  A school user can edit a School sort order because they have school view access.  A 
user with staff view will only be able to edit their own User sort orders. 

1. Click the  icon and select Manage Sort Orders . . .  

2. In the Manage Sort Orders pop-up window, click on the name of the sort order to be 

edited.  It will be highlighted. 

3. Click the   button. 

4. In the pop-up window: 

a. Name:  Enter the new name for the sort order, if appropriate. 

b. Owner:  Who will see and use this sort order?  If the user has district or school 

access, they will have the ability to set this sort order for all users with those 

views.  If the user sees no other selection, they are creating a User sort order. 

5. In the Available Fields window, click the fields of information to be added to the sort 

order.  Click the  button.  Alternatively, in the Selected Fields window, click the 

fields of information to be removed from the sort order.  Click the  button. 

6. Click Save. 

7. Click Close on the Manage Sort Orders window. 

 

 Copying a Sort Order 

A user may see a sort order in the list that suits their needs, but wants to add or remove some 
information from it.  If the user does not own the sort order, a copy can be made and adjusted to 
suit the need.  

1. Click the  icon and select Manage Sort orders . . .  

2. In the Manage Sort orders pop-up window, click on the name of the sort order to be 

copied.  It will be highlighted. 
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3. Click the   button. 

4. In the pop-up window: 

a. Name:  Give the sort order a name that makes sense for its data set. 

b. Owner:  Who will see and use this sort order?  If the user has district or school 

access, they will have the ability to set this sort order for all users with those 

views.  If the user sees no other selection, they are creating a User sort order. 

5. Click Save.  

6. Click Close on the Manage Sort Orders window. 

If a sort order has been copied, it may be practical to hide or delete the original to avoid 
confusion. 

 Deleting a Sort Order 

A user can only delete a sort order that exists at the level of their user role view.  In other words, 
a district user who has access to both district and school views can delete a District or School 
sort order.  A school user can delete a School sort order because they have school view 
access.  A user with staff view will only be able to delete their own User sort orders. 

1. Click the  icon and select Manage Sort Orders . . .  

2. In the Manage Sort Orders pop-up window, click on the name of the sort order to be 

deleted.  It will be highlighted.  

3. Click the  button.   

4. Click Close on the Manage Sort Orders window.  
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9.4 Quick Charts   

Charts provide an organized way to represent data visually. The Quick Chart feature enables 
the user to create bar, line, and pie charts from any standard list page. These charts can be 
saved for future use.  Users with privileges to manage school and/or district resources can 
create charts to share at both the district and school levels.   

Click the  icon to access the following options:  

• Create Quick Chart: Brings up the Quick Chart Wizard, which allows the user to 

customize many different areas of the resulting chart. 

• Bar Chart: Brings up a streamlined Quick Chart screen, which requests only minimal 

information required to create the bar chart. 

• Line Chart: Brings up a streamlined Quick Chart screen, which requests only minimal 

information required to create the line chart. 

• Pie Chart: Brings up a streamlined Quick Chart screen, which requests only minimal 

information required to create the pie chart. 

 To Create a Quick Chart: 

1. Click the  icon and select Create Quick Chart to open the Quick Chart wizard, or 

select Quick Chart from the Reports menu.  The Create Quick Chart wizard displays: 
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2. Step 1: Source.   

a. Select New chart. 

b. Click Next.   

3. Step 2: Report Type 

a. Click the Report Type drop-down to select one of the following: 

i. Quick Chart—Bar 

ii. Quick Chart—Line 

iii. Quick Chart—Pie 

4. Click the Format drop-down to select the format for the chart.  Select one of the 

following: 

a. Standard 

b. Enhanced  

 

 
 

5. Step 3: Field Selection.   

a. In the Categories (Horizontal Axis) box, click the  icon at Group by 

field and make a selection. The user can choose from the tables and fields that 

are related to the records in the current list. The Categories (Horizontal 

Axis) box, sometimes called the independent variable, sets the data to measure. 

If the choice is a Numeric, Date or Time field, additional options appear to further 

organize the data which will be displayed on the chart.  
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b. For bar and line charts, a Series (Legend Entries) box is available. Click the  

icon at the Group by field and make a selection. Series groups appear in a 

legend to the right of the chart and provide a color-coded guide to data shown in 

the chart. 

Note: Bar and line charts do not require both a category and series to be selected. Charts that 
exclude a category will not have x-axis labels. Charts that exclude a series will not include a 
legend. 

6. The Interval drop-down menu for numeric has the following options: 

a. Chart each value separately: Each numeric value gets its own data point. 

b. Interval group: The Interval field groups the results according to the number 

entered in the Interval group size field. For example, to display the group Year 

of Graduation in the chart in pairs, a 2 would be entered in this field.  

The Interval group size displays.  The value in this field sets the number of data 

points that get combined into a single category. 

c. Interval group summations.  The Interval group size displays. The value in 

this field sets the number of data points that get combined into a single category. 

d. Total summation: Sums the values of the Group by field. 

7. If the list of data being charted contains trivial cases which should be excluded from the 

chart, the option Group trivial results as "Other” is provided. Select this checkbox if 

the users wants to group all data points of less than a certain percent together into a 

single point called Other.  For example, if the user is only concerned with viewing the 
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most common conduct codes, select this option and enter a value of 5% in the Less 

than % field. This will group all codes which total less than 5% of the total data into a 

single Other group. 

Note: This option can only be used in the Categories or Series, not both.  

8. Click Next to continue the wizard and set chart header and footer display options. 

9. Click Finish to create the chart.  

Note:  The Finish button can be clicked at any point in the wizard.  New charts use the 

default format options if Finish is clicked at any point before the final step in the wizard.   

 To Use a Saved Quick Chart 

1. Click the  icon and select Create Quick Chart to open the Quick Chart wizard, or 

select Quick Chart from the Reports menu.  The Create Quick Chart wizard displays: 

 

 

2. Step 1: Source.  Click Saved report.  A table of saved Quick Charts displays in the 

dialog box. Select the Quick Chart to be viewed or edited. 

3. Click Next to continue editing, or click Finish to show the chart. 
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9.5 Quick Print   

Users can generate a Quick Print using the  icon in the menu bar on any list page.  

 To generate a Quick Print using the Quick Print icon: 

1. Go to the list page containing the type of data to be reported on. 

2. Select the records to be included in the report. 

3. If individual records have been manually selected from a large list, be sure to go to the 

Options menu and click Show Selected.  Users can also use a filter or query to isolate 

the records to report on. Quick Prints include any records that appear on the current list. 

4. Click the Quick Print icon  in the menu bar.  

 
5. Select one of the format options. 

a. Web Page (HTML): to view the information in an HTML file. 

b. CSV: to view the information in a text file that separates each field with a comma. 

If saved, the file will have a .CSV extension 

c. TXT: to view the information in a text file that separates each field with a comma. 

If saved, the file will have a .TXT extension. 

Note: The two comma-separated values formats (CSV and TXT) create identical 

files; the only difference is the file extension. Some Web browsers only handle 

one extension properly. 

d. Microsoft Word (DOC): to view the information in a Word document. 

Note: Different browsers handle quick prints in different ways.  Users may need to change 
browser settings to allow downloads, or use shortcut keys such as Ctrl + S to save the data 
prior to opening it. 

 Maximize  & Minimize   

Users can click on these icons to hide top tabs to allow more records per page to be 

visible or to return top tabs to their view. 
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10.0 Quick Reports 

Quick Reports provide an opportunity for a user to create a customized report that contains 
specific data elements from one or more tables.  If the report is something that would be run 
multiple times or by multiple users, a Quick Report can be created and saved, then selected 
from the list as needed.  

Quick reports can be created in different areas of the application with elements that are relevant 
to the chosen area (top tab and side tab) of the application. 

10.1  Creating a Quick Report 

Quick Reports can be created with different presentations. The following sample reports use the 
same fields, but are present differently:  

• Simple: A list of records and the selected fields 

 

• Detail: A page for each record with selected fields aligned vertically 
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• Group: A list of records and the selected report fields, grouped by a selected field 

(School Name in the sample)  
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• Summary: Cumulative values based on the records selected (School Name in the sample) 

 

In the example below, the simple Quick Report will provide a school with a report indicating 
which students have Release of Information indicators, and is created from the Student top tab.   

1. In the School view, click the Student top tab 

2. Click the Quick Reports Icon and Select Create Quick Report or, Click the Reports 

menu item and select Quick Report 

 

3. In Step 1 of the Wizard, select New Report.  Click Next. 
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4. In Step 2 of the wizard, select Simple.  Click Next. 

 

5. In Step 3 of the wizard, the current field set will display as the selected fields  

6. Select the desired fields and click the Add >> button to move it to the Selected Fields 

box.   

a. The drop-down menu Under Available Fields can be changed from the Student 

table to a different table to combine data elements from other areas of the 

application. 

b. The Sort button  will sort the available fields for the selected table in 

alphabetical order, making it easier to locate specific fields.  

7. In the Selected Fields box, click on any fields not needed and click the Remove button.   

 
 

8. Click Next. 
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9. In step 4 of the wizard, select the field(s) to sort by in the Available Fields list and use 

the Add button to move them to the Selected Fields box.   The primary sort will be the 

first field in the Selected Fields box; the secondary sort will be the second field, etc.  

 

 
 

10. Click Next. 

11. Step 5 of the wizard is optional.  Use these functions to create counts, and page breaks 

if desired. 

12. Click Next. 
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13. In Step 6 of the wizard: 

a. Report Title:  Enter a title for this report.    

b. Print date:  If selected, the date the report was generated will appear on the 

report.  

c. Body > Format:  Select the format for the report. 

d. Exclude byte order mark: Can be checked if the report will be loaded to a 

system requiring limitations in text.  Hover over the question mark symbol for 

details.  

e. Body > Font Face:  Select the font for the report.   

f. Body > Font Size:  Select the font size for the report.   

g. Body > Grid lines:  Select whether the report should have grid lines for 

horizontal, vertical, or both, or none. 

h. Shade alternate lines:  If selected, the data will appear with grey shading on 

alternate lines.   

 
 

14. Click Next. 

15. Step 7 of the wizard is optional.  It allows the user to rename the fields that will appear 

on the report.  To adjust the name of a field, select it from the Field drop-down.  In the 

Title field, enter a name.  Note that the field is only being re-named for the report – not 

for the application.  Font, Size, Bold, Italic and Underline can be selected to tailor the 

field name in the report.  
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16. Click Next. 

17. In Step 8 of the wizard, the report may be saved for future use.  To save this quick 

report, click the Save As radio button.   

a. Name: Enter a name for the saved report. 

b. Owner Type: Select from the drop down list.  

i.  District: Report will be available for District users 

ii. School: Report will be available for School users in the selected school 

iii. User: Report will be available for only the user creating the report 

c. School: Select the school (if applicable)  

  
 

18. Click Finish. 

10.2  Running a Saved Quick Report 

If a report was saved, it is now available in Quick Reports based on the Owner type selected. 
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Quick Reports provide an opportunity for a user to create a customized report that contains 
specific data elements.  For the example below, this is done from the Student top tab, but quick 
reports can be created in different areas of the application with elements that are relevant to the 
chosen area of the application.   

1. In the School view, click the Student top tab 

2. Click the Quick Reports Icon (printer) and Select Create Quick Report OR Click the 

Reports menu and select Quick Report 

 

3. In Step 1 of the Wizard, select Saved report. 

4. The available saved reports will display, select the report. 

5. Click Finish to run the report as is or click Next to make changes to the report an 

proceed through the steps of the wizard as outlined in Creating a Quick Report. 
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11.0 Email Functionality 

11.1  Email 

A Primary Email Address must be entered in User Preferences > Security tab for email 
functionality to work 

11.2  School View Send Email 

Whenever you are on a person based list in MYEDBC, such as Student List or Staff List you can 
send: 

• A mass email to everyone on the list 

• An email to a selected group on the list 

• An email to one person on the list 

 To send an email from a person based list. 

1) Go to the list containing the records of the people you want.  Note – you can narrow down 

this list of records by using Show selected, Omit Selected, a query, a filter, or a snapshot. 
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2) From the Options menu, click Send Email.  The Mass Email pop-up appears: 

 

Note: The email functionality in MyEducation displays a maximum of 150 email 
addresses, regardless of the number of recipients selected when sending emails. This is 
a performance safeguard, View the email log in School, District or Staff view for a 
complete list of recipients. 

3) Use the following table to fill in the fields: 

Field Description 

From This address is the primary email address listed in your user 
preferences. 

To The names of the recipients who will receive the message appear. 

 

Note: Attempting to send while there are no addresses in the To 
field, will result in an error message. This can occur if you manually 
delete all addresses by clicking the x in the corner of each address, 
for example, or if you open the Mass Email pop-up after creating a 
query that returns no results. 

Note: Within a subset of email addresses, you can delete a particular 
address by clicking the x in the corner. The Total Recipients number 
updates accordingly. 

Bcc To use multiple email addresses use commas between each email 
address 
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Students Contacts 
Teachers 

Use these checkboxes to select or deselect students, their contacts 
who opt to receive email (according to the student contacts details 
page), and their teachers as recipients of the email. 

 

 

Include Primary 
Email Address 

Select this checkbox if to send an email to the primary email 
address(es) of the recipient(s) included in the To field. 

 

Note: This checkbox might be selected by default, depending on 
your district’s communication preferences. 

Include Alternate 
Email Address 

Select this checkbox to send the email to the alternate email 
address(es) of the recipient(s) listed in the To field. 

 

Note: This checkbox might be selected by default, depending on 
your district’s communication preferences. 

 

Subject Type a subject for your email message. Limit of 200 characters 

Attachment If you want to attach a file to your message, click Choose File to 
navigate to the file you want to send. 

Emails sent from the MyEducation BC application have a combined 
attachment size limit of 7.1MB (total limit for all attachments in an 
email). If the total attachment size is larger than 7.1MB the email will 
not send successfully. 
 
There is also a limit of 56 characters for the file name of each 
attachment. If a file name exceeds 56 characters the email will send 
successfully, however an error message will appear: 

The error message is related to how the application is trying to handle 
the attachment, not the actual process of sending out the 
message.  The message will send successfully. 

 

Text Box Type your message inside the text box. A rich text editor provides 
the following formatting options: 

• Font 

• Font size 

• Formatting, including bold and italics, bullets and numbering 

• Color 

• Hyperlinks and images 

Note: To insert an image, click in the URL field, copy and paste the 
URL of the image. Then click OK. 
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4) Click Send, a confirmation message displays.  Confirm the details. 

5) Click yes or No.  If you click yes, a progress meter appears 

a) Note: There are only two direct recipients of the email message – the sender and the 

districts incoming email address.  Everyone else on the list is the blind carbon copied 

(Bcc’d) If you would like a copy of the message, include your own email address in the 

Bcc: field. 

11.3 School or District View Email Log 

Use the email log to review a list of emails sent by MYEDBC users through Send Email on the Options 

menu. The log contains records for messages sent from the District, School, Staff, Health, Personnel, and 
Special Education views. 

Users who need to see the Email Logs will need to have a security tag in their existing base role or 
added. 

In Admin top tab > Security side tab, create a role or add the security tag to a created role with the 

following:  School View > Core >  Email Log > Read (checkbox).  Please refer to security documentation 
on the L1 Information Station for assistance with security roles. 

From the log, you can see the details of a particular email that was sent. 

To view the email log: 

1) Log on to the District, or School view. 

2) Click the Admin tab, and then click the Logs side-tab. 

3) Click Email Log. 

4) Use the Filter menu to view records for the following: 

a) Today (default) 

b) This Week 

c) This Month 

d) All Records 

5) For each record, the list displays the following: 

To review an email’s details: 

1) Select the checkbox in the row of the email you want to review. 

2) On the side-tab, under Email Log, click Details. The emails details page appears. 

In addition to the information in the table above, the details page displays the email’s message, and lists 
any attachments that were sent. It is not possible to open the attachment. 
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11.4  Mass communications via email 

MyEducation BC has functionality to send out mass communications via email.  When School and/or 
District send out mass communications to staff it is important to note the difference between sending 

email messages via the Student Top Tab versus Staff top tab. 

The following functionality is the same in both School, Staff and District View. 

Student Top Tab: 

• Emails sent using the Student top tab scope to the student. When selecting teachers from 

here, the system will send an email to ALL teachers of ALL students in the list, regardless 

of the School or District the applicable teacher resides. 

• Student Top Tab > Contacts Side Tab: 

• Emails sent from this screen will send to all contacts with a valid email address, it does not limit 

to only those with receive email selected. 

Staff Top Tab: 

Emails sent using the Staff top tab scope to the school or district sending the email and will limit the 

recipient list to staff members within in the School/District. 

 

Troubleshooting 

• If a teacher reports receiving emails from an out-of-district source; look for students that have 

secondary associations for the schools/districts that sent the emails. Next, look at courses and 

homerooms associated to those students. These steps will help determine if the recipient is a 

teacher for any of those students.  

11.5 Send an Email to Group Members 

Whether your group or Page is for the high school chorus, j.v. soccer team, or English department 

faculty, it is likely that at some point you will want to send members an email. You can send your 
message to all or just some of the group members. 
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To send an email to group/Page members: 

• Log on to the District view. Click the District tab, then the Groups side-tab. 

• Log on to the School view. Click the School tab, then the Groups side-tab. 

• Log on to the Staff view. Click the My Info tab, then the Groups side-tab. 

1) Select the checkbox of the group you want to work with. 

2) On the Groups side-tab, click Members > People. 

3) On the Options menu, click Send Email. The following pop-up appears: 

 

11.6 Staff View Send Email 

A Primary Email Address must be entered in User Preferences > Security tab for teacher email 
functionality to work.    

Send Email can be found in the Options menu under the Student top tab or from a class 
roster. The former will default to send to all of the teacher’s students, the latter only to the roster 
of a selected class. A quick access icon to email a class is also found on the Teacher Classes 
widget at the far right of the class.  

  



 

Fundamentals v3.5 Page 75 

Provided there is a Student email address in the student’s basic demographic details, they will 
be selected for email. Teachers can also include parent/guardian contacts for their students. 
Contacts must have a Primary email and Receive email checked on their details. 
When using email in MyEd all recipients are Bcc’d.  

 
Recipients are colour coded according to students, contacts or teachers. Note the option to 
Include Alternate Email Address as well as the primary. Sending emails to all teachers will 
include teachers from other Schools or Districts that also teach the student(s). 

 

 Staff View Email Log 

Use the email log to review a list of emails sent by MYEDBC Staff View users through Send Email on the 

Options menu.  

From the log, you can see the details of a particular email that was sent. 

To view the email log: 

1) Log on to the Staff view. Staff View>My Info Top Tab>Email Log Side Tab 

2) Click the My Info Top Tab, and then click the Email Log side-tab. 

3) Use the Filter menu  to view records for the following: 

a) Today (default) 

b) This Week 

c) This Month 

d) All Records 

To review an email’s details: 

1) Select the checkbox in the row of the email you want to review. 

2) On the side-tab, under Email Log, click Details. The email's details page appears. 
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In addition to the information in the table above, the details page displays the email's message, and lists 
any attachments that were sent. It is not possible to open the attachment. 

11.7  BC Student Email Import 

The BC Student Email Import will help district users to mass load both student primary and 

alternate email addresses. 

Please refer to documentation BC Student Email Import located on the L! Information Station 
Records in the import file are validated based on following criteria: 

• District ID in the file matches the District ID on the parameter screen 

• District ID matches the District ID in MyEducation BC 

• Pupil number is active and primary to the District ID on the parameter screen 

• Primary email contains both an @ symbol and a (.) 

• Alternate email address contains both an @ symbol and a (.) 

Notes: Students can change the Primary email address in the user preferences. Student 

alternate email addresses can be added to a field set for viewing in School and Staff view 
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12.0 Enhanced Characters 

Some tables and fields will support Unicode characters. Users will be able to enter, store, and 
print progress comments with Indigenous language text and other special characters in the 
fields. 
 
Some fields connect to ministry and downstream legacy systems that cannot support Unicode 
characters. Some validations are on those fields, so they remain unaffected by the rollout of 
Unicode characters and Users will not be able to enter, store, and print progress comments with 
Indigenous language text and other special characters in the fields. 
 
Student records cannot accept any Enhanced Characters in any of their name fields. 
 
Staff Records cannot accept any Enhanced Characters in there Usual First and Last Name 
fields. 
 
Contact records can accept Enhanced Characters in both Legal and Usual Name fields. 
 
Not all fields support enhanced characters yet. You can enter them, and you will see them in the 
front end of the application until your cache is refreshed, at which time those characters will 
revert to question marks. (???). We are working with Follett to get all fields supported, but it is a 
long term, process. If the user gets question marks they need to remove those characters for 
the time being. 
 
The fields that have validations (cannot use Unicode characters) are as follows: 
 

Table Field GDE Appearances 

Address  City  Student Demographic  
Student Demographic—Enhanced  

Address  City Prov PC  N/A  

Address  Country  Student Demographic  
Student Demographic—Enhanced  

Address  RR Number/PO Box  Parent Information  

Address  State/province  N/A  

Address  Street address  Student Demographic  
Student Demographic—Enhanced  

Address  Street name  Parent Information  
Student Demographic  
Student Demographic—Enhanced  

Address  Street type  N/A  

Person  Gender  Student Demographic  
Student Demographic—Enhanced  
Student Next Year New GDE  
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Table Field GDE Appearances 

Person  Legal first name  Accident Information  
Admission/Withdraw Information  
Course Marks  
Cross Enrolled School Information  
Curriculum Marks Information  
Curriculum Marks History  
Emergency Contact Information  
Emergency Contact Information—
Enhanced  
ESL Number of Year  
Homeroom and Staff Assignments  
Incident Information  
Medical Information  
Parent Information  
School Team  
Sibling Information  
Standardized Tests  
Student Course History  
Student Course Request  
Student Course Selection  
Student Daily Absences  
Student Demographic  
Student Demographic—Enhanced  
Student Next Year New GDE  
Student Period Absences  
Student Period Absences—Enhanced  
Student Programs  
Student Schedule Drops  
Transportation Information  
User Account Information  

Person  Legal last name  Accident Information  
Admission/Withdraw Information  
Course Marks  
Cross Enrolled School Information  
Curriculum Marks Information  
Curriculum Marks History  
Emergency Contact Information  
Emergency Contact Information—
Enhanced  
ESL Number of Year  
Homeroom and Staff Assignments  
Incident Information  
Medical Information  
Parent Information  
School Team  
Sibling Information  
Standardized Tests  
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Table Field GDE Appearances 

Student Course History  
Student Course Request  
Student Course Selection  
Student Daily Absences  
Student Demographic  
Student Demographic—Enhanced  
Student Next Year New GDE  
Student Period Absences  
Student Period Absences—Enhanced  
Student Programs  
Student Schedule Drops  
Transportation Information  

Person  Legal middle name  Student Demographic  
Student Demographic—Enhanced  
Student Next Year New GDE  

Person  Usual first name  Published Reports Export  
School Messenger Address Book  
Sibling Information  
Student Demographic  
Student Demographic—Enhanced  

Person  Usual last name  Published Reports Export  
School Messenger Address Book  
Sibling Information  
Student Demographic  
Student Demographic—Enhanced  

Person  Usual middle name  Published Reports Export  
School Messenger Address Book  
Sibling Information  
Student Demographic  
Student Demographic—Enhanced  

Person  Preferred Second Name  Published Reports Export  
School Messenger Address Book  
Sibling Information  
Student Demographic  
Student Demographic—Enhanced  

School Name  Build View Workspace 
Course Marks 
Cross Enrolled Student Information 
Curriculum Marks Information 
Curriculum Marks History 
Published Reports Export 
School Details 
School Team 
Student Course History 
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Table Field GDE Appearances 

Student Course Request 
Student Demographic 
Student Demographic—Enhanced 
Student Next Year New GDE 
Student Programs 
User Account Information 

School  School Email  N/A  

School Course  Description  Build View Workspace  
Course Information  
Course Information—Enhanced  
Student Course Request  
Teacher Course  

Staff  Name  Admission/Withdraw Information  
Build View Workspace  
Course Marks  
Cross Enrolled School Information  
Curriculum Marks Information  
Emergency Contact Information  
Emergency Contact Information—
Enhanced  
ESL Number of Years  
Homeroom and Staff Assignments  
Incident Information  
Medical Information  
School Team  
Sibling Information  
Staff Information  
Staff Information—Enhanced  
User Security Information  

 
If you enter a character that is not supported in any of the fields above, you will receive an error 

message saying “***Field Name*** cannot contain non-ascii characters” 
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12.1 Reports and Extracts 

The following reports and extracts will display enhanced characters where available 

• Learning Update 

• Competency Based IEP Report 

• Individual Education Plan Report 

• Competency Summary Report 

• Annual Instructional Plan Report 

• Interim IB MYP Report Card 

• International Baccalaureate Report Card 

• International Baccalaureate – New Report Card 


