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1.0 Overview  

The transfer of demographic and course data between schools and the Ministry is necessary for 
the administration of provincial exams and graduation assessments.  The Ministry uses this 
information to produce transcripts of grades and school completion certificates on behalf of 
schools. 

This reference guide will provide users with the knowledge required to successfully perform 
these functions using MyEducation BC. 

 

1.1 Objectives 

Topics covered will include: 

• GRAD process and timeline 

• How to create Graduation Assessments 

• How to produce a GRAD extract in MyEducation BC 

• Description of the three types of files created by a GRAD Extract: CRS, DEM and XAM 

Files. 

• Scenarios that schools will encounter for reporting GRAD and how to ensure information 

is entered correctly for each. These scenarios include: 

o Deferrals 

o Adult 

o Challenge 

o Rewrites 

• How to review Student Exam Results 

 

1.2 Procedures 

There are two procedures related to GRAD: 

• Posting Course Dates procedure: creates a transcript record, sets start and end dates 

for courses submitted to GRAD. 

Calculate Credits procedure:  assigns credits for all completed courses including 

examinable courses that have a passing mark / blended mark 
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1.3 Key Points 

• Assessment records create graduation assessment requests and store the results 

• Assessment records are where the results are uploaded when they are received from 

the Ministry of Education.  

• All courses need End Dates.  Non-examinable courses need end dates for the CRS file.  

If a student transcript record exists, the course End Date is taken from that record. If no 

transcript record exists, End Dates are taken from the school’s course structure values. 

• Students who completed a course in a previous year and are writing the exam in the 

current year, need an Assessment record with a current year exam session date. If the 

student has not written the exam previously, edit the session date and location 

information for Session 1. If the Student is rewriting the exam, enter the session date, 

location and mark information in Session 2 fields.  

• Always select the appropriate definition in the Assessment Definition area to see all 

the fields and filters for any graduation assessment. 

   

• Assessment records will always be associated with the school the student is taking the 

course in. The Location may need to be changed for where the exam is going to be 

written. 
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• Students must have a Primary Program of Study assigned that will define graduation 

requirements for the student. The Primary program study checkbox must be checked in 

the Program of Study details. The GRAD extract, School Transcript and DVR reports will 

not run correctly without a Primary Program of Study attached to the student.  See 

Enrolment Management and Student Demographics for details on assigning the program 

to the student details. 
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2.0 Who is Included in the GRAD Extract? 

1. Students that are Primary to the school in grades 10-12 or with grade 10-12 courses. 

2. When a student is withdrawn or deceased, GRAD extract will create the DEM record and 

any XAM records for the student (but NOT CRS records).  

3. Multiple XAM and CRS records are created based on the students’ courses and whether 

they are registered for any Graduation assessments.   

All courses are to be reported only once per student, in the CRS record.   

2.1 Home School Not in MyEducation – Check Box 

The student’s primary school is responsible for reporting achievement to GRAD. In order for the 
MyEducation BC system to exclude students from the GRAD extract all students whose home 
school is not in MyEducation BC, must have the “Home School Not in MyEducation” checkbox 
checked.  This field is located at: 

School view > Student top tab > Details side tab > Demographics sub-top tab  

   

2.2 The DEM File 

One demographic record will be created for students (including withdrawn students), who are:  

• Enrolled in Grade 10, 11, 12, SU and GA, or 

• Registered in the Adult Graduation Program, or   

• Enrolled in a grade less than 10, but registered in a provincially examinable course in the 

current school year and scores (returned) are blank, or 

• Enrolled in a grade less than 10, but registered in non-examinable grade 10, 11, 12 

courses, or 

• Registered in the School Completion Certificate Program (‘SCCP’). 

• Does not have the Home School not in MyEducation checkbox checked 

2.3 The CRS File 

Course records will be created for non-examinable courses for students who are:  

• Enrolled in Grade 10, 11, 12, SU and GA  

• Registered in the Adult Graduation Program   

• Registered in the SCCP Program (School Completion Certificate Program). 

• Enrolled in Grade 08 or 09, but completed/enrolled non-examinable grade 10, 11, or 12 

courses 

For the above students, all completed and currently enrolled non-examinable courses that are at 
the grade level 10, 11, 12, SU or GA will be extracted.   
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2.4 The XAM File 

Exam records will be created for students who are: 

• Enrolled in Grade 08, 09, 10, 11, 12, SU and GA and have graduation assessment 

records in the current year.  

Refer to Graduation Assessments document on the MyEducationBC.info site for 

instruction on entering Provincial Assessments 

• Registered in the Adult Graduation Program who have opted to write the graduation 

assessment and have assessment records in the current year.  

 
 

3.0 GRAD Process Summary 

3.1 First Submission 

Tasks are displayed in the order normally associated with the GRAD process.   
 

Timeline Task Path Resource 

Aug/Sep Ensure all students are scheduled into 
their courses. 

Student top tab > Schedule side 
tab 

Student Scheduling 

Sep/Oct Remove current year “orphaned” 
transcript records, if applicable.   

This will happen when a student 
changes schools and the transcript 
record for a course has been created 
but does not have an equivalent 
scheduled course in the student 
schedule.   

Grades top tab > Transcripts side 
tab > set dictionary icon to All > 
set filter to No Student Schedule 
Equivalent.   

In the pop-up,  

Set School Year field to the 
current school year.  

Set Search based on to Final 
Mark is Empty 

Review the records and if there is 
no final mark and it is appropriate, 
delete these “orphaned” records.   

GRAD reference 
guide 

Sep/Oct  Ensure all Students have a Primary 
Program of Study and Primary 
program study checkbox must be 
checked 

Student top tab>Options> 
Program of study Creator – 
Primary School View>Student top 
tab>Transcript side tab> 
Programs of study side tab  

Enrollment 
Demographics guide – 
Primary Program of 
Study 

https://www.myeducationbc.info/resources/school-users/
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Timeline Task Path Resource 

Sep/Oct Ensure “Home School Not in 
MyEducation” checkbox 

The student’s primary school is 
responsible for reporting 
achievements to GRAD. In order 
for MyEdBC to exclude students 
from the GRAD extract, all 
students whose home school is 
not in MyEdBC, must have the 
“Home School Not in 
Myeducation” checkbox checked 

School View>Student TT>Details 
ST>Demographics Sub TT 

 

GRAD reference 
guide  

Sep/Oct Ensure manually entered transcript 
records have an appropriate final 
mark, credit value and course end 
date. 

Student top tab > Transcript side 
tab 

GRAD reference 
guide - To Manually 
Add an Historical 
Transcript Record to a 
Student 

Oct Prepare Grade Input   Grades top tab > Grade Input 
side tab > Options > Prepare 
Grade Input > set Report Type to 
Course > Finish 

Grade Management 
reference guide 

Oct Post course dates for Semester 1 
courses 

Grades top tab > Grade Input 
side tab > Options > Post Grades 
> Check Course dates box. 

Grade Management 
reference guide 

Oct Create graduation assessment 
records for students that will be writing 
the assessment in the Jan session. 

Assessment top tab > Student 
Assessment > Assessment Entry 
side tab 

Select Graduation Assessment 
definition 

Graduation 
Assessment reference 
guide 

Oct Check for missing assessment 
session dates. 

Manually populate session dates if 
necessary. 

Assessment top tab > Student 
Assessments side tab 

Set the Assessment Definition 
field at the top of the screen.  

Set filter to Missing Test Session 
Dates.  Does the Date 1 column 
have blanks? 

GRAD reference 
guide 

Oct  Run the GRAD extracts Student top tab > Options > 
Exports 

BC GRAD Extract – Course File 

BCGRAD Extract – 
Demographics File 

BC GRAD Extract – Exam File 

GRAD reference 
guide 
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3.2 Subsequent Submissions 

Tasks are displayed in the order normally associated with the GRAD process. See detail in this 
document for additional information, if required. 

Timeline Task Path Resource 

Feb/Apr/Jul Schedule students into courses – 
ensure all students are scheduled 
into their courses. 

Student top tab > Schedule side 
tab 

Student 
Scheduling 

Feb/Apr/Jul Remove current year “orphaned” 
transcript records for your own 
school, if applicable.   

This will happen when a student 
changes schools and the transcript 
record for a course has been 
created but does not have an 
equivalent scheduled course in the 
student schedule.   

Grades top tab > Transcripts 
side tab > set dictionary icon to 
All > set filter to No Student 
Schedule Equivalent.   

In the pop-up,  

Set School Year field to the 
current school year  

Set Search based on to Final 
Mark is Empty 

Check the school’s name for 
your own records 

Review the records and if 
appropriate, delete these 
“orphaned” records.   

GRAD reference 
guide 

Feb/Apr/Jul Ensure manually entered transcript 
records have an appropriate course 
end date and credit value. 

Student top tab > Transcript 
side tab 

GRAD reference 
guide - To 
Manually Add an 
Historical 
Transcript Record 
to a Student 

April Post course dates for Semester 2 
courses 

Grades top tab > Grade Input 
side tab > Options > Post 
Grades > Check Course dates 
box. 

GRAD reference 
guide 

Feb Create graduation assessment 
records for students that will be 
writing the assessment in the June 
session. 

Assessment top tab > Student 
Assessment > Assessment 
Entry side tab 

Select Graduation Assessment 
definition 

Graduation 
Assessment 
reference guide 

Feb/Apr/Jul Create graduation assessment 
records for students that will be 
writing the assessment in the June 
session. 

Assessment top tab > Student 
Assessment > Assessment 
Entry side tab 

Select Graduation Assessment 
definition 

Graduation 
Assessment 
reference guide 

Feb/Apr/Jul Review graduation assessment 
results uploaded from previous 
sessions.  Manually update missing 
values as necessary.  

Assessment top tab > Student 
Assessments side tab 

Select appropriate Assessment 
definition field at the top of the 
screen Sort or query for blank 
values. 

GRAD reference 
guide 
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Timeline Task Path Resource 

Feb/Apr/Jul Run the GRAD extracts Student top tab > Options > 
Exports 

BC GRAD Extract – Course File 

BCGRAD Extract – 
Demographics File 

BC GRAD Extract – Exam File 

GRAD reference 
guide 

 

3.3 Summer Submission 

For most students, the courses that are completed in the summer school will be included in the 
GRAD extract when the primary schools submit the extract in October.  The summer schools 
can manually submit their GRAD data using GRAD Change Form available on the Ministry’s 
secure website for students who are only active in the summer schools. 
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4.0 GRAD Processes – Detail 

4.1 Deleting “Orphaned” Transcript Records 

As students move between schools before completing courses, transcript records may be 
created as term grades or course dates are posted for the student’s courses.  If the student 
changes schools before completing the course, an empty, (orphaned) transcript record occurs 
on the student’s course history.   

To remove these records: 

1. In the School view, click the Grades top tab.   

2. Click the Transcripts side tab.  Set the  icon to All.   

3. Set the  to No Student Schedule Equivalent. 

4. In the pop-up window, set the School year field to the current year and set the Search 

based on field to Final Mark is Empty.  

5. Review the records and determine if it is appropriate to delete them.  If they were 

created at this school and will not be continued or given a final mark at this school, it 

may be appropriate to delete the record.  Only delete records from this school, contact 

other schools before deleting their records. 

6. Select the records for deletion by checking the box beside them.  

7. In the Options menu, select Delete.   

4.2 Manually Add an Historical Transcript Record to a Student 

Historical transcript records may need to be manually added for students who enroll in the 
school from out of province/country, or for students who come from a school that has not been 
using MyEducation BC.   

Adding historical course records for a student will require that the converted historical course 
catalogues have transcript definitions applied to the courses.  Refer to the section in this guide 
titled “To Add Transcript Definitions to Historical Course Catalogues”. 

To add an historical transcript record to a student: 

1. In the School view, select the Student top tab. 

2. Click on the Transcript side tab.  

3. In the Options menu, select Add.  A blank transcript screen will appear. 

4. Click on the  in the Year ID field.  Select the year in which the student completed this 

course.  

5. Click on the  in the School > Name field and select the school of record for the 

course.  

6. Click on the  in the Number field and select the course from the pick list. 

7. Populate the Final Mark, Blended mark and Provincial Exam Mark fields as 

appropriate. 

8. Populate the Credit field with the appropriate credit value.  
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9. Set the FAS Override flag, if necessary.  This is optional and need only be set as 

necessary for the diploma program the student is associated with. (Refer to Section 9- 

Extract Contents CRS File  for FAS Override flag details) 

 

 

10. Populate the Completion Date field as appropriate for the year of the course. Start 

Date and End Date may also be entered at this time. 

 

 

 

  

Note:  Manually entered transcript records not tied to a section (course code only), will be 
visible in the Student top tab > Transcript side tab only.   
 
They will not be visible in the School View > Student top tab > Academics side tab or in the 
Family/Student Portal under the Academics top tab. 
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4.3 Enter a Related Course Code for Independent Directed Studies 

The related course code for MIDS courses can be added directly to the student transcript once 
a transcript record has been created.  The related course must meet the criteria outlined in the 
Handbook of Procedures. 

1. In the School view, select the Student top tab.  

2. Click the Transcript side tab. 

3. Create or select the MIDS course requiring a related course code. 

4. Check the User Description checkbox and the IDS Related Course field becomes 
editable.   

5. Select the related grade 10-12 Ministry or BAA course code from the Picklist. 

6. Save the record. 
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4.4 How to Setup MIDS Courses  

• MIDS course and related school course code must have matching transcript definitions. 

• MIDS course and related school course code must have curricular competency rubric. 

If you are using multiple transcript definitions and rubric definitions for your grade 10-12 
courses, make sure your MIDS courses are assigned the same transcript and rubric definitions 
as the course entered in the related course code field BEFORE you attach the related course in 
the student transcript. 

Setup an MIDS course for each related course code used, and enter the transcript definition and 
rubric definition from the related course into the MIDS course. The school will only have to set 
this up once and it will carry forward each year after setup. 

NOTE:  If the transcript definitions and/or rubric are different, assigning the related course code 
will change the original MIDS information in the transcript record. 

Example:  MIDS 0A using the related course code MMUJB10: 
Ensure the transcript definition and rubric for MIDS 10 matches what the school has set up for 
MMUJB10. 

 

 
 

4.5 GRAD Override 

GRAD requires a course to have either an “E” or “C” in the “CRSE_TYPE” field in the school’s 
CRS record file. E indicates the result of a particular course was achieved through the 
Equivalency process, and C indicates challenge for course credit. See page 22 of the GRAD 
Specifications Document here: 

https://www2.gov.bc.ca/assets/gov/education/administration/kindergarten-to-grade-
12/exams/GRAD_data_transfer_specifications.pdf  

1. In the School view, select the Student top tab.  

2. Click the Transcript side tab. 

3. Create or select the course requiring a GRAD override setting. 

4. Select the appropriate GRAD Override value.   

https://www2.gov.bc.ca/assets/gov/education/administration/kindergarten-to-grade-12/exams/trax_data_transfer_specifications.pdf
https://www2.gov.bc.ca/assets/gov/education/administration/kindergarten-to-grade-12/exams/trax_data_transfer_specifications.pdf
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4.6 Aegrotat Standing for Provincial Exams 

Aegrotat Standing is an exemption from writing a provincial exam or graduation assessment that 
is granted by the Ministry of Education. Application must be made to the Ministry of Education 
per the Handbook of Procedures.   

Submit these student course records, as you do any other student, through the .xam file 
(meaning the assessment record must be created).   

If the student was approved for Aegrotat Standing by the Ministry of Education, the Ministry 
upload of exam marks will return AEG as the exam mark and the school final mark as the 
blended mark for provincial exams. A result of AEG will be returned for a graduation 
assessment. 

Occasionally, schools may need to update the assessment record manually.  For example, if the 
Ministry approval does not come back in time for the exam marks to be included in the Ministry 
exam mark upload.  Entering AEG into the transcript record exam mark field will indicate the 
course was granted AEG status. 

When correctly entered, the DVR and School Transcript report both display AEG as the 
assessment mark. 
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4.7 Arts Education and Applied Design, Skills and Technologies  

As indicated in the Handbook of Procedures for the Graduation Program, students have 
several options for satisfying the Arts Education and Applied Design, Skills and Technologies 
graduation requirement that schools must report to the Ministry. 

Some courses that meet the Arts Education and Applied Design, Skills and Technology 
requirement may be designated as 2.0 or 4.0 credit courses at the district level. If schools 
require both a 2.0 and 4.0 credit version of the course to schedule students into, a version of 
each will need to be created at the district level to be brought into the school. Refer to the 
School Setup reference guide for these instructions.   

If an individual student transcript records requires a specific Arts Education and Applied Design, 
Skills and Technologies designation on a course and a specific credit value, this can be 
achieved by setting the FAS Override flag and adjusting the credit value directly on the student 
transcript record.   

4.7.1 Grade 11 Board/Authority Authorized (BAA) Courses 

As indicated in the Handbook of Procedures for the Graduation Program, Grade 11 
Board/Authority Authorized (BAA) or First Nations Authorized (FNA) courses that align with the 
Arts Education 11 and/or Applied Design, Skills, and Technologies 11 provincial curriculum can 
meet the Arts Education and/or Applied Design, Skills, and Technologies graduation 
requirement.  

Grade 11 BAA (Board Authority Authorized) courses are eligible to meet the AST Graduation 
Requirement by default.  This is set at the Enterprise View and visible in both the District and 
School view: 

 

District View > Schedule top tab > Courses side tab 

 

https://www.bced.gov.bc.ca/exams/handbook/1415/handbook_of_procedures.pdf
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If a grade 11 BAA course is eligible to meet the AST requirement, the box will display “Y” (#1 
above). 

Users have the ability to check the “BAA Meets AST Grad Requirement” (#2 above), if the 
course meets the requirement for the district. 

The rules around the grade 11 "Y" courses are in the Handbook of Procedures. 

There is a link to the Handbook of Procedures in the L1 Info Station under Support Resources > 
L1 Intro and Heat > Intro to L1 Role v1.0. 

 

School View > Student top tab > Transcript side tab 

 

 

All grade 11 BAA courses are eligible to meet the AST requirement; this is set at the Enterprise 
View. (#1 above). 

If a grade 11 BAA course meets the AST requirement for a District, the BAA Meets AST Grad 
Requirement is checked at the District View.  This will determine if the course meets the AST 
requirement for GRAD for all students in the District.  This displays as read only in the School 
View > Student > Transcript for information purposes. (#2 above).  .   

School users can check the “BAA Meets AST Grad Requirement” (#3 above), if the course 
meets the requirement for the student’s specific course. Leaving the box unchecked on the 
student transcript record in the school view will not reverse the district flag setting. 
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4.8 Posting Course Dates 

Posting Course Dates creates a start and end date in the transcript record for the course and 
allows a completion date to populate when the final mark is posted. In standard schools this 
process should be done after the bulk of September student course changes and just prior to 
the first GRAD submission in October. Posting Course Dates is a part of the Prepare Grade 
Input process but it is not required for teacher gradebook functions in regular school.  Detailed 
instructions on the complete Prepare Grade Input and Posting Course Dates process can be 
found in the Grade Management document.  

Course dates should only be posted for current courses.  For example, in October, it is best 
NOT to post dates for second semester courses. If dates are posted for second semester 
courses, students who drop a course will have a student transcript record already created for 
that class which may need to be deleted. 

 
1. School view > Grades top tab and click the Grade Input side tab 
2. Here you may narrow the scope if you wish and select the courses you would like to 

create transcript records for then go to Options and Show Selected. A filter entitled 
“Schedule Term = ?” has been created to help users to only post date columns 
for current courses. 

3. Go to Options and choose Prepare Grade Input  
4. In the pop up choose current selection and click next 
5. In this screen select Course for the Report Type and click finish 

 

 
 

6. On the Grades top tab > Grade Input side tab, select the Options menu > Post Grades. 
A pop-up window for Posting Grades will display. Check the Post course dates box and 
click OK. 

7.  
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5.0 Viewing Exam Results  

After exam session dates have passed and exam and blended marks have been uploaded at 
MyEducation BC, the results can be viewed in the following locations: 

• School view > Student top tab > Assessments side tab > Details > Or 

• School view > Assessments top tab > Student Assessments side tab > Assessment 
History sub-side tab > Details leaf >. 

 

 
 

  

Remember to set the Assessment Definition field at the top of the screen when viewing 
assessment records in either location. 
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6.0 Calculate Credits Procedure 

Credits can be adjusted using the Calculate Credits procedure in the Grades top tab.  When this 
procedure is run, credits will be adjusted for all courses with posted final marks (non-
examinable) and those with Blended marks (examinable).  This procedure can be run at any 
time. 

To run the Calculate Credits procedure: 

1. In the School view, select the Grades top tab.  

2. Click the Transcripts side tab. 

3. Set the  icon to All. 

4. In the Options menu, select Calculate Credits. 

5. Confirm the Calculate For window indicates an appropriate number of records in 
Current Selection. 

6. Click OK. 

 

 

7.0 Running the GRAD Extracts 

The GRAD extracts are run as three separate files in MyEducation BC.  

Users need to have their computer configured to show file extensions so the files can be 
identified after download.   

For Windows: 

Control Panel > Folder Options > View top tab > uncheck Hide extensions for known file types 
 

For MAC 
Finder > Preferences > Advanced 
Check the box that says "show all filename extensions". 
 

To run the GRAD extracts: 
 

1. In the School view, select the Student top tab.  
2. In the Options menu, select Exports.  From the fly-out menu, select BC GRAD Extract 

– Course File. 
3. Confirm the school name is correct.  Click Run. Close the window.  

4. In the Options menu, select Exports.  From the fly-out menu, select BC GRAD Extract 
– Demographic File.  Click Run. Close the window. 

5. In the Options menu, select Exports.  From the fly-out menu, select BC GRAD Extract 
– Exam File.  Click Run. Close the window. 

6. In the Reports menu, select My Job Queue.  When the job is complete, click the 
blue hyperlink Finished (click to view). 

7. Save the file as schoolnumber.DEM, CRS, or XAM, as appropriate.  (Ex. 
02323044.XAM) 
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8.0 Extract Contents 

The following three tables show all the information contained in the files created by running a GRAD Extract: 

DEM File – the actual file is produced as a .txt and does not have the column headings as in the example below.  This is provided for 
reference. 

Internal 
GRAD 

ID 

Ministry 
School 
Number 

Pupil 
Number 

PEN 
Legal Last 

Name 

Legal 
First 

Name 

Legal 
Middle 
Name 

Address City Prov. Country Postal Code 

E02M 4343114 247843 188525877 O'Hara Parker Marvin 
741-7732 
Lewis St 

Port 
Coquitlam 

BC CN V1Y4J5 

E02M 4343114 247844 439401223 Constanine Marlo Kathryne 
193-2970 
Alma Ave 

Smithers BC CN V7N6C2 

E02M 4343114 247760 369029197 Wriglesworth Jessie Hadrian 
2420 

Anderson 
Dr 

Coquitlam BC CN V2D4E7 

E02M 4343114 247845 746399084 Hemingway Ernest Giles 
4635 Log 
Cabin Dr 

Vancouver BC CN V6D7V7 

 

Birth Date Gender Citizenship Grade Program 
Program Cadre 

N OR Y    
Default is N 

Student Status 
A=Active 

D=Deceased 
T=Terminated 

Grad 
Program 

SCCP Completion Date 
YYYYMMDD 

YYYYMMDD M C 11  N A 2004  

YYYYMMDD F C 11  N A SCCP 20170630 

YYYYMMDD M O 10  N T 2018  

YYYYMMDD M C 12  N A 1996  
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XAM File – the actual file is produced as a .txt and does not have the column headings as in the example below.  This is provided for 
reference. 

Internal 
GRAD ID 

Ministry 
School 
Number 

Pupil 
Number 

PEN 
Course 
Code 

Course 
Grade 
Level 

Course 
Year 

Month of 
Exam 

Interim 
School 
Percent 

School Final Percent 

E06M 4343114 247836 599269743 NME  2018 01   

E06M 4343114 247843 188525877 COM 12 2017 06 65 60 

E06M 4343114 247844 439401223 FRAL 12 2018 01   

E06M 4343114 247845 746399084 EN 12 2018 01   

 

XAM File (cont’d) 

Exam ID Course Status A=Active  W=Withdrawn Legal Last Name Number of Credits Course Type E=Equivalency   C=Challenge 

1763 A Thesen 4  

1966 A O'Hara 4 E 

1967 A Constanine 4  

1835 A Hemingway 4 C 
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CRS File – the actual file is produced as a .txt and does not have the column headings as in the example below. This is provided for reference. 

Internal 
GRAD ID 

School 
Facility 
Code 

Pupil 
Number 

PEN Q-Code 
Course 
Code 

Course 
Grade 
Level 

Year of 
Completion 

Month of 
Completion 

Interim 
Percent 

Final 
School 
Percent 

Final 
Letter 
Grade 

E08M 4343114 247836 599269743 Q EN 12 2018 1    

E08M 4343114 247836 599269743  YCAIS 11 2018 1 59 59 C- 

E08M 4343114 247836 599269743  MMA 12 2018 6    

E08M 4343114 247843 188525877  SS 11 2018 6    

CRS File (cont’d) 

Course Status 
A=Active  

W=Withdrawn 

Legal 
Last 

Name 

Number 
of 

Credits 

Related 
Course 

(Only used 
for IDS) 

Related 
Level 

(Only 
used for 

IDS) 

Course 
Description 

Course Type  
E=Equivalency 
C=Challenge 

Course Grad 
Requirement 

F=Arts Education  
A=Applied Design, 

Skills and 
Technology      

B=Both 

 

FAS Diploma Category 

A Thesen 4   ENGLISH 12  E  

“F" - meets Arts Education 
Req't only (must be at least 2 credits) 
   
"A" - meets Applied Design, Skills and 
Technology 
Req't only (must be at least 2 credits) 
   
"B" - meets Arts Education and Applied 
Design, Skills and Technology Req't (must 
be at least 4 credits) 
“N’ – Course Grad Requirement is blank 

A Thesen 4   
COMPUTER 
ANIMATION 

 B 
 

A Thesen 4   MATH 12     

A O'Hara 4   
SOCIAL 

STUDIES 11  
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9.0 GRAD Logic 

The following information outlines the basic standard MyEducation BC GRAD Logic.  

1. Credits are only adjusted when the “Calculate Credits…” procedure is run through the 
School view > Grade top tab > Transcript side tab > Options menu.  When this 
procedure is run, credits will be adjusted for all courses with posted final marks (non-
examinable) and those with Blended marks (examinable). 

GRAD Extracts can be created from the Options menu > Exports of the Student top tab of 
MyEducation BC: 

1. DEM File – This file contains demographic information. 

2. XAM File – This file contains information on provincially examinable courses and 
graduation assessments.  

If there is NO blended mark and NO exam mark on the Student Assessment Record: 

• The School Mark will be extracted and populated in this file, and 

• The Ministry will use the highest School Mark it has on record to create a blended 

mark. 

If there are NO results on the Student Assessment record for the Graduation assessment 
record: 

• The Numeracy assessment code and session date will be extracted. 

3. CRS File – This file contains information on non-examinable courses.  Each time a 
GRAD extract is run the School Mark is extracted and repopulates the value at the 
Ministry. The Ministry does not retain information on non-examinable courses; they rely 
on each GRAD extract to re-populate these values. This extract includes initial 
registration, interim and final letter grades, and interim and final letter grades.  
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10.0 Adding Transcript Definitions to Historical Course 
Catalogues 

Transcript definitions must be added to historical course catalogues in order for the course list to 
appear for the appropriate year when manually entering historical course records to a student’s 
transcript side tab.   

1. In the School view, select the Schedule top tab.  

2. Click the Courses side tab.  

3. Use the  icon to select the Year = ? filter.  In the pop-up window: 

a. Set the School year field to the year of the school course catalogue that needs 
transcript definitions.  For example, to search for the 2014-2015 course 
catalogue, enter 2015, for the 2013-2014 course catalogue, enter 2014, etc. 

b. Set the Search based on field to All Records. 

c. Click Submit.  The course list will now display all courses in the course 
catalogue for the year selected. 

 

4. If the TransDef > Name field is blank, assign transcript definitions to the courses.  This 
can be done using the mass update or modify list functions. 

 

11.0 Ministry of Education Resources 

The Ministry of Education website at http://www.bced.gov.bc.ca/exams/ has several resources 
related to Graduation Assessment write dates, requirements and graduation requirements. Of 
particular note is the Handbook of Procedures, which outlines all of the requirements for student 
graduation. This resource should be referred to and understood by all users who are 
responsible for GRAD and who are tasked with ensuring students meet graduation 
requirements.   

 

  

http://www.bced.gov.bc.ca/exams/
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12.0 Troubleshooting 

12.1 Common GRAD Data Errors 

GRAD Ministry Error Message  Troubleshooting in MyEdBC Student 
Record 

[07A]  Invalid or Blank Grad Reqt Year Code - must 
be 2018, 2004, 1950 (Adult), 1996 or 1986  

Ensure the student has a Program of Study 

 with the Primary flag checked 

 

School View>Student Top Tab>Transcript Side 
Tab>Program of Study>Options - Add 

[07B] Mismatch on grad year/ grade   Students with the Adult – Graduation Program of 
study must have a Subgrade of AD or AN in student 
details 

 

School View>Student Top>Details Side Tab>Grade 
Sub Level  

[021] Invalid grade - must be 
08,09,10,11,12,AD,AN,OT or HS  

 

Accepted Grade Levels are 08, 09, 10, 11 or 12 if 
applicable the subgrade AD, AN or HS 

Note: GRAD does not use the subgrades  SU, GA or GR 

 

School View>Student Top>Details Side Tab> Grade 
Level 

12.1.1 Invalid Grade: Accepted Graduation Program and Grade Level 
Combinations 

Below are the Grade levels accepted by GRAD for each of the Graduation Programs (Primary 
Program of Study) in MyEducation BC.  The commonly used grade levels are in bold.  

Graduation Program Student Grade Levels Student Sub Grade 
Levels 

2018 – Graduation Program 8,9,10,11,12 HS 

2004 – Graduation Program 8,9,10,11,12 HS 

School Completion Certificate Program 8,9,10,11,12 HS 

Adult – Graduation Program 

Note: requires a Subgrade 

8,9,10,11,12 AD, AN, HS 

 

Adult – Graduation Program Subgrades:  

• AD – Adult Graduating:  Has the Primary Program of Study = Adult Graduation 

Program and is expected to graduate in the current school year.  
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• AN – Adult Not Graduating:  Has the Primary Program of Study = Adult Graduation 

Program and is not expected to graduate in the current school year.  

 

Note:  Students that have already met Graduation Requirements on a given diploma will remain 
on that diploma. E.g., a student that met the 1995 Graduation Program Requirements will not be 
assigned the Adult Graduation Program when upgrading courses in a current year.  

12.1.2 Assessment Scores and Graduation Reports 

 

12.2 Troubleshooting Resources 

L1s have access to the Heat System for Self Services Resources. You can access Knowledge 
Base Articles (KBAs). KBAs are living documents and updated regularly. The information below 
is from KBA 10606, to see the most up to date information on any topic review the current KBA 
Troubleshooting Articles. 

12.2.1 No Primary Program of Study 

Student > Filter = No Program of Study  

• Identify the Grade 10-12 students in the list Options > Show Selected 

• Assign the students a Primary Program of Study using Options > Primary Program of 

Study Creator or through the Transcript > Program of Study side tab Options > Add 

12.2.2 Primary Program of Study missing data 

Global > Favorite > Graduation Student Program > List 

• Filter to Active Students or Grade Level = (10, 11 or 12) 

• Sort on Diploma Type column to identify any records with a blank Diploma Type 

• Return to Student > Transcript > Program of Study – delete the existing program record 

and create a new one. 

• Sort on PrimProgram column to identify and records with PrimProgram set to = N 

• Click into the blue hyperlink student name and check the Primary program study 

checkbox and Save 

• Or, Options > Mass Update > Field: Primary program study > Value: check the checkbox 
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12.2.3 Adult Program of Study Missing Sub Grade 

Student > Details  

• Students with the Adult Diploma should have the AN (not expected to attain grad 

requirements this school year) or AD (expected to graduate this school year) subgrade 

entered to avoid a Grad year, grade level mismatch error from GRAD.  

12.2.4 Transcript Record Errors 

Creating a field set with the following fields can assist in identifying errors originating from 
Student Transcript Records: 

• Table: School; Field: Name 

• Table: Equivalent School Course; Field: Number 

• Table: Equivalent School Course; Field: Description 

• Table: School Course; Field: Number 

• Table: Master Schedule; Field: Course 

Details on how to identify and correct the errors are below. 

 

 

12.2.5 MIDS Courses With Ineligible Related Course Codes 

• See the Handbook of Procedures for current eligible courses. 

• School > Grades > Transcripts 

• o   Create and use a Field Set that includes: 

o Table: Equivalent School Course, Field: Number 

o Table: Equivalent School Course, Field: Description 

• Set Dictionary to All and Filter to Current Students 

• Sort on the CrsNo column to bring the records with an equivalent course code to the top 

• Scan the list of records and identify any records with an ineligible course code.  Eligible 

courses include courses leading to graduation (Grade 10-12); XSIEP and XSPBK are 

not eligible.  See the handbook of procedures for details. 

• Correct the IDS Related Course in the Student Transcript Record from this screen or 

from Student > Transcript 

 

  

Note:  If the Transcript Record belongs to another school, contact the school 
before making any changes to the Transcript Record.   
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12.2.6 Transcript Records Missing a School Course Code 

• School course codes are required for the GRAD extract to run. 

• School > Grades > Transcripts 

• Create and use a Field Set that includes: 

o Table: School Course; Field: Number 

o Table: Master Schedule; Field: Course 

• Set Dictionary to All and Filter to Current Students 

• Sort on the School Course > CrsNo column to bring the records without a school 

course code to the top 

• Select the correct school course code for the record from the Transcript details here or 

in Student > Transcript. 


