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1.0 Purpose 

The purpose of this document is to provide school users with details on the settings and 
processes that impact the generation of report cards.  Detail on these activities can be found in 
the School Setup documentation. The items that will be reviewed in this document include: 

• Understanding the transcript cycle 

• School preference settings as they relate to report cards 

• Grade term setup 

• Grade term cover maps 

• Course attributes as they relate to report cards 

• Preparing Grade Input 

• Grade Input 

Note:  School Setup for the year must be completed before starting the Grade 
Management for the school year. 

2.0 School Preferences 

2.1 Grade Preferences 

School view > School top tab > Setup side tab > Preferences  

In the Category drop-down in the upper right corner, select Grade. 

The School Report Card message is entered in the Report card message field and can be 
changed here as needed.  

Details on the settings for Grade Preferences are found in the School Setup guide. 
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3.0 Comment Banks 

MyEducation BC has the ability to create both district and school-level comment banks. It is 
important to note that only one comment bank can be attached to a course. Ultimately, all 
comments, whether they are at the district or school level, must exist in one comment bank to 
be attached to courses. See Appendix A of this document for detailed instructions. 

If school users need access to both district and school comments for report card purposes, they 
will need to add their school comments to the district comment bank or vice versa. If schools 
choose to add comments to the district bank, these school-created comments will not be visible 
to other schools in the district. 

If a school intends to use only the school comment bank, comments can be created directly 
within the school comment bank. 

Teachers will see the school comment bank and can add their comments to the school 
comment bank. It is important to note comments added to the school comment bank by an 
individual teacher are scoped to that teacher and are thus not visible to other teachers. 

3.1 District Comment Bank 

District view > Admin top tab > Data Dictionary side tab > Comments leaf 

If a district comment bank exists, it is visible here. Click the blue hyperlink on the name and the 
comments entries are displayed.  

Click on the  icon and change the filter to All Records. If the schools have comment banks, 
they will be visible here. Clicking the blue hyperlink on the name will display the comment 
entries created by schools. 

3.2 School Comment Bank 

School view > Admin top tab > Comments side tab 

If a school comment bank exists, it is visible here. Click the blue hyperlink on the name and the 
comments entries are displayed.  

Click on the  icon and change the filter to All Records. If a district comment bank exists, 
schools will see it in the list. Schools cannot change district comments, but can add their own 
comments to the district comment bank. Alternatively, schools can view the district comments 
and add district comments to the school comment bank. One of these two processes is 
necessary if the school wants their users to be able to access district and school comments 
report cards. See Appendix A of this document for details on adding codes to district and 
school comment banks.  
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4.0 Grade Terms 

School view > Grades top tab > Grade Terms side tab 

Confirm that the grade terms reflect the number of times per year and the dates that the school 
issues report cards.  

If grade terms display, refer to the School Setup documentation for instructions.  

 

Single Term example 

Term Start Date End Date 

Term September 2  June 27 

 

Trimester example:  

Trimester Start Date End Date 

Tri 1 September 2  December 8 

Tri 2 December 9 March 13 

Tri 3 March 14 June 27 

 

Quarterly example: (typical secondary setup) 

Quarter Start Date End Date 

Q1 September 2 November 23 

Q2 November 24 February 2 

Q3 February 3 April 12 

Q4 April 13 June 27 
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Exploratory Rotation Example (e.g. Middle School)  

Trimester Start Date End Date 

F1 September 3 October 24 

F2 October 25 December 19 

F3 December 20 February 21 

F4 February 22 April 30 

F5 May 1 June 23 

Tri 1 September 3  December 8 

Tri 2 December 9 March 13 

Tri 3 March 14 June 27 

Q1 September 2 November 23 

Q2 November 24 February 2 

Q3 February 3 April 12 

Q4 April 13 June 27 

 

K-12 example: 

Trimester Start Date End Date 

Tri 1 September 3  December 8 

Tri 2 December 9 March 13 

Tri 3 March 14 June 27 

Q1 September 2 November 23 

Q2 November 24 February 2 

Q3 February 3 April 12 

Q4 April 13 June 27 
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5.0 Grade Term Cover Maps 

School view > Schedule top tab > Structure side tab > Terms sub side tab 

Grade term cover maps identify the grade term(s) a schedule term uses for reporting. 

For example, a full-year schedule term gets reported on in every term, so all boxes in the grade 
term cover map would be checked. A 9-week or 12-week course may be reported on in only one 
of the terms and so the appropriate box for that schedule term would be checked to reflect 
which term it fits into. It is important to review these before preparing grade input. 

Click on each schedule term and ensure the Grade term cover map boxes are checked 
appropriately.  
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Example of a common Elementary setup: An elementary school will typically have only one 
schedule term of Full Year. All boxes of the grade term cover map should be checked because 
all grades are reported in every term of the year. 

 

Example of a common secondary school setup: In this example, the secondary school is 
sending report cards four times per year (Quarterly). A secondary school will have the grade 
term cover map boxes checked as appropriate for the terms in which that course would report. 
For example, a semester course only has the first two or last two boxes checked depending on 
which semester the course falls in. 
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Examples of a K-12 school setup:  

MyEducation BC has been adjusted so K-12 schools can associate more than one grade term 
definition to a schedule term. This will result in the appropriate columns being created for each 
term, regardless of whether the course is reported on one time, three times or four times per 
year.  

Full Year schedule term example: 

 

Semester schedule term example:  
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Setting up a grid similar to the examples below, may help K-12 schools determine what 
schedule terms fit into each grade term to be reported on. For example, if the Semester length 
courses are only assigned to high school students who are reported on four times per year, then 
the first two Standard Trimester Grades boxes for the semester schedule terms must be 
checked.  
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6.0 Course Attributes 

School view > Schedule top tab > Courses side tab 

There are several course attributes that will affect report cards. The Report Card Field Set will 
give you a quick way to view the fields that will affect the visibility of courses and availability of 
comment banks on the report card. Details on these fields can be found in the School Setup 
document. 

6.1 Transcript Definitions 

• All courses must have a transcript definition if grades or comments are to be entered 
against them. Refer to the School Setup document, available on the 
MyEducationBC.info site; and the Current Transcript Definitions Explained document 
on the L1 Information Station within MyEducation BC.  

• Transcript Definitions determine the columns that display for Grade Input on report 
cards or Learning Update.  Using the Transcript Definitions Explained spreadsheet 
on the L1 information station, select a transcript definition that will:  

o Display on a report card or Learning Update the school is using  

o And displays the correct terms (e.g. Single, Trimester, Quarter) 

o And provides the options the school requires (e.g. English or French, % / Letter 
Grade or Performance Indicators on report card etc.) 

 

6.2 Report Card Field Set 

• Course attributes, such as the Term grades term map, Hide on report card, school 
comment bank, etc. should be reviewed if a course is not appearing as expected.  

• Mass update and modify list functions can be used to apply changes to these fields.  
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7.0 Preparing Grade Input 

Preparing grade input is the process of creating the columns that users will see for entering 
dates, grades and comments for the report card or Learning Update. The columns display in 
both the School > Grade Input screen and the Staff > Scores screen. If grade input is not 
prepared, users will not have fields to enter term data into.  

Schools with multiple grade terms (e.g. both Single and Quarter, or both Trimester and Quarter) 
will have warnings that columns were not prepared for certain grade terms that do not match the 
transcript definitions on the courses displayed in the list. For example, when all course sections 
are displayed on the screen and the Term selected for preparing is Tri 1, warnings will display 
for the courses with Quarterly transcript definitions. 

This is not problematic but may be confusing for users. Consider creating a filter that can be 
used prior to preparing grade input to avoid these messages appearing. Appendix B contains a 
suggestion for creating a query that can be saved as a filter.  

7.1 To Prepare Grade Input 

School view > Grades top tab > Grade Input side tab 

Select the individual sections to prepare grade input and use Options > Show Selected to limit 
the list, or run for all sections.  Then use Options > Prepare Grade Input to launch the wizard. 

1. In step one, identify which sections to prepare grade input. Click Next. 

 

2. In step two:  

a. Select the dropdown for Report Type: Term  

b. Select the dropdown for the GradeTerm that is currently being prepared 

c. Replace Existing Columns should never be done once grade data has been 
entered and posted for a student. Read the warning!  Checking this box will 
delete all data entered for the term selected. There are very few circumstances 
where this would be done. submit a ticket with the MyEducation BC support team 
to ensure it is the appropriate action for what you wish to accomplish.   

d. Click Next 
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3. In step three Enter the Post Window dates.  

a. Start Date: First day teachers are able to post data from the grade input columns  

b. End Date: Last day teachers are able to post data from the grade input columns 

i. After the End Date has passed, all changes will be made through the 
office.   

NOTE:  The teacher may still enter mark information in Staff view outside of 

the grade post controls, but they will not be able to POST these mark entries. 

c. Allow posting for: All Students 

d. Click Finish 
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7.2 Prepare Curricular Competencies 

Curricular Competencies are used in the Competency-Based Gradebook when creating and 
marking assignments.  Before a teacher can use curricular competencies, they must first be 
prepared by the school.   

Similar to Transcript Definitions, Curricular Competency Rubric Definitions are attached to 
courses in School > Schedule > Courses.  Curricular Competency Rubrics have grade scales 
built in for assignments.   

Note: Confirm with School Administration which rubric will be used for each course 
before preparing Curricular Competencies.  If changed after preparation, the new ones will 
add to the previous competencies, not replace them, even with the checkbox checked.  The 
teacher will need to manually remove the old competencies to remove them from display when 
creating assignments. 

The Transcript Definition defines the Grade Scale for the marks/scores that are entered into 
the report card term columns.   

The Rubric Definition defines the Grade Scale for the marks/scores that are entered into the 
assignments.  
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Preparing Curricular Competencies follows a similar process to Preparing Grade Input.  The 
rubric is associated to the course and then prepared for course sections. 

School view > Grades top tab > Grade Input side tab 

Select the individual sections to prepare grade input and use Options > Show Selected to limit 
the list, or run for all sections.   

 

In the Options menu, select Prepare Curricular Competencies Grading. This launches a 
wizard. 

1. In step one of the wizard use the selection tools to choose the course sections that require 
Curricular Competencies to be prepared, or select All sections (only sections of courses that 
have a Curricular Competencies rubric will have Curricular Competencies created).  Click 
Next 
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2. In step two of the wizard, a Prepare Curricular Competencies: Replace Existing Columns a 
checkbox displays to replace.  Leave unchecked. See note above on replacing 
competencies. Click Next 

3. In step three of the wizard, confirm the total sections to prepare.  Click Finish 

 

Once competencies have been prepared, school users can view them in Grades > Grade Input 
> Curricular Competencies: 
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Teachers can view them for a section in Staff > Gradebook > Curricular Competencies. They 
are now available for teachers to add to assignments. 
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7.3 Grade Post Controls 

School view > Grades top tab> Grade Post Controls side tab 

These are created when you prepare grade input. Grade post controls are the windows of time 
set for your staff to be able to enter and post marks. Once the end date passes, all mark 
changes must be made through the office.   

NOTE:  The teacher may still enter mark information in Staff view outside of the grade post 
controls, but they will not be able to POST these mark entries. 

 

To adjust the end date of a grade post control: 

1. Click on the blue hyperlink for the GradeTerm > ID to be adjusted.  

2. Adjust the Start date or End date as necessary. 

3. Click Save. 

 

 

 

 

 

 

  

NOTE:  Recommendation to only use Criteria Type = All Students.  Criteria Type = Specific 
YOG’s ,  restricts all of your grade terms to the specified YOGS the Criteria field 
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7.4 Transcript Column Attributes 

In the School View, select Grades Top Tab, Transcript Column Attributes Side Tab > Options > 
Add. 

7.4.1 Text Comment Length 

 

Field Description 

Grade Name Click to select the transcript column that you want edit, or type in its 
name 

Column Type This is a read only field 

Test comment length If you want to change the limit for the number of characters users 
can type in a text comment type column, type the number of 
characters. 

Bank name If you want to associate a comment bank with transcript column. 
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8.0 Course Dates  

Course Dates are a BC feature that is used in grade 10-12 Ministry Reporting, and Graduation 
Reports. The columns for course dates are prepared in the same way Term columns are 
created for Grade Input.  

8.1 Preparing Grade Input for Course Dates 

School view > Grades top tab > Grade Input side tab  

In addition to preparing grade input for terms to enable grade entry, High Schools, DL and CE 
schools will need to prepare grade input for course dates. This is necessary to create the 
columns for entering course dates relevant to DL and CE schools and create date columns in 
transcript records required for grade 10-12 Ministry reporting and graduation reports.   

The course date columns that are created are: 

• Course Start Date (not displayed in grade input screens): The course start date based 
on the schedule record for the course section. 

• Actual Start Date (Start Date in Grade Input screens): The date the student was 
scheduled into the course section, or the start date of the schedule term. 

• Active Date: The date the student has met the requirements to be counted for funding. 
See School Setup guide for preference setting options on Active Date population. 

• % Complete: The percentage of the course the student has completed at the time of 
posting. 

• Completion Date: The date the student completed the course. This will be automatically 
populated in grade input when a Final mark is entered and grades are posted. The date 
is posted to the transcript when dates are posted for the course.  

• Course End Date (not displayed in grade input screens): The course end date based on 
the schedule record. 

To prepare grade input for course dates: 

School view > Grades top tab > Grade Input side tab 

In the Options menu, select Prepare Grade Input. This launches a wizard. 

1. In step one of the wizard; define which sections to include in Prepare Grade Input for 
course dates.   
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2. In step two of the wizard: choose the Report type of Course. The Grade Term selection 
disappears, as the terms are not relevant to course dates.  

 

Replace Existing Columns should never be done once data has been entered and posted for 
a student. Read the warning!  Checking this box will delete any dates entered previously. 
There are very few circumstances where this would be done. submit a ticket with the 
MyEducation BC support team to ensure it is the appropriate action for what you wish to 
accomplish.  

3. Click Finish.  

The Course Dates Control lines found in Grades > Grade Post Controls should not contain a 
Grade Term > ID.  If one is entered manually by the school, the dropdown ‘Course dates for all 
students’ will display in the ‘Post Grades’ pop up, ‘Grades to post’ parameter selection in Staff 
view.  Staff may post course dates instead of grades, if the Term ID is entered.  Remove the 
Grade Term > ID from the Grade Post Control details to avoid confusion. 
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8.2 Entering Course Dates  

Course start dates, active dates and completion dates all provide necessary information for 
1701, TRAX, and SADE extracts. Entering and posting course dates will cause a student 
transcript record to be created with the dates that have been entered.  

Standard schools with grade 10-12 students do not need to populate active dates – the process 
of posting course dates will populate the course start and end dates based on the schedule term 
associated to the course section. 

 

Note: The course dates do not observe the grade post controls the way term grades do. Course 
dates can be entered and posted at any point during the school year, even if the push pins are 
black.  

 

To populate course dates: 

School view > Grades top tab > Grade Input side tab 

Click the blue hyperlink for the course with dates to be posted. This will produce the Input Grid. 

1. Set the Grade Columns drop-down to Post Columns - Course 

2. Enter the applicable dates.  

 

Note: The Active Date is populated based on the school preference settings. The Completion 
date will be populated automatically in the grade input grid when a final mark is entered and 
grades are posted for the course.  Posting dates will then populate the transcript record with all 
entered dates. All fields can be populated, modified or deleted and posted by a teacher or office 
admin staff.  
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8.3 Posting Course Dates 

Posting Course Dates creates a start and end date in the transcript record for the course, and 
allows a completion date to populate when the final mark is posted. In standard schools this 
process should be done after the bulk of September student course changes and just prior to 
the first TRAX submission in October.  Posting Course Dates is a part of the Prepare Grade 
Input process but it is not required for teacher gradebook functions in regular school.   

Course dates should only be posted for current courses.  For example, in October, it is best 
NOT to post dates for second semester courses. If dates are posted for second semester 
courses, students who drop a course will have a student transcript record already created for 
that class which may need to be deleted. 

School view > Grades top tab > Grade Input side tab 

Course dates are created in student transcript records when they are either manually entered 
on the transcript records or when staff “Post course dates” from the Grade Input screen 
(Gradebook).   

To post course dates: 

By individual course 

In the Grade Input details for the course section: In the Options menu, select Post Grades. 

In the Post Grades pop-up window, check the box Post course dates.  The Grade Term box 
will go blank as the terms are not relevant to course dates. Grades to post will change to 
Course dates for all students. Click OK 

 

 

 

 

NOTE:  If there are students in the withdrawn tab of the course section that have dates in the 
date columns, warning messages may appear when posting Course Dates.  These messages 
only apply to posting GRADES, not posting dates.  Course Dates in BC will not post from 
the withdrawn tab of grade input.  Therefore bypass the messages selecting either Yes or 
No.  No transcript record(s) will be updated or created regardless of the selection made.  See 
section Posting Grades section for details on the grade post messages that appear.  
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For multiple courses: This assumes all necessary dates have been entered into the input grid 
for each course. 

School view > Grades top tab > Grade Input side tab 

1. In the Options menu, select Post Grades. 

2. In the Post Grades pop-up window, check the box or Post course dates.  The Grade 
Term box will go blank as the terms are not relevant to course dates.  

3. Grades to post will change to Course dates for all students as outlined in the 
screenshot above. 

4. Click OK. 

8.4 Adjusting Course Dates After Initial Posting 

The dates, or blank values, in the course dates input grid will overwrite any manual changes to 
the transcript record the next time dates are posted for the course section.   

If changes to course dates are required, it is recommended that the change be made in the 
grade input grid for the course and re-posted. This will update the student transcript record with 
the new date and keep the data stream intact.  

Note: The process listed below should only be used with the full understanding that it 
requires an additional process to update the input grid after changes are made.   

To adjust course dates for multiple or random records: 

School view > Grades top tab > Transcript side tab > Dictionary = All > Field Set = Active Dates 

In the Options menu, select Modify List.  

1. Click the pencil icon at the top of the column to activate the dates for the column to be 

updated. Populate the dates as required.  

2. Click the green check mark to save the entries.  

3. Repeat for other date columns as necessary.  

Note: The Options > Mass Update function can also be used, but should be used with great 
care as date fields can only be updated to contain a value or to change a value. They cannot be 
changed back to blank, using the mass update function.  

If course dates are populated en masse through the Grades top tab > Transcripts side tab, it is 
important to know that this does not automatically populate the Grade Input grid with the values. 
Therefore, the Update Gradebooks function should be used to push these dates back to the 
grade input grid to avoid them being overwritten by blanks or previously entered values if course 
dates are posted from the Grade Input grid at a later date.  
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9.0 Grade Input 

Grade input refers to the process of entering grades and comments for students. This can be 
done by office users through the School view, or by teachers, through the Staff view. 

9.1 School View 

School users entering grades and/or dates can do so using School view. Grades are entered in 
the Grade Input screen and then posted to the transcript records.  

9.1.1 Entering Grades 

School view > Grades top tab > Grade Input side tab 

Select the class by clicking the check box beside the course and clicking the Input Grid leaf, 
OR click the blue hyperlink of the course. This will take you to the class list with students for 
grade entry.  

1. Enter grades, work habits and comments as appropriate. Data is automatically saved. 

Quick Tips: Use the Options menu for shortcuts available for entering data, or use the 
quick keys.  

Lookup (Ctrl+L): shows the user the valid values that can be entered into that field, if 
defined. 

Fill-Down Values (Ctrl+D): takes the value in the cell the user is in and copies it down 
to all students below that cell. 

Revert Current Cell (Ctrl+K): returns the cell value to the previously entered value.  

 

9.1.2 Posting Grades 

Once all grades are entered, they must be posted to create the transcript record for the student. 
This becomes the official term mark for the students. Grades can be posted by individual class 
or all classes at once.  

If a mark change is made after grades have been posted, the user must post grades again to 
update the transcript record.  

9.1.2.1 Teacher Change 

If the teacher of a class changes AFTER posting grades you can now associate the posted 
grades with new teacher rather than the original teacher without reposting the grades. 
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9.1.2.2 Posting Grades By Individual Classes: 

School view > Grades top tab > Grade Input side tab 

Select the class by clicking the check box beside the course and clicking the Input Grid leaf, 
OR click the blue hyperlink of the course. This will take you to the class list with students for 
grade entry.  

1. Confirm grade entry is complete.  

2. In the Options menu, select Post Grades. Confirm the correct Class is displayed.  

3. Select the appropriate Grade Term. 

4. Grades to post should be Term grades for all students. Click OK. 

• If there are student(s) in the withdrawn tab of the course section with a grade 
entered for the term, this warning message will appear:  

 

NOTE: This selection will apply to ALL students in the withdrawn tab 

▪ Yes – will post grades for withdrawn student(s).  Creates a transcript 
record for a student if one does not already exist.  Selecting yes may 
present a second option if grades were entered previously: 

 

o Yes – will overwrite previously entered grades 

o No – will not overwrite previous grades 

 

▪ No - does not post grades to transcripts for withdrawn students, and will 
not create a transcript record if one does not already exist. 
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9.1.2.3 Posting Grades For All Classes: 

School view > Grades top tab > Grade Input side tab 

In the Options menu, select Post Grades. 

1. Select the appropriate Grade Term.  

2. Grades to post should be Term grades for all students. 

3. In the “Post for…” section, select either Current Selection or All Classes. Click OK. 

• If there are student(s) in the withdrawn tab of the selected course section(s) with 
a grade entered for the term, this warning message will appear:  

 

NOTE: This selection will apply to ALL students in the withdrawn tab of the 
selected sections 

▪ Yes – will post grades for withdrawn student(s).  Creates a transcript 
record for a student if one does not already exist.  Selecting yes may 
present a second option if grades were entered previously: 

 

 

o Yes – will overwrite previous grades 

o No – will not overwrite previous grades 

 

▪ No - does not post grades to transcripts for withdrawn students, and will 
not create a transcript record if one does not already exist. 
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9.1.3 Viewing the Data 

Data can be viewed in the following areas of the School view: 

• By individual course: Grades top tab > Grade Input side tab > Input Grid. 

• By all courses: Grades top tab > Transcripts side tab > set dictionary icon to All. 

o This area can also be used to create queries for specific records. 

o Queries can be made on one or more students, teachers, courses, or sections. 

• By individual student: Student top tab > Transcript side tab. 

 

9.2 Staff View 

There are two ways for a teacher to enter a term grade for a report card: 

• Entering a term grade directly to term grade screen for report cards. (Teacher manages 

daily assessment outside of MyEducation BC). 

• Posting grades from teacher-created categories and assignments. (Teacher uses 

MyEducation BC to manage daily assessment). Entering a Term Grade Directly to the 

Term Grade Screen.  

Staff view > Gradebook top tab > Scores side tab 

In the Grade Columns field, choose Post Columns – Term. 

1. In the Term field, choose the appropriate term for which grades are being entered.  

 

o Black pushpins with no shape beside them appear in the column headers prior to 

the dates defined for mark entry and appear in the Grade Post Controls. 

o Green pushpins with a triangle beside them appear during the dates defined for 

mark entry. This lets the teacher know that the grade post window is open and they 

can enter marks and post them.  

o Red pushpins with a red square beside them appear when the Post button has been 

pushed and grades have been posted to the student record. Even if the pushpins 

are red, grades can be re-posted as long as school settings permit it. 
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2. Enter grades, work habits and comments as appropriate. Data is automatically saved. 

Quick Tip: Use the Options menu for shortcuts available for entering data, or use the 
quick keys.  

• Lookup (Ctrl+L): shows the user the valid values that can be entered into that 
field, if defined. 

• Fill-Down Values (Ctrl+D): takes the value in the cell the user is in and copies it 
down to all students below that cell. This works for comments as well as grades. 

• Revert Current Cell (Ctrl+K): returns the cell value to the previously entered 
value.  

For transcript definitions with a calculation, an “Update” button will appear in the Final 
column in the final reporting period for courses. Clicking the Update button will populate 
the final grade according to the calculation in the transcript definition.  

3. When data entry is complete, click the ‘Post Grades’ button. This process creates the 

grade record for the student which will appear on the report card.  

4. Repeat process until grades are entered for all classes.  

9.2.1 Posting Grades From Teacher-created Categories and Assignments 

Posting Grades from teacher created categories and assignments is covered in the 
Gradebook & Staff View guide on the MyEducationBC.info site.   
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10.0 Transcript Visibility Flag in Portals 

Student grades posted from Staff View or from School View are not automatically visible in the 
family or student portals when viewed from full site.  

“Hide in Portal” = Y is the default setting on all current year transcript records to avoid the marks 
and comments being visible in the family or student portal before the school is ready.   

Reminder: No current year course information, assignments or class attendance information is 
available in the Portal if the School has not toggled the transcript visibility in portal feature (Hide 
in Portal = N, not Y). 

 

Follow district or school process to update the flag from “Y” to “N” before publishing report cards 
to the Family and Student Portals. 

School View > Schedule top tab > Master Schedule side tab  

To update the flag for Hide in Portal, select the “Hide in Portal” FieldSet from the list (the Hide in Portal 
is list and mass updateable). 

 

The course(s) for the student(s) will always display in the mobile view.  Hide in Portal 
functionality currently does not work in the mobile view only the full view. 



 

Grade Management 3.5 Page 34 

 

Note: The Hide in Portal flag is visible in the School View > Grades top tab > Transcript side tab 
but is not updateable in this location.  The Hide in Portal flag must be updated from the 
Schedule top tab > Master Schedule side tab. 
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11.0 Generating Learning Update 

Learning Update can be run from various areas in MyEducation BC for all students or for an 
individual student.  Learning Updates may be printed or published to the Student and Family 
Portal.   

• School view > Grades top tab > Transcript side tab > Reports menu > Learning Update  

• School view > Student top tab > Reports menu > Learning Update  

• School view > Student top tab > Transcript side tab > Reports menu > Learning Update.  

The Published Reports Export can be used to verify which portal users have downloaded the 
Learning Update from the portal for viewing.   

• School view > Student top tab > Options > Exports > Published Reports Export 

 

Check out the Learning Update Report guide on the L1 Information Station for more information. 
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12.0 Other Functions 

12.1 Update Gradebooks 

This is an optional function that can be used as part of updating marks in the transcript record. 
Recommended practice is to make the grade in the grade input grid and re-post the 
grades/comments changes for the course. This will update the applicable transcript record(s) 
accordingly.  

This function pushes any changes made directly on the student transcript record in the School 
view, back to the teacher gradebook’s term grade screen. If you make manual changes to term 
grades in the Transcript screen, they are not automatically reflected in the teacher’s screen. 
Teachers should be aware of this process before it is executed as it will affect the marks they 
see in their term screen.  This process does not reach back into the actual teacher gradebook 
where individual assignment marks are recorded.  

To update gradebooks: 

School view > Grades top tab > Transcript side tab 

1. Select all records that have been changed and use Options > Show Selected. 

2. From Options menu, choose Update Gradebooks. 

3. In the Update Gradebooks from Transcript window: 

o Select the correct transcript definition and column from the pick list. For example: 

you may be updating the Tri 1 grade for courses with an Elementary – 

Kindergarten/Primary transcript definition.  

o Confirm the Current Selection reflects the number of records you selected to 

update.  

  
2. Click OK. 
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12.2 Calculate Credits 

When an administrative staff member posts final grades in the School view, credits are not automatically 
calculated. The Calculate Credits function will populate the credit value based on the system credit 
procedure. 

To calculate credits: 

1. In the School view, select the Grades top tab. 

2. Click the Transcripts side-tab. 

3. Select the records requiring a credit value. 

4. In the Options menu, select Calculate Credits. The Calculate Credits dialog box 

appears. 

5. Choose the appropriate option to calculate credits for the current selection or for all 

transcript records. 

6. Click OK. The system will assign credit values based on the system credit procedure 

rules.  
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Appendix A: Creating or Modifying Comment Banks 

Create or Modify a District Comment Bank 

Categories within comment banks create filters for users allowing them to narrow the list of 
comments seen in the entry screen. Do some testing with categories on the comment bank, as 
well as the codes, and then view the grade entry screen to confirm achieving the desired result. 

1. Log in to District view. 

2. Click on the Admin top tab. 

3. Click on the Data Dictionary side tab and select the Comments leaf. 

4. If a district comment bank exists, click on the name of the comment bank. If there is no 

bank, go to the Options menu and select Add to create the bank.  

 
5. Fill in the fields according to the table below. A red asterisk on the field indicates that it is 

required before you can save the comment. 

 

Field Description 

Bank name Enter a name for the comment bank that is descriptive for users. 

Category 1 This creates a filter for users in the comment bank.  The name of the category 
here should be generic (ex. Just call it Category). Then Category 1 on the actual 
comment can be called General for one comment, Work Habit for another 
comment, etc. This would create a drop-down menu called Category from the 
user screen and within the drop-down menu would be General and Work Habit. 

Category 2 This is optional, but can be used to further filter comments 

Category 3 This is optional, but can be used to further filter comments 

6. Click Save. 
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Adding or modifying a comment in the district comment bank 

1. Log in to District view. 

2. Click on the Admin top tab. 

3. Click on the Data Dictionary side tab and select the Comments leaf 

4. Click on the Codes leaf. If comments exist, you will see them in the list. Click on the blue 

ID hyperlink of an existing comment to edit its content, if necessary.  

 

 

5. To add a new code, go to the Options menu and select Add. 

6. Fill in the fields according to the table below. A red asterisk on the field indicates that it is 

required before you can save the comment. 

Field Description 

ID This identifies the comment entered. This value is often numeric, but can also be 
alpha or alpha numeric. 

Comment 
Preview 

This is a short preview of the comment that the user can see when they are in the 
selections screen. 

Comment Complete comment content.  

Category 1 This creates a filter for users when they enter comments.  For example, this 
comment may be in the General category. The user will be able to select General 
from a drop-down menu and see all the comments that have a Category 1 of 
General. Other comments may have a category of English, or Work Habit.  

Category 2 This is optional, but can be used to further filter comments. 

Category 3 This is optional, but can be used to further filter comments. 

Disabled 
indicator 

Checking this box will mean the uses cannot see the comment. 

7. Click Save. 
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Create or Modify a School Comment Bank 

Categories within comment banks create filters for users allowing them to narrow the list of 
comments seen in the entry screen. Do some testing with categories on the comment bank, as 
well as the codes, and then view the grade entry screen to confirm achieving the desired result. 

1. Log in to School view. 

2. Click on the Admin top tab. 

3. Click on the Comments side tab. 

4. If a school comment bank exists, click on the name of the comment bank to view the 

comments already entered. If there is no bank, go to the Options menu and select Add 

to create the bank.  

 

 

5. Fill in the fields according to the table below. A red asterisk on the field indicates that it is 

required before you can save the comment. 

Field Description 

Bank name Enter a name for the comment bank that is descriptive for users. 

Category 1 This creates a filter for users in the comment bank.  The name of the category 
here should be generic (ex. Just call it Category). Then Category 1 on the actual 
comment can be called General for one comment, Work Habit for another 
comment, etc. This would create a drop-down menu called Category from the 
user screen and within the drop-down menu would be General and Work Habit. 

Category 2 This is optional, but can be used to further filter comments 

Category 3 This is optional, but can be used to further filter comments 

6. Click Save. 

Adding a comment to the school comment bank 

1. Log in to School view. 

2. Click on the Admin top tab. 

3. Click on the Comments side tab. 

4. Click on the Codes leaf. If comments exist, you will see them in the list. Click on the blue 

hyperlink of an existing comment to edit its content, if necessary.  
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5. To add a new code, go to the Options menu and select Add. 

6. Fill in the fields according to the table below. A red asterisk on the field indicates that it is 

required before you can save the comment. 

Field Description 

ID This identifies the comment entered. This value is often numeric, but can also be 
alpha or alpha numeric. 

Comment 
Preview 

This is a short preview of the comment that the user can see when they are in the 
selections screen. 

Comment Complete comment content.  

Category 1 This creates a filter for users when they enter comments.  For example, this 
comment may be in the General category. The user will be able to select General 
from a drop-down menu and see all the comments that have a Category 1 of 
General. Other comments may have a category of English, or Work Habit.  

Category 2 This is optional, but can be used to further filter comments. 

Category 3 This is optional, but can be used to further filter comments. 

Disabled 
indicator 

Checking this box will mean the uses cannot see the comment. 

7. Click Save. 
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Adding a Teacher Comment to the School Comment Bank 

As only one comment bank can be added to a course, and this is done at the school level, a 
teacher wanting to create their own custom comments will add their comments to the existing 
school comment bank. Only the teacher creating the comment will see these.  

1. Log in with a teacher account.  

2. Click on Change View and select Staff view, if necessary.  

3. Click the Tools top tab.  

4. Select the Comments side tab.  

5. The School Comment bank appears. 

6. Click the Codes leaf.  

7. To add a new code, go to the Options menu and select Add. 

8. Fill in the fields according to the table below. A red asterisk on the field indicates that it is 

required before you can save the comment. 

Field Description 

ID This identifies the comment entered. This value is often numeric, but can also be 
alpha or alpha numeric. 

Comment 
Preview 

This is a short preview of the comment that the user can see when they are in the 
selections screen. 

Comment Complete comment content.  

Category 1 This creates a filter for users when they enter comments.  For example, this 
comment may be in the General category. The user will be able to select General 
from a drop-down menu and see all the comments that have a Category 1 of 
General. Other comments may have a category of English, or Work Habit.  

Category 2 This is optional, but can be used to further filter comments. 

Category 3 This is optional, but can be used to further filter comments. 

Disabled 
indicator 

Checking this box will mean the uses cannot see the comment. 

9. Click Save. 
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Using Tokens (Replacement Characters) 

MyEducation BC has the ability to use replacement characters for name, gender, he/she, etc. 
These are called “tokens”. The codes to be used for character replacement are as defined in the 
table below.  

Filter 
type 

Description If you type this: This appears in the 
comment: 

Count The number of elements in a 
collection. 

{{student.conductIncidents|count}} 2 

(the student has 2 conduct 
incidents on file) 

Capitalize The system capitalizes the first 
letter.  

{{person.firstName|capitalize}} Elizabeth 

Titlecase The system enters the text in 
titlecase format. 

{{“parents and caregivers”|titlecase}} Parents and Caregivers 

Ordinal The system enters a numerical 
value in ordinal format.  

{{person.firstName}}’s 
{{student.conductIncidents|count|ordinal}} 
incident was the last documented offense.  

Timothy’s 3rd incident was the 
last documented offense. 

Upper The system enters the test in all 
uppercase.  

{{person.firstName|upper}} JANE 

Lower The system enters the text in all 
lowercase. 

{{person.firstName|lower}} jane 

Trim The system enters the text with 
all white space trimmed. 

{{person.physicalAddress.addressLine01|tri
m}}, such as 123 Main Streetxxx 

123 Main Street 

(The address without any 
spaces before or after the text) 

Gender The system enters the gender 
term based on "Male" or 
"Female". 

{{“Male”|gender:boy,girl,it}} 

OR 

{{person.genderCode|gender:He, She}} 

Boy 

OR 

He or She 

Length The number of characters in text. {{person.firstName|length}}, such as Jane 4  

(number of characters in the 
student’s name) 
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Report Card Comments 

Move Between Students When Entering Report Card Comments 

School View> Grades TT> Grade Input ST 

Staff View > Gradebook TT> Scores ST 

When entering Comments for a student   Click  or .  This saves your comment, 
and opens the Edit Text Comment box for the previous or next student. Continue to click the 
buttons and enter comments as needed. Then Click Save to close the pop-up. 

 

Character Count for Post Column/report card comments 

When teachers in Staff View or School Staff in School view, enter a post column/report card 
comment in the Gradebook, the character count and limit appear at the bottom of the text 
comment box. This guide helps teachers stay within the Report defined text area. If the 
teacher enters a comment that exceeds the limit, the character count and limit are 
highlighted in red. This gives the teacher a chance to edit the comment and reduce its 
length.  MYEDBC will not save a comment if its length exceeds the limit . 
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If the comment is over the character limit, the comment cell displays red and an error message 

shows at the top of the scores screen.  The comment will not be saved if it is over limit. 

 

 

Changing the Comment Length limit on a report card 

The Comment Length limit on a report card can be decreased at the school level using the 
appropriate comment field in the Transcript Definition.  

 

School > Grades > Transcript Column Attributes 

Select the Transcript Definition using the Transcript Definition picklist 

• Options > Add 

Select the desired comment column in the Grade Name picklist 

(e.g. School Comment or Tri 3 Comment) 

Column Type:  Text Comment will display 

Text comment length will display the current max character count  

Decrease the max character count as needed 

Note:  Long text comments may cause report card formatting to run on to multiple pages. 

Changing the display order of courses on a report card 

Schools can determine the display order of the courses on report cards by using the Report 
sequence number field in the Course Details. 

Sequencing displays on the report card by lowest number to highest number.  A course with a 
sequence number of 10 will display before a course with the sequence number of 20.  

School > Schedule > Courses > Field Set = Report Card Field Set 

School > Schedule > Courses > Details > Template = Report Card Field Set 

  If schools would like groupings of courses to have the same sequence code (e.g. English at all 
grade levels), courses can be sorted and selected using Options > Show Selected and then the 
Report sequence number field can be Mass Updated.  
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Appendix B: Grade Input Query/Filter For Transcript 
Definitions 

When course sections that are reported on three times a year (trimester) and four times a year 
(quarterly) are in the same list in the grade input screen, the user will get a warning window 
when preparing grade input that will state that columns were not prepared for some course 
sections. For example, if MEN—07 is reported on in a trimester model and is in the same list as 
MEN—10 which is reported on in a quarterly model, preparing grade input for Tri 1 will create a 
warning window that columns were not created for MEN—10. This is expected, because MEN—
10 would not have a Tri 1 column, it would have a Q1 column (for the first quarter).  

Schools that are using both quarter and trimester grade terms (such as K-12 schools) may wish 
to create a query/filter to isolate the course sections reported on in either the trimester or 
quarterly model before preparing grade input. While this is not strictly necessary, it could avoid 
confusion for users so they don’t receive the warning that columns were not prepared.  

A query as shown below will provide for filtering course sections from within a range of course 
grade levels. Schools will use different grade level cut-offs and will make use of the operators 
“Less than or equal to” or “Greater than or equal to” to isolate the necessary course sections.  

This query would be created in the Grades top tab > Grade Input side tab.  

Set the Tables to Course and Fields to Grade Level. Use Operators Greater than or equal to, 
and Less than or equal to and base the search on All Records. Remember to use Save As… 
to get the option to save the query as a filter. 

 

  

 


