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2.2 Apr 2020 Minor edit of the document

2.3 Apr 2020 Updates throughout the document to match existing functionality

24 May 2020 Clarifications on functionality throughout the document

25 Jun 2021 Clarification added to section 2.0

2.6 Mar 2023 Added a new section 2.2 — Copy Journal entry from selected student
procedure
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1.0 Introduction to Journals for Students
Journals in MyEducation BC allow staff to keep notes for students related to a wide variety of

needs. These can be shared amongst staff and have the ability to be marked for deletion or for
a future follow up. Journal entries are not accessible in the Student or Family portals.

2.0 Creating a Student Journal Entry
Currently the baseline security roles enable school administrators, clerical — school admin
assistants, counsellors and teachers to create journal entries and edit their own entries;

student services have read access only to entries marked public. Entries not marked public are
only visible to the individual who created the entry.

2.1 Accessing the Journal

Student journals are available from multiple areas in the system; different functionality will
display depending on the location.

2.1.1 Accessing from Student Top Tab

To create a journal entry, check the box to select the student from the Student top tab and
then click on the Documents side tab.

Click on the Journal sub-side tab. All journal entries display for the selected student.
Depending on access rights, users can:

o view /review / revise / delete presented entries;
o filter for entries; or
e add an entry.

From the list of journal entries screen, existing journal entries can be opened by clicking on
the Date link. Clicking on the Comment link will open a popup of the comment only.

To create a new entry use Student TT > Documents ST > Journal > Options > Add.
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2.1.2 Accessing from School Top Tab

To create a journal entry, select School top tab > Journal side tab. The user can view /

review / revise / delete presented entries; filter for entries; or add an entry.

Notes:

o Some fields available from Student top tab are not available here.

e Edits to existing journals created by other users may be done in this screen only.
e Secondary student journal entries may also be edited here. However, to maintain
historical accuracy, communicate with the primary school before adjusting a non-

primary student record.

From the list of journal entries screen, previous entries can be opened by clicking on the
Student name link. Clicking on the Comment link will open a popup of the comment only.

To create a new entry use School TT > Journal ST > Options > Add.

2.1.3 Accessing from Staff view > Student Top Tab

To create a journal entry, select Staff View > Student top tab and then click on the

Documents side tab.

Click on the Journal sub-side tab. The user can review / revise / delete presented entries,

filter for entries or add an entry.
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From the list of journal entries screen, previous entries can be opened by clicking on the
Date link. Clicking on the Comment link will open a popup of the comment only.

To create a new entry use Staff View > Student TT > Documents ST > Journal > Options
> Add.

Note: This screen contains the same fields as School view > Student top tab.
2.1.4 Accessing from Global top tab > Student or All side tab

Users with access to the Student Journal tables in the Global top tab can use this functionality
to groom the list of entries.

To access a journal, select Global top tab > Student or All side tab. Select Student
Journal table.

User can view / review / revise / delete presented entries, filter for entries or add an entry.

I T T D e e |
Pages School  Student  Staff Attendance Conduct Grades Assessment Schedule  Extracurriculars [e

Student Tables :: Student Journal :: 20/04/2020 - 1:40 PM - AU

Analytics

Favorite

Student

» List Date * D0/04r2020 x|
Audit Records
Time 140 PM
Type AU v
Admin Reason cote %
Follow-up code
Other Duration in minutes D

Al test

Staff

System

Comment

Name Aafi, Kejun

Expiration Date 29/04/2020 23]

[R) save X Ccancel

2.2 Copy Journal Entry from Selected Student Procedure

The Copy Journal Entry From Selected Student procedure will copy a previously created
student journal to all the students in a selected snapshot. Snapshots can be created at the
School and Staff view, and the level determines the ownership of the snapshot.

Note: In Staff view the students in a snapshot are limited to the students the teacher has access
to e.g., students also available in the ‘Students in My Classes’ and ‘Students in My Homeroom’
filters. A snapshot is different from a filter. Where a filter is dynamic and always returns the
latest data, a snapshot is a static list. It always displays the same records unless it is manually
edited. Only the user who created the snapshot can add or remove students from it.
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Details on Snapshots are found in the Snapshots section of the Fundamentals guide located

on the MyEducationBC.info site.

2.2.1 Navigation: Copy Journal Entry From Selected Student Procedure

The Copy Journal Entry From Selected Student Procedure is run the same way in School, and Staff views

from the following paths.

School View: Student Top tab > Documents Side Tab > Journal > Select and click into an existing journal

detail for a student > Options > Copy Journal Entry From Selected Student

Staff View: Student Top tab > Documents Side Tab > Journal > Select and click into an existing journal

detail for a student > Options > Copy Journal Entry From Selected Student

Following are the steps to copy a procedure from school/Staff view

1. Click Student top tab > Select a Student > Documents side tab > Journal
2. Click into the Journal details for the selected student

3. Options > Copy Journal Entry from Selected Student
o

Delets

ArErTINC LI =y 1

In the pop up, fill in the parameters for the copy procedure

https:/devil.myeducation.gov.bc.calaspen/runTool.de?maximized =falseBloid =P — O

5 https://devD1.myeducation.gov.bc.ca/aspen/runTooldo?maximized =falsefioid=P...

Copy Journal Entry From Selected Student

Snapshot of students to copy to * Q

Preview only

Note: Snapshot ownership determines which users can see which snapshots.

Add Copy Journal Entry From Selected Student

A
.H.
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Select the student snapshot (created above). The snapshot contains the
students that will receive a copy of this student journal in their Journal
side tab.

Snapshot of students to
copy to

Preview Checked: It will be checked by default and provides the opportunity to
confirm the settings in the parameter screen are correct. Results
message is displayed giving the user information to adjust the settings or
shapshot.

Un-Checked: Runs the copy procedure and creates journals for the
students in the snapshot

Note: It is highly recommended to run the copy procedure in Preview
mode first to confirm details before creating multiple Plans

When the Procedure is run in either Preview or copy mode, a results message pop up displays
to confirm the details of the run.

Note: It is highly recommended to run the copy procedure in Preview mode first to confirm
details and results before creating multiple Plans.

2.2.2 Copy Journal Entry From Selected Student Procedure Results

Here is a sample log message and the list of Business Rules that apply to the Copy Journal
Entry Procedure.

Log Message

Mes=zages

Mumber of students selected for Journal entry creation @ 4

Mumber of Journal entry created :4

Mumber of Journal entry skipped :8

Following is the list of students skipped :

The remainder of the skipped students are not in & class or homeroom taught by
this teacher

List of Business Rules and Error Messages

1. If Student does not have an active enrollment Student does not have Active status
status — skip student

2. If student is not primary at the School running Student is not primary to the selected school
the procedure — skip student

Journals v2.6 Page 8



o)
e MyEducation FUJ ITSU

COLUMBIA

3. Staff View — If students included in the The remainder of the skipped students are
snapshot selected are not in a section or not in a class or homeroom taught by this
homeroom taught by the teacher — skip student | teacher

Note: In Staff view the students in a results file are limited to the students the teacher has
access to e.g. students also available in the ‘Students in My Classes’ and ‘Students in My
Homeroom’ filters.
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The fields provided in the student journal template allow for filtering and querying. This assists
with the management of student records.

3.1.1 Fields of particular note within the journal template

e Journal Type:

Journal Type has pre-defined selections from the Enterprise reference table for use in
filtering and querying: Call, Email, Meeting and Other. Districts may also create their own

reference codes.

Type Meeting v

Reason code
Reporter's name
Reporter Type
Author's name

Author Type

Post-secondary planning ¥
IMs. Principal

Vice Principal

IMs. Principal

Vice Principal

¥ | redCode; redDescription

¥ | redCode; redDescription

Is public? Ca

e Expiration Date:

Some journal entries are intended to be kept with the student permanently; others are meant
to be kept only while the student remains at the current school, or for a given school year.
Districts or schools that do not wish to have student Journal Entries travel to another school
or to the next school year, can choose to have these entries set to expire.

All Journal Entries with an Expiration Date that is on or before the scheduled EOYR date,
will be deleted when the Enterprise job is run to remove expired Journal records.

Topic Sample Journal - meeting

Date * 19/05/2017 =]
Time * 2:59 PM

Duration in minutes 20

Security Level

Expiration Date 30/06/2017 @

e Is public?
Checking this option for a journal entry allows all staff who have access to the student, to
view journal entries for that student. Not checking this option keeps the note private, only
visible to the staff member who created the record. From the journal list for an individual

student, the Public field indicates the setting for each entry.

Note: School Admin can see all the journals created by a teacher, regardless of the
selection in the Is public? field.
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Type

Reason code

Meeting v

Reporter's name Ms. Principal
Reporter Type Vice Principal
Author's name Ms. Principal
Author Type Vice Principal

Is public? )

Post-secondary planning ¥

¥ | redCode; redDescription

¥ | redCode; redDescription

e Follow up and Completion Date
The follow up code, follow up date and completion date are fields that can be queried
and filtered. These fields can be useful when follow up on an issue is required. For
example, using a follow up code of Needed, with a blank completion date will enable
users to query for those records still requiring attention. Global > Student > Student
Journal > List > Options > Query

New Query

Tables Student Journal

Follow-up code
Referral code

Is public?
Comment
Follow Up Date
Completed Date

Fields

Operator Is empty

Value

Search criteria

Follow-up code Equals Needed
And Completed Date |s empty

Search based on | Current Year - All Entries

=0 E2m

Simple Mode v

4.0 Filters

Select the filter tool from Student Top Tab > School Top Tab > Staff View to display a list

of available filters.

Manage Filters

Current Year - All Entries

Current Year - Shared Entries

Current Year - Personal Entries

All Entries
All Shared Entries

All Personal Entries
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e Current Year — All Entries - current year records only
o All records Created by this user
o OR are marked as is public?
o OR are created by a teacher in the Staff view (all staff view entries are visible to
administrators in school view)
e Current Year — Shared Entries — current year records only that are marked public
e Current Year — Personal Entries - all records created by the user in the current year
o All Shared - all records marked public
o All Personal - all records created by the user
o All Entries — all years
o Allrecords Created by the user
o OR are marked as is public?
o OR are created by a teacher in the Staff view (all staff view entries are visible to
administrators in school view)

Note: In Staff view, personal (not-public) entries are not visible to other staff.
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