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1.0 Create Course Catalogue for the Build in the District 
View 

1.1 District Course Catalogue 

The district course catalogue should be reviewed and adjusted each year, as necessary. 

Course flavours in MyEdBC allow a district and/or school to make copies of courses.    

Note:  Course flavours must be created at the district level before the school can create a 
flavour.  See the section 1.3 Creating Copies of Courses (Flavours) at the District Level.   

1.1.1 Copy District Course Catalogue 

The first step for preparing courses for the coming year is to copy the District course catalogue 
forward to the next year.  This process will only copy courses, from your District, that exist in the 
Enterprise Level Catalogue for the same year. 

• Log on to the District view 

• Click the Schedule top tab 

• Click the Courses side tab 

• Click Options and select Copy Course Catalogue… 

• The following window will open: 

 

 

• Select the Year to Copy from and the Copy to year. 
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There may be courses that do not copy and you will be presented with a similar message to 
this: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Courses 
listed in 

this window are ones that existed in the District catalogue and do not have a match in the 
Enterprise course catalogue. 
 

Courses at the District level can only be copied once.  If a single course exists in the next year, 
the application prevents copying forward.  The user will be presented with the following dialogue 
box: 
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1.1.2 Adding Courses to the District Course Catalogue 

If you need additional courses, which were not in the current year they can be added for use 
next year. 

• Log on to the District view 

• Click the Schedule top tab 

• Click the Courses side tab 

• Click Options and select Add.   

• The Course Pick List pop-up window appears. 

• In the Course Catalogue date field select the dates for the next school year. 

• In the Department field, select All.  This will ensure you see all courses at the Enterprise 

level. 

Note: Only courses that are not already in the year’s catalogue will appear. 

 

• Check the box beside the course(s) you would like to add. 

• Click OK.   

• Go to the Courses side-tab and perform a search for the course you selected. 

• Check the box beside the course and click the Details leaf. 

• Populate the fields as appropriate for the district. 

• Click Save. 

Repeat until all courses required by the district are displayed in the Course list. 

  



 

Module 2 - Course Catalogues, Student and Staff Setup v1.9 Page 5 

1.1.3 Course Packages 

Course packages are a special type of course used during the scheduling process.  Course 
packages are used as a way to assign multiple course requests to a student or groups of 
students.  A course package of Grade 8 Core courses, for example, can be created and then 
assigned to all incoming grade 8 students.  Other examples may be for courses that make up an 
elective rotation, like Applied Skills and/or Fine Arts.    Flavors of course packages can be 
created, just like other courses. 

The following course packages have been created at the Enterprise level. 

 

 

Individual courses included in the package can be setup in the School or Build view (details of 
steps are included in the section on school course catalogue). 
 

1.2 District Preferences  >  Schedule 

In District Setup > Preferences > under the Category of Schedule, settings determine how the 
schools can use courses.  
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Field Default 
Value 

Comment 

Auto Update school 
course 

checked Checked:  Any changes to a district course will be automatically 
pushed down to the school courses if the related scheduling 
field is district-owned.  
Unchecked:  Any changes to a district course will NOT be 
automatically pushed down to the school courses if the 
scheduling field is district-owned. 

Course Field Ownership: 
Academic level 

District Academic Level is used for GPA. This field is open for districts 
to make available to schools or not via District TT > Setup > 
Preferences > Schedule. 

Course Field Ownership: 
Description 

School District Name: set to district name if schools should not be able 
to adjust the description of a course. 

School: set to school if schools will be permitted to edit the 
description of a course in School >Schedule >.Courses > 
Details 

Course Field Ownership: 
Grade level 

Enterprise Setting is Enterprise only. 

Course Field Ownership: 
Master type 

Enterprise Setting is Enterprise only. 

Course Field Ownership: 
Number 

School District Name:   set to district name if schools will not be 
creating course flavours (multiple versions of a course). 

School:  set to school if schools will be creating course flavours 
per the course number mask.  

Course Field Ownership: 
Short description 

District District Name:   set to district name if schools should not be 
able to adjust the short description of a course. 

School:  set to school if schools will be permitted to edit the 
short description of a course School > Schedule >.Courses > 
Details. 

Course Field Ownership: 
Credit 

District  Credit values default from the Enterprise level, but are editable 
by Districts or schools to allow for BAA course credit definitions. 

District Name:   set to district name if schools should not be 
able to adjust the credit value of a course. 

School:  set to school if schools will be permitted to edit the 
credit value of a course in School > Schedule >.Courses > 
Details. 

Course Field Ownership: 
GPA Inclusion indicator 

District District name:  prevents schools from choosing whether a 
course will be included in GPA calculations.  

School:  The default value from the district course attribute can 
be adjusted by the school. School is the suggested setting for 
BC school districts. 

Course Field Ownership: 
Hide from grade input 

District District name:  Prevents schools from choosing whether a 
course set with this value at the district level will be visible for 
reporting on.  Gradebooks will not be created for courses with 
this setting.  

School:  The default value from the district course attribute can 
be adjusted by the school. School is the suggested setting for 
BC school districts. 
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Field Default 
Value 

Comment 

Course Field Ownership: 
Hide from report card 

District District name:  Prevents schools from choosing whether a 
course set with this value at the district level will appear on 
report cards. 

School:  The default value from the district course attribute can 
be adjusted by the school.  School is the suggested setting for 
BC school districts. 

Course Field Ownership: 
Hide from transcript 

District District name:  Prevents schools from choosing whether a 
course set with this value at the district level will appear on 
transcripts. 

School:  The default value from the district course attribute can 
be adjusted by the school. School is the suggested setting for 
BC school districts. 

Honor roll type  District name:  Prevents schools from choosing whether a 
course set with this value at the district level will appear on 
transcripts. 

School:  The default value from the district course attribute can 
be adjusted by the school. School is the suggested setting for 
BC school districts. 

Course Field Ownership: 
Weight 

District Used in scheduling. 

Course Field Ownership: 
Alternate group 

District Alternate group is a means of categorizing Alternate course 
selections into groups 

Course Field Ownership: 
Department 

District Define if District or School can edit the department value on a 
course. 

Course Field Ownership: 
Minimum minutes per 
session 

District Setting used with in the application for Elementary timetable 
builder, that is not used in BC 

Course Field Ownership: 
Summary 

District District name:  Prevents schools from entering a narrative for a 
course. 

School:  The default text from the district course attribute can 
be adjusted by the school or the school can create their own in 
School > Schedule > Courses > Details. 

Course Field Ownership: 
Teacher preparation code 

District Used for grouping sections together when scheduling teachers. 

Course Field Ownership: 
Total minutes per cycle 

District Setting used with in the application for Elementary timetable 
builder, that is not used in BC 
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Field Default 
Value 

Comment 

Advanced>Miscellaneous 
Course number mask 

 

Note:  In order for schools 
to create flavours, the 
district must create the 
flavour first.  The schools 
then create a flavour of the 
district flavour. 

 

blank Blank:  district can create course flavours.  Only one version of 
each provincial course code can be brought into the district 
course catalogue.  District will be required to put 3 characters on 
the end of the course code. 

aaaaaaaaaab:  District must create a flavour and add three 
characters to the enterprise course code.  School can create 
flavours of the district flavour and can add up to one character 
to the district course code. 

aaaaaaaaaabb:  District must create a flavour and add three 
characters to the enterprise course code.  School can create 
flavours of the district flavour and can add up to two characters 
to the district course code. 

aaaaaaaaaabbb:  District must create a flavour and add three 
characters to the enterprise course code.  School can create 
flavours of the district flavour and can add up to three 
characters to the district course code. 

Course Field Ownership: 

Hide from Attendance  

District Hide from attendance feature hides/un-hide a course from 
taking attendance. This drop down is use to cascade hide from 
attendance functionality to school level. Make sure “Auto 
Update school course” field is “checked” 

 

1.3 Creating Copies of Courses (Flavours) at the District Level 

Flavours present a concept in MyEd that relates to copies of courses, in this case referring to 
district copies of Enterprise courses. A flavour is added to the copy of a course in a field of its 
own. This is a requirement of the application when creating different versions of a course, but 
the flavour does not have any relevance to schedule building or student scheduling. The course 
number mask requires districts to add 3 characters to the ministry codes. Districts can set the 
maximum number of additional characters schools might choose to add to school level copies of 
these codes for their scheduling needs. Schools can then make as many copies with distinct 
codes and flavours as they require. 

• Log on to the District view. 

• Click the Schedule top tab. 

• Click the Courses side tab. 

• Check the box beside the course that requires a flavour. 

• Click the Details leaf. 

• Click Options on the menu and select Copy.   

• Populate the Number field with the course code you are copying, adding three 

characters to the end. 

• Populate the Flavor field with a description of the copied course – this may be a course 

code or description.   

Note:  The Flavour field is just a description of the course. 
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• Click Save. 

• Return to the Courses side tab.  The course flavour will now appear in the district course 

catalogue.  Schools can see this flavour, bring it into their own school and create 

additional flavours.  Instructions for creating flavours at the school level are in the School 

Setup document. 

 

2.0 Define the Build Year Context 

You MUST correctly set this value to the next school year to prevent overwrite of the 
current year’s schedule. 

This value tells the application what the next year is going to be. 

This can be set for all school in the district: 

District > Schools > Options > Mass Update > Field = Build Year Context > Value = date 
for the next school year 

OR individual at each school 

School > Setup > Details > Build Year Context field 

School level Steps: 

1. Click the red X and delete the existing value 

2. Save the record 

3. Click the magnifying glass 

4. In the pop up window select the next school year 

5. Click OK 

6. Click Save on the School Details screen.  
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3.0 Create Course Catalogue for the Build Year 

Schools have the means of copying their current year course catalogue to the build year. They 
can also pull courses from the district to create or add to their course catalogues. 

3.1 Copying the School Course Catalogue  

School course catalogues can be copied forward from one year to the next. In order to do so, 
the course must first exist in the district course catalogue. This process is similar to that for the 
district course catalogue as described in Section 1.1 above. 

• Log on to the School View 

• Click the Schedule top tab 

• Click the Courses Side tab 

• Go to Options and select, Copy Course Catalog 

• From the popup window: 

▪ Select the year to copy from and the year to copy to 

▪ Note the option to “Replace existing”  

▪ Select to Copy all, copy a Selection, or copy from a Snapshot. 
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▪ The message shown below displays as a reminder courses must exist in the district 
course catalogue. Unlike at the district level, there will be no follow up message 
indicating which courses were not copied as a result of missing from the district 
catalogue.  
 

 

▪ Once complete, change the filter to the build year and check the number of courses 
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3.2 Pulling Courses From the District to the School Course 
Catalogue 

• Log on to the School view. 

• Click the Schedule top tab. 

• Click the Courses side tab. 

• Click the  icon and ensure Build Year is selected. 

• Click Options on the menu and select Add.  The Course Pick List pop-up window 

appears, displaying the district course catalogue.  Ensure the Course Catalogue reflects 

the build year and that School Level field is set to All to view the entire course catalogue. 

 

 

• Check the box beside the course(s) required. 

• Click OK.  This adds the selected course(s) to your Courses side tab. 

• Go to the Courses side-tab and perform a search for the course you selected. 

• Check the box beside the course and click the Details leaf. 

• Populate the fields as appropriate for the school.   

• Click Save. 

• Click on the Grading sub-top tab 

 

Creating Copies of Courses (Flavours) at the School 

The ability to create more than one version of a course (course flavours) requires that specific 
settings are in place at the district level.   

For schools to create copies of courses, the district must have created a copy first.  Schools can 
see this copy (not the flavour), bring it into their own school and create additional copies. A 
flavour is required but has limited value. Consultation with district support personnel may be 
required if schools need additional courses created at the district level. 
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3.2.1 Creating Flavours at the School Level 

• Log on to the School view. 

• Click the Schedule top tab. 

• Click the Courses side tab. 

• Check the box beside the course that requires a flavour. 

• Click the Details leaf. 

• Click Options on the menu and select Copy.   

• Populate the Number field with the course code you are copying, adding the appropriate 

number of characters required by the district preference setting. 

• Populate the Flavor field with a description of the copied course – this may be a course 

code or description.   

Note:  The Flavour field is just a description.  The actual flavour is the unique course code.  

 

 

 

• Click Save. 

• Return to the Courses side tab.  The course copy will now appear in the school course 

catalogue.   

• Populate the details on the General and Grading tabs for the copy.   
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3.2.2 Setting up Course Packages 

Course packages are used to enter requests quickly for a group of courses several students 
must take. From the Build View > Student > Requests, course packages can be expanded out 
to those courses contained within. 

Begin by making a flavour of the chosen, PKG-- course for the selected grade level. Depending 
on the District > Setup > Preferences > Category > Schedule, the school may be able to edit the 
course number (code), description and/or short description. In the lower block, course package 
field, enter the course codes to be contained within the package. 
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4.0 Define Next School for Students 

Students need to have a Next School value set, in order to assign them course requests. This 
value can only be set, for Primary Active students at your school. 

From the Student top tab in the School view, select the Primary Active Students filter, then the 
Pre-Transition field set. This field set contains the next school (NextSKL>Name) field.   Setting 
this field determines the student’s primary school following End of Year Rollover. 

The next school field is mass-updateable. It can also be set using Modify List or from within a 
student’s details screen. 

 

 

Graduating students do not need a Next School; the next school value for grade 12 students is 
left blank. 

 

5.0 Rollover Secondary School Assignments for Staff 

Primary teachers at your school do not need to be rolled over to the build year.  If a teacher 
exists in the active year, they will be available for scheduling in the Build year. 

If you know staff positions will be required next year, but do not know the staff’s name, you can 
create a “fake” staff record as a place holder.  e.g. Eng1 2016, Eng2 2016 

When you are preparing to build your school's schedule for next year, and your teachers have 
secondary school associations, you can roll over those secondary school associations to build 
the schedule for next year by contacting your district’s L1. 

5.1 Rollover Secondary School Association Process 

Only District User or L1 can do the Rollover secondary school Association for the staff with the 
existing secondary school association from the School View. 

School View>Staff TT> Options >Rollover staff School 
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This functionality will create the next school year association only for the staff who are primary 
to school from where this procedure is run. 

To roll over secondary school assignments for staff members: 

• Log on to the School view. 

• Click the Staff tab. 

• On the Options menu, click Rollover Staff Schools. The system asks if you want to roll 

over the current secondary school staff associations to the build year. 

• Click OK. 

 

6.0 Define New Secondary School Assignments for Staff 

Defining new secondary school assignments for staff is only managed at the district level by 
District User or L1 Support that has access to all staff. From the Staff top tab in either the 
School View or District View, click on the Schools side tab > Options > Add. Complete the form 
as needed. This is the recommended process for assigning secondary school associations for 
staff. Creating staff association from this area gives access for a specified year only. 

 

 

 

 

 


