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1.0 Entering and Viewing Student Requests 

One of the most important and time-consuming tasks in preparing to build your master schedule 
is collecting, entering and validating student course requests.  

Requests are 'fuel' for the scheduling engine. The engine attempts to build the schedule that is 
best for students, based on their requests. 

There is a variety of methods to enter and manage requests.  Use one or a combination of the 
following methods to enter student requests: 

• Enter requests for one student at a time from either the School view or the Build view. 

• Mass entry of requests using Multi Add in the Build view. 

• Batch Entry of student requests by typing student IDs and course numbers into a grid, in 
the Build view 

• Course packages. 

• Student online selection (not covered in this document). 

There are several ways to view and manage requests once they have been entered. Use the 
table found in Appendix A to determine how you want to view student requests. 

1.1 Understanding Priorities 

Student Course Request and Course Load Priorities 

There are three different Priority fields that determine which students and requests are loaded 
first when the Load Engine encounters conflicts. If there are no conflicts, sections are scheduled 
when the Load process identifies the best fit to fulfil most requests. This would mean that a 
course that has only one section would likely be loaded first.   

Knowing how these Priorities interact with each other will be helpful in figuring out why students 
were loaded into specific classes. 

With all priorities, the highest priority is the smallest number greater than zero. 

1.1.1 Schedule Priority on a Student 

The first priority is Schedule priority, which is a Student Schedule Attribute. This Priority is 
used to determine which students are loaded first.  

There are two places in the application to set Schedule priority on a Student.  Build view and 
School view.  However, it is most commonly set in Build view as part of scheduling activities.   

From the Build view Student top tab > Field set = Load Priority, from here the value can be set 
individually on Student details, or using Options > Modify list or using Options > Mass Update: 
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From the School view:  Schedule top tab > Schedule Attributes side tab > Students sub side 
tab, from here the value can be set individually on Student details, or using Options > Modify list 
or using Options > Mass Update: 

 

For example, two students have a request for the final seat of a course. The student with the 
highest priority (smallest number greater than 0) will be loaded into that course.  Another 
example is if you set your Next Year grade 12 students to a Load Priority of 10 and your Next 
Year grade 11 students to a Load Priority of 20, the Next Year grade 12 students will be loaded 
FIRST. 

1.1.2 Course Request Priority  

The second priority is Course priority, which is a Request Schedule Attribute. This priority is 
used to determine which request for a student is loaded first. This can be used with Primary 
Requests or General Alternate Requests.   

For Primary Requests, this Priority determines which Primary Requests MyEducation BC 
will try to load first. This Priority will override the Load Priority set on a Course. Any 
Primary Request with a Course Priority other than 0 will be loaded before any Primary 
Request with a 0, even if the Primary Request with a 0 has a higher Load Priority on the 
Course.  

For General Alternate Requests, this priority can determine which General Alternate 
Requests MyEducation BC will try to use first. For example, if a Primary Request cannot 
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be satisfied, MyEducation BC will need to use a General Alternate Request to replace it.  
MyEducation BC will use the Course priority field to determine which Alternate is loaded 
first 

There are two places in the application to set Course priority on a Course request.  Build view 
and School view.  However, it is most commonly set in Build view as part of scheduling 
activities.   

From the Build view: Student top tab > Requests side tab > Details > Course priority: 

 

From School view: Student top tab > Schedule side tab > Requests sub side tab > Details: 

 

For example, a student has a request for two different courses. MyEducation BC will load the 
one with the highest priority (smallest number greater than 0) first.  For example, if a student 
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has a request for English 10 and the Course Priority is 10 and the student has request for Foods 
10 and the Course Priority is 20, the Load engine will schedule the English 10 course first. 

1.1.3 Load Priority 

The third priority is Load priority, which is a Course Schedule Attribute. There are two places in 
the application to set Load priority on a Course.  Build view and School view.  However, it is 
most commonly set in Build view as part of scheduling activities.   

From the Build view: Courses top tab > Field set = Load & Balance – Rqrd Crs Field, from here 
the value can be set individually on Course details, or using Options > Modify list or using 
Options > Mass Update: 

 

From the School view: Schedule top tab > Schedule Attributes side tab > Course Attributes sub 
side tab, from here the value can be set individually on Course details, or using Options > 
Modify list or using Options > Mass Update: 
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2.0 Individual Entry of Student Course Requests 

Student course requests can be entered for one student at a time from either the: 

School View > Student top tab > Schedule side tab > Requests sub side tab or; 

Build View > Student top tab > Requests side tab. 
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2.1 Primary Requests 

2.1.1 Entering Primary Requests 

From the student requests screen (School view > Student > Schedule > Requests), primary 
requests can be entered in the upper block of this screen.  

This can be done by entering the course codes, separated by a comma into the School Course 
> Number box, then clicking the Add button.  

Requests can also be added using the Select button, using this method multiple courses can be 
chosen.  When using the Select feature, the grade level in the pick list represents the grade 
level of the courses the student will be selecting from for the next school year. 

 

 

2.1.2 Attributes of Primary Requests 

Upon entry, student requests are all primary requests with no restrictions or constraints. 
Attributes can then be assigned to requests helping direct the build and load engines.  

Click on the details of a course request to set attributes. 

• Section Type:  

o Allows for defining specific sections as unique, e.g. a course MEN--12 could 

have a section type of Hnr (representing an Honors sections).  If a section is 

flagged as Hnr and a student’s request is flagged as Hrn, the load engine would 

place them into the matching section.  Section Type Codes can be added to the 

reference table and these are then used to apply to the section and requests. To 

access the codes: Build View > Global top tab> Reference side tab > Filter “All 

Records > select Section Type Codes > Codes leaf > Options > Add. 
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• Is Inclusion Section:  

o This functionality allows for controlling the number of Inclusion Requests per 

section.  It can be used as a means of identifying students with a designation and 

assisting with the composition of a class (section).  Student requests are flagged 

as Is Inclusion Section. The number of these types of requests that can be 

loaded into a section is controlled through a Scenario Preference setting.   There 

is no direct link between a student having a primary designation and the 

student’s request being flagged as Is Inclusion Section. 

o Check to indicate if this an inclusion request. 

 

• Content Term Code:  

o If the school is offering students the option of completing portions or terms of a 

course that perhaps they failed in an earlier attempt, this provides the means to 

select the term to repeat. 

 

• Is Optional: 

o Where a course may be offered, but has not yet been confirmed, this choice can 

be selected. Choosing Is Optional sets the request as a Primary request should 

the course be offered, but the request will be ignored without the need to delete it 

if the course is dropped. Scenario preferences will need Include Optional 

Requests checked if this is to be used. 

• Course Priority: 

o See section 1.1.2 Course Request Priority above for detailed information on how 

priorities work and interact with others. 

 

• Staff Name, Section Number, Term Code: 
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Each of these fields is available to set constraints on a request. This limits the builder’s 

ability to find a “best fit” for the schedule.

 

2.2 Alternate Requests 

When running a load, users can choose to use alternates or not. 

There are two main types of alternates provided in MyEducation BC.  

General alternates refer to those course requests that would be over and above the primary 
requests. For example, if a student does not get a primary request then an alternate would be 
substituted.  

The other type is a direct alternate, which is specific to a particular primary request. For 
example, if a student does not get into the requested Woodwork course, substitute with Metal 
Fabrication instead. 

How to use: 

• Is Alternate Course: 

o Checking this box sets this request as a general alternate selection. 

 

• Alternate Course Priority: 

o This option allows a priority to be set on the alternate request. If a priority is not 

set, all alternates are treated equally by the load engine. 

 

• Alternate Course Type: 

o Two alternate types are available 
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▪ Substitute: This is the default, and this alternate request will substitute for 

a primary request not granted. 

▪ Auto-fill: This option will use the alternate requested to fill any openings in 

a student’s schedule; this includes periods outside of the standard 

timetable.  

• Alternate Course Number 1 and 2: 

o This sets a direct alternate request for the primary request indicated at the 

School Course > Number field. If the primary request cannot be met, Alternate 

Course 1 will attempt to be scheduled.  If this cannot be scheduled, then 

Alternate Course 2 will be attempted. 
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3.0 Mass Entry of Student Course Requests 

The various methods of mass entering, updating and managing course requests in bulk, is done 
in the Build view. 

3.1 Multi Add 

Using the Multi Add function, requests can easily be added by course number for a group of 
students or an entire grade level or by snapshot. 

Important Note: Keep in mind that any information on the Global tab - including requests - is 
shared across all scenarios.   It is possible to delete all course requests for students, therefore, 
use caution when deleting! 

To add student requests for a selection of students or a snapshot: 

1. In the Build view. 

2. Click the: 

a. Global top tab > Requests side tab > Options > Multi Add…or 

b. Student top tab > Options > Multi Add Requests…or 

c. Courses top tab > Options > Multi Add Requests… 

3. The Multi-Add Request dialog box displays: 

 

Note: This can also be accessed by the Student top tab or the Courses top tab. Select the 
appropriate students or courses then Options > Show Selected then Options > Multi-Add. 
Choose Current Selection to enter requests for the selected students or courses.  Grade level 
reflects the student’s CURRENT grade. 
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3.2 Course Packages 

Create a course package to enter requests quickly for a group of courses several students must 
take.  The course package is only a holding course used during the scheduling process.  These 
special courses have been defined at the enterprise level with a master type of ‘Package’.  The 
following packages have been created; districts and/or schools can make copies of these (just 
like other courses) as required. 

 

For example, assume next year’s Grade 8 students all take the same set of courses at a school.  
Create one course package and include all courses within it. This way, when requests for the 
course package are entered then expanded in the Build view, the system automatically enters a 
request for all courses. 

Note: In MyEducation BC, students that are going to be in an elective rotation (wheel) need to 
have requests for those courses.  

3.2.1 How to build a course package (this can also be done in Build view): 

1. Log on to the School view. 

2. Click the Schedule tab. 

3. Click the Courses side-tab. 

4. Find the course package and click Details. 

5. At the bottom of the page, in the Course package area, type in all the Course Numbers 

separated by commas that will be part of this package:  
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6. Click Save. 

Notes: If any of the course numbers are incorrect, the application will not Save until they are 
corrected. 

The next step is to give students the Request for this course package.  This can be done using 
the Multi Add function covered in the previous section.  

3.2.2 Expanding Packages 

Once students have been given the request for the package, it needs to be Expanded. 

1. From the Build view > Global top tab > Requests side tab: 
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2. Options > Expand Packages (this will expand ALL course packages) 

3. Once expanded, the students will now have a request for each course contained within 

the package: 

Note: The package course remains should you need to collapse the package. 
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3.2.3 Collapsing Packages 

If for some reason students need to be reverted to just having a request for the package, it can 
be collapsed back (this will be done for all packages). 

1. From the Build view > Global top tab > Requests side tab 

2. Options > Collapse Packages 

3. All students again have only a request for the package: 
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3.3 Batch Entry 

Batch entry of student course requests works very well when students are provided a course 
selection sheet to submit for entry. This option also provides the ability to have a good visual 
inspection of students who may be short of course requests. 

Batch entry of requests is accessed from Build View > Global top tab > Requests side tab > 
Batch Entry side tab. 

• Parameters are available for setting the matrix, which includes the number of students 

per batch, the number of primary requests and the number of alternate requests.  

• Groups of students can then either be selected individually, selected by grade(s), or by a 

snapshot. Students can also be pulled by entering their pupil number into the ID field at 

the far left. 

• Course requests are then entered by clicking in a cell and typing in the course code. 

Only valid course codes for courses existing in the build year will be accepted by the 

system. An error message will pop up if the code does not match a build year course 

code. 

Note: The cell presented for manually entering pupil numbers and course codes does not give 
the ability to see the entire entry; this is especially true using Internet Explorer. Copy and 
pasting course codes ensures accuracy. 
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3.4 Filter Requests and Filter Students 

MyEducation BC provides a tool to filter student requests and a tool to filter students. Both allow 
the user to scope down to a specific subset of students.   

3.4.1 Filter Requests 

Filter requests provides a means for the user to find students who have requested a particular 
set of courses and then show if they have another set of courses requested.  

For example: Show all students who have requested English 10 who have also requested 
English 9. 

This feature is useful to identify students with particular combinations of courses. If a course 
was accidentally assigned to a group of students, this is a quick method for isolating those 
students and the incorrect course and then removing it from their requests. 

Filter requests is accessed from the Build view > Global top tab > Requests side tab > Options > 
Filter Requests. 

• The upper block is used to identify the students with All (Intersection) or Any (Union) of 
a chosen group of courses. 

• The lower block determines which course request or requests will be displayed for the 
students identified using the upper block filter. 

In the example shown below, requests are filtered to show all students with requests for both 
MAWM-11 and MSC--11; but only show MCH--11 for this selection of students. 

 

3.4.2 Filter Students 

Build view > Student > Options > Filter Students… 

Filter students allows the user to find students by grade, homeroom, or house/team/platoon 
code that have a course or courses with a given schedule status. This can be used to locate 
students that may be missing a required course as in the example below students missing a 
request for Planning 10. 
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4.0 Reports 

There are several reports that can be used to analyze and assist with the management of 
course requests.  

4.1 Course Request Verification report 

This report is run from the Global > Requests > Reports, lists all students and the individual 
requests each has. 

 

 

4.2 Request Count Verification report 

This report can be run from the Global > Requests > Reports or Student > Reports. 

Parameter options provide the ability to analyze the number of requests, by varying groups of 
students.  Including the ability to determine which students have More than, Less than or Equal 
to X number of requests. 

This report will run for students that have a Next School matching the school running the report. 

NOTE: This report will not run for student’s that have a Secondary Association for the school 
running the report (even if those students have a request).
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4.3 Course Request Tally report 

This report, can be run from the Global > Requests > Reports or Course > Reports    

The report can be run based on the School or District Department for the course. 

If this is run with the parameter of Show calculated section counts, the Section Count column 
will show decimals. 

 

 

 

If show inclusion counts is selected, the number of inclusion request displays in ( ) following the 
number of requests. 
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4.4 Course Request List report 

This report is run from the Courses top tab.  It shows a list of all students who have requested a 
course. 
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4.5 Student Request 

This report is run from the Global > Requests > Reports and shows each students requests on 
one page. 
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5.0 Appendix A: Viewing Student Course Requests 

To view 
requests by: Do the following: 

Course 1. Log on to the Build view or the School view. 

2. In the Build view, click the Courses tab. In the School view, click the Schedule 
tab, then the Courses side-tab. 

3. Select a course, and click the Requests side-tab. All student requests for that 
course appear. 

Note: Use the Filter drop-down to select Build year or Current year to view the specific 
course requests. 

Student 1. Log on to the Build view or the School view. 

2. Click the Student tab, and search for and select the student. 

3. Click the Requests side-tab. 

Note: The request page displays the school year context, total number of primary and 
secondary requests, scheduled percentage and total credits. 

All requests 1. Log on to the Build view. 

2. Click the Global tab, and the Requests side-tab. All requests entered for the 
build year for the current scenario appear. 

Note: On the Options menu, click Filter Requests to view a specific group of requests. 
The Requests Filter dialog box appears. Search for students requesting the same 
courses, or some of the same courses, or search for students in the same house, team, 
or platoon. 

 

 

 

 


