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Student View 

1.0 Online Student Course Requests 

Students can log on to the Student portal and enter course selections for the coming school 
year. 

Schools define course selections using an Academic Track Type, Academic Tracks and then 
group courses by subject area into Track Selections.  

Parents/Guardians with family portal access can monitor their child’s selections. Counselors and 
administrators can see and approve requests in the School view. 

1.1 Preferences and Setup 

Pre-planning at the district and school levels prior to using online student course requesting is 
essential. Some important areas to consider are:  

• Will the district and/or schools accommodate more than one Academic Track Type and 

for what purpose(s)?  

• Who will manage the Academic Track Selection Subject Area reference codes? Both the 

district and the schools can create their own subject area codes.  

• Agreement should be reached as to processes regarding the copying of Academic 

Tracks among schools in the district.   

• Who will manage student and parent/guardian user accounts? This topic is beyond the 

scope of Module 5, but must be included in district/school planning for online student 

course requests. 

• At the school level, decisions will have to be made regarding the assigning of required 

courses. 

• At the school level, decisions will have to be made regarding the number of maximum 

and minimum subject area selections. 

• At the school level, decisions will have to be made regarding when to open the online 

course selection window, and for which grades. 
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1.1.1 Online Student Course Request Checklist 

Preparing for student online course requests should follow the order of the checklist provided 
below. 

o Build year context set in school details 

o Course catalogues for next school year complete 

o Assign students’ Next School  

o Assign students’ an Academic Track Type; this can only be done for Primary students 

o Create or Copy Academic Tracks – School Course Selections Outline 

o Build Track Selections – Subject Areas 

o Create/distribute/manage student/parent accounts for portal access 

In order to enable students’ ability to do online course requests, the build year context must be 
set (School View > School > Setup > Details) and the school course catalogue must be 
established for the build year (School View > Schedule > Courses, filter for Build Year).  

Students will need their Next School assigned and should also have their Academic Track Type 
set. This is done in the School View > Student list, using the Pre-transition field set. Both of 
these fields can be Mass Updated, and Modify List can also be used.  

Note: The Academic Track Type field is not available in a student’s Details screen. 
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1.2 Student Portal and Course Requests 

Initial setup will be time consuming, however once complete it will carry over from one year to 
the next with very little likelihood of modification being necessary. 

Logging in to the portal, students will find course requests from My Info > Requests.  

Students will find the Instructions block at the top of the entry mode window. Above this is a line 
indicating the next school year for which the requests are made, the number of primary and 
alternate requests selected, the percent scheduled and the total credits. 
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1.2.1 Primary Requests 

The screenshot below is for a student going into grade 12, within the English Language Arts 
Track Selection - which as illustrated below is displayed as ‘Subject area’ to a student. 

 

Students select the course of their choice and click OK. 
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1.2.2 Alternate Requests 

When creating Track Selections (displayed to students as a Subject area), there is an option to 
indicate if a request should show as an Alternate: 

 

  



 

Module 5: Online Student Course Requests  v1.8 Page 9 

1.2.3 Notes for Counselor 

There is a field for students to include notes for the counsellor. It is recommended that students 
be encouraged to speak to a counsellor. This area may be a good means of making a request 
to discuss the student’s choices with their counsellor but there is no automated feature to notify 
the counsellor. The note is viewable as the student’s requests are reviewed.  
 

 

1.2.4 Posting 

Once a student has completed their course selections, they should click on the Post button at 
the bottom of the window, this will enforce the Maximum credit & Minimum credit defined in the 
Academic Track the student has been assigned too.  Note that all selections are automatically 
saved, but posting will time stamp the submission. 

 

1.3 Parent Portal 

Student contacts who are identified as parents or guardians, who have family portal access 
checked in their details, and who have user accounts, will have access to the course selection 
window. From Family View > Family > Schedule > Requests, parents will not only be able to 
view their child’s course requests but they have the ability to make selections and changes on 
behalf of their children in the same way as the student can. 

 

  



 

Module 5: Online Student Course Requests  v1.8 Page 10 

2.0 School View Setup 

2.1 Academic Tracks 

Academic tracks, is the term used in MyEducation BC that refers to the school course selections 
outline for online student course requests. This is analogous to the student course request 
sheets common in a paper-based course selection process used in many schools. 

Terminology used in MyEducation BC online student course requests can be confusing. The 
following will help to address this. 

• Academic Track Type: Students must be assigned an academic track type for online 

course requesting. This is confusing as the field name presented from the Student tt > 

Pre-transition field set is called Academic Track and not Academic Track type. Academic 

Track Type codes are defined in the reference tables, School view > Admin > Reference 

Tables > Academic Track Type > Codes; OR District view > Admin > Data Dictionary > 

Reference > Academic Track Type. 

• Academic Tracks: This term refers to the school course selections outline. Schools 

should only require one academic track as the outline will encompass each grade, the 

instructions as well as the subject areas and courses contained within. 

• Track Selections: Track selections are the grade level subject areas and the courses 

within each from which students make their selections. 

• Subject Areas: It is recommended that subject areas be defined at the district level to be 

used by each school. These are created in the reference table > Academic Track 

Selection Subject Area.   

 

2.2 Define Academic Tracks – School Course Selections Outline 

An academic track defines a set of possible course selections available to a specific group of 
students. They are analogous to the colored course selection sheets common in a paper-based 
course selection process. Define an academic track and courses that students can or must 
complete when assigned to that track. 

To define an academic track / Creating the course selections outline 

From School View > Schedule > Academic Tracks, go to Options > Add. 

Academic tracks can be copied; however, more than one track type would have to exist in order 
for this to be useful. To copy an existing track, select the track and click Details. On the Options 
menu, click Copy. Type a number to indicate the number of copies of the track that is desired. 
Generally, a single academic track should suffice. 

The Academic Track page displays: 
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• A name is required for the academic track. In the example above, this track is named 

Hugh Boyd Secondary Course Selections.  

• Type is also a required field. This is the Academic Track Type. 

• A minimum and maximum number of credits can be set for students. Users are 

cautioned that this applies to all students using online course requests; therefore, the 

Minimum should be set at 0.0 to accommodate non-credit courses.  These values will be 

enforced when the Student POSTS, after selecting their course requests. 

• Click the Secondary student only check box if this selection sheet is for incoming 

secondary students only. 

• Use the Grade Levels area of the page to include all the grade levels that are part of the 

current track. Click Add to add a grade level, and do the following: 

o Click the drop-down to select a grade in the grade level column. 

o Type the instructions that display for students in that grade level on their 

Requests page in the Student Portal. 

o In the StartDate and EndDate columns, define the date range in which students 

in this grade level can use the Student Portal to make their course selections.  

These dates control if the Entry Mode is available, as seen in the Student view 

Note: The Grade Level selected is for next year’s grade as illustrated in the 
preceding screen capture. 
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2.3 Track Selections – Subject Areas 

Track selections are used to define the subject areas, and courses within each, for a given 
grade from which a student is allowed to choose. Subject areas are defined in the Reference 
Tables > Academic Track Selection Subject Area > Codes. 

Schools may wish to determine the order in which subject area selections appear in the student 
request window. By default, codes are displayed in the portal alphabetically and all have a 
sequence number of 0. School users can define the order of appearance by determining the 
sequence number of each code. This is set from within the details of each code or can be set 
from the Codes view in the default field set shown below. The SeqNo field can be set using 
Modify List. A sequence number value of zero is the highest. 

 

 

 

2.3.1 To define track selections/subject areas: 

From School View > Schedule > Academic Tracks, select the academic track. Then click on the 
Track Selections side tab > Options > Add. 

From the new academic track selection page: 

• Select the grade level for this track selection/subject area, required. 

• Set a sequence number here or from the field set to change the order of the subject area 

selections. 

• Use the drop-down list to select the subject area. 

• Name can be the same as the subject area 

• Determine the maximum and minimum selections students can make in this subject 

area. 

• For Alternate Requests, the lower block found on the student course request entry 

screen, check Alternate only. 

• Force Recommendations – leave blank 
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• Allow direct alternates is useful for non-academic selections where students have a lot of 

choice. For example, in Fine Arts if the student doesn’t get Dance, then choose Drama 

as a direct alternate choice. 

• Complete the instructions field for this subject area. The text editor allows for many 

presentation options. 
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2.3.2 Course Selections 

The lower block of the track selection page is where the user adds the courses to the track 
selection/subject area.  

Clicking on Multi-Add and selecting the Department field; then using Control-F to query for the 
given department, allows for a much quicker means of choosing the courses. 

 

Users can re-order the selection of courses by dragging and dropping from the “stack”        icon 
next to the sequence number.  

 

 

Clicking on the hyperlinked SeqNo enables editing of the course record. Users are presented 
with the following editable fields: 

 

• SeqNo: This can be changed to re-order the presented list of courses. 

• Course Number Do NOT change these here as it will break the link to the courses in 

the catalogue and a blue exclamation mark will appear next to the course code as a 

result. It is recommended to delete the unwanted course and select the correct one 

rather than changing a code and/or name. 
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• Course Description: This description can be changed by the school. It will then display 

in the Student view when a course is being chosen. This does not change the school 

course description. 

• Required: This is checked if the course is required, displaying for the student but not 

allowing any changes to be made. 

• Default: Check this setting to designate the current course to be selected by default; 

however, the student can change this request if they wish. 

• NeedApproval: This is just a flag that indicates to the student that they need approval 

from a counselor; it does not stop them from requesting the course. 

• LinkedCourseNumbers: This very powerful feature allows the user to link courses 

when requesting one of a pair (or more). In the LinkedCourseNumbers field, type the 

code of the course or courses to be linked using a comma to separate when more than 

one course is linked. For example, students who request MAT--12 Automotive 

Technology 12 must also take MAST-2A Automotive Service Technician 12. When the 

latter is linked to the former, a request for one automatically assigns both requests. 
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2.4 Copy Academic Tracks and Track Selections 

If a school has created an academic track that would be helpful to share within the district, a 
copy can be made and pushed to other schools. Schools can also pull other school’s tracks. 

It is recommended that the copying of academic tracks be done at the district level as this can 
be either a push or pull option. It is worth noting that when using this feature, both the academic 
tracks selected and the accompanying track selections are also copied. This will allow districts 
to set up one school and then copy the setup to other schools. 

 

2.4.1 To copy academic tracks between schools: 

From School View > Schedule > Academic Tracks go to Options > Copy. The Copy Academic 
Tracks dialog box appears. 

 

• Copy Mode allows for the push or pull of academic tracks 

• Destination/Source School(s) gives the user the ability to select multiple schools in the 

district. 

• The Name block identifies available academic tracks. 

• Be sure to check Exclude courses missing from school course catalog to avoid copying 

courses that may not exist or wish to be offered at the selected school(s). 

Note: When copying Academic Tracks, schools acquiring copies must review all areas of 
academic tracks to ensure that they meet the school’s requirements. 
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2.5 Secondary Students  

The following information provides the functionality and necessary setup to enable secondary students to 
do online request AT their home school FOR their secondary school. The two schools will need to work 
together, to ensure that the setup and timing of the setups match. 
 
NOTE: Only secondary students from within a district can complete online requests. 
 
Overview of which school must complete which components of the setup. 
Secondary school: 

• Defines an Academic Track Type Name. 

NOTE: The name of this must match the name at the Primary school. 

• Creates an Academic Track defined as Secondary student only 

• Assigns the Academic Track Type to student. 

• Creates the Track Selections. 

• Can create a secondary association for next year. 

NOTE: If a current year secondary association exists, for this school, it must be end dated prior to 

creating the new one. 

Primary school: 

• Defines an Academic Track Type Name. 

NOTE: The name of this must match the name at the secondary school. 

• Defines (controls) the dates a student can choose courses at their secondary school. 

• Can create a secondary association for next year. 

NOTE: If a current year secondary association exists, for the same school that this association is 

being created for, that must be end dated prior to creating the new one. 

 

 
 

 


