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1.0 Rotations

A rotated master schedule displays the sections of courses, in the order they actually happen on
a given day.

There are two ways schools schedulers build master schedules:

1. The most common way is as a Flat schedule. This is very typical for secondary schools
and is a direct reflection of the “scheduling board™ used. Four (or 8) periods across the
top, with various ways to indicated if the section is Full Year or Semester. After the
schedule is complete, some kind of rotation is applied. In BCeSIS, that is through the
use of Tumble Patterns. No secondary schools create a "scheduling board™ with all of
the rotations on it; it is far too complex.

2. The second way is a Rotated schedule. This is often done at the middle school level,
again it is usually reflected on a “scheduling board", but as there is more limited choices
at a middle school the complexity of building it this way is reduced.

MyEducation BC has the ability to build a Flat schedule and then rotate it, after it is built. The
master schedule, student schedules and attendance are all displayed, based on the ‘rotation’
created.

Note: Schools that have double periods and take attendance in both periods must create a
rotation.

Consideration should be given to the decision to rotate a schedule or not, as it will impact all
users in these areas. The following section shows the results, views and discusses the
implications of a using a rotated schedule.

For example, assume a school wants to rotate the schedule from a 2-day x 6-period matrix to a
6-day x 7-period matrix, as shown below.

Days
Day 1 Day 2

Periods 3
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Days

Periods

~N | | ;|

Master schedule, showing flat un-rotated and rotated schedule expressions:

Hugh Boyd Secondary 2016-2017 School View » M Select School  Coltura, Sbneighbourhood v @ Log OFf

Pages School = Student = Staff Atftendance Conduct Grades Assessment JEI4CLIICW Global = Tools  Admin

Master Schedule

Master
-]
Sections
Details -
Rebuild [ = |[T32MEN-1T—24 0 of 307 sslected &7 Custom Selection
Teachers.
Roster CrsCode Description GrdLvl SecNo ScheduleTerm > Code Unrotated Schedule Schedule Primary Staff > Name Total = Max Clssrm
Matrix View MEN-11  ENGLISH 11 it 24 Fv 204) 2(4) 43)6(2) &(1)  Knappett, Ekn 2 ELE
MEN--08 ENGLISH LANGUAGE ARTS 8 08 05 5% 2(3) 2(3)4(4)6(1) B(2)  Knappett, Ekn 3 30 213
Classes
MFN5-12  BC FIRST NATIONS STUDIES 12 12 12 2% 1(2) 1(2)3(1)5(4) 7(3)  Haijsj, Jamespaul 3 30 214
Class Size MSC--08 SCIENGE 8 INCENTIVE 08 05 5% 201 2(1)4(2)6(3) B(4)  Davidesau, Ties 3 30 202
summary
T MSS--08 INDIVIDUALS AND SOCIETIES 8 INCENTIVE 08 05 FY 104) 1(4) 3(3) 5(2) 7(1) Meilenramsay, Ronleslie 31 30 18

Student schedule corresponding to a flat un-rotated schedule:

Day 1- Day 2 -
MCKT-1A-01 | MENFA10-05
PROFESSION COOK 1 1A ENGLISH FOUNDATIONS LEVEL 1
s affrey, Kazuia
1-1
MENFA10-05 a1
ENGLISH FOUNDATIONS LEVEL 1 PROFESSIONAL COOK 1 1A
atfrey, Kazuko Salazar. Gabrese
2.2 [=-21] c14s
MSC-10-02 | MEN-10-05
SCIENCE 10 ENGLISH 10
MNoresn, Cue ‘Wark, Jamison
3.3 B230 B215
MEN-10-05 | MSC~10-02
ENGLISH 10 SCIENCE 10
Wark, Jamison Noreen, Cus
44 B215 B230
5.5
6.5

Student schedule corresponding to a rotated schedule:
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COLUMBIA
1-1 2-2
MAWM-11-14
MEN-—11-11 MVAMT11-21 I AN TRy MSS_11-22 MPLAN1OLEA, 13 MEI_11-23 APPRENTICESHIP e
ENGLISH 11 PHOTOGRAPHY 11 SOCIAL STUDIES 11 LEADERSHIP 11 BIOLOGY 11 AND WORKPLACE
11 | ARTS 11 g i K SCULPTURE 11
W Rukog, D Appuf, F Appuf, F. Hoampeyhpi, V. MATH 11 Rukog, D)
PG 124 SE SR 114 114 203 Pohsiagt, P ,
108 = 124
VHEC-1A-12 ML MSACS11-24
Bk D Pre TRy MSS—11.22 MEN—11-11 MUAMT11-21 APPRENTICESHIP i MPLAN10LEA-13 MBI-11-23
ol AL o &=} = Al W
22 e SOGIAL STUDIES 11 ENGLISH 11 PHOTOGRAPHY 11 AND WORKPLAGE T e LEADERSHIP 11 BIOLOGY 11
- Appuf, F. Pfbifd, . Rukog, D. MATH 11 Rukog, D Appuf, F. Hoampeyhpi, W
s 14 P 124 Pohsixgt, P = 114 203
108 = 124
MAV 1Y, MSACS11-24 YHEC-1A-12
MPLAN1OLEA-13 MEI-11-23 APPRENTICESHIP o MEN—11-11 MVAMT11-21 B Pee TRy MSS—11.22
Al bl o ol AL 5 ~1
53 LEADERSHIP 11 BIOLOGY 11 AND WORKPLACE SER IS NG ENGLISH 11 PHOTOGRAPHY 11 Sen s SOCIAL STUDIES 11
h Appuf, F. Heampeyhpi, \. MATH 11 Rukog, D. /. Rukeg, D. Appuf, F.
114 203 Pohsingt, P. ol P6 124 ST 114
206
MAWM-11-14
APPRENTICESHIP oA aND MPLAN1DLEA-13 MEI-11-23 T MSS--11-22 MEN--11-11 MVAMT11-21
la 4 AND WORKPLACE e e LEADERSHIP 11 BIOLOGY 11 s SOCIAL STUDIES 11 ENGLISH 11 PHOTOGRAPHY 11
MATH 11 Rukog, D) Appuf, F. Hoampeyhpi, . Appuf, F Pfbifd, . Rukog, D.
Pohsinat, P. o9, D 14 203 » Sucar 114 P& 124
206
55
6-6
17

Class Office:

The periods displayed in this view reflect the time slots of the day in a flat un-rotated schedule. If
the schedule had been rotated, the periods displayed reflect the actual order of the rotated
blocks on that given date.

Class Attendance Office Input

Daily Ofice
Y = = ®
Daily P B
Roster = || 1:Aaren, Duncandetach v = 0 of 745 selected &7 Date «4[07/02/2017 (|
Daily Batch Name Usual Name: Pupil # Grade Daily Code 1 2 3 4 5 [ 7 8
Aaron, Duncandetach Agron, Duncandetach 1369261 12
Daily
R Abssikhalii, Amadullsh Abasihali, Amadulah 553605 12
Daily Abazi, Catinas Abazi, Catinas 650438 n
Summary
Abseke, Caroledave Abseke, Carcledave 623310 12
Class
Office Adubofourpoky, Patricies Adubofourpoky, Patriciea 850505 08

1.1 Create a Rotation:

Log on to the Build view.

Click the Scenario tab.

Select the scenario you want to rotate, and click the Rotations side-tab.

On the Options menu, click Add. The New Schedule Rotation page appears.
Type the rotation ID and a description.

o gk w b

Type the rotated dimensions. This creates the proper size matrix for you to identify the
rotation map.

7. Select the Differs by term checkbox if you want to define a different rotation for each
schedule term. If you select the checkbox, the Select Term drop-down appears. Select
the first term you want to define a map for.

8. On the original schedule matrix on the left-hand side of the page, select a period and
day. Then, on the rotated schedule matrix on the right-hand side of the page, select the
periods and days in which you want that period to meet. Repeat this process for all
periods and days.

If you select the Differs by term checkbox, define the rotation map for each non-overlapping
term that spans the entire school year. For example, you might define rotations for Semester 1,

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 6
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Quarter 3 and Quarter 4. To define rotations that differ by term, select a term at the Select
Term field each time you finish a map for a term.

Note: Switching back and forth between terms does not delete the rotations you are creating;
you cannot save the rotation until all rotations have been identified for all terms in the Select
Terms drop-down.

2.0 Patterns and Pattern Sets

In MyEducation BC, schedule patterns represent all of the different ways course sections meet
in your school’s schedule. Schedule patterns consist of a course’s days per cycle and periods
per cycle. Patterns are always built based on the Flat schedule.

To create a schedule pattern, you determine the size (days and period), style, and terms of the
pattern. Depending on your selections, MyEducation BC provides you with a clickable
Days/Period grid in which you click boxes to select the possible meeting times within the
pattern:

Hugh Boyd Secondary 2017-2018
1 10Jand 7

Build View v A Select School Coltura, Sbneighbourhood v ® Log OFf

Default Template

Sohedue pattern type

‘ Days 7] Ecolods pattern on
save

By period

— o

Days

Periods

E

£

In order to build your schedule, you need to map out all schedule patterns valid for your master
schedule. Schedule patterns have different shapes. For example, courses meet on the all days
in a period have a different shape, than courses that meet every other day in a period.

Note: To give you a head start, MyEducation BC can initialize your schedule patterns from your
current year’s master schedule. But, if you rotated your current schedule, it is better to create
your schedule patterns from scratch.

Notes: To copy patterns from another school, click Copy Patterns on the Options menu. Select
which school you want to copy from, and either select the Copy all checkbox, or select each
pattern you want to copy.

You do not have to delete patterns from the Global tab. If you do not use them, the system will
ignore them.

After you create all of your schedule patterns, group your patterns into pattern sets that apply to
the different meeting shapes of courses. For example, you might create pattern sets named
Full Year and another named Semester.

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 7
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2.1 Pattern Library

Within the Pattern Library create all schedule patterns that could be assigned to courses in your
school:

Hugh Boyd Secondary 2017-2018
1 10Jan17

Build View v A Select Schaol  Coltura, Sbreighbourhood v @ Log Off

Pages Scenarioc  Workspace Courses Student Staff Rooms Rules [elLE]

Patterns
Pattern
T TR :
Details
Pattern Criteria Days = All Periods = AI; PPC = Al Pattern Style = All Patiern Type = A1
Sets
Requests ‘
0 of 24 selected 7 All Records

Logs

Pattern Days Periods PPC TPY PattemType
Referance

A1) 1 2 1 00 (0

Aid) 2 7 1 00 (0) Flat

A(1-2) 2 7 2 0o (0)

Ai2) 2 7 1 00 (0) Flat

AB(1) 2 7 2 00 (0 Flat

A-B(2) 2 7 2 0o (o) Flat

B(1) 1 2 1 00 (D)

B(1) 2 7 1 oo (0) Flat

B(1-2) 2 7 2 00 (0)

B(2) 2 7 1 oo (0 Flat

o) 2 7 1 00 (0) Flat

To create a Simple Schedule Pattern:

Log on to the Build view.

Click the Global tab.

Click the Pattern Library side-tab.

On the Options menu, click Add. The New Schedule Pattern page appears:

0w N PR

In the area at the top of the page, you define the shape of each pattern:

Hugh Boyd Secondary 2017-2018
Build View w A Select School Coltura, Sbneighbourhood » ® Log Off

1 10Jan17

Pages Scenario Workspace Courses Student  Staff  Rooms Rules

Patterns :: New Schedule Pattern

Pattern
vz SRR =3 @
g4

B save X Cancel Defautt Template
Schedule petten style | [ Simple v Schedule psttemn type
Requests
Days: 2 Explode pattern on
| save
Logs
Periods. By period
o Terms Do not use
By day

5. At the Schedule pattern style drop-down, select one of the following:

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 8
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Simple Use simple patterns to create patterns for courses that meet on a fixed schedule
of days and periods during a cycle. For example, courses that meet first period every
day.

Recommendation: This is the most common type of pattern that schools in BC will need
to create.

Compound Use compound patterns to create patterns for courses that have complicated
shapes, such as lab courses, by combining a simple pattern and a list of child patterns.
For example, courses that meet second period every day, and an additional consecutive
period once per week.

6. Type the number of Days and Periods in this schedule pattern to create a matrix for
selecting the possible period/day combinations.

Note: If you have defined days and periods for this scenario, those values default in
these fields. Do not change these values unless this scenario has multiple bell
schedules.

7. To determine the schedule terms this pattern applies to, click the Terms drop-down to
select one of the following:

Do not use: This pattern can be used for any schedule term. You should select this for
most patterns. For example, the system can use an everyday pattern to schedule a first
semester, second semester, or all-year course.

Same across terms: This pattern applies to a particular schedule term and has the
same day and period across terms. Then, type the number of terms in the empty box.
For example, assume a course meets every day during the first and third trimester. After
you select this checkbox, type 2 in the empty box, and press TAB; two Term boxes
appear above the mat- rix. Select the terms for which you want this pattern to apply.

Vary across terms: This pattern only applies to a particular schedule term and has
different days and periods for different terms. Then, type the number of terms in the
empty box. After you type the number of terms to which this pattern applies, the system
displays that number of matrixes, for each of which you paint the appropriate patterns.
(This option is not com- mon.)

Recommendation: This option can be used when a school wants the Build engine to
determine if the sections should be FY or Semester. The following is an example:

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 9
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Hugh Boyd Secondary 2017-2018

Build View v
1 10Jan17

Pages Scenario  Workspace Courses Student  Siaff Rooms Rules

Patterns :: New Schedule Pattern

Pattern
» Dtalls
Pattemn

Sets
Schadue pattern style Schedie pattemtype [ 7|
Requests ‘
e F— Exgoce ostemon
save
| — .
Periods. By e
Tems
Refarence ‘ El By day
Terms D D
Days
A 2

Periods

Hugh Boyd Secondary 2017-2018
1 10Jani7

Build View v

Pages Scenario Workspace Courses Student Staff  Rooms Rules

Patterns :: New Schedule Pattern

Pattern
» Dstalls
Pattemn

Sets
Schadue pattern style Schedie pattemtype [ 7|
Requests ‘
e F— Exgoce ostemon
| -
=E : P ]
Periods. By period
Tems
Referance ‘ B ] By dey
Terms D U
Days
A 2

Periods

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 10
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10.

11.

In the above images there is a pattern of 1(A-B) for semester 1 but NO PATTERNS in
semester 2

Click the Schedule pattern type drop-down to select one of the following (for information
purposes only — not required)

Recommendation: This can be left blank for schools in BC:

Flat: A pattern that meets the same number of days, the same number of periods each
cycle.

Free Form: A pattern that meets any days and periods without a clear shape.
Lab: A pattern that meets one flat block, with an extra period(s) on certain days.

You can explode Simple and Compound pattern types. Below Explode pattern on
save, select the By period and By day checkboxes if you want the system to create
every possible pattern based on the pattern you create in the grid after you click Save.
Exploding patterns minimizes the number of patterns you actually define. Most schools
need to define only a few patterns, and the system creates all versions of that pattern for
them. For example, if you explode a simple pattern with two schedule days 1(A-B) by
period, the system creates patterns for 2(A-B), 3(A-B), 4(A-B), and 5 (A-B).

Note: By period pushes the pattern down, and By day pushes the pattern across.
In the grid, click the boxes that represent the periods and days of this schedule pattern.

Note: To select all unselected or deselect all selected days in a column, click the Days
column header. To select all unselected or deselect all selected periods in a row, click
the Period row header.

Click Save

Create Compound Patterns

Compound Patterns do not need to be used; they help reduce the number of patterns created
for courses with complicated shapes, especially lab courses. A compound pattern contains a
primary (simple) pattern and a list of its child patterns. Each child pattern is automatically
combined with the primary pattern for use by the scheduling engine.

To create compound patterns:

1.

When defining a schedule pattern, at the Schedule pattern style field, select
Compound. The page displays the Days/Period grid for the Primary pattern, with the
Compound patterns list at the bottom.

Click the boxes in the Days/Periods grid to define the Primary pattern, such as every
day, Period 1.

Below the Compound patterns list box, click Add to add the child pattern of the primary
pattern. A dialog box with the Days/Period grid for the child pattern appears. For
example, this course needs to meet an additional period, two days per cycle:

You can explode the pattern By period or By day. For example, if you explode the
pattern by day, the system creates a pattern in the Compound patterns list for every
possibility of a course meeting two periods per week, with a day in between, such as
2(B-D), 2(C,E), and 2 (D,F).

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 11
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5. Click OK to add this child pattern to the Compound patterns list at the bottom of the
page.
Click Combined view for each child pattern to view the grid for that compound pattern:

Evaluate the pattern. If you want to delete a pattern, select the pattern in the Compound
patterns list box, and click Delete.

8. Continue to click Add to add any additional possibilities for the extra periods for this

Patterns :: New Schedule Pattern
Patte
Lib Options v Reporsw [l Help v
vy (el GRS ESR
Sets
Schedule patten style | [ Compound v chedile pattam i
Req
Days 2
Leg Periods 7
Reference e Do nat use
Printer Frindly Versior
Primary pattern Combined pattern
Days Days
A 2
- A
8
Periods N Periods
=
F
Compound patterns
Pattern view Number of days Number of periods Periods per cycle
) 2 7 1 << Normal view
I =

2.2 Pattern Sets

After you create schedule patterns, you need to group these patterns into pattern sets. Then
you attach a pattern set to every course. This is the information that the scheduling engine uses
to figure out how to schedule sections of courses.

Create course pattern sets for each of your different shapes of courses. For example, you might
create pattern sets named Every day, Alt. days Regular, After School, etc. Then, associate each
course with a proper pattern set, based on the shape of the course

Note: Do not delete pattern sets from the Global tab. If you never attach a course to a pattern
set and never use it, the scheduling engine ignores it

To create a pattern set:

1. Log on to the Build view.
2. Click the Global tab.
3. Click the Pattern Sets side-tab.

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 12
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Note: You can also create a pattern set on the Pattern Library side-tab. Select the
patterns you want to group into a pattern set. Then, on the Options menu, click Add to
Pattern Set.

On the Options menu, click Add. The New Schedule Pattern Set page appears.

Define the name of the pattern set, such as Alt. days.

Click Save.

On the Pattern Sets side-tab, click Patterns.

On the Options menu, click Add. The Schedule Pattern dialog box appears.

© o N o g &

Select the patterns you want to add to the pattern set, and click OK. These patterns
become part of the pattern set.
Pages Scenarioc Workspace  Courses Student Staff Rooms Rules Global

Pattern Sets

Pattern
Y

Pattern Sets 0of 7 selected
Dstalle g

Pattarns

Name OwmerType

Requests Combined Studies Pstiems Schosl

Logs | Englich & School
Refaranca | e o Sched
Hair Program Schoal
Mon Scheduled Classes Petterns Schoal
Regular Year Long Courses Schoal

sample Schaal

10. Continue creating Pattern Sets until you have all combinations your school requires.

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 13
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3.0 Appendix A: Determining a School’s Rotation

The following section outlines a process for determining the number of Rotated Days required

for a school. There is no exact “one way to do this,” but the following should be of assistance as
you work with individual schools.

1. Write down all the unique tumbles/rotations/bell schedules currently at the school. This

information comes from a variety of places (and should be looked at and integrated
together):

BCeSIS — Tumble patterns screen, Attendance Calendar;
MyEd — Bell schedules currently in use;

A schools website — Most schools post their ‘block rotation’;
Discussions with the school.

Using all of this information, the following table was created:

Monl -

Mon3 Mon4
13 13 13 13
1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1
Tuesl  Tues2 _ Tues4
12 12 12 12
14 14 14 14
1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1
9 9 9 9
Wedl  Wed2  weds [ICSN
13 13 13 13
1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1
- Thurs2 Thurs3 Thurs4
12 12 12 12
1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1
Fril - Fri3 Frid
14 14 14 14
1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4



BRITISH
COLUMBIA

©
MyEducation FUJITSU

2.

5.

Analyze the information to determine any patterns. In the above example it was
determined that during a given week this school does the following and information was
color coded:

Week 1 - Mon1, Tues2, Wed3, Thurs4, Fril < YELLOW >
Week 2 — Mon2, Tues3, Wed4, Thursl, Fri2 < [REB >
Week 3 — Mon3, Tues4, Wed1, Thurs2, Fri3 < GREEN >
Week 4 — Mon4, Tuesl, Wed2, Thurs3, Fri4 < GREY >

Determine the ‘core’ periods used during the day to schedule sections. This information
was gathered by looking at the school’'s website and seeing that they outline four time
slots during the day; then reviewing the existing Master Schedule in MyEd (or BCeSIS)
to determine in which periods Math, English, Science and Social Studies are scheduled
(these four courses at all grade levels tend to be in what schools refer to as regular
periods). Sections scheduled in the upper periods 5 -14, were then reviewed to double
check the ‘core’ periods.

Write down all the unique orders of these ‘core’ periods and place non-core periods at
the end, as in the example below:

1 2 3 4
2 1 4 3
3 4 1 2
4 3 2 1
9 9 9 9
12 12 12 12
13 13 13 13
14 14 14 14

This school had four unique rotations of the ‘core’ periods

This information was then used to determine the school needs to Rotate the schedule
out to 4 Days:

Day 1 Rotation | Day 2 Rotation | Day 3 Rotation | Day 4 Rotation

1 2 3 4
2 1 4

3 4 1 2
4 3 2 1
9 9 9 9
12 12 12 12
13 13 13 13
14 14 14 14

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 15
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6. In MyEducation BC, Build view> Scenario top tab > Rotations side tab > the following
Rotation would be created:
l_l}Rl'l‘lSé—l MyEducation? ondary 2014-2015 = og Ot
COLUMBIA lyEducation 5( Build View
Pages Scenario’| Workspace Courses  Student Staff Rooms Rules Global
Options Reports Help
Scenarios :: Version 1 Rotation :: 4 Day Rotati 4| 4 | N
Details Cancel Default Tempiste -
Preferences Identifier * 4 Day Rotation
Terms Description 4 Day Rotation
S e
Periods
Rotations Differs by term [}
ey Original Schedule Rotated Schedule
Days Days
213 4
1 1 BB
2 3E: BB
3 B
4 EEE:
5 R
6 NEEE
Periods | 7 Periods| 7 27 r|ar A Clear
8 8 |Ealne|es ne
B : R
10 10 Sl e wlmle
11 11 [
12 12 [l el e
13 13 | 1ale 5| vl 1e
14 14| S E e
Note: This scenario was created with a Build year context of the current year (due to
setup requirements). The dates should in fact be for the coming school year.
7. This school would then require 1 Bell Schedule, which could be created in August:

ell Period number I Bell Period Identifier I Period Name | Start Time I Duration (Minutes)
1 1 1 8:40 AM 80
2 2 2 10:05 AM 80
3 3 3 11:40 AM 75
4 4 4 1:40 PM 80
9 9 9 3:00 PM 60
12 12 12 3:00 PM 60
13 13 13 3:00 PM 60
14 14 14 3:00 PM 60

There would be additional options for the times of Bell Period Numbers 9-14 that could
be explored in August.

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 16
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8. The final step would be to create the School’s Calendar, which would be done in the
August timeframe. Below is a representation of the Calendar and how it would look:

Date: Day
Mon Sept. 7 Labour Day
Tues Sept. 8 2
Wed Sept. 9
Thur Sept. 10
Fri Sept. 11
Mon Sept. 14

Tues Sept. 15
Wed Sept. 16
Thur Sept. 17
Fri Sept. 18
Mon Sept. 21
Tues Sept. 22
Wed Sept. 23
Thur Sept. 24
Fri Sept. 25
Mon Sept. 28
Tues Sept. 29
Wed Sept. 30
Thur Oct. 1
Fri Oct. 2
Mon Sept. 28
Tues Sept. 29
Wed Sept. 30
Thur Oct. 1
Fri Oct. 2

B A WNR[APWNERBRAWNEREREDDSWINE P WNIEFE AW

Module 6a — Rotations, Pattern Library and Pattern Sets v1.4 Page 17
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4.0 Appendix B: Full Year and Semester Option

This section outlines the setup steps required to have the Build engine determine if sections of a
course should be Full Year or Semesters. It is not required if you are going to manually do this.

4.1.1 Structure

The structure of a scenario must contain both Full Year terms and Semester terms:

Pages Scenario Workspace Courses Student Staff Rooms Rules [eilsE]]

Pattern Sets
Pattemn -
Pattern Sets 0 of 7 selected (7
Dstalls
Pattams
Mame OwmerType
S Combined Studies Pattams School
Logs | English 8 School
i | Everyday School
Hair Program Schosol
Non Schaduled Classes Pattams School

Regular Yesr Long Courses School

sample School

4.1.2 Patterns

Patterns need to be created and added to the Pattern Library that represent the periods Full
Year or Semester sections could possible meet.

From the Global > Patterns > Options > Add, create this pattern:
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By day
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Repeat for all possible periods in the first semester as in the screen capture below.

Note the asterisk in point number 2. This indicates the pattern is varying across terms.

Point number three indicates in which of the 2 semesters, these periods are represented (10
indicates 1% semester).

Hugh Boyd Secondary 2017-2018 Build View v M Select School  Colf
1 10Jan17

Pages Scenario Workspace Courses Student  Siaff Rooms LTS Global 1

Patterns

Pattern
Library Reporsw
Detalls

Pattern Criteria Days = All; Periods = All. PPC = All; Pattern Style = Al Pattern Typs = All
Sats
Y Change Filter...

Requests ‘
Logs 0 of 25 selected &7

Pattern Days Periods PPC TPY PatternType
Reference

1Az 2 7 2 2 (10)

Next create another set of patterns that represent the second semester:

This time select the small table representing the second semester, as has been done in number
3 below.

Hugh Boyd Secondary 2017-2018
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Pages Scenario Workspace  Courses Student  Staff Rooms Rules

Patterns :: New Schedule Pattern

Pattern
= Dotalls
Pattern

Sets

Schedule pattern style | [ Simple v Schedule pattemn type | | v
Requests ‘

- — Exgodeoatin on

‘ zaus

Lose - —

Periods. Ty

Terms | Vary across terms ¥ |
Reference ‘ El By day

Terms |:| D
Days
A 2

Periods

Repeat for all possible periods in the second semester as in the screen capture below.
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Pages Scenario Workspace Courses Student Staff Rooms Rules QellE]

Patterns

Pattern
Library
Detalls

Pattern Criteria Days = All: Periods = Al PPC = All; Pattern Style = All; Pettern Type = All:
Sets

Requests ‘

- ‘ 0 0f 26 selected (7

Pattern Days Periods PPC TPY PatternType
Refaence

144-2) " 2 7 2 2 (10) sf—

144-2) " 2 7 2 12 (1) A—

Note that there are now 2 records for each period, the difference between the two can be seen
in the TPY column.

The semester 2 patterns are represented by 01.

Next ensure you have patterns that represent just sections that could be offered Full Year. The
image below shows a 2 day school with all the possible patterns that a Full Year or Semester
section could be scheduled into:
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Pages Scenario  Workspace  Courses Student  Staff Rooms  Rules el

Patterns
Pattern
Library
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Eefornos ‘ Pattern Days Periods PFC TPY PatternType

104-2) 2 7 2 2 (10)

10420 2 7 2 12 (@1

Al 1 2 1 oo ()

Al 2 7 1 0o @ Flat
Al12) 2 7 2 0o @

A2) 2 7 1 0o () Flat
AB{1) 2 7 2 00 () Flat
B2 2 7 2 00 (0 Flat
B(1) 1 2 1 00 ()

B(1) 2 7 1 0o oy Flat
B(1-2) 2 7 2 oo )

B(2) 2 7 1 0o () Flat

4.1.3 Pattern Set

Once created, the patterns need to be grouped into a set with an appropriate name to indicate
this set should be used for Full Year and Semester sections.

Global > Pattern Set > Options > Add > Enter the Name > Save

Next click the side leaf Patterns > Options > Add > from the popup window, select all patterns
that should be included:
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B(1) 1 2 1 o) Simple
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c(12) 2 7 2 oo Simple

D(12) 2 7 2 w0 Simple

4.1.4 Course setup

In the Course > Detail > Required area > set the course up to represent a Full Year course and
choose the special pattern set created in the previous step: The course setup should look like
the following image:
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= &=
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e
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Narber

Snapshats ‘ Department Fine Arts
Description AP 2D DESIGN PORTFOLIO 12 Course psckage
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Credit a0
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Section envollment mex ([0 | Periods per cysle

Schedule Pattem Set > M—‘
— eryday & Alt days Reg Q,

4.1.5 Build

When the Build is run (covered in Scheduling Module 8) it will choose, based on all parameters
entered, which sections will be scheduled as FY and which in S1 or S2:
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