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Introduction 

This scheduling module covers the steps to create course sections, manually enter constraints 
against sections, assign teachers to sections, the build validation process, using the Build 
engine to create the master schedule and how to resolve issues encountered.  

The Build engine will (try to) populate the following fields Schedule Term, Schedule – Period 
(Day) and Room, for all sections.   

It will not schedule Teachers against sections.  

1.0 Initialize the Workspace 

After you determine the number of sections you need for each course, you must initialize the 
Workspace.  This will create the number of sections for each course, indicated in the Course 
Details > Sections scheduled field. 

1.1 Steps to Initialize 

1. Click the Workspace top tab. 

2. On the Options menu, click Initialize Sections. The Initialize Sections dialog box 

appears: 
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3. Select one of the following to select which courses you want to initialize sections for: 

• All courses. 

• Selection: A list of all courses appears. Select the courses you want to initialize. 

• Department: A list of departments appears. Select which departments of courses 

you want to initialize. 

• Grade level: A list of grade levels appears. Select which grade levels of courses 

you want to initialize. 

• Snapshot: A list of snapshots appears. Select the snapshot of courses you want 

to initialize. 

4. Click OK. 

The system creates the number of sections, for each course that you defined.  In the example 
below 133 sections were created: 

 

 

  



 

Workplace and Build Validation v1.6 Page 6 

2.0 Conflict Matrix 

This feature provides a dynamic view of the students who have chosen two courses. 

It is a side tab in the Build view > Workspace top tab. 

 

Courses to display can be viewed by: 

 

In the example above you can see 2 students have chosen MAWM-11 and MFOM-11. 

Clicking on the hyperlinked number, in this case 2, will show a list of those students. 
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As adjustments are made to course requests the: 

 

• button can be used to update the Conflict Matrix values. 

Clicking this button indicates that you want the system to recalculate the information if you leave 
this page, manually make a change to a section and then return. 
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3.0 Pre-Schedule – Terms, Schedule and Rooms 

Before the Build process is run, schools may want to indicate specific Terms, Schedules 
(Period/Day), or Rooms for sections. This is a way of putting direct constraints into the 
schedule. When these are pre-set/manually entered, the Build engine will not alter the settings 
and will schedule remaining sections around them. 

3.1 Setting Section Details 

1. Click the Workspace top tab. 

2. Click on the Master side tab and then into Details of a Section: 

 

1. Set a specific room 

2. Set a specific Term 

3. Set a specific Schedule (Period/Day). A schedule cannot be set unless a Term is 
defined. 

4. Set a teacher 
 
 
 
 

3. Click Save 
  

Note:  The Build engine is NOT going to add teachers to sections. 
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4. When any one of the first 3 are set, the Prescheduled check boxes to the right of these 

are checked on Save.  Example: The section shown below was prescheduled to be in 

Room 103 and the Prescheduled room check box is now checked.  This checkbox is 

what the Build engine references to determine if the section was Prescheduled and if 

should be ignored. 

 

Looking back at the Section list, we can now see that this section is Prescheduled into this 
room: 

 

 

 

  

Note:  It is VERY important that schools realize the Build engine will populate a Room for 
all sections.  This is very different from BCeSIS – which would not auto fill in a Room.  

Schools must, therefore, use a Room Rule or Preschedule sections into rooms. 
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4.0 Assign Teachers to Sections 

Once sections are created, the distribution of teachers across sections can be completed; if this 
is your schools process.  There are several methods available to complete this. 

4.1 Section Details, Modify List and Mass Update 

1. Click on an individual section to enter the Details. 

2. Click the  symbol next to the Staff > Name and select a staff from the pop up: 

 

3. Click OK, on the pop up window. 

4. Click Save, on the course section detail. 

5. The teacher chosen is now assigned to this section. 

The Modify List or Mass Update, available under the Workspace > Options menu, can also 
be used. Be sure when using Mass Update that you have done an Options > Show Selected for 
the appropriate list of course sections when assigning a given staff member. 
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4.2 Add Co-Teacher(s) to Multiple Course Section(s) 

Build View > Scenario top tab > Filter = Current Build Context   

 

Users can add one or more teachers to one or more course sections for current build context 
within a scenario using the BC Multi-Add Co-teacher(s) to section(s) procedure. 

• Users must be assigned the add on role to use this procedure - Add Co-Teacher to 

Multi-Course Sections Add-On Role 

• Note:  Co teachers can be added and users should also check to make sure they have a 
primary teacher attached to the course section, the Prepare Grade Input will not run without 
a primary teacher added.  

 

Build View > Workspace top tab > Master Schedule side tab > Options > BC Multi-Add 
Co-teacher(s) to section(s) 
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1. School view > Schedule top tab > Master side tab > Filter = Current year 

2. Select all the sections you would like to add the Co-Teacher to then go to Options > 

Show Selected. 

3. Then Options > BC Multi-Add Co-teacher(s) to section(s) 

 

 

4. Use the following table to fill in the fields: 

Field Description 

Course section(s) to include Current Selection 

Name Click    to select Teacher(s) to assign to selection sections. 

Role Co-Teach 

Gradebook access 
Select this checkbox if the teacher(s) should have access to this 
section(s) in the gradebook. 

Preview Only 
Uncheck if you would like the procedure to run.  If checked it will list the 
sections it would add the co-teacher(s)’ too if it were to run. 

5. Click Run 
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4.3 Assignments 

To create teacher assignments: 

1. Click the Workspace tab. 

2. Click the Assignments side-tab. The Assignments page appears: 

 

This view allows you to see all sections of courses, within a Department and all Teachers 
assigned to a Department, depending on the filters chosen.  

1. At the top of the page, click the Course filter drop-down to filter the courses that appear 

in the grid by Department, Grade level, or Snapshot. Each time you select a different 

value in a field, the page refreshes to display the appropriate courses in the grid. 

 

2. Click the Teacher filter drop-down to filter the teachers that appear in the grid by 

Department, Grade level, or Snapshot. Each time you select a different value in a field, 

the page refreshes to display the appropriate teachers in the grid. 

 

3. The Select the Class courses only checkbox should be checked when using the 

Course filter set to Grade in order to omit any courses with a master type of Package. 

4. Select the Courses with sections only checkbox to display only courses with at least 

one section defined. 
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For each course (displayed in columns), the page displays the number of sections defined. At 
the bottom of each column, the page keeps a tally of how many of those sections are assigned 
and unassigned. 

Staff members in the department appear in rows. Next to each staff member’s name, the total 
number of sections for all courses assigned to the teacher appears. 

 

In each cell of the grid, click into the cell and enter the number of sections of the course you 
want to assign to a teacher. 

 

1. Sections offered shows the number of sections created for each course. 

2. Shows the number of sections assigned to each teacher.   

3. Shows the total number of sections assigned 

4. Shows the total number of sections that still need to be assigned to a teacher. There 

are still 4 sections of MGEO-12, 3 sections of MSS--10IB and 1 section of MSS--

10IBINC, that need to be assigned to teachers. 

5. Once sections are assigned, click Save. 

  

Note: This number is not just the number of sections that currently appear on the page based 
on the filters you define.  It shows all sections that have been assigned to this teacher. 
Classes groupings of courses for teachers must be considered when reviewing the totals 
displayed. 
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Going back to the Workspace, we can now see that these sections have the teachers 
assigned: 

 

 

  

Note: It is a school scheduler’s choice if they want to assign teachers to sections prior to 
Building the schedule or after it is built.  Often, if there is a teacher constraint, the teacher will 
be applied to a section prior to Building, for those section(s) that the teacher teaches.  For 
sections that do not have a teacher constraint, no teacher need be assigned prior to Building. 
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5.0 Validate for Build 

The validate process checks to ensure all required scheduling attributes are set up.  If any are 
missing you cannot run the Build process. 

5.1 Process for Running – Validation 

From the Workspace top tab > Master/Sections side tab: 

1. Click Options > Build > Validate: 

 

2. The Validate Schedule pop up window appears, click OK.  The Operation in progress 

status will appear: 

 

3. Once complete a Pink Message will appear indicating there are Fatal errors. Most 

schools will encounter errors; this is just part of the process. If no Fatal errors are 

encountered, a Green Message will appear indicating No Fatal errors. 
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5.2 Resolving Fatal Validation Errors 

Once Build Validation is complete, the errors and information about them can be found on the 
Feedback side tab: 

 

Click on the link Fatal for details of all errors: 

 

 

The Messages are very accurate and should be read; they provide very detailed information. 

To resolve an error click on the  button. This will take you to a screen where the 
problem exists.   

  



 

Workplace and Build Validation v1.6 Page 18 

5.3 Examples of Fatal Validation errors 

5.3.1 Field Course > sections must be greater than 0 (record: A2DP-12, 0, value: 
0).  

Clicking the  button will take you to a popup window displaying the Course > Details for 
A2DP-12.  You can see the Sections scheduled = 0: with this value set to zero, no sections 
were created, during the initialization process; yet the Include in Scheduling box was checked – 
this is inconsistent if you are going to Include the section in scheduling you need to create at 
least one section.  

 

There are three ways this could be corrected: 

• If you are not offering the course uncheck Include in scheduling or; 

• If you are offering the course, update the Sections scheduled value and then from the 

Workspace re-Initialize for only this course or; 

• If you are offering the course, update the Sections scheduled value and then from the 

Workspace manually add the required sections. 

 

5.3.2 Field Course > enrollmentMax must be greater than 0 (record: A2DP-12, 0, 
value: 0) 

 
Depending on how the sections were added, in the first error, this needs to be 

greater than zero and the section(s) created must have enrollment max greater than 

zero. 
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5.3.3  Field Course > baseTermNumber must be greater than 0 (record: A2DP-12, 
0, value: 0) 

 
This error can be corrected by entering the correct number of Base terms per year. 

 

  

Note:  There are multiple errors for the same course A2DP-12.  All of these errors, can 
be fixed at the same time.  Then re-run the Build Validation process again. 
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5.3.4 Field Room > maxCapacity must be greater than 0 (record: 113, , value: 0) 

 
 

5.3.5 Field Teacher > maxInARow must be greater than 0 (record: Carrbriant, 
Eqsusanbrian, , value: 0) 

Even though the Build engine will not schedule Teachers, the Max in a row for every Teacher 
that has Include in scheduling checked – must have this value set greater than zero. 

 

 

Once all Fatal errors have been corrected, re-run the Build Validation process.  This is an 
iterative process that needs to be completed until ALL Fatal errors are corrected. 
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6.0 Build 

6.1 Building the Master Schedule 

When you build your master schedule, the system attempts to fill in the Term, Schedule 
(Day/Period) and Room for each of the sections you have prepared on the Workspace, while 
abiding by the scheduling attributes and rules defined. 

 

6.1.1 Steps to run the Build: 

1. From the Workspace click Options > Build > Build 

2. The Build Schedule dialogue box opens: 

 

3. Select the Maintain scheduled sections checkbox if you want to keep any previously 

scheduled sections as they are. 

4. At the Room assignment mode field, select one of the following: 

• Assign valid room only: The scheduler assigns a room to a section only if it obeys all 

constraints. The build stops if a room cannot be found that respects all constraints. 

• Assign best available room: When a valid room cannot be found for a section, the 

scheduler assigns a room based on the list of constraints that are set to be relaxed. 

The build stops if a room cannot be found after easing constraints. 

• Assign blank if no room available: The scheduler schedules the sections even if a 

room cannot be assigned. 

 

5. If you have defined specific courses as courses a teacher is qualified to teach on the 

Staff tab, Assignments side-tab, the Dynamic teacher assignment mode field appears. 

Select one of the following to determine how you want Aspen to schedule such courses: 
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• Leave blank if no teacher available: If the scheduling engine cannot schedule a 

qualified teacher for a section of a course, it leaves the staff member assigned to 

the section blank and continues the build process. For example, if several teachers 

have a course with six sections identified as something they are qualified to teach 

on their Assignments side-tab, and the engine cannot schedule a qualified teacher 

for two of those sections, it schedules the four sections it can, leaves the staff name 

blank for the two it cannot, and continues to build. 

• Assign available teacher only: If the scheduling engine cannot schedule an 

available, qualified teacher for a section of a course, the build stops. 

• Do not attempt: Aspen does not reference courses on the Assignments side-tab on 

the Staff tab. 

6. Only select the Save build files checkbox if you are have been directed to.  The 

information generated in this file can be used by the application developers to 

troubleshoot serious errors.  Most schools do not have to select this checkbox during 

the build process. 

7. Click OK to start the build 

How the Build engine proceeds 

The application will calculate a System Rank, prior to beginning the Build.  This is the order in 
which it will schedule sections.   

 

1.  The System Rank column; 

2.  These sections were Pre-Scheduled and therefore were not calculated into the rank; 

3.  Shows the order sections will be scheduled. 
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Once started, a progress window will open indicating the progress the builder is making through 
scheduling all sections in the Workspace. 

It is important to take note of the progress window.  You should see the follow: 

 

          

• If the progress window does not ever show a course section i.e. the number 

• Of where it is at. 

• chances are it never started 

• THERE IS A PROBLEM WITH YOUR PATTERN SETUP (see section 5.2 Resolving 

Fatal Build errors) 

The build might reach a section that it cannot schedule due to conflicts with previously 
scheduled sections.  When this happens, the system attempts to reschedule previously 
scheduled sections to make room for the current section.  If the system still cannot schedule the 
section after the repair attempts, the build will stop at that point and generates a Fatal error: 

 

Note:  This value is calculated based on the applications defined scheduling algorithm.  It 
can be adjusted by going into the Details of a section and entering a new value in the User 
rank adjustment field 
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Fatal errors during the Build tend to be more complicated to resolve than Validation errors.  
These therefore often require much more thorough investigation. 
 
The following is a suggested process. 
 
 
It is important to go through all the available information, collect what is provided and then begin 
the investigation. 
 

1. Fix button from the Feedback area is one piece of information. 

2. Click the Analysis side tab and then each sub side leaf (Section, Teacher, Room, 

Pattern): 

 
3. Within each of these there will be sub top tabs (e.g. Section has – Attributes, Course, 

Course Section and Course Rules): 
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4. Go through all of the information to determine the error. 

 
 
 
If you never see the Progress window display course sections, as mentioned above, and the 
window disappears almost immediately, it indicates the process never started.  This is usually 
caused by errors with the Patterns and/or Structure (Days, Periods) of the Scenario. 
 
See how no sections are listed as progressing 

 
 
 
It can be further determined that nothing started by checking the Workspace and sorting by 
System rank: 
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No way to determine if it is an issue with the Patterns and/or Structure, is to run the Build 
Readiness Checklist report: 

• Scenario tt > Details > Reports > Build Readiness Checklist. 

• Number 8 on this list indicates: 

 
There are no Patterns matching the structure (in this example the number of Periods was 
changed AFTER patterns were created. 
 
You can see this scenario has 8 Periods: 
 

 
 
When you look at the Patterns, they were only built with 7: 
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To correct this, either rebuild patterns, re-add to Pattern Sets, re-add to Pattern Sets to Courses 
or change the number of Periods back to a value that matches the Patterns. 
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6.2 Resolving Fatal Build errors 

The process for resolving Build errors follows the same steps as correcting validation errors.  
Click on the word Fatal and the details of all errors open: 

 

Build errors are often more complicated to resolve than Validation errors and will require a more 
complete analysis of all the scheduling attributes and rules used in this scenario. 

 

You can also click the Rules leaf on the Workspace, Details side-tab to view any rules 
associated with this section. The rules are the restrictions that you place on a section and might 
be the reason the system is having trouble scheduling the section. 

Then you build the schedule again, and the system stops at another section it is having trouble 
scheduling. Fix that problem and build again. Each time you build the schedule you have the 
option of locking the sections that are already scheduled, or unlocking them to be rescheduled. 

You might want to save the Workspace as it is but continue to build the scenario. To do so, copy 
the scenario and rebuild the new copy. 

When the system builds a schedule you are happy with, you can load students into the schedule 
(covered in the next learning event) to maximize section balances and requests satisfied. 

 


