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1.0 Overview 

1.1 What is PEN? 

The Personal Education Number (PEN) is a unique nine-digit number assigned to each student 
enrolled or registered with any; B.C. Early Learning (Strong Start program), Public or 
Independent school, B.C. Certified Offshore School, Yukon School, or public Post-Secondary 
Institution by the Ministry. 

The student’s original PEN record is assigned the first time the student is registered by any B.C 
or Yukon school. This could be by a StrongStart Centre, Elementary School or even a student 
entering a Public Post-Secondary Institution that never attended a B.C. K-12 school. This 
number stays with the student, for their entire career in the Pre K-12 education system in B.C. 

Follow the registration guidelines outlined in the MYEDBC Enrollment and Demographics 
documentation on the MyEducationbc.info site and the Standards Manual that can be found on 
the L1 Information and MyEducationbc.info site 

1.2 PEN Assignment 

Users have no ability to enter a Student PEN in MYEBC.  

PEN assignment occurs as follows: 

• After Registration is completed in MYEDBC, an automatic process for students without a 
PEN runs. Those students who need A PEN are automatically submitted to the Ministry’s 
PEN system each night for processing. 

• A PEN is automatically assigned to the student, or a PEN error is generated and sent to 
the school district’s PEN contact. 

Note: This process does NOT need the PEN Contact Add-On Role 
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2.0 Real Time PEN Processes 

The following procedures and reports have been implemented to give users the ability to 
request real time PEN information from the Ministry PEN Registry.  

2.1 PEN Contact and PEN Contact Add-On Role  

The PEN Contact person listed on the PEN Request Report and the PEN Validation Report is 
the School or District level contact who is registered with the Ministry as the person who 
receives the PEN Activity Report.  This is the School or District PEN Contact person determined 
by your district process. 

The security role, PEN Contact Add-On, must be added to any MyEducation BC user’s 
account to run the Request Student PEN and the Validate Student PEN and Demographic 
Data Procedures but is not needed to run the reports.  The PEN Contact Add-On role is not 
needed for the automatic nightly PEN retrieval process. 
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2.2 Parts of the Real Time Pen Processes 

This document describes two procedures used to retrieve information from the Ministry PEN 
Registry and update student records. There are also two reports that can be run to provide 
output to the user after the procedures have been run. 

2.2.1 Procedure 1 

Note: These procedures require the user to have the PEN Contact Add-On role 

 
The Request Student PEN Procedure must be run prior to the PEN Request Report. 
 

2.2.2 Procedure 2 

Note: These procedures require the user to have the PEN Contact Add-On role 

 
The Validate Student PEN and Demographic Data Procedure must be run prior to the PEN 
Validation Report. 
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2.3 Request Student PEN Procedure 

School View > Student top tab > Options > Request Student PEN 

The Request Student PEN procedure allows a school to instantly request a missing PEN for a 
student.  The PEN field will be populated automatically when the request is submitted.  

Run this procedure prior to running the PEN Request Report (Step 2). 

This functionality is in addition to the automatic procedure that runs each night for all schools in 
the province that updates missing PENs and identifies potential duplicates for all schools 
province wide.  

Note - Ensure you are in the MyEducation BC Production environment (not SDTest) prior to 
running the Request Student PEN procedure. 

Scenario: There is a missing PEN for several student records, and you want to request a PEN 
immediately, outside of the automatic, overnight procedure. 

 

 

Select the students you want to retrieve a PEN for:  Options > Show Selected 
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Run the Request Student PEN procedure: 

School View > Student top tab > Options > Request Student PEN 

 

 

The Student PEN is immediately populated in the student record. 
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Other messages that might be received with the Request Student PEN procedure: 

 

 

• Student record is not updated with a PEN (1, 2, 4, and 5) 

• validation errors (summarized in Appendix A)   

• Student record already has PEN (3 and 7) 

• PENs have already been assigned 

• Multiple potential matches found. PEN for student records will need to be updated as 
part of nightly batch processing (6 and 8)  

o the one-off PEN request process provides an immediate response so there is no 

opportunity for any human intervention on the PEN side 

o the nightly batch process will pick up the student and submit it via the batch 

process which allows it to go into a queue in the PEN Registry 

o the Ministry PEN coordinator will look at the multiple matches and determine 

which is the correct one to send back to the requesting school 
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2.4 PEN Request Report  

This report should be run after the Request Student PEN Procedure. Reports are updated by 
the Procedure. 

Note: The reports do NOT need the PEN Contact Add-On Role 

The PEN Request Report summarizes the status and results of the PEN Requests submitted to 
the PEN Registry using the PEN Request Procedure, provides information about each student 
record that was submitted, and outlines details on both the successful and failed PEN 
assignments.   

 

 

District View > Student top tab > Reports > PEN Request Report 

When running this report from the District View, you have the option of choosing a single school, 
multiple schools, or all schools. 

School View > Student top tab > Reports > PEN Request Report 

When running this report from the School View, the report will default to the current school. 

 

 

The report will display the following sections: 

• New PEN assigned to students 

• PEN cannot be assigned – It is already assigned to another student 

• PEN cannot be assigned – Pupil number does not exist 

• PEN request received validation errors 

• PEN request received no response 
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2.4.1 New PEN assigned to students 

If a student registration meets all validation requirements, a PEN will be assigned to the student 
record and the following message will display in the report: 
 

 

 

2.4.2 PEN cannot be assigned – It is already assigned to another student 

 

In this case the student was not assigned a PEN: 

1) A student was registered in MyEducation BC with Pupil # 2599684  

2) There is a suspected duplicate student record with Pupil # 1278977  

3) The duplicate student record is at Cougar Canyon Elem.   Contact the Conflicting School 
to resolve the issue. 

4) If “Is Archived” = Y, the duplicate student record exists in the Archive and the process for 
retrieving the student from the student archive should be followed. (Refer to the 
Enrollment and Demographics document on the Myeducationbc.info site for information 
on the “Flag for Retrieval” process.    

 

2.4.3 PEN cannot be assigned – Pupil number does not exist 

 

In this case, a duplicate student record was identified and prior to the PEN being applied to the 
MyEducation BC record, the duplicate was deleted.  The system then tried to apply the PEN to 
the student record, but the student registration is missing.  
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2.4.4 PEN request received validation errors 

In this case, several students are registered that should return validation errors from the PEN 
Registry: 

 

 

 

 

Refer to Appendix A and B for a full list of Validation Fields and Error codes.  

2.4.5 PEN request received no response 

The PEN request has not been processed by the PEN registry. The request is still in queue. 
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2.5 Validate Student PEN and Demographic Data Procedure  

The Validate Student PEN and Demographic Data procedure pulls PEN student demographic 
information from the Ministry PEN system and should be run as ‘Step 1 of 2’ before the ‘PEN 
Validation Report’ (Step 2) to ensure you have the most up-to-date student data from the 
Ministry database 

The demographic data that is retrieved from the Ministry PEN system database can then be 
displayed in the PEN Validation Report and compared to what is in MyEducation BC so users 
can update student demographic data as required. 

Run this procedure prior to running the PEN Validation Report (Step 2). 

School View > Student top tab > Options > Validate Student PEN and Demographic Data 
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2.6 PEN Validation Report 

This report should be run after the Validate Student PEN and Demographic Data Procedure to 
ensure you have the most up-to-date student data from the Ministry database.  

The PEN Validation Report displays student demographic data in MyEducation BC that is 
different than what is stored in the Ministry PEN system.  

Differences between MyEducation BC data and the PEN registry data are highlighted with 
BOLD text. 

 

District View > Student top tab > Reports > PEN Validation Report 

School View > Student top tab > Reports > PEN Validation Report 
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Note – If you run this report from the District View for a list of students from multiple schools, 
you must choose “Select All” in the report parameter screen.  
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Appendix A – PEN Request Report Error Codes 

Validation Issue Type Codes: a list of possible validation errors: 

 

Code Description 

1CHARNAME Field consists of just one character 

APOSTROPHE Field contains only an apostrophe character 

BEGININVALID Field begins with one of several special characters 

BLANKFIELD Required field is blank 

BLANKINNAME Field has embedded blanks 

BLOCKEDNAME Field value is on the list of blocked names, that are flagged as an error 

CHKDIG PEN not valid because check digit is invalid 

DOB-INVALID Birthdate is not a valid date 

DOB_PAST Birth date is before 1900 

DOB_FUTURE Birthdate is in the future 

EMBEDDEDMID The middle name is part of the first name 

GENDER_ERR Invalid Gender code 

GRADECD_ERR Invalid Grade code 

INVCHARS Field contains invalid character 

INVPREFIX Field starts with XX or ZZ 

NUMBERNAME The legal given name contains a number 

OLD4GRADE Age is too old for Grade 

ONBLOCKLIST Name matches one of the values on the block list: PEN_NAME_TEXT 

PC_ERR Postal Code is not in the format of a Canadian postal code 

REPEATMID Middle name is a repeat of the First of Last name 

SCHARPREFIX Field starts with an invalid special character 

YOUNG4GRADE Age is too young for Grade 
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Appendix B – Validation Issue Field Codes 

When a student is registered in MyEducation BC and a PEN Request is sent to the PEN 
Registry, the system will perform validation checks on the following list of fields to ensure the 
validity of the data and the student information before assigning a new PEN to a student record. 

 

Code Description 

LOCALID Local identifier used by the school for the student 

SUBMITPEN Value provided by the school as a suggestion for the matching PEN 

LEGALFIRST Legal First Name or Names 

LEGALMID Legal Middle Name or Names 

LEGALLAST Legal Last Name or Names 

USUALFIRST Usual First Name or Names 

USUALMID Usual Middle Name or Names 

USUALLAST Usual Last Name or Names 

POSTALCODE Canadian Postal Code of student, or for offshore schools, postal code of the BC contact 
managing the school 

GRADECODE Code used to indicate the grade-level of the student at the time of the request 

BIRTHDATE Date of birth of the student 

GENDER Gender of the student 

 


