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LEADERSHIP IN LEARNING

1 Course Tallies and Lists with Designations
1.1 Quick Reports

The following Quick Reports are available to assist with looking at class composition:
Course Requests by Course with Designations:

Build View > Global top tab > Requests side tab > Reports > Quick Reports > Saved
Reports > SD36 Course Requests by Course with Desig. > Finish

Class Lists with Designations:

Build View > Workspace top tab > Schedules side tab > Reports > Quick Reports > Saved
Reports > SD36 Class Composition > Finish

Combined Classes Enrollment Totals:

Build View > Workspace top tab > Master side tab > Sections sub side tab > filter: SD36
Sections Combined > Reports > Quick Reports > Saved Reports > SD36 Combined Class
Totals > Finish

1.2 Tallies in Excel

Below are steps to find the number of Low Incidence and Intensive Behaviour requests for each
course in addition to the total number of requests in Excel:

1. Build View > Global top tab > Requests side tab
2. Field set: SD36 SPED Designations
3. Click the printer icon and select CSV

1h

Create Quick Report

Web Page (HTML)

TXT

csv

Microsoft Word (DOC) Choose fields to add to report:
4. Open the file in Excel and apply a filter to the top row (Data > Filter) Name
5. Filter on the Designation column - P

¢ Filter to display low incidence designations of A to G and change ¢

them all to the word “Low”

o Filter to display high incidence designations of K to P and blanks
and change them all to “N/A”

e Leave the H designations as an “H”

e Clear the Filter

AltType

6. Click back into cell A-1 and select Insert > Pivot table e
a. Inthe ‘Create PivotTable’ window leave the settings at the o
default Of: Difg fields betwRen areafjpelow:

i. Select a table or range (your entire table should be
selected automatically)

ii. New Worksheet
b. Click OK
7. Click and drag CrsNo into ROWS, Designation into COLUMNS, and $ows LuEs
Designation into VALUES (becomes Count of Designation), = oo T | Comt of Desig
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8. This will produce the following table which includes counts of H (intensive behavior), Low
(low incidence), N/A (high incidence and no designation), and a Grand Total:
j Count of Dasignation Column Labels ~
4 Row Labels - H Low NfA Grand Total

nnnnnnnnnnn

10. Open a new tab and Paste Values
11. You can now filter, sort, and edit as necessary.

This Excel tally can also be run on Course Sections once you have loaded students into
sections from the Build View > Workspace top tab > Schedules side tab > field set: SD36
SPED Designations

2 Section Enrollment Max

There are two ways that you are able to limit the maximum number of students that can be
scheduled into a section:

1. Reduce the Section enroliment max from the Courses top tab
2. Use the Reserve Seats option. See “Scheduling 4 - Build, Load and Load Analysis”
document, Section 6 for information on this option.

3 Control Inclusion Students

Control Inclusion Students is a Build Scenario Preference that is used to limit the number of
student requests flagged as “Inclusion” that can be loaded into a section e.g. if the Inclusion
count is set to 2, the system will only load a maximum 2 Inclusion Requests in each section.

Note: Unfortunately for combined ‘classes’ groupings, this limit is on each individual section in
the grouping, rather than for the grouping as a whole i.e. for a classes grouping of MAF--11
and MAF--12, if the inclusion count is set to 2, the system will allow 2 inclusion requests in
MAF--11 and 2 in MAF--12 for a total of 4 inclusion requests in the class.

There are three steps to set this up:

1) Setthe Control Inclusion Students preference in the scenario
2) Indicate Student Course Requests as Inclusion
3) Indicate Course Sections as Inclusion sections

ESIS-OFFICE@surreyschools.ca Version 1.2 2
Tel. 604.595.6052 Fax 604.595.6053 Published: 2017-04-07
servicedesk.surreyschools.ca



mailto:ESIS-OFFICE@surreyschools.ca

fSurrey Schools

LEADERSHIP IN LEARNING Scheduling-Class Size and Composition

3.1 Set the Control Inclusion Students Preference

Build View > Scenario top tab > click into the scenario > Preferences side tab > Category:
Scenario-basic

In the Control inclusion students field, use the drop-down arrow to select either:

e By ratio (%) to control the ratio of inclusion requests by a specific percentage of the
class enrollment total. Type the percentage in the field.

e By count to control the number of inclusion requests by specifying the exact number of
inclusion requests the system can schedule in each inclusion section. Type the number
in the field.

To limit the number of Inclusion requests that can be scheduled to 2, you will need to select
‘By count’ and enter the number ‘2’.

Click Save.
Semiahmoo Sec 2017-2018

Build View v A Select School @ Log Off

CLELWEGO Workspace  Courses  Student  Staff  Rooms Rules  Global

Scenarios :: [ LN F B TTUEEE « 4 Q

Details
| o -
Preferences
Category: Scenario-basic v

Terms

T

Schedule expression format Period first v Use content term code
Days

Use numeric section numbers @ Show location )
Periods Use study halls Show house @

Rotations LszmEEiy C Show team £
Use bell schedule 2 Show platoon 2

Bell

Schedules Control inclusion students By count ¥ |2 Show section type @

Include optional requests Use student schedule weight

Use reserve seats 4
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3.2 Indicate Student Course Requests as Inclusion

The flag of inclusion is on the Course Request, not on the student. This means that a student
could have some requests flagged as inclusion and others not.

3.2.1 Set all Low Incidence and Intensive Behaviour Student Requests
1. Build View > Global top tab > Requests side tab >
2. Field set: SD36 SPED Designations
3. Filter: SD36 A-H Designations

Pages Scenario Workspace Courses Student Staff Rooms Rules ol

Requests
Pattem S
Manage Filters. 2
< A SD36 A-H Designations
;dem ‘ = “{  Primary Requests ¢
Name Grade Pu| All Records No SectNo  SchoolCourse > Description
Requests Requests from students not attending .
o7 ADST General Explorations A
Requests v SD35 A-H Designations |
Details 07 == ENGLISH LANGUAGE ARTS &
o7 G MFR-08-8 FREMNCH 8
Batch Entry

o7 G MMA-08-5 MATHEMATICS &

Logs

o7 G MSC-08-5 SCIENCE 8
= | -

This will call up all Requests for students with an A-H Designation so that you are able to
use Mass Update to set these requests to Inclusion.

4. Options > Mass Update > Field: Is inclusion section? > check the Value box > click
Update

e
¥4

Value

5. If you have courses where you do not want to limit the number of Inclusion requests, it
is recommended that you uncheck Is inclusion section for those requests using either
Modify List, Mass Update, or updating individual student course requests.

Note: If you have any courses that should not have the number of Inclusion Requests
limited, you will need to set the Course Requests for those courses back to not inclusion.
You can use Filter Requests and Mass Update as outlined in the next section.

It may be advisable to re-run this process before each load to ensure that your Inclusion
Requests are up to date.
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3.2.2 Modify List and Mass Update Inclusion Flag

You can use modify list or mass update to update the Inclusion flag on student requests from
either:

Global top tab > Requests side tab or
Courses top tab > select the course > Requests side tab (this option is course by course)

1. Modify List: Check or uncheck the box for the applicable students(s) in the Inclusion?
column and click the green check box to Save before navigating to the next page.

Requests
Pattern
Library c e H =
Sets - N - Inclusion? TermCode  SecT
[] Name Grade Designation Homeroom  SchoolCourse>CrsNo  SectNo  SchoolCourse > Description OldDesignation =, o0 ’ ,
Requests
O 02 R 7 MEN-09-A-JAZZ ENGLISH 0 (JAZZ BAND 9) ]
Requests g
D‘:hﬂs O 08 R 7 MEN-09-8 ENGLISH 9
0 08 R 7 MFR-10-8 FRENGH 10 [}
Batch Entry -
0 08 R 37 MMA-08-8 MATHEMATICS @ ( )
Logs O 08 R 37 MMU~09--A-CONCERT CONGERT BAND 9 (PES) 0

2. Mass Update:
a. Select the students(s) you wish to mass update > Options > Show Selected or
Use the > Options > Filter Requests to query for the requests to update
b. Options > Mass Update > Field: Is inclusion section? > check or uncheck the
Value box > click Update

Field Is inclusion secfion?

Value

The request(s) set as Inclusion will have a “Y” under the Inclusion? Column:

Pages Scenario Workspace Courses = Student Staff Rooms Rules e[t

Requests

Pattern
(i ‘ e - T = =
SL

Pattern ‘ < [ vi[=] 0 0f 765 selected (7
Sets
O Name a Grade  Designation Homeroom SchoolCourse > CrsNo SectNo SchoolCourse > Description OldDesignation Inclusion?  TermCc
Requests
O o8 R i MEN—09-A-JAZZ ENGLISH 9 (JAZZ BAND 9) N
Requests B
Detsile O 08 R a7 MEN-D3--8 ENGLISH 9 Cvy D
O 08 R i MFR--10-5 FRENCH 10 N
Batch Entry -
O 03 33 7 MMA-08-8 MATHEMATICS 9 ( Y >
Logs O 08 R a7 MMU—03--A-CONCERTS CONCERT BAND § (PEG) N
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3.2.3 Individual Students Requests
Individual student requests can be flagged as Inclusion from either:

School View > Student top tab > select the student > Schedule side tab > Requests sub side
tab > click into the Details of course request or

Build View > select a scenario > Student top tab > select the student > Requests side tab >
click into the Details of course request

Build View > select a scenario > Global top tab > Requests side tab > click into the Details of
the course request

1. Check the Is inclusion section? Box

Semiahmoo Sec 2017-2018
05 - First Build and | oad - Fri. March 10

Pages Scenaric Workspace Courses

Students :: - = :: MEN--09—-8 /&
Details ‘
Requests
- s Save X Cancel
Schedule T
Chool ourse =

Sl e a—
Schools ‘

Section type
Transcript ‘ ( s inclusion section? [ ,

2. Click Save

4 Course Section - Is Inclusion Section

Sections will need to be set as “Is Inclusion Section?” in order for requests flagged as Inclusion
to be scheduled into the section. If you do not have this set, no requests set as Inclusion will be
able to be scheduled into the section.

Note: This step can only be completed once you have the course sections initialized in the
Workspace.

Build View > Workspace top tab
You are able to Mass Update the course sections:

Options > Mass Update > Field: select Is inclusion section? > Value: check the box > Click
Update

Field [Is inclusion section?  w

Value [

e
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The sections set as Inclusion will have a “Y” in the Inclusion? Column:

Pages Scenario VLI E-ELIM Courses  Student ' Staff ' Rooms  Rules ' Global

Sections
Master "
Sections
Details < [1MAC-11-5-01 V=] 007412 selected (7
Roster =
Teachers ] Course SecNo ScheduleTerm > Code Unrotated Schedule Team Schedule PrimaryStaff > Name  PrimaryRoom > Num { Inclusinn?) Total Max SecT
Rules
O MAC—11-5-01 0 Y 1] 30
Classes
O MACC-12-5-01 01 Y o 30
Class Size [0 MADGEDS-S-01 01 v D =
Summary
O MADIT08-5-01 01 Y o 30
Matrix View
O MADPT08-5-01 0 A 1] 24
Assignments | [0 MAE-09-5-01 01 Y 0 30

5 Course Tally Report

Once student course requests are flagged as Inclusion, they will display on your Course Tally
Report if you select the “Show inclusion counts” box prior to running the report:

Course Tally

Courses to include Current selection v

Search value

Scheduled students only

Show inclusion counts i

Show calculated secfion counts

Sort results by

Format [Adobe Acrobat (PDF) v

D K

The Course Tally report will indicate the number of requests flagged as inclusion in brackets
next to the total count e.g. in the example below MBI--11--S has 120 total requests, 8 of which
are flagged as Inclusion:

Surre) Semiahmoo Sec
Y Course Tally
Page 1 2017-2018 March 30, 2017
Enroliment Section
Number | Description Department Lvl Primary | Alternate Total Max Count
MAC—11- | ACCOUNTING 11 Business Education Regular 23 (0) 6(0) 29 (0) 30 077
-5
MACC- ACCOUNTING 12 Business Education Regular 14 (0) 1(0) 15 (0) 30 047
12-S
MADGED | ADST @ - General Explorations | Applied Skills 17 (0) 28(0) 45 (0) 30 057
9-S (Modules)
MADIT09 | ADST - Information and Applied Skills 19 (0) 18 (0) 37(0) 30 063
—S Communications Technologies
MADPTO | ADST - Power Technology Applied Skills 17 (0) 16 (0) 33 (0) 24 071
9-S
MAE--09- | ARTS EDUCATICON 9 Fine Arts 68 (0) 57 (0) 125 (0) 30 227
-S
MAF—11- | ART FOUNDATIONS 11 Fine Arts Regular 28 (0) 5(0) 33 (0) 30 093
S
MAF--12- | ART FOUNDATIONS 12 Fine Arts Regular 30 (0) 6(0) 36 (0) 30 10
-S
MAT—11- | AUTOMOTIVE LEVEL 1 Technology Education | Regular 16 (0) 9(0) 25(0) 24 067
-S
MAT—12- | AUTOMOTIVE LEVEL 2 Technology Education | Regular 16 (0) 2(0) 18 (0) 24 067
-8
MAWM- | APPRENTICESHIP & Mathematics Regular 28 (0) 0(0) 28 (0) 30 093
10--S WORKPLACE MATH 10
MAWM- | APPRENTICESHIP & Mathematics Regular 14(0) 0(0) 14.(0) 30 047
11-S WORKPLACE MATH 11
MBI-11- | BIOLOGY 11 Science Regular 116 (8) 4(0) 120 (8) 30 387
S
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