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Version History

Version | Date Description

5.0 Jul 2015 Added Commit the Master Schedule section.
Updated Fees, and Transportation sections.
Updates to the School Preferences > Schedule category for future add/drops.

5.1 Sep 2015 Updated information on grade terms and schedule terms with new K-12 functionality.
Updated references to conversion schools.

5.2 Aug 2016 Removed section 14 Transportation. Removed references to conversion and minor
revisions throughout.

6.0 Aug 2017 Clarified section 2.11 School Preferences: Family/Student Portal Averages and overall

cumulative average; and section 7.5 Mass Updating Comment Bank Category Fields:
Category 1 can be replaced with ALL; added School Preferences: Active date enabled by
setting; reformatting and updates throughout for release 5.6/5.7
6.1 Dec 2017 | Updated Section 2.7 School Preferences — Scheduling.
e Student Schedule Workspace: Master select fields
Added Appendix A — Master select fields - how to control columns displayed on the pop-
up window within the student schedule workspace.
6.2 Jun 2018 Updated Section 2.7 School Preferences — Scheduling.
e Student Schedules

o  Student schedule sort order

How to control the order in which course sections are displayed.

6.3 Dec 2018 | Updated Section 2.7 School Preferences — Scheduling.
Hide from attendance, updated 8.7.1 Assigning Homerooms to multiple teachers, 8.7.2
Assigning Homerooms to multiple students

6.4 Jan 2019 Release 5.9 updates to section 2.7
6.5 May 2019 | Added hyperlinks to Table of Contents
6.6 Jul 2019 Release 5.10 updates to section 2.1 School Preferences — Daily attendance
6.7 Oct 2019 Section 1.1, page 6 Update for Student Portfolios release
6.8 Oct 2019 Updated section 6 — Reference Codes
6.9 May 2020 | Updated School Details screenshot and details to include Max days per page setting used
in student schedule reports
7.0 Aug 2020 | Release 6.1
7.1 Sep2020 Updated Section 1.1 Define School Details.
7.2 Jul 2021 Section 8.1 Staff — Usual Frist and Last Name Fields
7.3 Jul 2021 6.3 Upgrade
Added Section 7.7 Text Comment Length Override
7.4 Dec 2021 | School Setup Details — Email address field and functionality
Added the Appendix for the Miscellaneous fields
7.5 Sep 2022 | Added Address Catchment Enforced to School Setup Details
Section 7 — Updated Comment Bank Language to Variables (not tokens)
7.6 May 2023 | Updated section 1.1 screenshots to reflect DOLS functionality
7.7 Jul 2023 Transcript Definitions — 2023 Reporting Order
Display Comment Column
7.8 Aug 2023 6.6 Screenshots
7.9 May 2024 | Update screen captures; Add Quick Status / Day Number information; 2023 Reporting
Order, Add Co-teacher to multiple course sections -
8.0 Aug 2024 Updated screenshots and new 6.7 Release information
Confidentiality
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1.0 School Details

1.1 Define School Details

School view > School top tab > Setup side tab > Details > General

School Name fields should not be prefaced with the school district number as users with

access to multiple schools will lose the ability to easily search for a school by name in Change
View > Select School.

Pages

Setup

Setup
» Details
Preferences

Guided
Tasks

Online
Registration

Schedules

Calendars

Events

Lockers

Membership

Journals

Cashier's
Office

Ed. Plans

Grid Codes

UGG Student  Staff  Attendance

School Setup :: NorKam Senior Secondary

Lo Lo Yoo

i

School Identifier

Name *

Type

School level

District Online Leaming School @
Start grade

Number of grades

Build Year Context > School year

Default Transcript Definition > Name [)d Term 10-12 2023 English %-LG

School Sub Type
Phone 1
Phone 2

Fax Number

Online
Registration

7324044

NorKam Senior Secondary

Conduct

Standard v

Secondary
(@]
9

8

2024 QX

v

Schedule

Jax

Regular Day School v

250-974-4942

Principal

Vice Principal
Vice Principal 2
Vice Principal 3
Vice Principal 4
Is inactive?

Is archive?

Extracurriculars

Global Tools Admin

Caesar, Jock
Semenye, Phongsathon

Spiteri, Lanceritchie

0

N

Class to Daily Attendance Procedure?

%

BC Default Template

Q3
Q3
Q.

Also change the category field on top right side to “All Fields” to see additional fields that need
to be completed.

School Setup v8.0

Page 5



BRITISH

COLUMBIA MYEdUC&tiOﬂ

[e®)
FUJITSU

Pages Staff Attendance Conduct Grades Assessment

School Setup :: NorKam Senior Secondary

lsety
| encmen

Setup
» Details
Auto-saved at 9:17 AM
Preferences
Guided School Identifier 7324044
Tasks
Name * n NorKam Senior Secondary
Online Type Standard ~
Registration
School level Secondary v
Schedules
Is inactive? O
Callstls Follett customer ID
Events Is archive? N
Start grade 9
Lockers
Number of grades 8
Membership
ShortName NSS
Journals Class to Daily Attendance Procedure?
Cashier's Conversion Status PROD
Office
school hide 0
Ed. Plans Active directory group name
Grid Codes State identifier
Disable waiting list indicator O
Groups
Transcript Definition 1D

Schedule

Extracurriculars

Global

Tools

Admin

All fields

School Zone
Superintendant Dr. Rhonda Nixon
Local School Number 2739
School Sub Type Regular Day School v
Principal > Name Caesar, Jock

Principal > Name: Caesar, Jock

klgrucp@eb15.rm.ci

Principal Email

Vice Principal > Name Semenye, Phongsathon
Administrator 3 > Name Spiteri, Lanceritchie
Administrator 4 > Name

Administrator 5 > Name

School Email norkam-secondary-office@sd73.bc.ca
Organization 2 > Name Kamloops/Thompson

Fax Number

Principal > Work phone 250-509-8516

Principal > Cell phone 250-831-7873

Phone 1 250-974-4942

Phone 2

Fax 250-377-2225

ave Aufo-saved at 9:22 AM

School Setup v8.0
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On the General sub-tab, use the following table to enter information in the fields:

Field

Description

School Identifier

The Ministry code that identifies this school.

Name

Enter the school’s name. This name appears at the top of every page in the
School view and on every report printed in the School view, when logged on
to this school.

School Name fields should not be prefaced with the school district number as
users with access to multiple schools will lose the ability to easily search for a
school by name in the Change View > Select School.

Type

Select the appropriate school type. Most schools will be Standard. School
type determines how some Ministry exports and reports are produced.

School level

Select the school level, such as secondary or elementary.

District Online Learning
School

Check the box is your school is a District Online Learning School (DOLS).
Catchment area boundaries will be enforced for the DOLS if this box is
checked

Is inactive?

Select the checkbox to indicate the school is inactive.

Start Grade

Enter a number to indicate the lowest grade level at the school. For example,
type 9 for a high school that begins with grade 9. Kindergarten is represented
by a 0.

Number of Grades

Enter the number of grade levels taught at the school. For example, type 4
for a high school that teaches grades 9-12.

ShortName

Enter the acronym for the school

Class to Daily
Attendance Procedure?

Check the box if your school will be taking attendance by period and wants
the period attendance calculated to a daily value to populate Daily
attendance. In this scenario, if the office has already recorded a daily record,
the procedure will not overwrite the office entry.

Build Year Context >
Identifier

From the picklist, select the year you want to build a schedule for when using
the Build view.

Default Transcript
Definition > Name

This field is required to pull courses into the school. Enter the Transcript
Definition that will be auto assigned to all courses. Transcript Definitions can
be changed once the course is in the school course catalogue.

School Sub Type

Select the School Sub Type for your school. Most Schools will be Regular
Day School.

Phone 1

Enter the school’s main telephone number. This information will display in the
restrictive query when a match is found for a student belonging to your
school.

School Setup v8.0
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Field Description

Phone 2 Enter the school's secondary telephone number.
Fax Number Enter the school fax number if applicable
School Email

Change the template to “All fields” to see the School Email field. The school
email address must be 50 characters or less. Ensure it is a monitored email
address.

The school email will show in the Registration Wizard, Annual Instructional
Plan, BC Student Information Verification Form, Report Cards 10-12 Multi-
term, and student schedules.

Principal > Name

Select the name of the principal of the school from the pick list. This field
must be populated to Opt-In to Student Portfolios

Note: For administrators that are secondary to the school, this must be
completed by district personnel who have the appropriate role.

Vice Principal 1, 2, 3, 4 >
Name

Select the name(s) of the Vice-Principal(s) of the school from the pick list.

Is archive?

This setting is not relevant to MyEducation BC schools so it is a non-editable
field.

School view > School to

p tab > Setup side tab > Details > Address

Enter the Address of the School and Save

[P Student = Staff = Attendance = Conduct = Grades = Assessment = Schedule = Global = Tools = Admin

School Setup :: Smithers Secondary

Setup

=
Setup
General

Address

Guided
Tasks

Street address @ 7076 Langley St
Schedules
RR Number / PO Box  |PO Box 276
Calendars
Events

Lockers

Membership

Joumnals

Cashier's
Office

Ed. Plans

Grid Codes

Groups

City Prov PC [0 wite House BC vez 218

BC Default Template

(S5}

School Setup v8.0
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2.0 School Preferences

School view > School top tab > Setup > Preferences >

The Category drop down defines the configuration areas:

2.1 School Preferences: Daily Attendance

School view > School top tab > Setup > Preferences > Daily Attendance > Basic

These preferences default to the district settings and can be changed at the school level.

Those with * are only found in School view preferences.

Field Default | Additional Notes
Value

Daily Attendance: Checked Checked: Staff view > Attendance will have a Daily side tab.
Show Dalily side (Recommended if Classroom input type is Homeroom)
tab in Staff view Unchecked: Staff view > Attendance will have a Class side tab

only. (Recommended if Classroom input type is Period)
Daily Attendance: Period Homeroom: choose homeroom if Staff view posting of
Classroom input homeroom attendance creates the student Daily attendance
type record

Period: choose period if Staff view posting of class attendance
in a specified period creates the student Daily attendance

record

See the Attendance Management guides for details.
Daily Attendance: If Period is selected above, identify the period attendance
Classroom input posting that will create a daily attendance value for a student.
period
General Settings: 90 The days of attendance history shown in the Recent Attendance
Recent attendance filter. School View > Attendance top tab > Daily History side
history cut-off tab > filter Recent Attendance.
(days)

School Setup v8.0 Page 9
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Buttons (Daily):
Number of buttons

i MyEducation
Field Default | Additional Notes
Value
General Settings: * | Unchecked | If Homeroom Daily Attendance is selected in Classroom
Allow daily Input Type:
attendance for past Checked: teachers can enter and post or edit a previous Daily
dates attendance value.
Unchecked: teachers cannot enter or edit a previous Daily
attendance record. Required changes must be done through
the office.
General Settings: * 10 If Allow daily attendance for past dates is checked, enter the
Previous day limit number of days a teacher can go back and post attendance.
General Settings Un- Checked: School View> Attendance> Daily Roster> Post
Post from school Checked | Button
daily roster (Recommended if the school user want to post the attendance
from Daily Roster). This option overrides the district preference
of posting attendance from Daily Roster
Un-Checked: School View> Attendance> Daily Roster>
Save Button
(Recommended if the school user don’t want to post and just
want to save the attendance from Daily Roster)
Daily Roster Input 3 Enter the number of buttons available in School > Attendance >
Buttons: Number of Daily Roster
buttons
Daily Roster Input Select the Attendance Code for each button used
Buttons: Buttons 1-
5 Code
Daily Roster Input Checked: pop-up window appears for users to enter details on
Buttons: Buttons 1- the entry (reason, portion of time absent, excused, etc.).
5 Pop-up Unchecked: users will only have the button without the popup
Checkbox for additional details
Daily Office Input 3 Enter the number of buttons available in School > Attendance >
Buttons: Number of Daily Office
Buttons
Daily Office Input Select the Attendance Code for each button used
Buttons: Button 1-5
Daily Office Input Checked: pop-up window appears for users to enter details on
Buttons: Button 1-5 the entry (reason, portion of time absent, excused, etc.).
Pop-up Checkbox Unchecked: users will only have the button without the popup
for additional details
Staff View Input 2 Enter the number of buttons available in Staff > Attendance >

Daily side tab (must have Show daily side tab in Staff view
checked)

Staff View Input
Buttons (Daily):
Button 1-5

Select the Attendance Code for each button used

School Setup v8.0
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Field

Default
Value

Additional Notes

Staff View Input
Buttons (Daily):
Button 1-5 Pop-up
Checkbox

Checked: pop-up window appears for Staff view users to enter
details on the entry (reason, portion of time absent, excused,
etc.).

Unchecked: users will only have the button without the popup
for additional details

School view > School top tab > Setup > Preferences > Daily Attendance > Advanced

Field Default Comment
Value
Weekend Unchecked | Checked: allows for school setup to take attendance on
Attendance: Saturday
Saturday
attendance
Weekend Unchecked | Checked: allows for school setup to take attendance on
Attendance: Sunday
Sunday attendance
*Second Daily Unchecked | Checked: allows a second Daily attendance to be recorded.
Attendance: Unchecked: does not allow another Daily attendance record to
Second daily be created.
attendance
*Second Daily Enter the value you want the AM attendance record to be
Attendance: calculated at. For example, if being absent in the morning
AM portion absent counts as a half-day absent, this value would be .5.
*Second Daily Homeroom: choose Homeroom if Staff view posting of
Attendance: homeroom attendance creates a student daily attendance
Classroom input record
type Period: choose Period if Staff view posting of class attendance
in a specified period creates a student daily attendance record
*Second Daily If you have selected Period as your Class input type for Second
Attendance: Daily Attendance, select the period that will create the second
Classroom input portion of the student daily attendance record
period
*Second Daily Unchecked | Enable this field to push daily attendance for AM and/or PM to
Attendance: the respective class attendance periods from the Class
Push AM/PM from Attendance Office Input page. When this and the Second daily
Class office attendance preference are enabled, a new column, Daily
Code (PM), appears on the Class Attendance Office Input
page (School view, Attendance > Class Office).
Attendance Activity | Unchecked | This functionality is not used in BC
Tracking

School Setup v8.0
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Field Default Comment
Value
Restrict [Edit] link Unchecked If District Preferences allow, Schools will have the ability to edit

in staff view

Note: setting
applies to both
Daily and Class
Attendance

this field and determine the preference.

Checked: The [edit] link in Staff view changes to [view], Staff
can read the entry and changes are made in the office

Unchecked: Staff can change the entry through the [edit] link

2.2 School Preferences: Class Attendance

School view > School top tab > Setup > Preferences > Class Attendance > Basic

Field

Default
Value

Comment

Post Mode

Post

Post: Staff view Class Attendance can be posted to the student
Class Attendance record multiple times on a given day.

No Post: Staff view Class Attendance is saved in the Staff view
but not posted from Staff view to the student Class Attendance
record.

Post Once: Staff view Class Attendance may be posted one
time on a given day, after the initial posting, changes to class
attendance are made in the school office view.

Allow date change

Unchecked

Checked: Enables a date field in the top right of Staff >
Attendance > Class to allow teachers change the date and
enter attendance for past dates.

Unchecked: Date cannot be changed in Staff > Attendance >
Class. Class attendance for past dates is entered in the school
office view.

Track class
attendance by
period

Unchecked

Checked: attendance is taken for both periods of a double-
block class.

Unchecked: attendance can only be taken once for a double-
block class.

This setting functions with a schedule that is rotated in the
Build View.

Display comment
column

Unchecked

Checked: Comment column will appear in Staff View.
Teachers can enter comments directly on Class
Attendance input page

Staff View Negative
Attendance Input
Buttons: number of
buttons

Enter the number of buttons available in Staff > Attendance >
Class

School Setup v8.0
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Attendance Input
Buttons — Number
of buttons

i MyEducation
Field Default | Comment
Value
Staff View Negative Select the Attendance Code for each button used
Attendance Input
Buttons (Staff view
Class): Button 1-5
Staff View Negative Checked: pop-up window appears for Staff view users to enter
Attendance Input details on the entry (reason, portion of time absent, excused,
Buttons (Staff view etc.).
Class): Button 1-5 Unchecked: users will only have the button without the popup
Pop-up Checkbox for additional details
School View 3 Number of buttons to appear if the school is using
Negative Negative Class Attendance.

School View
Negative
Attendance Input
Buttons: Button 1-5

Select the Attendance Code for each button used

School View
Negative
Attendance Input
Buttons: Button 1-5
Pop-up Checkbox

Checked: pop-up window appears for Staff view users to enter
details on the entry (reason, portion of time absent, excused,
etc.).

Unchecked: users will only have the button without the popup
for additional details

School view > School top tab > Setup > Preferences > Class Attendance > Advanced

Field Default | Comment
Value

Positive attendance | Unchecked | Checked: ALL course sections use positive attendance;
students are assumed absent unless they are recorded as
present. (i.e., StrongStart Centres)
Unchecked: the default for course sections is negative or
standard attendance; students are assumed present unless they
are recorded as absent. Individual course sections can be set as
positive attendance.

Positive Attendance Blank Enter the number of buttons available in Staff > Attendance >

Input Buttons: Class

Number of buttons

Positive Attendance Blank Select the Attendance Code for each button used

Input Buttons:
Buttons 1-5

e Positive Attendance Course Sections will have A and P
buttons in In Staff > Attendance > Class by default

e In StrongStart Schools one button must be identified as
POS to allow for the coding required for Ministry reporting.

School Setup v8.0
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Field

Default
Value

Comment

Positive Attendance
Input Buttons (Staff
view Class): Button
1-5 Pop-up
Checkbox

Checked: pop-up window appears for Staff view users to enter
details on the entry (reason, portion of time absent, excused,
etc.).

Unchecked: users will only have the button without the popup
for additional details

2.3 School Preferences:

Conduct

School view > School top tab > Setup > Preferences > Conduct

Field Default | Comment
Value
Detention Blank These fields appear in the Conduct area of MyEducation BC to
Management: track students who have been assigned detentions.
Session 1-3 - Name School view > Conduct top tab > Detentions side tab

2.4 School Preferences:

Staff Attendance

School view > School top tab > Setup > Preferences > Staff Attendance

Button 1

Field Default | Comment

Value
General Settings: Unchecked | Checked: school can assign a TOC for a teacher on Saturday.
Saturday Unchecked: school is not able to assign TOCs on a Saturday.
Attendance
General Settings: Unchecked | Checked: school can assign a TOC for a teacher on Sunday.
Sunday Attendance Unchecked: school is not able to assign TOCs on a Sunday.
General Settings: This is the date that your school went live in MyEducation BC.
Accrual Cutover
date
Input Buttons: 1 This field should not be changed. It is required for TOC
Number of buttons functionality.
Input Buttons: TOC This field should not be changed. It is required for TOC

functionality.

Input Buttons:
Button 2-5

No other buttons should be defined.

2.5 School Preferences: Lunch Counts

School view > School top tab > Setup > Preferences > Lunch Counts

School Setup v8.0
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Field Default
Value

Comment

Take Lunch counts | Unchecked | This optional functionality allows teachers to record the number of
lunches ordered by students when the teacher takes attendance.

Lunch count 01-10

Lunch count buttons 01 through 10 allow the school to define the
type of lunch item being counted. (milk, juice, soup, salad, etc.)

2.6 School Preferences: Grade

School view > School top tab > Setup > Preferences > Grade

These preferences default to the district settings and can be changed at the school level.

Those with * are only found in School view preferences.

Field Default | Comment
Value
Gradebook: 0 Enter the number of days after the start of school before student
Add/Drop ignore Add/Drop notifications display on the Staff view > Pages screen.
window (days)
*Gradebook: Determines what happens to a student’s assignment scores when
Add/drop align the student transfers from one course section to another:
gradebook scores ) . ,
behavior Department: The assignment scores are copied to the student’s
new course if the course’s previous and new department match.
The assignment categories must be the same in both sections. The
total points for both assignments must be the same.
Course number: The assignment scores are copied if the previous
and new course numbers match. The assignment categories must
be the same in both sections. The total points for both assignments
must be the same.
Do not copy: The assignment scores are not copied.
Gradebook: Allow | unchecked | checked: teachers can post grades from the term grade entry
multiple posts by screen to report cards multiple times, if the grade post window set
staff by the school is open.
Unchecked: teachers can post grades from the term grade entry
screen to the report card one time only. After posting changes for
report card grades must be done at the office.
Gradebook: Allow | Unchecked | checked: allows teachers to adjust the weight of term marks for
editing of term calculated transcript definitions.
weights by staff _ .
Unchecked: does not allow teachers to adjust the weight of term
marks.
Gradebook: 1 How many days after the schedule term ends will classes appear in
Current classes the current classes drop-down in Staff > Gradebook > Scores,
day offset

School Setup v8.0
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in gradebook:
Term Average

Field Default | Comment
Value
Gradebook: Active DL/CE schools will use this setting to identify how the Active Date
date enabled by is triggered. See the DL and CE Schools Setup and Processes for
details
Calculations: 0 Type the number of decimal places you want the system to
Decimals calculate for term marks.
Calculations: BC-GRD- | THIS SHOULD NOT BE EDITED AT THE DISTRICT OR SCHOOL
Credit Update 001 LEVEL
Procedure
Calculations: Hide | Unchecked | Checked: Hides the percentage bar from Family/Student view >
assignment score Academics > Assighments > Score column. Recommended for
percentage bar (in Standards Based Schools. Checked is the suggested setting to
Family/Student work with the BC K-9 competency-based curriculum.
view) Unchecked: percentage bar is visible in Family/Student view >
Academics > Assignhments > Score column.
*Averages to show Display category average by term: Staff > Gradebook will display
in gradebook: an average for each category by term
C_ategory average Display category cumulative average: Staff > Gradebook will
display mode display the average for each category regardless of term
*Averages to show | Checked | Checked:term average column displays in Staff > Gradebook >

Averages/All

Unchecked: term average does not display in Staff > Gradebook >
Averages/All. Recommended unchecked for schools using
Standards Based Grading

*Averages to show
in gradebook:
Semester
cumulative
average

Checked: user gradebook preferences will allow an option for
Semester cumulative average column in Staff > Gradebook >
Scores

Unchecked: Semester cumulative average checkbox is not an
option in user gradebook preferences

For use in schools with an even number of grading terms. Average
displayed in this column is the assignment averages (weighted by
gradebook preference) by term for the semester.

*Averages to show
in gradebook:
Overall cumulative
average

Checked: user gradebook preferences will allow an option for
Cumulative average column in Staff > Gradebook > Scores

Unchecked: Cumulative average checkbox is not an option in user
gradebook preferences

Average displayed in this column is the assignment averages
regardless of term, based on user gradebook preferences (Total
Points).

Report Cards:
*Report card
message

The school message that will print on the student report cards.
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calculation options:
Credit mode

Field Default | Comment
Value
Report Cards: Leave this blank.
*Honor roll
qualification list
*Transcript auto- Disable Disable: User will not see any auto-calculation options.

Enable — Checked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes
automatically selected on the student's transcript page. The user
can de-select the box.

Enable — Unchecked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes not
selected on the student's transcript page.

Force: To force the system to auto-calculate a student's credits,
GPA, grades, or rank when you manually change a grade on his or
her transcript. The update checkbox appears on the student's
transcript page, but the user cannot deselect it. This setting is not
recommended.

Student top tab > Transcript side tab > click on a record to see
the detail.

If the school setting is Disable, there will be no check boxes
between the Save button and the course detail.

If the school setting is an Enable choice, the buttons will appear,
with the ability to check or uncheck as defined by the setting the
school has chosen.

The Force setting is not recommended as it interferes with the
ability to add historical transcript records.
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Field

Default
Value

Comment

*Transcript auto-
calculation options:
GPA mode

Disable

Disable: User will not see any auto-calculation options.

Enable — Checked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes
automatically selected on the student's transcript page. The user
can de-select the box.

Enable — Unchecked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes not
selected on the student's transcript page.

Force: To force the system to auto-calculate a student's credits,
GPA, grades, or rank when you manually change a grade on his or
her transcript. The update checkbox appears on the student's
transcript page, but the user cannot deselect it.

Student top tab > Transcript side tab > click on a record to see the
detall

If the school setting is Disable, there will be no check boxes
between the save button and the course detail.

If the school setting is an Enable choice, the buttons will appear,
with the ability to check or uncheck as defined by the setting the
school has chosen.

The Force setting is not recommended as it interferes with the
ability to add historical transcript records.

*Transcript auto-
calculation options:
Rank mode

Disable

Disable: User will not see any auto-calculation options.

Enable — Checked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes
automatically selected on the student's transcript page. The user
can de-select the box.

Enable — Unchecked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes not
selected on the student's transcript page.

Force: To force the system to auto-calculate a student's credits,
GPA, grades, or rank when you manually change a grade on his or
her transcript. The update checkbox appears on the student's
transcript page, but the user cannot deselect it.
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Field Default | Comment
Value
*Transcript auto- Disable Updates the Teacher's Gradebook when this is checked and the
calculation options: update process is run.
Grade mode

Disable: User will not see any auto-calculation options.

Enable — Checked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes
automatically selected on the student's transcript page. The user
can de-select the box.

Enable — Unchecked: To enable auto-calculation of a student's
credits, GPA, grades, or rank when you manually change a grade
on his or her transcript, and to have the update checkboxes not
selected on the student's transcript page.

Force: To force the system to auto-calculate a student's credits,
GPA, grades, or rank when you manually change a grade on his or
her transcript. The update checkbox appears on the student's
transcript page, but the user cannot deselect it.

Grades top tab > Transcript side tab > Details > Options > Update
Gradebooks

The Force setting is not recommended as it interferes with the
ability to add historical transcript records.

*Rank Options: Grade Select Total Points or Grade Point Average depending on how your
Rank type Point school calculates rank.

Average
*Rank Options: Cumulative | seject cumulative points or Current year points only, depending on
Ra';k Calculation whether you are using Cumulative (historic and current), or Current
mode

year only.

If historical courses are not included in calculations, set to Current
Year Only.
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2.7 School Preference: Gradebook

School view > School top tab > Setup > Preferences > Gradebook

This preference is available at the District and School view. Establishing who can edit a
particular setting provides districts and schools the ability to standardize the look and function of
the teacher gradebooks.

Each of the settings below can have the owner set to one of the following dropdowns:

e District — The district controls the setting (available at District only)
e School — The school controls the setting (available at District and School)
e User — The teacher controls the setting (available at District and School)

The settings that are editable on this preference were previously Teacher Gradebook
preferences only.

Changes made to the preferences will NOT affect users that have already set their preferences.
Changes apply to NEW schools and NEW users.

Shade alternate lines v Owner. User -
Track administrator updates v Owner: User -
Add Assignments
Tab direction ACTOSS ~ Owner. User -
Add to all linked classes by default kil Owner. User -
8how studies Owner: User -
Missing Assignments
Enable gradebook features v Owner. User - wmer[User
Show missing column - e
Assignment column order Date due (ascending) Qwner. User - ot . - owner[Ooer
ount empty as missing : -
Show points in headers Owner. User -
’ Show unscored W Owner. User -
Show category names in headers v Owner: User -
Averages
bli it i v Owner: User -
Publish assignment statistics Default weighting Categories only - Owner. User -
Show student alerts v Owner: User - Decimal . owner [Goer
ecimals g -
hle student de Owner: User -
Enable student details Cradaeeale Qx Owner. User - =
Enable student academics Owner: User -
Semester Cumulative average e Owner. User -
bl dent d Owner: User -
Enable student data e N owner:[User -
Show course selection recommendation ¥ Owner: User -
Anchor averages Owner: User -

For each field, review what the default setting will be and indicate who owns the field.

Refer to the Traditional Gradebook reference guide for detailed instructions for each setting.

Field Default Comment
Value

Checked Shades alternate lines in the gradebook for ease of
Owner=User | Viewing.

Shade alternate lines

Track administrator Checked A blue exclamation mark appears next to any grades or
updates Owner=User | comments changed by an administrator.
Tab direction Across Down or Across. Which direction should the cursor go

Owner=User | when the tab key is pressed during grade entry?
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Enable gradebook
features

Field Default Comment
Value

Show studies Unchecked | |nciudes rosters for advisory or study periods - not used in
Owner=User | BC or Yukon at this time.
Checked This MUST be checked or gradebook functions will not

Owner=User

work.

Anchor averages

Assignment column Date Due Ascending displays oldest assignments at left.
order (ascending) | Descending displays most recent assignment at left.
Owner=User | Sequence number displays assignments in sequence
assigned by the teacher.
Show points in headers Unchecked | Displays total points for an assignment in the column
Owner=User | header
Show category names in Checked Displays abbreviated category code in the assignment
header Owner=User | column header.
Publish assignment Checked Pertains to Student/Parent Portal. If checked, displays
statistics Owner=User | highest, lowest, and mean scores next to assignments
viewed in the portal. Often determined at the district level.
Show Student Alerts Checked Displays alert icons next to student names.
Owner=User
Enable student details Unchecked | A information icon 52 next to the student's name in the
Owner=User | scores page provides student contact information.
Enable student Unchecked An information icon next to the student’s name in the
academics _ scores page provides student academic information.
Owner=User
Enable student data Unchecked | An information icon next to the student’s name in the
Owner=User | SCOres page provides student demographic information.
Show course selection Checked Displays recommendation column. Recommendations
recommendation Owner=User pertain to teacher suggestions for course selections in the
- next year. Recommendations can only be made at times
set at the school level. Teachers may want to leave this
box unchecked when not in use.
Unchecked | Displays running average for the marking period in the

Owner=User

column to the right of student’s names.

Add Assignments

by default

Add to all linked classes

Checked

Owner=User

When course sections are linked for categories and
assignments, the add assignment screen will automatically
check the box to add the assignment to all linked classes
on any template where the option exists. Course sections
can be deselected if the assignment should not be added
to that section. Refer to Traditional Gradebook, section
Gradebook: Assignments for details
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Field

Default
Value

Comment

Missing Assignments

Show missing column

Unchecked
Owner=User

If you create special codes that you enter for missing
assignments, select this checkbox to view the Missing
column on the Scores page.

For each student, the Missing column includes
assignments entered using special codes (see section 5.0
Optional Tools below for further information on the use of
special codes).

Note: This column is for the teacher only. Students and
family members do not see it in the portals, and office and
administrative staff members do not see it in the School or
Enterprise views.

Count empty as missing

Unchecked
Owner=User

If you selected the Show missing column checkbox, select
this checkbox to count any assignments that were due
before today and that you have not entered scores for, as
missing.

Note: A Teacher might want to select this checkbox at the
end of a term once all assignment scores are recorded.
Otherwise, the Missing column will include scores for
assignments that have not been graded.

Show unscored

Checked

Owner=User

Only used with courses that have a rubric definition
assigned to it.

Averages

Default weighting

Categories
only

Owner: User

This setting is significant as it sets the default mark
calculation for the gradebook. This setting can be
overridden at the course detail level for individual courses.
A short explanation of each of the settings is provided
below, detailed explanations can be found in Traditional
Gradebook: Appendix A and from online resources.

e Categories only (weighted categories) if you want to weight
only the categories in your gradebook.

o Assignments are converted to a percentage then
averaged within each category. The category average
is multiplied by the assigned weight, and the weighted
category averages are added together.

e Category and assignments (weighted) if you want to weight
both categories and weight the assignments within those
categories.

o Assignments are converted to a percentage, multiplied
by the assigned weight and a category average is
calculated. The category average is then multiplied by
the assigned weight, and the weighted category
averages are added together.

e Select Total points if you want the overall value of an

assignment to be determined by the maximum points
possible for the assignment.
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Average

Field Default Comment
Value

o Assignments are not converted to a percentage. The
total points a student earns is divided by the total
number of points possible.

o Select Category total points if you want a category weighted
and the value of an assignment within a category to be
based on the points possible for the assignment.

o Assignments are not converted to a percentage. Within
each category, total points earned are divided by total
points possible to determine the category average. The
category average is then multiplied by the assigned
weight, and the weighted category averages are added
together.

Additional Resources:

Help > Quick Reference Cards > Gradebook—Beginning-

of-the-Year Setup

Help > Videos > Teacher Gradebook > Setting up your

Aspen Gradebook > QRG > Understanding Averaging

Modes.

Decimals 0 Determines how many decimal points to use in calculating
Owner=User | grades. Affects averages in Gradebook only. Grades
posted to transcripts will conform to the district defined
decimal rules.
Grade change tracking Unchecked
days 0
Owner=User
Grade Scale No default | ¢ Some districts have uniform grade scales. If not established
value. Must by the district, participants can select a scale from the list
be selected viewed by clicking the magnifying glass.
by the ¢ Provincial Mark Scale Final assigns numeric value of 25%
owner. for letter grade — F, no numeric value for letter grade —I.
Owner=User | ; proyincial Mark Scale Interim assigns no numeric value for

letter grade - F, numeric value of 25% for letter grade - I.

e The IB Grade Scale is for use by authorized IB Schools
only.

¢ If the district or school permits, teachers can go to the Tools
top tab > Grade scales side tab > Options > Add to create
their own grade scales.

Semester Cumulative Unchecked | e Select this checkbox to show semester running averages
Owner=User on your Scores page. MyEducation BC calculates semester

running averages based on the assignment grades within
each of the terms inside of it, not on the average for each
term.

¢ Students and family can view this column in the Student
and Family views.
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Field Default
Value

Comment

¢ Note: Your school must enable the School Grade
preferences (for Show semester averages in the
gradebook) for this user preference to be activated.

e MyEducation BC uses the column header Semester # (for
example, Semester 1) for semester running average
columns.

Unchecked
Owner=User

Cumulative Average

Select this checkbox to show an overall course cumulative
mark calculation when using Total Points averaging mode.
Selecting this option along with a default weighting of
Total Points or Category Total Points produces a total
cumulative mark calculation. Note: this option is only
available if the School > Preferences > Grades has
Semester Cumulative Average and Overall Cumulative
Average checked.

2.8 School Preferences: Schedule

School view > School top tab > Setup > Preferences > Schedule > Basic

These preferences are editable by the school but default to the settings from district and/or
province. Those with * are only found in School View preferences.

Note: This preference is different than the Schedule preference managed at the district level.

Field Default Comment
Value
General: Schedule mode Secondary | MUST BE SET TO SECONDARY IN ALL

SCHOOLS. (See the Set Active Schedule section
of this document)

General: Elementary schedule
grade level cut-off

N/A - all schools in BC should be set to Secondary.

General: Section number pad
length

This setting determines how many characters are
generated when a new section is created for a
course.

(MEN—12-005 would be 3 characters; MEN—12-5
would be 1 character) Recommended setting of a
minimum of 2 to avoid truncating and assist with
sorting by section.

General: Shared build year
scenario

These values relate to work done in the Build view.
Do not adjust these values.

General: Allow Build year request
edits

These values relate to work done in the Build view.
Do not adjust these values.

General: Align teacher
assignment with certification

These values relate to work done in the Build view.
Do not adjust these values.
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Field

Default
Value

Comment

Allow percentages for additional
section types

These values relate to work done in the Build view.
Do not adjust these values.

Student subject selection: Disable
automatic recommendation
acceptance

These values relate to work done in the Build view.
Do not adjust these values.

Student subject selection: Subject
selection fields

These values relate to work done in the Build view.
Do not adjust these values.

Teacher recommendation: Show
recommendations in School view

These values relate to work done in the Build view.
Do not adjust these values.

Teacher recommendation:
Enforce Recommendation code
match

These values relate to work done in the Build view.
Do not adjust these values.

Teacher recommendation:
Teacher recommendation fields

These values relate to work done in the Build view.
Do not adjust these values.

Schedule Matrix:
Default time filter to date

Checked — Allows user to include a time filter to
Schedule Matrix

Homeroom:

Require room for homeroom
fields on Staff

Unchecked — Allows user to select homeroom from
pick list or type homeroom as free form text
Checked — Restricts user to only selecting
homeroom from pick list.

Student Schedule: Student
schedule sort order

The values in these fields are the java hames of
database fields. The following is a description of
each and the corresponding value that is displayed
on the student schedule:

scheduleDisplay = the period/day

termView = schedule term
section.scheduleTrackld = track ID
section.courseView = Course code & Section #

By adjusting the order these are listed, you can
control the sort order on the student’s schedule.
For example, to have the student schedule sorted
by Term (e.g. FY, S1, S2) Move termView to the
beginning of the line — as below:
termView,scheduleDisplay,section.scheduleTrackl
d,section.courseView

Student Schedule: Student
schedule matrix cell

These values relate to work done in the Build view.
Do not adjust these values.

Student schedule workspace:
Student schedule fields

These values relate to work done in the Build view.
Do not adjust these values.
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Field

Default
Value

Comment

Student schedule workspace:
Master select fields

The names in this field control the columns and
order of columns on the pop-up window, in the
Student > Schedule > Workspace > button
Select....

Columns can be added, removed and re-ordered
within this area.

See Appendix A-Master select fields for a list of
Java names that represent the column headers.

Student schedule workspace:
Allow future add/drop

Unchecked

Checked: allows changes to a student schedule to
be set for a selected future date in School >
Student > Schedule > Workspace.

Unchecked: does not allow the option of setting a
student schedule change for a future date.

Student schedule workspace:
Allow past add/drop

Unchecked

Checked: allows changes to a student schedule to
be set for a selected past date in School > Student
> Schedule > Workspace.

Unchecked: does not allow the option of setting a
student schedule change for a past date.

Student schedule workspace:
Pending student schedule
change fields.

These values relate to work done in the Build view.
Do not adjust these values.

Student schedule workspace:
Align Add/Drop window (days)

Number of days after start of the school year that
student schedule adds/drops are displayed in the
Staff view > Pages > classes widget.

School view > School top tab > Setup > Preferences > Schedule > Advanced

warning

Field Default Comment
Value
General: Pattern day IDs These values relate to work done in the Build view.
Do not adjust these values.
General: Pattern period IDs These values relate to work done in the Build view.
Do not adjust these values.
Number of sections deleted with 0 Zero indicates that all deletions will issue a

warning. Any time a section is deleted, you will
receive a warning.

Program total minutes override by
grade level

Select this preference to override course program
total minutes by grade level. The format is grade
level, colon, total minutes. Separate grade levels
with commas.

Example: 01:1980, 02:1980, 03:1980

In this example, grade levels 1, 2 and 3 have
overrides set to 1,980 minutes.
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Field Default Comment
Value
Commit - Map of user defined Blank Not Required.
fields for master Fields from (Basic tab) Student Schedule

Workspace — could be entered here to move the
values in the following fields (Related to
Designation Tallies) from the Build view to the
school view when Commit Schedule is run, after
EOYR.
fieldAQ0O4,fieldA005,fieldA006,fieldA007,fieldA0O8, fi
eldA009,fieldA010,fieldA011,fieldA012,fieldA013,fi
eldA014,fieldA015,fieldB002.

Alternately it could be left blank and after Schedule
Commit is run, the Update Designation Tallies
(scheduled at the district level) will update values in
the School view the next time it is ran.

Initialize Sections - Initialize Blank Not used in BC or Yukon.

Sections Procedure Functionality was added to have a customized
Initialize Sections Procedure.

2.9 School Preferences: Receipt Printing

School view > School top tab > Setup > Preferences > Receipt Printing

Additional information on these preferences can be found in Help > Online help > search for
receipt printing > Define District (Root Organization) Receipt Printing Preferences. Districts
requiring assistance with this can submit a request through a HEAT ticket.

Field Default Value | Comment

Enable receipt printing checked Checked: enables receipt printer based on
settings defined.

Unchecked: disables receipt printer.

Width 300

Height 400

Left margin 25

Top margin 25

Font Lucida Console
Font size 10

Line height 10

Daily attendance receipt content

Class attendance receipt content

Payment receipt content
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2.10 School Preferences: Secondary School Management

School view > School top tab > Setup > Preferences > Secondary School Management

Field Default Comment

Value
Secondary Unchecked | Checked: to see secondary students in the school (cross-enrolled).
Students Recommended setting for all schools in BC is Checked.

Unchecked: if the school does not have secondary students.

Secondary None: The secondary school cannot create a Daily Attendance value
School daily for secondary students.
attendance Sole: Only the secondary school create a Daily Attendance value for
management secondary students.

Shared: Both primary and secondary schools can create a Daily
Attendance value for secondary students. The school that creates the
Daily Attendance value for a student is the school that can edit the
record.

This setting is not for Class Attendance, either school can create a
Class Attendance value for a student scheduled into a course section
at the school.

2.11 School Preferences: Communication

School view > School top tab > Setup > Preferences > Communication

Field Default Comment
Value
Forum Unchecked | Checked: all forums require a page administrator to approve all posts
Options: before they appear to users.
Requires Unchecked: choose which forums are moderated (all, some or none)
moderation
Notifications — | Unchecked | NOT USED IN BC or YUKON
Enable push
notifications
Scheduled Job Enter email addresses for school users to receive notifications of failed
Notification: scheduled jobs. Separate individual email addresses with commas.
Job failure
delivery
address
Scheduled Job The time at which the system will begin sending email notification for a
Notification: failed or skipped job.
Delivery start
time
Scheduled Job The time at which the system will stop sending email notification for a
Notification: failed or skipped job.
Delivery end
time
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Field

Default
Value

Comment

Scheduled Job
Notification:
Repeat time (in
minutes)

Set time to determine how often to send the failed job email
notification. Suggested repeat time is 30 minutes or greater.

2.12 School Preferences: Family/Student Portal

School view > School top tab > Setup > Preferences >Family/Student Portal

Field

Default
Value

Comment

General: Show
Semester
Averages

Checked: displays the semester average by term for assignments set
as public in Family/Student Portal > Academics > Averages Table
Unchecked: does not display the semester average by term in
Family/Student Portal > Academics > Averages Table

General: Show

Checked: displays the gradebook overall cumulative averages for

overall assignments set as public in the Family/Student Portal > Academics >

cumulative Averages Table

averages Unchecked: does not display the overall cumulative averages for
assignments set public in the Family/Student Portal > Academics >
Averages Table

General: Average: displays the average of all scores entered for a standard;

Grades sum of scores divided by number of scores

calculation for Trend: displays the Power Law Trend equation, referencing each

standards

score entered. Trend is the suggested setting to work with the BC K-9
competency-based curriculum.

General: Show
cumulative
standard
summary

Checked: displays a cumulative standard summary on the Academics
page. Checked is the suggested setting to work with the BC K-9
competency-based curriculum.

Unchecked: term based standard summary on Academics page.

General: Allow
curriculum
maps in portal

Checked: displays a read-only version of the curriculum map for a
section in the Portal, if the Show in Portal option is checked in the
section of the teacher gradebook.

Unchecked: no curriculum maps display. Unchecked is the
suggested setting to work with the BC K-9 competency-based
curriculum.

General:
Display only
letter Grades in
the portal

Checked: displays only letter grades in Family/Student Portal >
Academics. Letter grades must be set up in the transcript definition
grade scale.

Unchecked: displays marks as entered.
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display mode

Field Default Comment
Value
Academics: Term average: Averages by term display in Family/Student Portal >
Term Academics > Classes
performance

Cumulative average: Cumulative averages display in Family/Student
Portal > Academics > Classes

Average
summary
display mode
in detail

Display category average by term: Family/Student Portal >
Academics > Classes > Details > Average Summary Grid displays the
Gradebook category average by term

Display category cumulative average: Family/Student Portal >
Academics > Classes > Details > Average Summary Grid displays the
overall Gradebook category average

2.13 School Preferences: Remote Services

Field

Default
Value

Comment

One Search:
Database
configuration

N/A

Interfacing MyEd BC to One Search/C&L. This functionality is not
currently available for BC.

Destiny
Integration:
Site number

Interfacing MyEd BC to Destiny.

Destiny
Search

Site

2.14 School Preferences: Extracurriculars

Event Status
Codes

Field Default Comment
Value
Extracurricular | N/A Select the status code(s) that students must have for:

e Their names to appear on the attendance page for an
extracurricular program's event.

e An event to appear on their calendar in the Family and Student
portals.

e Access to an extracurricular program's Page.
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3.0 Commit the Master Schedule
Schools must select a scenario in the Build view to use as their master schedule. This can only
be done after End-Of-Year Rollover is complete.

Commit Master Schedule sets the Active Schedule in the School view > School top tab >
Schedules side tab and:

e Populates the schedule structure in the School view > Schedule top tab > Structure side tab

e Populates the master schedule in the School view > Schedule top tab > Master side tab

To commit a master schedule for the upcoming school year:
This process can take several minutes to complete.
Build view > Scenario

o Check the box beside the appropriate scenario and click the Details side-tab. Ensure the
correct scenario name appears under the school name at the top of the screen.

e Click the Terms side tab. Start and End dates for each schedule term must be defined. (An
error will display in the Commit Schedule process if this is not done.)

e Click the blue hyperlink to see the detail of each schedule term.

o If the date fields are not populated, click the button to display the fields.
o Populate the Start date and End date for each schedule term as appropriate.
o Select the appropriate Grade term cover map(s) for each schedule term.

o Click Save.

Code FY ~

Name FY

Base terms per year 1 @

Term map
B Set date

Term Date Ranges Start End

1 05092023  EE 27/06/2024 A

Grade term cover map

(a1 ]
A
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1. Inthe Options menu, click Commit Schedule. The Commit Schedule pop-up appears, with
two options:

o Replace the Active Schedule: This will create the active schedule in the school view.

e Update the Active Schedule: Once a schedule scenario has been committed, changes
can still be made in the Build view. If you want to apply these changes to the active
schedule, you will select this option.

2. Select Replace the Active Schedule. Click OK.

Note: Commit Control Windows, which define the date range in which schools can perform the
commit master schedule process are set at the Enterprise level.

4.0 Set Active Schedule

Schools require an active schedule to create schedule terms. If you have committed the
schedule from the Build view the Active Schedule will already be set.

Do not re-set an Active schedule! Setting the active schedule more than once can create
duplication of courses for student reporting.

To confirm an Active Schedule:
School view > School top tab > Setup > Preferences > Category: Schedule

Ensure the Schedule Mode field is set to Secondary. This field is Secondary regardless of the
type of school. Do not change it!

School view > School top tab > Schedules > Filter set to Active Schedule

When an Active Schedule is set there will be a row visible showing the triangle indicator
on the Name field of the Active Schedule

If no triangle is visible: Filter to All Records if the current year is visible, click into the details of
the record and select Options > Set Active Schedule > Ok > Save

If the current year is not visible in All Records: Options > Add, populate the Name, Start and
End date > Save. Options > Set Active Schedule > Ok > Save

o YearlID: shows the current school year context.

e Name: Should indicate the current year with a black triangle in front, as in the
screenshot below.
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e Start Date: the start of the school year schedule for this year. Must be on or after the
Enterprise Start Date and the District Start Date of the current school year.

e End Date: the end of the school year schedule for this year. Must be on or before the
Enterprise Start Date and the District Start Date of the current school year.

e DPC: Indicates the number of days the school has in its master schedule.
e PPD: Indicates the number of periods the school has in its master schedule.

e TPY: Indicates the smallest number that all the base terms in the school can be divided
into evenly. This is determined from the Schedule top tab > Structure side tab > Terms
sub-side tab in the master schedule. (See example in the screenshot on the next page).

e Terms: Indicates all the schedule terms (course durations) represented in the Schedule
top tab > Structure side tab > Terms sub-side tab in the master schedule. (See example
in the screenshot below).

. DPC PPD TPY Term
DPC: This school operates with only a Day 1

and rotates the periods using bell schedules 1 17 4 1441211

PPD: This school has a total of 17 periods
available to schedule courses into.

TPY: This school offers full-year (base term
= 1), semester (base term = 2). and 9.5
week courses (base term = 4). The number
4 in the TPY field represents the smallest
number that all these base terms can be
divided into evenly. ie. 1,2 and 4 can all go
into 4.

Term: This field represents all of the
schedule terms available in this school: 1/4
represents the 9.5 week courses, 1/2
represents the semester courses, 1/1
represents the full-year courses.

5.0 School Calendar

Districts must initialize a calendar to determine the session dates and non-session dates within
their district.

A school calendar name of Standard will allow all schools with secondary students to take
attendance on students from other schools with a calendar name of Standard.

School top tab > Calendars side tab > Dates leaf
R senee

School Calendar :: 2019-2020 - Standard Q

L L1~ e s = @
AlR

Schadules

< |[4117242018 v [ > 0 of 366 selected &7

Date InSession? DayNum DayType Ball > Nome.

mmmmm
......

11242019 N 0
Events 252018 Y 1 Regular Bes
ks 262019 7 1 Raguiar Bos
2018 Y 1 Reguiar Bs

Membarship
111282019 ¥ 1 Reguiar Be!

Journals

¢ If the school does not see dates in the School top tab > Calendars side tab > Dates
leaf, the school should:
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o Contact the district support desk and ask if the district calendar has been
initialized. If not, the school should wait for the district calendar to be initialized as
that process could overwrite the manually created school calendar.

Review the school Active Schedule Calendar, re-assign schedule days and modify in-session
dates as necessary to reflect school-specific session or non-session dates.

5.1 Modifying Individual Dates

School view > School top tab > Calendars > Select the current school year > Dates

School dates should be populated, if Dates are not populated contact the district service desk to
initialize the calendar.

Review the dates, days when attendance is taken in the school show InSession =Y. Any non-

instructional/non-attendance days that are needed the school level can be entered now or later
in the year.

To change or add a non-attendance day:

e Click into the blue hyperlink date

e Uncheck the Is school in session checkbox

e Select the Schedule day type from the dropdown list
e Save

Pages L I Student Staff Attendance Conduct Grades Assessment Sch

School Calendar :: 2023-2024 - Standard :: 06/09/2023

Setup
=

Online

Schedules

Date * 08/09/2023 =
Details.
» Dates Schedule day number 1
Events Schedule day type v
Schedule Bell > Name * Admin Day Qx

Lockers Alternate Calendar

BC Day

Closure Day

Curriculum Impl
Early Dismissal Day
Easter Monday
Cashier's Emergency Closure
Office Exam Day

Family Day

Good Friday
Indigenous Day
Labour Day

Grid Codes Labour Dispute
Parent Interviews
Pro D

(e Remembrance Day
Semester Break -

Journals

Ed. Plans

This date is now not an attendance date in the school. In School > Attendance on the non-
attendance dates the screens will show not in session and a pop-up showing it is not a valid
calendar day.
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Student Staff Attendance Conduct Grades Assessment Schedule Extracurriculars Global Tools Admin Mobile View

School Calendar :: 2023-2024 - Standard Q
Setup = - -
-] comm—e Wi = o= .
Online
Registration 1:06/09/2023 v = 0 of 333 selected 7 Custom Selection
Schedules (] Date hsy - e Bell > Name
Calendars I [ 06/09/2023 N 1 #4 - Homeroom I
Details
= Dates ) 07092023 Y 1 #5 - Homeroom

School view > School top tab > Calendars > Select the current school year > Dates > Filter set
to Days in Session

Pages Lol Student  Staff  Attendance Conduct Grades Assessment Schedule Extracumiculars  Global Tools  Admin

School Calendar :: 2019-2020 - Standard Q
S
Schodules Manage Fitters.
o013 5] 007186 selected &7 Gys in Session
N — All Records
Calendars O oom v Days in Session Deytium L] pex
oy

] eaaog Reguiar sl

Events ] owzot Reguiar Bell
Lockers ] esans

] ema0g Reguiar Bel

¥
¥
¥
¥
-

1
1 Reguiar Bel
1
1

Membership

O 9maos Regular Ball

Only dates with the Is School in Session checkbox checked appear in the Days in Session filter.
Enter the Day Number and Bell Schedule Name if used in the school.

Adjust records as required using Options > Mass update or Modify List or click into the blue
hyperlinked date and edit the individual record as required.

o InSession?: will =Y for all records in this filter
e DayNum: type the Schedule Day Number
o From: School > Schedule > Structure > Days
e Schedule day type: will = blank for all records in this filter, day type is used with days
not in session
e Bell > Name: select the Bell Schedule for the day from the picklist
o From: School > Schedule > Structure > Bell Schedule
e Save
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5.2 To Reassign Schedule Days

If your school uses a schedule with schedule days, and a day is defined as not-in-session on
the school’s calendar, the schedule days can be re-numbered to match the days school is in
session.

Pages LI LU Student  Staff  Attendance  Conduct Grades  Assessment  Schedule  Extracumriculars = Global  Tools = Admin
School Calendar :: 2019-2020 - Standard Q
Setul
N .- | o~ | @ o= .
1:9/312019 ~ 0.0f 298 selected (7 All Records
Calendars -
Details O Date InSession? DayNum DayType Bell > Name
» Dates
| O 9/3/2019 N 0 Curriculum Impl I
Events [ 9M4iz019 ¥ 1 1-2 Day
lodes ) asiz010 Y 2 1-2 Day
O osi2019 Y 1 1-2 Day
Membership
O arzo1e N 0
dntmas O 92019 N 0
Cashier's O 9/9/2019 Y 2 1-2 Day
Office
O 9102018 ¥ 1 3-4 Day
Ed. Plans O 9112019 ¥ 2 3-4 Day
Grid Codes O 9122018 Y 1 3-4 Day
[ en32019 Y 2 -4 Day

School view > School top tab > Calendars side tab > Dates > Options > Reassign Schedule Days
Filter = All Records
In the popup enter the following:
e Start Date: the date changed to a Not in Session date
o End Date: the day the reassignment of day numbers should end
e Initial Schedule Day: the day number to begin with on the Start Date

Pages [ELLLN Student Staff  Attendance Conduct Grades Assessment Schedule Extracurriculars  Global ~ Tools — Admin

School Calendar :: 2019-2020 - Standard Q
Reassign Schedule Days
- [ em—
Schedule: —
Calendar ID Standard e (19732019 ¥ 0 0f 298 sslected & Al Reco
Calendars Date InSession? DayNum DayType Bell > Name
Start Date 12106/2017 = Dot O ., P P P ,
+ oes
End Date 30/06/2017 m I [ /32018 N o Cumculum Impl
Events O 242018 ¥ 2 1-2 Day
Initial Schedule Day 2 -
(s [ 52019 ¥ 1 1-2 Day
O aszo1s ¥ 2 1-2 Day
Membership
R i 9872019 N L
Cashier's O  ases ¥ 1 1-2 Day
Offica
O snozos ¥ 2 3408y

Note: If you want your schedule days to match the days school is in session, you need to
reassign schedule days for every day you define as not in session on your calendar (except
weekends, if your school is not in session on weekends).
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5.3

Creating a School Calendar

When the district initializes a calendar, a standard calendar will be created for each school
checked with the district calendar was initialized. A school should not normally have to initialize
a school calendar unless they are creating more than one calendar in their school.

PwnNPE

5.4

NoakwdrE

Log on to the School view.

On the menu bar, click Options and select Add.

In the Calendar ID field, enter a unique description for this new calendar.

Select the Static Schedule Days checkbox if the school does not adjust schedule days
for not-in-session dates. For example, if the schedule operates with Days 1-7, and the
day before a holiday is Day 4, the schedule day when school resumes is Day 6.

The Required Number of in Session Days will populate automatically from the district
calendar. The field can be modified, if necessary.

Number of days in session cannot be populated — this will be determined when the
calendar is initialized, and the school can refine the calendar as necessary.

Use the Q> icon to select the School Year Context > Year ID. This should match the
year you for which you are creating the calendar.
Click Save.

Initializing the School Calendar

Log on to the School view.

Go to the School top tab.

Click the Calendars side tab.

Check the box beside the calendar you want to initialize.

Click the Details leaf under the Calendars side tab.

In the Options menu, select Initialize Calendar.

In the Initialize School Calendar pop-up window, select, or de-select Saturday and
Sunday if school is in session on these days.

Set the Initial Schedule Day, if applicable. (There will only be a value in this drop-down
menu if at least one day is defined in the Schedule top tab, Structure side tab, Terms
sub-side tab).

Click OK.
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6.0 Reference Codes

Reference tables provide a list of codes for users to select from in various areas of the
application. Codes created at Enterprise level cannot be modified by districts and schools.
Some reference tables allow districts or schools to add their own codes, in addition to the
enterprise codes. Districts and schools have the ability to modify, hide or disable codes created
at the district or school level.

Common reference tables reviewed by schools are:

e Attendance Reasons

e BC Departments

e Conduct Action

e Conduct Incident

e Preferred Gender

e Schedule Term Codes

e Report Card Settings — Single Term
e Report Card Settings — 3 Term

6.1 Adding a Reference Code at the School Level
School > Admin > Reference > Select the Reference Table > Codes

e Filter to All Records

e Options > Add
o Code: Enter the code to appear in drop down menus
o Description: Enter the description of the code
o Save
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7.0 School Comment Banks

Only one comment bank can be assigned to a school course. If schools want to access
comment banks from the school as well as access the district comment banks for a course, the
schools must create the comment bank codes within the district comment bank.

Pages School Student Staff Aftendance Conduct Grades Assessment Schedule Extracurriculars Global Tools LG

Comment Bank Tables

Reference =Y -
N o = o

Comments
Details
Codes
Fields Name Category1 Category2 Category3 Owner

0 of 1 selected &7

Licenses ) School Comments Category 1 Subject Vanguard Secondary School (School)

Logs

7.1 Setting School Comment Bank Details

School comment banks can be set up with 3 categories to help users filter comments and find
the ones they want to use more easily. Categories set in the details of the school comment bank
create an upper-level filter. Categories assigned to comment codes will appear within these
categories.

Search by Comment Number in the Grade Input and Gradebook Scores screen is simplified
when Category 1 is set to ALL. Category 2 and Category 3 can be used to scope the comments
as the school chooses. See section 7.5 for details on mass updating the Category fields.

School > Admin > Comments > School Comments

1. Enter or adjust Bank name as desired.
2. Populate Category 1, 2, and 3 as appropriate for the school.

Student  Staff Attendance Conduct Grades ' Assessment Schedule = Global Tools

Comment Bank Tables :: School Comments

Reference
(o]
Comments

Codes
Fields

Bank name * Scheol Comments
Licenses Category 1 * Al
Logs Category 2 Department
Category 3 Care Competency
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7.2 Adding a Comment

School > Admin > Comments > School Comments > Codes > Options > Add

Enter the comment fields as appropriate:

o ID: enter a value relevant to the comment.

¢ Comment Preview: enter text representing the comment.

¢ Comment: enter the complete comment to appear on the report card.

e Category 1, 2 and 3: enter categories per school naming conventions

¢ Disabled indicator:
o Checked: Comment remains in the list but is not visible for users to select.
o Unchecked: Comment is visible for users to select.

e Save.

7.3 Modifying an Existing Comment

School > Admin > Comments > School Comments > Codes

To modify an existing comment:

e Click into the blue hyperlinked ID for the comment to be modified
¢ Make the necessary changes and click Save

7.4 Deleting an Existing Comment

School > Admin > Comments > School Comments > Codes

To delete an existing comment:

e Click into the blue hyperlinked ID for the comment to be deleted
e Options > Delete

If you have multiple records to delete:
School > Admin > Comments > School Comments > Codes

e Select the comments to delete by checking the box next to the ID
e Options > Show Selected

e Confirm the records displayed are to be deleted

e Options > Delete
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7.5 Mass Updating Comment Bank Category Fields

The example provided will move the Category 1 entry into the Category 2 column and mass
update the Category 1 column to ALL. This will allow comment search by number to work
without the selection of a category first.

e Log on to the School view. Calegosvl ay pCaegory2y LCategoryd
e Click the Admin top tab ENGLISH
¢ Click Comments side tab ENGLISH
e Codes sub side tab ENGLISH
ENGLISH
Options > Mass Update ENGLISH
In the pop-up window click the Advanced button ENGLISH
ENGLISH
ENGLISH
Value
ENGLISH
ENGLISH
=)
o Inthe Field dropdown select Category 2
o Inthe Source dropdown select Another Field
o Inthe Value dropdown select Category 1
o Click Update
Field Category 2 v
Source Another field  ~
Value
Force save O
Category1 a Category2
- ENGLISH ENGLISH
This will update the Category 2 field with the Category 1 values. ENGLISH ENGLISH
A confirmation pop-up message will appear: ENGLISH ENGLISH
Update the field "Category 2" with the contents of the Category 1 field for EMGLISH EMGLISH
all records in the current selection?
EMGLISH EMGLISH
OK Cancel ENGLISH ENGLISH
. . . EMGLISH ENGLISH
Click OK, all comments Category 2 values will be updated with the
Category 1 information: ENGLISH ENGLISH
Now Category 1 can be replaced with ALL ENGLISH ENGLISH
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Options > Mass Update

In the Field dropdown select Category 1

In the Value field enter: ALL
Click Update

Field

Value

6 Advanced

This will update the Category 1 field with ALL. A confirmation pop-up message will display:

Update the ﬁgld "Category 1" with the value "ALL" for all records in the Ealnnnaie erencedes
current selection?
ALL EMNGLISH
S ALL ENGLISH
ALL EMNGLISH
] ] ] ALL ENGLISH
Click OK, all comments Category 1 values will be updated with ALL
ALL ENGLISH
ALL EMNGLISH
ALL ENGLISH
In the Comment Entry window in School > Grade Input and Staff > ALL ENGLISH
Gradebook > Scores a number can now be entered in the search field e L
to search all comments in the school comment bank. Selecting a
subject will further narrow the scope if desired but is not required.
Student
>
Category 1 |ALL v Show My Codes
Subject | All v
|50
fiperzon firstName|lowercapitalize]] has shown an enthusiazm for
unit projects.
ALL FRENCH
firztName|lower| needs to lete and log an
average of 150 minutes of physical activity each weeh. Fleaze zee
attached log.
ALL GENERAL
B save % Cancel ;\1’6
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7.6 Using Variables in the School Comment Bank

Variables can be used to “personalize” comments in the school comment bank. The table below

identifies the variables that represent various replacement characters.

Filter Type Description If you type this: This appears in the

comment:

Count The number of {{student.conductincidents|count}} 2 (the student has 2
elements in a conduct incidents on
collection. record)

Capitalize | The system {{person.firstName|capitalize}} Elizabeth
capitalizes the first
letter.

Titlecase The system enters {{"parents and caregivers"|titlecase}} Parents and Caregivers
the text in titlecase
format.

Ordinal The system enters {{person.firstName}}'s Timothy's 3rd incident
a numerical value in | {{student.conductincidents|count|ordi | was the last documented
ordinal format. nal}} incident was the last offense.

documented offense.

Upper The system enters {{person.firstName|upper}} JANE
the text in all
uppercase.

Lower The system enters {{person.firstName|lower}} jane
the text in all
lowercase.

Trim The system enters {{person.physicalAddress.addressLin | 123 Main Street (the
the text with all e01|trim}}, such as xxx123 Main address without any
white space Streetxxx spaces before or after the
trimmed. text)

Gender The system enters {{"Male"|gender:boy,qirl,it}} Boy
the gender term
based on "Male" or OR OR
"Female". {{person.genderCode|gender: He, He or She

She}}

Length The number of {{person.firstName|length}}, such as 4 (number of characters

characters in text. Jane in the student's name)
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7.7 Text Comment Length Override

When a teacher enters a report card comment on the Gradebook Scores page, a character
count and limit appear at the bottom of the Edit Text Comment box. MyEducation BC will not
allow the teacher to type more characters than the set comment length. MyEducation BC
observes the school’s transcript column or course text comment length, if one is set. If not, then
MyEducation BC observes the Enterprise comment length setting of 10,000 characters or the
District comment length if one is set.

The Comment Length limit on a report card can be adjusted at the school level within the
Transcript Definition (Transcript Column Attribute) or at the Course level (Course Text
Comment length).

It is recommended you do not use both methods.

B =t0lmyeducation.gov.ba.ca,
Alfarsovilafuerns, Jhonloyd

Actual comenanis replaced as part of scramble process -

7.7.1 Transcript Column Attribute Comment Length Changes
School View > Grades TT > Transcript Column Attributes ST

e Select the Transcript Definition using the Transcript Definition picklist

Tranzcript Definition 4 Term 10-12 2023 English %-LG Q

e Options > Add

Transcript Column Attributes :: New Transcript Column Attributes

Grade
o) ®
S— = T —

|Grade name [a1 Comment ®la

Column type Text Comment

Text commentlength (10000 h

[Scnool Comments Jax

Calculation
Overrides

Average
Calculations

Credit P
Adjustments Auto recalculate’

School View and Staff View show the change of maximum characters.
This change will affect all course comments for courses using the modified transcript definition.
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@ 1st01myeducationgov.beca

Stadenl Aonzovitatuene. Jhonlioyd

Actual comments replaced as part of seramble process .

The course comment character limit is only updated
when the Transcript Column Attribute update method
is used: School View > Grades TT > Transcript

Column Attributes ST

7.7.2 Course Text Comment Length changes

To set a comment length limit at the course level

Schedule TT > Courses ST
Copy any Field Set and add “Text comment length” field to it and click Save.

Available Fields “ Selected Fields

[ School Course ~]| Depariment =

FTETSTEr ST Credit
[Progress grades term map Hide on PSR
\Academic level

[Recommendation Code

[Report sequence number Course = Academic level

[SECTIONS Master type

[SEMESTER Course > School Year Contexi = School year

[SHORT_NAME Course > School level m

[Short description Grade level

summary Transcript Definition > Name

Target grade type Rubric Definition = Name

Teacher preparation code
arm arades farm man

Exclude from class size export
Course > Course funding code
Course » Subject Area

Comment Bank Table > Bank name

TAT AITETITATE RETUEs!s
Total Course Requests Fee Type

The school can enter the revised character limit in the “Text comment length” field for the
applicable courses (School view > Schedule TT > Courses ST > select the course > Details >
Select field set with “Text Comment Length” added to it). When the field is left blank it will
default to the enterprise limit of 10,000

‘Smithers Secondary 20202021

School View does not show the change in character limit in the comment edit box but displays
an error message if you exceed the character limit.

Staff View does accurately display the change in character limit.

This method limits the changes to the comment length to the specific course.
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8.0 School Setup
8.1 Staff

Detailed information on managing staff accounts is contained in the Security Management
document.

Check that the Usual First Name and Usual Last Name fields are filled. Functionality attached to
this data for report cards

8.2 Grade Terms

Grade Terms must be entered for all schools in your district. In the School view, each school
will define the dates for each grade term. For example: If you operate with four grading quarters
(Q1, Q2, Q3, Q4), you might define the grade term dates as follows:

Quarter Start Date End Date
Q1 September 2 November 23
Q2 November 24 February 2
Q3 February 3 April 12
Q4 April 13 June 26

Trimester example: If you operate with three grading terms per year (Tri 1, Tri 2, Tri 3), you
might define the grade term dates as follows:

Trimester | Start Date End Date
Tril September 2 December 8
Tri 2 December 9 March 13
Tri 3 March 14 June 26

Additional grade terms can be defined to reflect the reporting requirements for other grades.

Example: A school operating with Grades K-12 may have both Quarters and Trimesters
defined. This would allow them to report on Grade K-7 courses three times per year and Grade
8-12 courses four times per year.
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Reporting Period | Start Date End Date
Q1 September 2 November 23
Q2 November 24 February 2
Q3 February 3 April 12
Q4 April 13 June 26
Tril September 2 December 8
Tri 2 December 9 March 13
Tri 3 March 14 June 26

8.2.1 Defining grade term dates for a school:

School > Grades > Grade Terms > Options > Add

The New Grade Term Date page appears.

Assessment

Pages School Student Staff Attendance Conduct el

Grade Term Dates :: Standard Quarterly Grades - Q1

Grade
o~

» Details

Transcripts

Grade Term Definition > Mame Standard Quarterly Grades

Transcript

Column

Attributes Term ID * (a1 1Q
_ Start date * 11/08/2023 =

Calculation

S ETIE End date * 1311172023 =

Average

Calculations —

e Term ID: Select the correct grade term from the picklist

 Start Date and End Date: Use the calendar icon to select the Start and End dates of the

Grade Term
e Click Save.

Repeat for each grade term required in the school.
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8.2.2 Setting the Grade term cover maps

School > Schedule > Structure > Terms > Details

In the grade term cover map section, select the checkboxes that represent the terms that
classes with this schedule term will be reported on and save.

After committing a Master Schedule, these checkboxes will be populated. It is recommended to
reset and save the grade term cover maps to ensure they are linked correctly as a part of start-

up.

Code
Mame
Base terms per year

Term map

Term Date Ranges

1

Grade term cover map

FY w

Full Year

1

Start

11/09/2023

End

27/06/2024

The grade term cover map can appear differently for schools that have both quarterly grade
terms and trimester grade terms. The following scenario describes an example where a school
has trimester grade terms for grades K-7 and quarterly grade terms for grades 8-12.

Grades top tab > Grade Terms in this scenario may appear as:

Transcripts

Transcript
Column
Attributes U o

0 a2
Calculation

Overmrides
Q3

Average
Calculations o4

Credit 8w
Adjustments
O Tz

Grade Input i w9

Grade
Details

WD E =

Start

06/09/2023

13/11/2023

31/01/2024

22i04/2024

06/09/2023

11272023

02/04/2024

End

09/11/2023

26/01/2024

19/04/2024

27/06/2024

28/11/2023

15/03/2024

27/06/2024

00f 7 selected (7

GrdTermDef » Name

Standard Quarterly Grades
Standard Quarterly Grades
Standard Quarterly Grades
Standard Quarterly Grades
Standard Trimester Grades
Standard Trimester Grades

Standard Trimester Grades

In this setup, schedule terms will display two sets of grade term cover maps. The school will
determine which schedule terms are associated to which grade term, depending on whether the
course is reported three times a year or four times a year.
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8.3 Schedule Terms

Schedule terms define course section durations. A schedule term must be created for each
portion of the school year in which a single course section can be scheduled.

For example, some school schedules may offer course sections in three trimesters (12-week
courses) and a full-year term (full year courses). Another school schedule may offer courses in
two semesters (semester length courses) and a full-year term. Review the Schedule Term
Codes reference table to ensure all the values required for the school are shown in the table.

8.3.1 Define the Schedule Term Codes reference table

School > Admin > Reference
e Search for the Schedule Term Codes reference table in the search bar
e Select the table
e Click the Codes leaf
e Set the Filter to All Records
Review the records to ensure all Schedule Terms the school uses are listed.
To add additional terms:
Options > Add

o Code: Enter the value that appears in drop down menus for selection
o Description: Enter a description of the Term

e Click Save.

Reference Tables :: Schedule Term Codes

Reference

» Codes

Fields ROOT  ListView>> Categories Only
0 of 14 selected &7

Comments
() Code Description Disabled State Owner

Licenses
O FY Full year N BC (Enterprise)

Logs
O a1 Quarter 1 N North Okanagan-Shuswap (District)
w] Qia3 Q1and Q3 N North Okanagan-Shuswap (District)
[m} Q2 Quarter 2 N North Okanagan-Shuswap (District)
0 Q204 Q2 and Q4 N North Okanagan-Shuswap (District)
O a3 Quarter 3 N North Okanagan-Shuswap (District)
w] Q4 Quarter 4 N North Okanagan-Shuswap (District)
w] 81 Semester 1 N BC (Enterprise)
m} s2 Semester 2 N BC (Enterprise)
O SEM1 Semester1 N North Okanagan-Shuswap (District)
O SEM2 Semester2 N North Okanagan-Shuswap (District)
w] T Term1 N North Okanagan-Shuswap (District)
[m} T2 Term2 N North Okanagan-Shuswap (District)
[m} T3 Term3 N North Okanagan-Shuswap (District)
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8.3.2 Define schedule terms

School > Schedule > Structure

In the screenshot below, the school offers full-year courses (defined by the code FY) and
Semester courses (defined by the codes S1 and S2).

Pages School Student Staff Attendance Conduct Grades Assessment JRITLITTN Extracurriculars Global Tools Admin

Schedule Terms

Schedules

Courses

Rooms.
Structure

Terms
Details

Days
Periods

Bell Schedules

Master
[ ovins< | repora- J s - )| COETIETNSEN E @

0 of 10 selected &7
Name ™Y CoveredTPY BaseTPY BaseMap UniversalMap GradeTermMap
Full Year 12 1 1 1 NN 1
Quarter 1 12 1 4 1000 111000000000 100
Quarter 2 12 1 4 0100 000111000000 1m0
Quarter 3 12 1 4 o010 000000111000 omn
Quarter 4 12 1 4 0001 000000000111 (]
Semester 1 12 1 2 10 11111000000 10

Semester 2 2 1 2 0 000000111111 on

Click the blue Code link to view the details of the schedule term. The screen shot below shows
the first of the school’s semester courses.

Course sections of this duration can happen as many as 4 times per year (Base
terms per year). Clicking the Set button generates the Term map.

This schedule term is defined as the first of the 2 semesters, so the first box of
the Term map is selected.

Term date ranges define when this schedule term starts and ends.

Grade term cover map defines which of the 4 grade terms the school is going to
report on this course section. These boxes may not appear if grade terms have
not been defined and can be populated after grade terms are created.

Schedule Terms :: 81
IMaster
Options v Reporis v
Schedules
=
Courses
Code 51 »
Rooms
MName 51
Structure
Base terms per year 2 @
Terms
» Details Term map ]
Term Date Ranges Start End
Days
1 05/09/2023 = 26/01/2024 F+]
Periods
Grade term cover map 00
Bell Schedules
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Use the following table to enter information in the fields for all required schedule terms:

Field

Description

Code

Select the code for the schedule term. For example, you might select FY for a full-
year term, and S1 for Semester 1.

Name

Type a name for the schedule term (Quarter, Tril, 12-week, etc.)

Base terms
per year

Type the total number of this type of schedule term in your schedule. For example,
for a course that meets one-third of the year (a single trimester), there are three
base terms. For a course that meets half of the year (a single semester), there are
two base terms.

Term map

Select the checkbox that represents which of the base terms this specific schedule
term covers. For example, if you are defining Semester 1 and there are two base
terms, select the first checkbox to indicate that this term is the first of the two
terms.

Note: The system displays checkboxes that equal the number of base terms
you identify at the Base terms per year field. For example, if you identify 3
base terms, three checkboxes appear.

Term Date
Ranges

Type the date or click the B icon to select the Start and End dates of this
schedule term. The system validates these dates against the school year dates.
For example, you cannot enter a start date that is before the first day of the school
year.

Grade term
cover map

This identifies which grade terms classes using the schedule term will be reported
on.

For example, if you are defining the Semester 1 schedule term and your school
operates with quarter grade terms, you select the first two checkboxes. This
indicates to the system that a value will be entered for the first two terms within this
schedule term, but not the last two.

K-12 schools may have a combination of trimester and quarterly grade terms, in
which case, two sets of grade term cover map boxes will appear and schools will
need to associate the appropriate grade term to the schedule term, depending on
how many times a year courses of that duration are reported on.
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8.4 Days/Periods

Days and periods must be set in order to create the school bell schedules which follow. To add
schedule days:

8.4.1 Define the number of days

Schedule > Structure > Days

Review the information to ensure the days the school requires are listed.
To add additional days:

Options > Add

From the Add Day window, enter the number of days in the Day count field that are required in
total and complete the lower section as shown below:

Schedule Days

IMaster

Schedules

W, Ims01.myeducation.gov.bc.ca/aspen/addDayPeriod.do - Google Chrome — O X
Courses e 2% Ims01.myeducation.gov.be.ca/aspen/addDayPeriod.do l°}
Rooms
O 1 Day count 2
Structure
Terms Number Identifier Name
Days 1 I [t |
Details
2 2 |
Periods
=

e If too many days are created in error, re-enter the Add Day window and type in the
number of days required in the Day count box. This will adjust the number of days
below to the appropriate number and remove any extras.

8.4.2 Define the number of periods
Schedule > Structure > Periods

If necessary, use the Options> Add to create additional periods. In the Add Period window
complete the number of periods to be used in the bell schedule. These will include periods for
out of timetable courses for which attendance will be taken.
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Schedule Period

IMaster
Schedules
Courses
Rooms
Structure
Terms

Days

Periods
Details
Bell Schedules

Elementary
Lunch
Configurations

Schedule
Attributes

Rules

Academic Tracks

0O 000D o0 oo oo oo

W, Ims01.myeducation.gov.be.ca/aspen/addDayPeriod da?maximized =falsefideploy...

[m]

X

23 Ims01.myeducation.gov.bc.ca/aspen/addDayPeriod.do?maximized=false&deploym... &

Period count

Number Identifier Name

1 [1 | [Block 1 |
2 2 | [Block 2 |
3 [ | [Block 3 |
4 [4 | [Block 4 |
5 [5 | [Block 5 |
6 [6 | [Block & |
7 [7 | [Block 7 |
8 [8 | [Block 8 |
9 [9 | [1a |
10 [10 | [FI careers |
1 [x | [ Block |

o Iftoo many periods are created in error, re-enter the Add Period window and type in the
number of periods required in the Period count box. This will adjust the number of

periods below to the appropriate number and remove any extras.
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8.5 Bell Schedules

Each date in the school Calendar is assigned a Bell Schedule, indicating the periods offered on
that date and their length. This enables schools to find students throughout their course rotation

using the quick status icon. A

MyEducation BC allows schools to use several bell schedules to operate differently on different
dates of the year. For example, you may have flex day once a week where the period durations
are shorter. This can be accommodated through creating a bell schedule for that rotation and

assigning it to the appropriate calendar dates.

8.5.1 Defining bell schedules

School > Schedule > Structure > Bell schedules > Options > Add

The New Schedule Bell page appears:

Bell Schedules :: Monday ED 1234 - Monday ED 1234

Master y
Optionsv M Reportsw
Schedules
=

Identifier * MED1

Name * Monday ED 1234

Courses
Rooms

Structure
Description Monday ED 1234

Terms Include in scheduling?
Days Number of total minutes | 298

Number of schedule periods | 7
Periods

Bell Schedules Combine days Q

Elementary
Lunch
Configurations MAM
Schedule [}
Attributes
Rules
Academic Tracks s}

Graduation (m]

Recommendation
Controls

ell period number Bell period Identifier

Period name

Monday AM
1
2
3
4
Monday PM

Monday-Friday

Start time

7:30 AM

9:00 AM

943 AM

10:32 AM

11:13 AM

12:00 PM

12:00 PM

I«

End time

9:00 AM
9:38 AM
10:20
AM
11:08 AM
11:50 AM
1.00 PM

1:00 PM

Default Template: -

Duration (Minutes)

e Type a unique ldentifier, Name, and Description for the bell schedule.

e The ‘Include in scheduling?’ checkbox, is functionality that will be used by the build
engine. During initial setup there are no implications of setting this box either way.

e For each period, define the Start time and Duration (Minutes).

e Continue to follow steps 4-8 to define all of the bell schedules the school uses.

the actual schedule.

Note: The start time for each period does not have to be sequential like the period
number order. You can change the order of periods for a particular day without modifying

e To add an additional period for an after-school program, or another extra period not in
the academic schedule, click Add. The Add Bell Period dialog box appears. Define the
Bell period number, Period name, Start time, and Duration (Minutes), and click OK.

e Click Save.
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Note: When a student is enrolled at a primary school that has a bell schedule and a

secondary school that does not have a bell schedule, the “Quick Status” alert displays “No
Schedule day found.”

8.5.2 Using Bell Schedules to Rotate Periods

Note: If a Rotation was created in the Build view, this section is not applicable.

The following pages provide examples of different ways to Rotate Periods using Bell Schedules.
Scenario 1

2-day schedule, 4 regular periods, plus 2 periods outside of the timetable.

This scenario has 4 course rotations — R2, R3, R4 and R5

School > Schedule > Structure > Bell schedule

In this example 4 Bell Schedules have been created, each representing a different rotation.

[ ]
Pages School Student Staff = Attendance Conduct Grades  Assessment Schedule | Gilobal Tools  Admin

Options Reports Help

Bell Schedules

Master 0of4 selected (7 Custom Selection

Name

Description
Schedules o

Rotation 2 Rotation 1.2.3.4
Courses

Rotation 2 Rotation 2,1.4.3

Rooms

Rotation 4

OoOoIEOE

Rotation 3.4,1.2

Rotation 5

Terms Rotation 4,3.2.1

Days
Periods

Bell Schedules
Details

e Click on the Name of a Bell Schedule to view the details.
o Enter Start times for each period to reflect the order in which course periods should

appear for that rotation. For example, to accommodate the second rotation of 2,1,4,3 the
following is the setup.

e Click Save. This will re-order the periods to your defined rotation.

Pages School Student Staff  Attendance = Conduct Grades = Assessment g@ﬂ Global Tools  Admin

Options Reports Help K
Bl : Rotaton 3 - Rotation 2,14, BRREE
[Save](Cancel Defaut Templste -
Master
Schedules dentifier ¢ R2
anes Mame * Rotation 3
Description Rotation2,1,4.3
Rooms
Include in scheduting? | []
Terms Number of schedule -
riods
Days =
Periods
Bell Schedules E=dr Q
> Details
‘Schedule Attributes Bell period number Bell period dentifier Period name Start time Duration (Minutes)
Ep 2 2 8:30 AM 7
Rules
&1 1 1 5:45 AM 7
Academic Tracks
[l | n 1100 AM 7
Recommendation || F1 = 2 1215 FM 75
Controls
[l 5 s 300 P o
Preferences e o o —— o
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In the above example:

Courses scheduled into period 2 will start at 8:30 am.
Courses scheduled into period 1 will start at 9:45 am.
Courses scheduled into period 4 will start at 11:00 am.

Courses scheduled into period 3 will start at 12:15 pm.

Scenario 2

1-day schedule, 8 regular periods, plus 2 periods outside of the timetable.

This scenario has 4 course rotations — R2, R3, R4 and R5

School > Schedule > Structure > Bell schedule

In this example, 4 Bell Schedules have been created, each representing a different rotation.

E—
Pages School Student Staff Attendance Conduct Grades  Assessment Schedule Global Tools  Admin

Options Reports Help =] 7]
Bell Schedules
— 0 of 4 selected £7 Al Records
STTETES [F] |mame: Description
[ |Rotation 2 1 Day & Periods 1.2.3.4
Courses
[7] |rotation 3 1Day & Periods 5.6.7.8
Rooms [ |Retation 2 1Dsy & Periods 2.1.4.3
Terms [ |Retatien & 1Day & Periods 6.5,8.7
Days

Periods

Bell Schedules
Details

e Click on the Name of a Bell Schedule to view the details.

o Enter Start times for each period to reflect the order in which course periods should
appear for that rotation. For example, to accommodate the second rotation of 2,1,4,3 the
following is the setup.

e Click Save. This will re-order the periods to your defined rotation.

Pages School Student Staff  Attendance Conduct Grades  Assessment m Global Tools  Admin
Options Reports Help
Bell Schedules :: Rotation 2 - 1 Day & Periods 1,2,3,4 < < [ |
Master (o] (Gares Defaut Template -
Schedules Identifier * 2
S Name * Retation 2
Description 1 Day & Periods 1224
Rooms
Include in scheduling? =]
Terms Humber of schedule. e
Days periods
Periods
Bell Schedules | Combine days Q
Schedule Attributes Bell period number Bell period Identifier Period name Starttime: Duration (Minutes)
- [ 1 1 220 A =
] 2 2 545 A1 s
Academic Tracks
5] = 3 11:00 AM s
Recommendation || g1 ls A 1215 PM s
Controls
B e e 200 P [
P ] 10 10 200 M ]
Delste

In the above example:
Courses scheduled into period 1 will start at 8:30 am.
Courses scheduled into period 2 will start at 9:45 am.
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Courses scheduled into period 3 will start at 11:00 am.

Courses scheduled into period 4 will start at 12:15 pm.

Pages School Student = Staff Attendance @ Conduct Grades | Assessment ed Global Tools  Admin
Options Reports Help
Bell Schedules :: Rotation 5 - 1Day & Periods 6,5,8,7 IR [ S
Master -m -GB"EE‘ Default Template -
Schedules Identifier * RS
EaEeS Hame * Rotation 5
Description 1Dey & Periods 6,5.3,7
Rooms
Include in seheduling? m
Terms Humber of schedule o
Days periods
Periods
Bell Schedules (0D Q
» Details
Schedule Altributes Bell period number Bell period dentifier Period name Start time Duration (Minutes)
1 ] 8 2:30 AM 75
Rules o
(=] 5 5 9:45 AW 75
Academic Tracks
(=] 8 8 11.00 AM 75
Recommendation El}= 7 7 12:15 PM 75
Controls
] ] ] 2:00 M 0
Preferences e 10 1o 2:00 PM o
Delete

In the above example:

Courses scheduled into period 6 will start at 8:30 am.
Courses scheduled into period 5 will start at 9:45 am.
Courses scheduled into period 8 will start at 11:00 am.
Courses scheduled into period 7 will start at 12:15 pm.

8.5.3 Assigning Bell Schedules to Calendar Dates

School > School > Calendars > Dates > Filter to Days in Session

Use Options > Modify List (for different values) or Options > Mass Update (for a single value) to
update the Days in Session with a Bell Schedule.

8.6 Assigning Calendars to Students
Every student in the school must have a Calendar assigned. Calendars can be assigned
individually in:
School > Student > Details > Calendar
Or for a group of students:
School > Student > Select the students > Options > Show selected
» Confirm the correct students are listed

e Use a field set with the student Calendar field
e Options > Mass Update
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8.7 Assigning Homerooms to Teachers and Students

Homerooms are assigned to teachers individually through:

School > Staff > Details

Homerooms are assigned to students individually through:

School > Student > Details

Homerooms can also be assigned all at once by using either the features of Modify List or
Mass Update.

8.7.1 Assigning Homerooms to Multiple Teachers:

School > Staff > Options > Modify List
Enter the homeroom and save using the green checkbox

Staff List

Details r—y

Attendance

1:Abbotimeevay, Markangel v | (= 0 0f 160 selected &7 Primary Active Staff
SR ; Type i Homeroom Primary HmRm Tchr ~ HomePhone  CellPhone Emaill school > Nan
] Name saffip InclusiveEdRole o' 5 P = he P hs
Schools
) Abbottmcevoy, Markangel ~ $1053038  Teacher BOULAN 136 Y uTEsmninGhicw@v4cTvvryT Mount Bouche
Licenses
O Adamjr, Harinie 51059746 Teacher SCHULT P14 N unuyustp2gw09@xwnn2k5 ni Mount Bouche
Degrees
O Affiick, Rafaslkazuki 51042341 Teacher CROGERS126 Y kukjdngbixcdSuwc@ikehubk gh Mount Bouche

Positions
(J  Agcanas, Zhuhao 51010611 Teacher DRISCQ 019 Y 778-715-3900  778-057-0789  82cxbnilu7cple@ebeljvx fc Mount Bouche

PD
Extracurricular [0  Agnetis, Tuochen 721360 Teacher SM IANSNOW Y 250-873-1457 dxf04qvodip3kixm @4pkva15 et Mount Bouche

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
selected, homeroom can only be selected using the magnifying glass pick list. With this
preference turned on the Next homeroom field cannot be used.

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
not selected, homeroom can be selected using the magnifying glass pick list or homeroom can
be typed as free text. With this preference turned off the user can enter a free text value into the
next homeroom field.

8.7.2 Assigning Homerooms to Multiple Students
8.7.2.1 Option 1: Modify List

School > Student > Field Set including the Homeroom field > Options > Modify List
Select the homeroom for each student and click the green checkbox to save

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
selected, homeroom can only be selected using the magnifying glass pick list. With this
preference turned on the Next homeroom field cannot be used.

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
not selected, homeroom can be selected using the magnifying glass pick list or homeroom can
be typed as free text. With this preference turned off the user can enter a free text value into the
next homeroom field.
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8.7.2.2 Option 2: Mass Update

School > Student > Field Set including the Homeroom field
o Select the students for a single homeroom
e Options > Show selected
e Confirm the correct students are listed
e Options > Mass Update
Repeat as required for all homerooms, setting the filter to All Students to select the next group.

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
selected, homeroom can only be selected using the magnifying glass pick list. With this
preference turned on the Next homeroom field cannot be used.

If the School Schedule preference Homeroom — Require room for homeroom fields on Staff is
not selected, homeroom can be selected using the magnifying glass pick list or homeroom can
be typed as free text. With this preference turned off the user can enter a free text value into the
next homeroom field.
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9.0 School Course Catalogue

Review the school course catalogue and adjust as necessary for the needs of the school.

MyEducation BC introduces the concept of course flavors, which allows a district and/or school
to have the same course code more than once. This is governed by your district preference
settings.

9.1 Creating the School Course Catalogue

School > Schedule > Courses > Confirm Filter is set to Current Year > Options > Add
The Course Pick List pop-up window appears, displaying the district course catalogue.

Ensure the School Level field is set to All to view the entire course catalogue.

Course Catalog: 2016-2017
School Level All
2| AT A i At v ][5 0of 628 selected (7 Schools will only be able to update
Search on GrsCode the values that have been “shared”
A . to the school level in the District
ATT-AM AM Attendance P refe rences.
ATT-PM PIM Attendance
FFRALO9 FRANCAIS LANGUE SECONDE-IMMERSION @ Regular
FFRAL10 FRANCAIS LANGUE SECONDE-IMMERSION 10 Regular For Example: Departments
FSCHFO8  SCIENCES HUMAINES 8 Regular reference code table
LEN-10 LD ENGLISH 10 Regular
LEN--11 LD ENGLISH 11 Regular
LFINA1D LD FINE ARTS 10 Regular
LFINATT LD FINE ARTS 11 Regular
LFINA12Z LD FINE ARTS 12 Regular

e Check the box beside the course(s) required and click OK

e Go tothe Courses side-tab and perform a search for the course you selected.

e Check the box beside the course and click the Details leaf.

e Populate the fields as appropriate for the school.

e Click Save.

e Click on the Grading sub-top tab

o Use the @ icon to select the appropriate Transcript Definition > Name and Rubric if
appropriate for this course.

e Repeat until all courses required by the school are displayed in the Courses list.

Note: Transcript and Rubric Definitions can be mass updated on courses. It is not necessary to
do them individually. Using the Show Selected and Mass Update functions may be appropriate
here.
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9.2 Transcript Definitions

Transcript Definitions are attached to courses at the School View > Schedule Top Tab >
Courses Side Tab. They can be set up for the Current year or the Build year using the
appropriate filter. Use caution assigning for build year in this screen to avoid accidently
changing current year settings.

The Transcript Definition defines the Grade Scale for the marks/scores that are entered into
the report card term columns.

The Rubric Definition defines the Grade Scale for the marks/scores that are entered into the
assignhments.

Use the Report Card Field Set to see Transcript Definition Name and Rubric Definition Name
School View > Schedule Top Tab > Courses Side Tab

All courses require a transcript definition for reporting and transcript creation.

» Assigned to all courses requiring student transcript records and/or Learning Updates

+ Defines columns presented/calculations in Grade Input columns

» Displays on the Learning Update the school is using. Historical Report Card or Learning
Update

» Displays the correct terms (e.g., Single, Trimester, Quarterly)

* Provides the options the school requires (e.g., Calculations, Curricular Competencies,
School Final on report card etc.)

* The Transcript Definition defines the Grade Scale for the marks/scores that are entered
into the report card term columns.

» All courses in MyEducation BC must have a transcript definition if grades, comments or
work habits are to be entered against them.

Refer to the Transcript Definitions Explained document on the L1 Information Station within
MyEducation BC.

Pages School Student Staff Attendance Conduct Grades Assessment EEICLUICEN Extracurriculars Global Tools  Admin

School Courses
Master N > — o -
Options v Reports v Search on CrsNo ) = & 1h = =
Schedules
T:ATT--AM voo> 0 0f 64 selected 47 School Year: 2022-2023
Courses
[J  CrsNo Description GrdLvl  TransDef > Name RubricDef > Name Name
Courses
Details 0O ATT-AM AM Attendance School Comme
Build
Request O ATT-PM PM Attendance School Comme,
Sections
Depart " (0 MADST06-L  APPLIED DESIGN SKILLS AND TECHNOLOGIES 6 06 3 Term K-9 2023 English EMG-DEV-PRF-EXT  Applied Design, Skills & Technologies 6-8  School Comme
epartmen
Cod
odes O MAE—K ARTS EDUCATION K KF 3 Term K-9 2023 English EMG-DEV-PRF-EXT  Arts Education K School Comme
ez 0O  MAE-01 ARTS EDUCATION 1 01 3 Term K-9 2023 English EMG-DEV-PRF-EXT  Arts Education 1 School Comme
Structure O MAE-02 ARTS EDUCATION 2 02 3 Term K-9 2023 English EMG-DEV-PRF-EXT  Arts Education 2 School Comme

School Setup v8.0 Page 61



as .
i MyEducation

Q
FUJITSU

9.3 Creating Course Flavours

The ability to create more than one version of a course requires that specific settings are in
place at the district level. See the District Setup documentation for details on district settings for

this function.

For schools to create flavours, the district must have created a flavour first. Schools can see this
flavour, bring it into their own school and create additional flavours. Consultation with district
support personnel may be required if schools need additional courses created at the district

level.

9.3.1 Creating Flavours at the School Level

School > Schedule > Courses > Details > Options > Copy

o Populate the Number field with the course code you are copying, adding the appropriate
number of characters required by the district preference setting.
e Populate the Flavor field with a description of the copied course — this may be a course
code or description.

| The Flavour field is just a description. The actual course version is the unigue course code. ‘

Pages School Student Staff Attendance Conduct Grades Assessment R CLINEE Extracurriculars  Glc
School Courses :: 2022-2023 - MCH--12 - CHEMISTRY 12
Master i
Options v Reports v Help »
Schedules
Auto-saved at 9:01 AM
Courses ——
General Grading
Courses ., dev03.myeducation.gov.bc.ca/aspen/cloneCourse.do?m... — O X
Detail
g E:mc:s Master type * Class @ dev03.myeducation.gov.bc.ca/aspen/cloneCourse.do?maximiz... @ N
Request
! Number * MCH--12 0
Sections m MCH-12A
Description CHEMISTRY 12 O
Department Flavour = (Chem 12| )
Codes Short description MCH--12 v']
EXTERNAL COURSE CODE CH 12 |
Department Science 0
Structure
LANGUAGE 0
Schedule MARK GRADE TYPE Teacher preparation code
e Click Save.

e Return to the Courses side tab.
e Populate the details on the General and Grading tabs for the flavour.
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9.4 Adding Transcript Definitions to Historical Course Catalogues

This task is necessary to allow the school to add historical course records to students
registering in their school from other jurisdictions.

School > Schedule > Courses > Filter for Year =? > Enter the Historical Year missing Transcript
Definitions

9.5

'Seal‘-ﬂcn CrsNo I L( l

Manage Filters. ..
¥ Current Year
pn Build Year b
All Records
IMMERSION, i
2012-2013 Courses
SH12 Course Code Contains?
TING 12 Grade Level =7 il
Included in Scheduling
CTION TO R( i
Year = 7
ies 09 Anp

Confirm the correct records are selected
Options > Mass Update > Transcript Definition
Select the Transcript Definition

Click Update

Creating Course Sections

If a master timetable has been committed as an Active Schedule from the Build view, sections
will already be populated for the courses. Additional sections can be created individually or
several sections can be created at once.

951

Creating an Individual Course Section

School > Schedule > Master > Options > Add

Number: select the Course from the picklist

Section Number: will auto populate, change if needed for school name/numbering
conventions

Primary Staff > Name: select the main/primary teacher for the course section

o Forinformation on adding co-teachers or multiple co-teachers to a course section
or multiple course sections, refer to documentation: Master Schedule
Management, “Add Co-teacher(s) to Multiple Course Section(s).”

Schedule Term > Code: select the schedule term from the pick list

Enrolment maximum: enter the maximum number of students allowed for this course
section

Enter remaining optional fields per school/district policy
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e Click Save

Pages School Student Staff Attendance Conduct

Sections

Teachers

Roster Master type

Matrix View Number *

Section number *

Classes
Primary Staff > Name
Class Size
Summary Primary Room > Number
Schedule Term > Code
Schedules
Schedule
Courses
Rooms
Team
Structure P
Schedule Section type
Attributes
Platoon
Rules

Master Schedule :: MCH--11-005 - CHEMISTRY 11

Master )

Options » Reports v
» Details

) Save Cancel

Class
MCH-11 Q
005
Adarsh, Yeol
103 Qx
31 Qx

1(1) 2(2) 3(3) 4(4)

Grades

Assessment

aQx

Schedule STUEETHTIETCEEN eIl

Identifier

Enrollment maximum 35
Enroliment total 0

Is section closed at max enrollment?
Study criteria

Schedule Rotation > |dentifier

Is inclusion section? O

Track ID

Team schedule mode
House schedule mode
Section type schedule mode

Platoon schedule mode

Tools J

I

9.5.2 Creating Multiple Sections for a Course

Step 1: Define the number of sections

School > Schedule > Schedule Attributes > Options > Modify List

Enter the number of sections you require for each course and click the green checkbox to save

Step 2: Initialize the sections

School > Schedule > Master > Select the courses that require additional sections

e Options > Show Selected

e Confirm the course sections selected

e Options > Initialize Sections

Refer to Master Schedule Management documentation, “Add Co-teacher(s) to Multiple Course

Section(s).”
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10.0 Lockers

School view > School > Lockers > Options > Add

e Populate the Number field with the locker number.

o Populate the Combination code field with the locker combination.

e The Comment field can be used to record additional information, as required.
e Click Save.

Click into the details of the lockers to modify or delete using Options > Delete

Lockers can be assigned to students through the Student top tab.
e Student > Details: select the locker from the picklist for one student

¢ Modify List: The locker field can be added to a field set for populating multiple students.
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Appendix A — Master Select Fields
The Master select field in the school preference of scheduling, controls the columns and order
of columns on the pop-up window, in the Student > Schedule > Workspace > button Select...

Columns can be added, removed, and re-ordered within this preference setting (School view >
School top tab > Setup side tab > Preferences leaf > Category = Schedule).

By placing the Java name in the Master select field, the column name will display.

The default fields are:
courseView,staffView,description,sectionClass.name,sectionClass.id,termView,unrotatedSched
uleDisplay,scheduleDisplay,enrolimentTotal,sectionClass.enrollmentTotal,enrolimentMax,sectio
nClass.maxEnrollment,fieldA004,fieldA0O5,fieldA006,fieldA007,fieldA008,fieldA009,fieldA010,fie
IdAO011,fieldA012,fieldA013,fieldA014,fieldA015,fieldB002,enrolimentMaxCloselndicator,section

Type,teamCode,platoonCode,inclusionindicator

NOTE: Ensure each Java name is separated by a comma.

Java name Column Name Description

(what is displayed)
courseView Course Shows the course code and section #
description Description Course Description (per district preference)
staffView Teacher Teacher
termView Term Schedule Term

unrotatedScheduleDisplay

Unrotated Schedule

Unrotated Schedule value - only populated if
schedule has been rotated.

scheduleDisplay Schedule Day and Period
enrollmentTotal Total Total students in the section
enrollmentMax Max Maximum number of students that can be in

this section

enrollmentMaxCloselndicator

Closed at Max?

Is the section closed when maximum
enrollment is met?

sectionType SecType The name of the section type

teamCode Team Team name

platoonCode Platoon Platoon nhame

inclusionindicator Inclusion? Is this section flagged as an Inclusion section?
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The following fields were added to the default values in the Master select field in December 2017,
as part of the 5.8 release of MyEducation BC.

Java name Column Name
fieldAOO4 A
fieldAOO5 B
fieldAOO6 C
fieldAOO7 D
fieldAOO8 E
fieldAOO9 F
fieldAO10 G
fieldAO11 H
fieldAO12 K
fieldAO13 P
fieldAO14 Q
fieldA015

fieldB002 ELL
sectionClass.name Name
sectionClass.id ID
sectionClass.enrollmentTotal|ClassTotal
sectionClass.maxEnroliment |Class Max
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Appendix B: Miscellaneous Reference code

Miscellaneous code to be displayed under the student demographics template can be entered
under District and/or School View

School View > Student Top Tab > Details Side Tab > Miscellaneous Sub Top Tab

Details
(e~
Contacts
Altendance —
Demographics Addresses Alerts Citizenship Programs Permissions L‘aga:ﬁﬁ_: & Buses Miscellaneous
Conduct
Transcript Miscl
Misc2
Assessments
Misc3
Academics Miscd
Schedule Misc5
Misc6
Membership
Misc7
Transactions Misca
Documents
Al Risk

Admin TT > Data Dictionary ST > Reference > Miscellaneous 1 Fields > Codes > Options > Add

Enter Code and description

Reference code cannot exceed 25 characters

Pages School Student  Staff Attendance Conduct Grades Assessment Schedule  Extracurriculars Global Tools

Reference Tables :: Miscellaneous 1 Fields 4« <«

Reference

» Codes
Fields.

ROOT  ListView>>  Categories Only
0072 selected £7

Comments
[] Code Description Disabled State Owner Category Category?

Licenses
O Code 1 Code 1 N AE Perry Elementary (School) N

Logs O Code 2 Code 2 N A E Perry Elementary (Schoel) N

There are eight miscellaneous field reference tables.
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L Pages School Student = Staff Attendance Conduct Grades  Assessment Scl ule ' Extracurriculars = Global e Admin
Reference Tables
Reference . —
Codes
Fields 0of 8 selected (7
Comments [] Name Category Owner ExciCodeMgt
FEgisEs ‘ []  Miscellaneous 1 Fields Student All (Enterprise) N
[]  Miscellaneous 2 Fields Student All (Enterprise) N
Logs
O Miscellaneous 3 Fields Student All (Enterprise) N
O Miscellaneous 4 Fields Student All (Enterprise) N
O Miscellaneous 5 Fields Student All (Enterprise) N
[]  Miscellaneous 6 Fields Student BC (Enterprise) N
[]  Miscellaneous 7 Fields Student BC (Enterprise) N
O Miscellaneous & Fields Student BC (Enterprise) N

Codes added to these reference tables can be used on the student demographics template on

the miscellaneous tab.

Student List :: 03 - Amayarojas, Ellisegrace o Q
Details .

ca
Contacts
Attendance

Demographics ~ Addresses Alerts Citizenship Programs Permissions La’éﬂ:‘;g: E
Conduct
: Misc1

Transcript

Misc2 Code 2 I%
Assessments

Misc3
Academics Miscd
Schedule Miscs

Misc6
Membership

Misc?
Transactions Misc8
soners
At Risk

Buses

Miscellaneous
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