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1.0 Introduction to Student Scheduling 

Student scheduling or student timetabling is managed in the School View from the Student top 
tab, by selecting a student and clicking on the Schedule side tab. Student schedules can be 
built manually or from course requests. Individual student timetables are viewed, printed, or 
published from the Schedule side tab > Reports. Schedules are changed in the Workspace sub-
side tab. 

2.0 Security Roles 

Student>Student Course Request>Default is checked allowing security roles to make changes 
to course maximum when adding student to a class. 

• Column = Other, checkbox = Allow course maximum override 

• Check the setting on security role assigned to staff, Admin Top>Security Side Schedule 

Builder security role does have this. 

• Teacher security role does not have this. 
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3.0 Student Schedule 

3.1 Viewing a Student Schedule 

From the Student List, click in the box to the left of the student’s name to select the student, 
then click on the Schedule side tab. Users are presented with the option of either a List View or 
a Matrix View. 

3.1.1 Matrix view  

Matrix View provides a chart display of the student’s schedule with days across the top and 
periods down the left side. The top block provides the means of selecting a school (if the 
student is taking courses at secondary schools).  A time frame drop-down list allows for the 
selection of schedule terms offered at the school (e.g., Full year, Semester 1, Semester 2, or 
the option of Today). 
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If the School Preference (School > Preferences > Category=Schedule > Default time filter to 
date=CHECKED), then the option to view the schedule on a specific date is available: 

 

 

3.1.2 List View 

The List view can be helpful where a school has multiple days, periods, and terms which can 
result in the matrix looking overly complicated. 
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3.2 Printing a Student Schedule 

Individual student schedules can be printed or published as either a Student Schedules Matrix 
BY TERM report or a Student Schedules Sheet BY TERM report. 

Student TT > Schedule ST > Reports > Scheduling Reports  > Student Schedules  
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3.2.1 Print or Publish 

Student Schedules can be Printed or Published to the Portal. 

 

 

 

 

In the parameter form, the following options display: 

Field Default Description / Comment 

School Current School 
of the user. 

The user is not able to change this value. 

 

Term Blank Users can select a single, multiple or all terms.  The number of terms 
presented is based on the school’s structure. 
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Field Default Description / Comment 

Days to 
include 

Blank Users can select a single, multiple or all days.  The number of days 
presented is based on the school’s structure. 

Periods to 
include 

Blank Users can select a single, multiple or all periods.  The number of periods 
presented is based on the school’s structure. 

Course 
Identifier 

Blank User can select this option to be displayed on the report based on the 
availability of data 

Team Blank User can select this option to be displayed on the report based on the 
availability of data 

Platoon Blank User can select this option to be displayed on the report based on the 
availability of data 

House Blank User can select this option to be displayed on the report based on the 
availability of data 

Study 
Criteria 

Blank User can select this option to be displayed on the report based on the 
availability of data 

Print Text 
box 

Blank User can select this option to display a box on the report before the student 
schedule 

Students to 
include 

All Options are All, YOG, Homeroom, Guidance counselor or Snapshot 

Search 
value 

Non-enabled This field is not enabled with the above option of All. 

For all other Students to include values, it is a free form text box. 

Sort 
students by 

Name Options are Name, YOG, and Homeroom 

Effective 
Date 

Current date Effective date can be used if, there are schedule changes in a Pending state 
(i.e. future or past add/drops) This field displays if the School Schedule 
Preferences allow for future or past add/drops 

Max days 
per page 

Value from 
UDF 

Days to display can be selected by the user. A default value can be set for 
the school in School>Setup>details or District>Schools>Details – see School 
Setup Guide for more information  

Print Page 
Number 

 Checked This option is checked by default, this will print the page number on each 
page 

Format Adobe 
Acrobat(PDF) 

Options are Adobe Acrobat(PDF), Web Page (HTML), Microsoft Excel (XLS) 
and Comma separated values (CSV) 
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3.3 Printing Multiple Student Schedules 

Printing and publishing multiple student schedules can be done using Student Schedule (Matrix) 
or (Sheet) BY TERM. All - generates student schedules for all students in the school.  

This can be done in the School View and the Build View. 

Schedule TT > Master ST > Reports > Scheduling Reports > Student Schedules 
Or 
Student TT >Reports > Scheduling Reports > Student Schedules  
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4.0 Workspace 

It is in the Workspace that a student’s schedule is managed; courses are added, dropped and 
the schedule posted. To adjust a student’s schedule, go to Student TT > Schedule ST > 
Workspace ST. Users have the option of a List view or a Matrix view. 

MyEducation BC offers the ability to enter course requests in the current year and use the 
Reschedule functionality to determine the best placement of course sections. Reschedule 
considers the load rules when determining the best placement.  Changes made with the 
Reschedule function are not permanent until posted.   

Course sections can also be directly selected and manually scheduled, using the Matrix view. 
Where the latter method is used, an Update option is provided to pull the courses from the 
student schedule matrix into the Course Requests. 

Where schools have selected Allow future add/drop as a School > Set up > Preference under 
the Category > Schedule, users will be able to set future dates for a student’s schedule change 
to take effect. Although enrollment totals will display a current enrollment number, the 
application will include these future changes when applying maximum enrollments. 

4.1 Using the Workspace in the Build View Prior to Committing a 
Schedule 

Prior to or following End of Year Rollover (EOYR) and prior to committing a scenario, from the 
Build View, student schedules can be managed. This will include students who need a schedule 
change, or new students to the school.  

Users with the additional security role of Schedule Builder Limited can access the Workspace in 
the Build View. The user will change view to the Build View and must select the correct scenario 
from the Scenario top tab and click on the scenario to lock it in. Then go to the Student top tab > 
Options > Refresh. This will bring in any changes to the student enrollment including newly 
admitted students. Once this is done, access the Workspace from, Student (select the student) 
> Schedule > Workspace. Managing the students schedule in the Build View then follows the 
same processes and functionality outlined below.  
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4.2 Matrix View 

The matrix view divides the screen into two sections, the schedule matrix on the right and 
course requests on the left. From the List View, click the hyperlinked Matrix View found at the 
top right of the screen. 
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4.3 Matrix View: Course Requests – Left Side 

Primary requests are displayed at the top of the left side of the screen. 

• Requests can be entered in the Number field by typing the course codes separated by a 

comma and then clicking the Add button. 

 

 
 

• The Select button opens a pick list of courses to choose from. Multiple selections can be 

made using this method. 

 

 

• Drop All will remove all course requests. 

• Update button adds course request for sections directly into the schedule matrix.  

• Primary requests displayed at the top left of the screen provide a variety of active 

functions for the student schedule builder.  

 

Hovering over a request with the mouse, highlights where in the matrix sections of the 

course are offered. Course requests can then be dragged and dropped into those areas. 

It is best to click on the course description rather than the course code so as to avoid 

opening the course details popup. See Work Mode below for settings related to drag-

and-drop functionality. 
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A red X provides for the deletion of an individual request.  

 

Clicking on the blue hyperlinked course code opens course request attributes.  For the 

course to be considered in the Inclusion count, the request must be marked as an 

inclusion request in the window. 

 

Course descriptions displayed in bold red indicate course requests that have not been 

scheduled. 

 

The Allow over max check box provides the user the ability to override the course 

maximum enrollment setting for scheduling the request. 

 

• Alternate. Alternates are determined by dragging primary requests into this area. 

Should a request populate this area, it can be dragged into the primary request field or 

deleted altogether using the red X. 

 

• Secondary requests are those courses students are taking from another school. These 

fields are only displayed when a student is enrolled in a course from a secondary school. 
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4.4 Matrix View: Schedule Matrix - Right Side 

 

• Percent scheduled - Class credits shows the percentage of the schedule that has 

sections scheduled. This can be misleading where there are periods outside of the 

“regular” day as is the case in the example above. The system includes all periods in the 

timetable and calculates the percent accordingly. Set the Term code to FY for the Class 

credits to display all the classes scheduled at the primary school. If courses appear 

missing based on the credit count, this is due to those being calculated from courses 

taken at secondary schools. The List view is more suited to the display of all courses 

from all schools. 

• Term Code can be changed to view the schedule by term, semester, or full year (FY). 

Setting to FY will include all the terms as well as full year providing a more 

comprehensive view. 

• Work Mode by default is set to manual. This allows for the drag-and-drop of course 

requests into open periods of the student schedule. Change to Auto-Shuffle to drag a 

course from the left and drop on a space that is already scheduled, bumping out the first 

class and returning it to the Request list where it will display in red. 

• Checkbox for Allow Conflicts, if selected, will allow more than one course to be placed 

in the same period on the matrix. This can be used temporarily in trying to work out the 

schedule. In DL or Alternate schools, this would provide the “Flex Ed” ability of entering 

multiple classes in a single period. 

• Allow All Over Max checkbox will allow classes to be scheduled that have reached 

maximum enrollment. 

• Allow over inclusion count this will only appear if an Inclusion count has been defined.  

This is done from the Schedule top tab > Preferences side tab > Category=Scenario-
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basic > Control inclusion students.  Checking this box will allow you to ignore the value 

defined in this preference. 

• Each period on the matrix displays the scheduled class and two symbols, a red X to 

drop the class and a Padlock to lock the class so that it can’t be moved when 

Reschedule is used. 

• Course (think section) text entry box under the lower left side of the matrix allows direct 

entry of course section numbers separated by commas. This field is case sensitive and 

must include the correct code with section number. Once entered, click Add. 

 

 
 

• Ignore Warning checkbox allows a class to be scheduled despite a conflict. 

• Drop All button drops all classes from the schedule. 

• Lock All locks all classes currently on the schedule. 

• The Reschedule button will generate a schedule based on the Course Request list and 

class availability. See Appendix A for further information on using Reschedule and 

addressing validation errors. 

Changes within the matrix can be made dynamically. Clicking in an empty space 

automatically opens the Schedule Master Pick List with the Period filter defaulting to 

the period clicked. 
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Course sections can be dragged from one period to another open period. 

 

 
 

Where changes have been made, an asterisk (*) will display beside the course code 

indicating that the current schedule has not yet been posted and committed. 

 

 
 

• Post and Revert buttons are located on the lower right corner of the screen.  After 

sections have been dropped and changed, the Revert button can be used to restore the 

schedule to the last posted version.  When satisfied with the schedule, click Post to 

commit the schedule.  

• The transcript message only appears after you hit 'Post' to finalize the course changes. 

• Where a transcript already exists for a student, moving to a new section of the course 

will trigger the Update transcripts to new section popup shown below. This allows the 

user an option to merge the transcript record for the new course section with the one 

already created; thereby avoiding a second record for the same course.   
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After the new transcript is created, schools can use the Update Gradebook function to move 
selected information in the grade and date transcript columns of the new transcript record into 
the Gradebook and Grade Input screens of the new course section.    

o Grades > Transcript > select Transcript(s) > Options > Show selected > Options > 

Update Gradebooks 

  



 

Student Scheduling  v3.5 Page 19 

4.5 Viewing Designation/ELL and Classes Totals 

4.5.1 Designation/ELL/Remedy 

The number of students with a Primary Designation or ELL (including ESL) or Remedy will 

display on the popup window accessed from the Student > Schedule > Workspace > Select… 

button, in both the School and Build views.  The choice of columns and order displayed, can be 

controlled through a School level preference; see the School Setup reference guide. 

 

  

 
These totals are automatically updated when a student’s schedule is Posted. 

If a student’s Primary Designation or ELL program participation or Remedy is added, deleted, or 
changed there is a manual procedure, to update the class composition for course sections. 

This procedure, is available in the following locations: 

School view: 
Student > Select a student > Membership > Programs > Options > Update Designation/ELL 
Tallies. 
District view: 
Student > Select a student > Membership > Programs > Options > Update Designation/ELL 
Tallies. 

Tools > Jobs > Options > Add…> 
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1. Select a Tool = Procedure 

2. Procedure = Update Designation/ELL Tallies 

3. Input parameters > Select All Active Schools or an individual school 

Build view 

Workspace top tab > Master side tab > Options > Update Designation/ELL Tallies > Choose a 
Scenario. 
 
When the manual procedure is run, it runs for all students, given the parameter selection. 

4.5.2 Classes Totals 

The Classes Name, ID, ClassTotal and ClassMax will display on the popup window accessed 
from the Student > Schedule > Workspace > Select… button, in both the School and Build 
views.   These totals are automatically updated when a student’s schedule is Posted. 

 

These values will only be displayed if a Classes grouping has been created.   Classes created 
are in the following path: 

School view > Schedule TT > Master ST > Classes > Details 
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The table below matches the column names with the field, on these two screens 

Workspace column name Classes screen 

Name Name 

ID Identifier 

ClassTotal Class enrollment total 

Class Max Class maximum enrollment 
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4.6 List View 

The List View provides an alternative means of managing student schedules. To access the List 
View from the Matrix View, click on the hyperlinked, List View found at the top right of the 
screen. 

The window is divided into an upper block displaying the Student Schedule and a lower block 
of Course Requests. Schedule terms, periods and days [Per(Day)] are shown in the fields 
provided. This view offers a “cleaner” display of the list of classes and course requests. 
Counsellors may prefer this view as it is easy to see if the student has the correct number of 
classes scheduled. This view does not offer the drag-and-drop feature available in the matrix 
view. 
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4.7 List View: Upper Block - Student Schedule 

Clicking in the header of any fields in the Student Schedule block will sort the field.  The List 
view displays all classes scheduled, including those from other schools. This is very helpful for 
the counsellor to determine if classes are missing. In the example below, the Schedule field has 
been sorted which makes it easy to see that each of the regular day periods 1(A-B) through 4 
(A-B) have a class assigned for each semester. 

 

 

Classes in the List View can be selected and dropped. They can also be added using the 
Course field or the Select option. To the far right of the screen is the Lock field provided for 
use with the Reschedule function. 
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4.8 List View: Lower Block - Course Requests 

Course requests are managed in the List View using the Number/Add, Select or Drop options. 
Course requests can pull from classes directly entered into the Student Schedule using the 
Update button. The drag-and-drop feature is not an option in this view. Courses offered from 
other schools also display in this view along with the school’s name. Note that Planning 10 at 
the bottom of the requests in the example below, is taken from a secondary school. Courses 
can only be managed by the schools to which the request is made.  

 

Courses not scheduled display the description in bold red with an Add… hyperlink. Clicking this 
link opens the Schedule Master Pick List filtered to the sections of the course selected. 
Sections can be selected to fill openings in the student schedule. 
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4.9 Future Add/Drop Classes 

Where the school preference to Allow future add/drop is set to yes, an option will be presented 
at the top of the screen to View and make changes as of, with a date field provided. An 
additional block, Pending Student Schedule Changes will be found in the List View between 
the Student Schedule and the Course Requests. In the Matrix View, this is presented in the 
bottom right block. 

Set the date for the change to take effect and add or drop the appropriate class(es) as usual. 

 

 

Posting changes will generate a popup indicating the effective date. 

 

The Pending Student Schedule Changes block displays all pending changes. 

 

Changes to the date displayed in the View and make changes as of field will display the 
student schedule as of that date. A date set beyond the effective dates for changes will show 
the schedule after the changes, a current date will display the schedule at this point in time. 

Note: Enrollment totals on sections reflect the current date, not future changes. However, 
modifying class rosters will take into account pending changes. For example, if a future 
addition will meet the maximum enrollment, trying to add another student in the interim will 
not be allowed generating a popup message that the class is full. 
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5.0 Additional Scheduling Tools 

5.1 Change History 

Change History is found from Student > Schedule > Change History. A record of posted 
schedule changes is displayed showing what was changed, when, where and by whom. Note 
that these records can be deleted. 

 

 

5.2 Student Schedule Change History in Global Top Tab 

Student Schedule History is accessible from Favorites Side Tab>Student Schedule Chang 
History 
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5.3 BC Student Course Change History Report 

School View>Student TT>Reports> Student Course Change History 

The report displays all the Add/Drop records for a student within the selected date range 

 

In the pop-up parameter screen enter the date range of the records to include, the students to 
include in the report and the desired format of the report.  

Note: The BC Course Change History - for Auditors report, prints the BC Course Change 
History report with a page break between students for audit purposes. 

5.4 Colour Coded Departments 

Departments can be colour coded so that those viewing a student’s schedule in the matrix view 
can more easily distinguish classes of a given department.  

These colours can be assigned from the Schedule top tab > Courses > Department Codes.

 

Classes will be displayed in the student’s schedule > matrix view, in the department selected 
colours.  
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5.5 Conflicts 

The Conflicts sub-side tab provides a view only matrix which shows sections offered, with 
those scheduled highlighted in blue. The Comment field will indicate if a course request was not 
fulfilled. Clicking on a scheduled period will display the Schedule Master Pick List for that 
section with enrollment totals and max. This does not take into account Classes groupings. 
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Appendix A: Reschedule 

The Reschedule functionality assesses the master schedule structure and enrollments to find a 
“best fit” for the student. In doing so, if any aspect of the schedule structure is not complete or if 
the expression and matrix are out of synch, the result will be validation errors. Building a school 
schedule in MyEducation BC using the builder will minimize the likelihood of these errors. 

 

 

Should there be validation errors, click on Messages to view the validation errors. Helpful filters: 
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From Schedule > Master two filters are provided to assist schedulers in identifying areas that 
may interfere with the use of using the Reschedule functionality as well as those affecting 
structural integrity of the schedule. 

• Schedule Validation - This filter provides a list of sections missing a schedule term or 

schedule expression.  

• Schedule expression out of synch with matrix - This filter provides a list of courses for 

which the schedule expression and matrix are out of synch. From the Schedule > Master 

use Options > Synchronize Schedule. The popup parameter window allows the user to 

choose the Current selection from the list or All sections. Depending on whether the 

matrix is correct, and the schedule expression is wrong, or whether the expression is 

correct and the matrix is not, will determine which option to select for Synchronize 

schedule. Hovering the mouse over the green exclamation mark to the right of the option  

 

 

Some common validation errors include: 

• Teacher cannot be blank: assign a teacher to the section 

• Teacher is not a valid teacher: teacher must have include in scheduling (Staff > 

Schedule > Attributes) 

• Schedule expression out of synch with matrix: use filter of same name from Schedule > 

Master to find course sections for correction 

• Schedule bitmap is empty or invalid: use Schedule Validation filter from Schedule > 

Master to identify sections in need of attention 

 

Note: Student schedules can be manually entered and Posted without using the 
Reschedule procedure. 
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Appendix B: Scheduling Reports 

5.6 BC Student Course Change History Report 

School View>Student TT>Reports> Student Course Change History 
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5.7 BC Scheduled Student Report 

The BC Scheduled Student Report provides schedulers and counselors a list of students which 
have too few courses scheduled or too many courses scheduled. The user has the ability to 
search based on Term, Day and Period. 

Run the BC Scheduled Student report to view the courses each student is scheduled in based 
on sections and/or course credits 

Use the results to determine if you need to change any student course sections scheduled 
information and update student schedule if/when required  

Report can be run form Build View or School View 

 

SCHOOL VIEW 

To run the BC Scheduled Student report: 

• Log on to the School view. 

• Student Top Tab 

• On the Reports menu,  

Click Scheduling Reports> BC Scheduled Student Report: 

 

BUILD VIEW 

To run the BC Scheduled Student report: 

• Log on to the Build view. 

• Select Scenario  

• Click the Student Top Tab. 

• On the Reports menu,  

Click Scheduling Reports> BC Scheduled Student 

Report: 
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In the pop-up parameter screen enter the students to include in the report, the Term, Day and 
Period of the records to include, and select the number of either Course Sections or Credits 
you would like to see displayed.  

User can also select to sort the results by YOG or Name and can filter students based on the 
Include in Scheduling flag. 

 

 

Note:    You can run the report by Course Sections or Course Credits 
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Field Description 

School The school’s name will be displayed in a read-only 
field. 

Student to Include This field is auto populated with current selection 
by default and contains following values in the 
dropdown 

- All 

- Current Selection 

- Snapshot 

- Grade  

Search Value This field is disabled by default. When grade or 
snapshot is select from the dropdown “Students to 
include” this field gets enabled for the user to 
enter value. 

Term This is a mandatory field and it blank by default. 
The user can select one or multiple terms using 
this option  

Select number of course sections or credits This field is auto populated with course section by 
default and contains following values in the 
dropdown 

- Course Section 

- Credits  

Only show students with This field is auto populated with Greater Than by 
default and contains following values in the 
dropdown 

- Greater Than 

- Greater Than or Equal To 

- Less Than 

- Less Than or Equal To 

- Equal 

Number This is a mandatory field, and it is blank by 
default. The user needs to enter a number from to 
filter the report 

Sort Results by This field is used to sort the report. This will be 
auto populated with YOG by default and contains 
following values in the dropdown 

- YOG 
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- Name 

Students Include in scheduling  This is a checkbox field which is checked by 
default. This option will filter the data and display 
the results based on students which are include in 
scheduling only  

Format This dropdown is auto populated with adobe 
acrobat value by default, but it also contains 
following options  

- Adobe Acrobat (PDF) 

- Webpage (HTML) 

- Microsoft Excel (XLS) 

- Coma Separated (CSV) 
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5.8 BC Unscheduled Periods report 

 

The Student Unscheduled Periods report collects student data based on the student's Primary 
School. 

This report does not include build year information. 


