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Confidentiality

This document contains is proprietary and confidential to Fujitsu Consulting (Canada) Inc. (including the
information of third parties, including but not limited to, Follett of Canada Inc., submitted with their
permission). In consideration of receipt of this document, the recipient agrees to treat this information as
confidential and to not use or reproduce this information for any purpose other than its original intent or
disclose this information to any other person for any purpose, without the express prior consent of Fujitsu
Consulting (Canada) Inc. (and any applicable third party.)
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1.0 Overview

The transfer of demographic and course data between schools and the Ministry is necessary for
the administration of provincial exams and graduation assessments. The Ministry uses this
information to produce transcripts of grades and school completion certificates on behalf of
schools.

This reference guide will provide users with the knowledge required to successfully perform
these functions using MyEducation BC.

1.1 Objectives

Topics covered will include:

e TRAX process and timeline

e How to create Graduation Assessments

e How to produce a TRAX extract in MyEducation BC

e Description of the three types of files created by a TRAX Extract: CRS, DEM and XAM
Files.

e Scenarios that schools will encounter for reporting TRAX and how to ensure information
is entered correctly for each. These scenarios include:

o Deferrals
o Adult

o Challenge
o Rewrites

¢ How to review Student Exam Results

1.2 Procedures

There are two procedures related to TRAX:

e Posting Course Dates procedure: creates a transcript record, sets start and end dates
for courses submitted to TRAX.

e Calculate Credits procedure: assigns credits for all completed courses including
examinable courses that have a passing mark / blended mark

1.3 Key Points

o Assessment records create graduation assessment requests and store the results
o Assessment records are where the results are uploaded when they are received from
the Ministry of Education.

TRAX v3.2 Page 4
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All courses need End Dates. Non-examinable courses need end dates for the CRS file.
If a student transcript record exists, the course End Date is taken from that record. If no
transcript record exists, End Dates are taken from the school’s course structure values.
Students who completed a course in a previous year and are writing the exam in the
current year, need an Assessment record with a current year exam session date. If the
student has not written the exam previously, edit the session date and location
information for Session 1. If the Student is rewriting the exam, enter the session date,
location and mark information in Session 2 fields.

Always select the appropriate definition in the Assessment Definition area to see all
the fields and filters for any graduation assessment.

Assessment Definition [LITERACY ASSESSMENT 12 |Q A

Assessment records will always be associated with the school the student is taking the
course in. The Location may need to be changed for where the exam is going to be
written.

TRAX v3.2 Page 5
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e Students must have a Primary Program of Study assigned that will define graduation
requirements for the student. The Primary program study checkbox must be checked in
the Program of Study details. The TRAX extract, School Transcript and DVR reports will
not run correctly without a Primary Program of Study attached to the student. See
Enrolment Management and Student Demographics for details on assigning the program
to the student details.

7 records &7
Name Credit  Description
@ 2004 - Graduation Program 20.0 2004 Graduation Program
() 2018 - Graduation Program 80.0 2018 - Graduation Program
() Adult - Graduation Program 20.0 Adult Graduation Pregram
) School Completion Cert Program 0.0 School Completion Certificate Program
(7 ZZ7- 19895 -Graduation Program 520 1995 Graduation Program
() ZZIZ-DoNot Use 20.0 ZZ7 - Do Mot Use
() ZZ7 - School Completion Cert 0.0 Z77 - School Completion Certificate -DO NOT US
3

Student List :: 11 - :: 2018 - Graduation Program ﬁ
Details
Contacts

Attendance

(E=Te—Grasuaton Program Jax

Conduct

800

Transcript 2018 Graguaton Program

Credit 2018 - Graduation Program
umm

Summary

Grade Point Progra
Summary Desery

Programs of
Study
+ Oetais
primary?

Graduation
Summary Requirement Waivers

Assessments

> Cade > unit >Type Description Reason

Academics No maiching racords
Schedule

Mambarship m m

Transactions

Documents
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2.0

1.
2.

2.1

Who is Included in the TRAX Extract?

Students that are Primary to the school in grades 10-12 or with grade 10-12 courses.
When a student is withdrawn or deceased, TRAX extract will create the DEM record and
any XAM records for the student (but NOT CRS records).

Multiple XAM and CRS records are created based on the students’ courses and whether
they are registered for any Graduation assessments.

All courses are to be reported only once per student, in the CRS record.

Home School Not in MyEducation — check box

The student’s primary school is responsible for reporting achievement to TRAX. In order for the
MyEducation BC system to exclude students from the TRAX extract all students whose home
school is not in MyEducation BC, must have the “Home School Not in MyEducation” checkbox
checked. This field is located at:

School view > Student top tab > Details side tab > Demographics sub-top tab

2.2

Home School Mot in
MyEducation

The DEM File

One demographic record will be created for students (including withdrawn students), who are:

Enrolled in Grade 10, 11, 12, SU and GA, or

Registered in the Adult Graduation Program, or

Enrolled in a grade less than 10, but registered in a provincially examinable course in the
current school year and scores (returned) are blank, or

Enrolled in a grade less than 10, but registered in non-examinable grade 10, 11, 12
courses, or

Registered in the School Completion Certificate Program (‘'SCCP”’).

Does not have the Home School not in MyEducation checkbox checked

TRAX v3.2 Page 7
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2.3 The CRS File

Course records will be created for non-examinable courses for students who are:

e Enrolled in Grade 10, 11, 12, SU and GA

o Registered in the Adult Graduation Program

e Registered in the SCCP Program (School Completion Certificate Program).

e Enrolled in Grade 08 or 09, but completed/enrolled non-examinable grade 10, 11, or 12
courses

For the above students, all completed and currently enrolled non-examinable courses that are at
the grade level 10, 11, 12, SU or GA will be extracted.

2.4 The XAM File

Exam records will be created for students who are:

e Enrolled in Grade 08, 09, 10, 11, 12, SU and GA and have graduation assessment
records in the current year.

o Registered in the Adult Graduation Program who have opted to write the graduation
assessment and have assessment records in the current year.

TRAX v3.2 Page 8
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3.0 TRAX Process Summary

3.1 First Submission

Tasks are displayed in the order normally associated with the TRAX process.

Timeline | Task Path Resource
Aug/Sep Schedule students into courses — Student top tab > Schedule side Student Scheduling
ensure all students are scheduled into | tab
their courses, including provincially
examinable courses.
Sep/Oct Remove current year “orphaned” Grades top tab > Transcripts side | TRAX reference guide
transcript records, if applicable. tab > set dictionary icon to All >
This will happen when a student set filter to No Student Schedule
changes schools and the transcript Equivalent.
record for a course has been created In the pop-up,
but does not have an equivalent Set School Year field to the
scheduled course in the student current school year.
schedule. Set Search based on to Final
Mark is Empty
Review the records and if there is
no final mark and it is appropriate,
delete these “orphaned” records.
Sep/Oct Ensure all Students have a Primary Student top Enrollment
Program of Study and Primary tab>Options>Program of study Demographics guide —
program study checkbox must be Creator — Primary Primary Program of
checked School View>Student top Study
tab>Transcript side
tab>Programs of study side tab
Sep/Oct Ensure Home School Not in The student’s primary school is TRAX reference guide
MyEducation” checkbox responsible for reporting
achievements to TRAX. In order
for MyEdBC to exclude students
from the TRAX extract, all
students whose home school is
not in MyEdBC, must have the
“Home School Not in
Myeducation” checkbox checked
School View>Student TT>Details
ST>Demographics Sub TT
Sep/Oct Ensure manually entered transcript Student top tab > Transcript side | TRAX reference guide
records have an appropriate final tab - To Manually Add an
mark, credit value and course end Historical Transcript
date. Record to a Student
Oct Prepare Grade Input Grades top tab > Grade Input Grade Management
side tab > Options > Prepare reference guide
Grade Input > set Report Type to
Course > Finish
TRAX v3.2 Page 9
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Timeline | Task Path Resource
Oct Post course dates for Semester 1 Grades top tab > Grade Input Grade Management
courses side tab > Options > Post Grades | reference guide
> Check Course dates box.
Oct Create graduation assessment Assessment top tab > Student Graduation
records for students that will be writing | Assessment > Assessment Entry | Assessment reference
the assessment in the Jan session. side tab guide
Select Graduation Assessment
definition
Oct Check for missing assessment Assessment top tab > Student TRAX reference guide
session dates. Assessments side tab
Manually populate session dates if Set the Assessment Definition
necessary. field at the top of the screen.
Set filter to Missing Test Session
Dates. Does the Date 1 column
have blanks?
Oct Run the TRAX extracts Student top tab > Options > TRAX reference guide
Exports
BC TRAX Extract — Course File
BCTRAX Extract —
Demographics File
BC TRAX Extract — Exam File
TRAX v3.2 Page 10




BRITISH

COLUMBIA MyEducation

o
FUJITSU

3.2 Subsequent Submissions

Tasks are displayed in the order normally associated with the TRAX process. See detail in this

document for additional information, if required.

Timeline | Task Path Resource

Feb/Apr/Jul | Schedule students into courses — Student top tab > Schedule side | Student
ensure all students are scheduled tab Scheduling
into their courses.

Feb/Apr/Jul Remove current year “orphaned” Grades top tab > Transcripts
transcript records for your own side tab > set dictionary icon to
school, if applicable. All > set filter to No Student
This will happen when a student Schedule Equivalent.
changes schools and the transcript | In the pop-up,
record for a course has been Set School Year field to the
created but does not have an current school year
equivalent scheduled course inthe | gt Search based on to Final
student schedule. Mark is Empty

Check the school's name for
your own records

Review the records and if
appropriate, delete these
“orphaned” records.

Feb/Apr/Jul Ensure manually entered transcript | Student top tab > Transcript
records have an appropriate course | side tab
end date and credit value.

April Post course dates for Semester 2 Grades top tab > Grade Input TRAX reference
courses side tab > Options > Post guide

Grades > Check Course dates
box.

Feb Create graduation assessment Assessment top tab > Student Graduation
records for students that will be Assessment > Assessment Assessment
writing the assessment in the June | Entry side tab reference guide
session. Select Graduation Assessment

definition

Feb/Apr/Jul Create graduation assessment Assessment top tab > Student Graduation
records for students that will be Assessment > Assessment Assessment
writing the assessment in the June Entry side tab reference guide
session. Select Graduation Assessment

definition

Feb/Apr/Jul Review graduation assessment Assessment top tab > Student TRAX reference
results uploaded from previous Assessments side tab guide
sessions. Manually update missing | Select appropriate Assessment
values as necessary. definition field at the top of the

screen Sort or query for blank
values.
TRAX v3.2 Page 11
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Timeline Task Path Resource
Feb/Apr/Jul Run the TRAX extracts Student top tab > Options > TRAX reference
Exports guide
BC TRAX Extract — Course File
BCTRAX Extract —

Demographics File
BC TRAX Extract — Exam File

3.3 Summer Submission

For most students, the courses that are completed in the summer school will be included in the
TRAX extract when the primary schools submit the extract in October. The summer schools
can manually submit their TRAX data using TRAX Change Form available on the School
Secure Website (SSW) for students who are only active in the summer schools.

TRAX v3.2
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4.0 TRAX Processes — Detail

4.1 Deleting “Orphaned” Transcript Records

As students move between schools before completing courses, transcript records may be
created as term grades or course dates are posted for the student’s courses. If the student
changes schools before completing the course, an empty, (orphaned) transcript record occurs
on the student’s course history.

To remove these records:

In the School view, click the Grades top tab.

Click the Transcripts side tab. Set the D icon to All.

Set the ﬂ to No Student Schedule Equivalent.

In the pop-up window, set the School year field to the current year and set the Search

based on field to Final Mark is Empty.

5. Review the records and determine if it is appropriate to delete them. If they were
created at this school and will not be continued or given a final mark at this schooal, it
may be appropriate to delete the record. Only delete records from this school, contact
other schools before deleting their records.

6. Select the records for deletion by checking the box beside them.

7. Inthe Options menu, select Delete.

PN

4.2 Manually Add an Historical Transcript Record to a Student

Historical transcript records may need to be manually added for students who enroll in the
school from out of province/country, or for students who come from a school that has not been
using MyEducation BC.

Adding historical course records for a student will require that the converted historical course
catalogues have transcript definitions applied to the courses. Refer to the section in this guide
titted “To Add Transcript Definitions to Historical Course Catalogues”.

To add an historical transcript record to a student:
In the School view, select the Student top tab.

Click on the Transcript side tab.
In the Options menu, select Add. A blank transcript screen will appear.

A wbdhpE

Click on the Q in the Year ID field. Select the year in which the student completed this
course.

5. Click on the Q in the School > Name field and select the school of record for the
course.

6. Click on the Q in the Number field and select the course from the pick list.

7. Populate the Final Mark, Blended mark and Provincial Exam Mark fields as
appropriate.

8. Populate the Credit field with the appropriate credit value.

TRAX v3.2 Page 13
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9. Set the FAS Override flag, if necessary. This is optional and need only be set as
necessary for the diploma program the student is associated with. (Refer to Section 9-
Extract Contents CRS File for FAS Override flag details)

Year ID * 2020-2021 B[ Final Mark =X
School > Name ‘Ahhntsfﬂrd Senior Secondary |Q)( Blended Mark \:I
Grade level 10 Override [ ] Provincial Exam Mark \:I
Description SPORT ACADEMY FITNESS & CONDITIONING 10 TRAX Override
Teacher Maroofi, Kavren FAS Override
Teacher Maroofi, Kavren |Q)( Hide on report card A-
Section number 01 Hide on transcript E
N

10. Populate the Completion Date field as appropriate for the year of the course. Start

Date and End Date may also be entered at this time.

Completion Date 271012017 B

Note: Manually entered transcript records not tied to a section (course code only), will be
visible in the Student top tab > Transcript side tab only.

They will not be visible in the School View > Student top tab > Academics side tab or in the

Family/Student Portal under the Academics top tab.

4.3

Enter a Related Course Code for Independent Directed Studies

The related course code for MIDS courses can be added directly to the student transcript once

a transcript record has been created. The related course must meet the criteria outlined in the
Handbook of Procedures.

1.

2
3.
4

In the School view, select the Student top tab.
Click the Transcript side tab.
Create or select the MIDS course requiring a related course code.

Check the User Description checkbox and the IDS Related Course field becomes
editable.

Select the related grade 10-12 Ministry or BAA course code from the Picklist.
Save the record.

TRAX v3.2
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Pages School m Staff = Attendance Conduct ' Grades  Assessment Schedule  Extracurriculars

Student List :: 10 - Arranguez, Inkajosefine :: INDEPENDENT DIRECTED STUDIES 10A - SPORTS SCHOOL

Details
(ot
Contacts

Attendance
Update Grades: Update GPA: Update Rank: Update Credits:
Conduct
Year D * [2021-2024 Bl[e}
[Transcript School > Name | Smithers Secondary |QX
Transcript Grade level 10 Override [
» Details
Number * [MIDS-0ASPS Q
Credit Description INDEPENDENT DIRECTED STUDIES 10A - SPORTS SCHOOL
Summary )
Teacher Saggesebrito, Aldyn
Grade Point Teacher Saggesebrito, Aldyn |Q X
Summary
Section number 01

Programs of

Study User description h

Graduation Course description |
Summary

fios Retated Course  mmuUTHI0Q, X |

Assessments

4.4 How to Setup MIDS Courses

¢ MIDS course and related school course code must have matching transcript definitions.
e MIDS course and related school course code must have curricular competency rubric.

If you are using multiple transcript definitions and rubric definitions for your grade 10-12
courses, make sure your MIDS courses are assigned the same transcript and rubric definitions

as the course entered in the related course code field BEFORE you attach the related course in
the student transcript.

Setup an MIDS course for each related course code used, and enter the transcript definition and
rubric definition from the related course into the MIDS course. The school will only have to set
this up once and it will carry forward each year after setup.

NOTE: If the transcript definitions and/or rubric are different, assigning the related course code
will change the original MIDS information in the transcript record.

Example: MIDS 10 using the related course code MMUTH10:

Ensure the transcript definition and rubric for MIDS 10 matches what the school has set up for
MMUTH10.

TRAX v3.2 Page 15
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School  Student

Pages

School Courses

Schedules ‘

[Courses
O CrsNo

Staff  Attendance

Master
D X8 C5 =

Courses
Details 0O | MIDS-0ASPS

Build

Request O | MMUTH10

Conduct  Grades

Assessment

7

Description

INDEPENDENT DIRECTED STUDIES 10A - SPORTS SCHOOL

MUSICAL THEATRE 10

Schedule

GrdLvl

Extracurriculars  Global Tools

Admi

To add a related course to an MIDS course
on a student's transcript, the
Transcript Definition
and
Rubric Definition
MUST BE THE SAME
for each course

TransDef > Name ‘ RubricDef > Name

Quarterly - With School Exam

Quarterly - With School Exam

45 TRAX Override

TRAX requires a course to have either an “E” or “C” in the “CRSE_TYPE” field in the school’s
CRS record file. E indicates the result of a particular course was achieved through the
Equivalency process, and C indicates challenge for course credit. See page 22 of the TRAX
Specifications Document here:

1. Inthe School view, select the Student top tab.
2. Click the Transcript side tab.
3. Create or select the course requiring a TRAX override setting.
4. Select the appropriate TRAX Override value.
TRAX v3.2 Page 16
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4.6 Aegrotat Standing for Provincial Exams

Aegrotat Standing is an exemption from writing a provincial exam or graduation assessment that
is granted by the Ministry of Education. Application must be made to the Ministry of Education
per the Handbook of Procedures (see section 12 below).

Submit these student course records, as you do any other student, through the .xam file
(meaning the assessment record must be created).

If the student was approved for Aegrotat Standing by the Ministry of Education, the Ministry
upload of exam marks will return AEG as the exam mark and the school final mark as the
blended mark for provincial exams. A result of AEG will be returned for a graduation
assessment.

Occasionally, schools may need to update the assessment record manually. For example, if the
Ministry approval does not come back in time for the exam marks to be included in the Ministry
exam mark upload. Entering AEG into the transcript record exam mark field will indicate the
course was granted AEG status.

When correctly entered, the DVR and School Transcript report both display AEG as the
assessment mark.

4.7 Arts Education and Applied Design, Skills and Technologies

As indicated in the Handbook of Procedures for the Graduation Program, students have several
options for satisfying the 4.7 Arts Education and Applied Design, Skills and Technologies
graduation requirement that schools must report to the Ministry.

Some courses that meet the Arts Education and Applied Design, Skills and Technology
requirement may be designated as 2.0 or 4.0 credit courses at the District level. If schools
require both a 2.0 and 4.0 credit version of the course to schedule students into, a version of
each will need to be created at the district level to be brought into the school. Refer to the
School Setup document for these instructions.

If an individual student transcript records requires a specific Arts Education and Applied Design,
Skills and Technologies designation on a course and a specific credit value, this can be
achieved by setting the FAS Override flag and adjusting the credit value directly on the student
transcript record.

4.7.1 Grade 11 Board/Authority Authorized (BAA) Courses

As indicated in the Handbook of Procedures for the Graduation Program, Grade 11
Board/Authority Authorized (BAA) or First Nations Authorized (FNA) courses that align with the
Arts Education 11 and/or Applied Design, Skills, and Technologies 11 provincial curriculum can
meet the Arts Education and/or Applied Design, Skills, and Technologies graduation
requirement.

For each Grade 11 Board/Authority Authorized (BAA) course, Districts must indicate whether
the course meets the requirement or not by setting the FineArts/Applied Skills Credit

TRAX v3.2 Page 17
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Override value on the District View > Schedule top tab > Courses side tab > Details sub side
tab. Selecting ‘A’, ‘F’, or ‘B’ will result in ‘B’ for Both in the TRAX CRS extract. It is important to
note that all Grade 11 BAA courses will indicate a ‘B’ for Both in the TRAX CRS extract if this
value is left blank. Therefore, for Grade 11 BAA courses that should not meet this requirement,
the FineArts/Applied Skills Credit Override must be set to ‘N’ for Not Meet.

Page 18
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4.8 Posting Course Dates

Posting Course Dates creates a start and end date in the transcript record for the course and
allows a completion date to populate when the final mark is posted. In standard schools this
process should be done after the bulk of September student course changes and just prior to
the first TRAX submission in October. Posting Course Dates is a part of the Prepare Grade
Input process but it is not required for teacher gradebook functions in regular school. Detailed
instructions on the complete Prepare Grade Input and Posting Course Dates process can be
found in the Grade Management document.

Course dates should only be posted for current courses. For example, in October, it is best
NOT to post dates for second semester courses. If dates are posted for second semester
courses, students who drop a course will have a student transcript record already created for
that class which may need to be deleted.

1. School view > Grades top tab and click the Grade Input side tab

2. Here you may narrow the scope if you wish and select the courses you would like to
create transcript records for then go to Options and Show Selected. A filter entitled
“Schedule Term = ?” has been created to help users to only post date columns
for current courses.

Go to Options and choose Prepare Grade Input

In the pop up choose current selection and click next

In this screen select Course for the Report Type and click finish

abkw

Prepare Grade Input: Select Columns Step 2

Report type Course v

Replace Existing
Columns

6. On the Grades top tab > Grade Input side tab, select the Options menu > Post Grades.
A pop up window for Posting Grades will display. Check the Post course dates box and
click OK.

Post Grades

Post course dates L

Grade Term r

Grades to post Course dates for enrolled -
Post For..

. Current selection: 3
All Classes
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5.0 Viewing Exam Results

After exam session dates have passed and exam and blended marks have been uploaded at
MyEducation BC, the results can be viewed in the following locations:

e School view > Student top tab > Assessments side tab > Details > Or

e School view > Assessments top tab > Student Assessments side tab > Assessment
History sub-side tab > Details leaf >.

Remember to set the Assessment Definition field at the top of the screen when viewing
assessment records in either location.

6.0 Calculate Credits Procedure

Credits can be adjusted using the Calculate Credits procedure in the Grades top tab. When this
procedure is run, credits will be adjusted for all courses with posted final marks (non-
examinable) and those with Blended marks (examinable). This procedure can be run at any
time but is also typically done after exam/blended marks are loaded from the Ministry of
Education. This should be run after the Blended Marks to Transcript procedure has populated
the student transcript records with the provincial exam and blended marks.

To run the Calculate Credits procedure:
1. Inthe School view, select the Grades top tab.
2. Click the Transcripts side tab.

Set the E:I icon to All.

3.

4. Inthe Options menu, select Calculate Credits.

5. Confirm the Calculate For window indicates an appropriate number of records in
Current Selection.

6. Click OK.

7.0 Running the TRAX Extracts

The TRAX extracts are run as three separate files in MyEducation BC.

Users need to have their computer configured to show file extensions so the files can be
identified after download.

For Windows:
Control Panel > Folder Options > View top tab > uncheck Hide extensions for known file types
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For MAC
Finder > Preferences > Advanced
Check the box that says "show all filename extensions".

To run the TRAX extracts:

1.
2.

3.
4.

In the School view, select the Student top tab.

In the Options menu, select Exports. From the fly-out menu, select BC TRAX Extract
— Course File.

Confirm the school name is correct. Click Run. Close the window.

In the Options menu, select Exports. From the fly-out menu, select BC TRAX Extract
— Demographic File. Click Run. Close the window.

In the Options menu, select Exports. From the fly-out menu, select BC TRAX Extract
— Exam File. Click Run. Close the window.

In the Reports menu, select My Job Queue. When the job is complete, click the
blue hyperlink Finished (click to view).

Save the file as schoolnumber.DEM, CRS, or XAM, as appropriate. (EX.
02323044.XAM)
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8.0 Extract Contents

The following three tables show all the information contained in the files created by running a TRAX Extract:

DEM File — the actual file is produced as a .txt and does not have the column headings as in the example below. This is provided for
reference.

Ministry . Legal Legal
Internal Pupil Legal Last - . .
TRAX ID School Number PEN Name First Middle Address City Prov. Country Postal Code
Number Name Name
. . 741-7732 Port
EO2M 4343114 247843 188525877 O'Hara Parker Marvin Lewis St Coquitlam BC CN V1Y4J35
. 193-2970 .
EO2M 4343114 247844 439401223 | Constanine Marlo Kathryne Alma Ave Smithers BC CN V7N6C2
2420
EO2M 4343114 247760 369029197 | Wriglesworth Jessie Hadrian Anderson | Coquitlam BC CN V2DA4E7
Dr
. . 4635 Log
EO2M 4343114 247845 746399084 | Hemingway Ernest Giles Cabin Dr Vancouver BC CN VeD7V7
Program Cadre Syl S_tatus .
Birth Date Gender Citizenship Grade Program NORY _A:AC“Ve Cire SCOCF oy EieT LR
. D=Deceased Program YYYYMMDD
Default is N o -
T=Terminated
YYYYMMDD M C 11 N A 2004
YYYYMMDD F C 11 N A SCCP 20170630
YYYYMMDD M 0] 10 N T 2018
YYYYMMDD M C 12 N A 1996
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XAM File — the actual file is produced as a .txt and does not have the column headings as in the example below. This is provided for

reference.
internal | IGRY | Pupil PN Course | ‘G | Course | Monthor | STUT | ohool Final percent
Number Level Percent
EO6M 4343114 247836 599269743 NME 2018 01
EO6M 4343114 247843 188525877 COM 12 2017 06 65 60
EO6M 4343114 247844 439401223 FRAL 12 2018 01
EO6M 4343114 247845 746399084 EN 12 2018 01
XAM File (cont’d)
Cour_se Status Legal Last Number gourge Type
Exam ID A—Actlve Name of_ E=Equivalency
W=Withdrawn Credits C=Challenge
1763 A Thesen 4
1966 A O'Hara 4 E
1967 A Constanine 4
1835 A Hemingway 4 Cc
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CRS File - the actual file is produced as a .txt and does not have the column headings as in the example below. This is provided for reference.

i Final
Internal ECh.cl’.OI Pupil PEN d Course Cou:jse Year of Month of Interim F'r?al | Letter
TRAX ID acility Number Qi Code Sells Completion Completion Percent =Y
Code Level Percent Grade
EO8M 4343114 247836 599269743 Q EN 12 2018 1
EO8M 4343114 247836 599269743 YCAIS 11 2018 1 59 59 C-
EO8M 4343114 247836 599269743 MMA 12 2018 6
EO8M 4343114 247843 188525877 SS 11 2018 6
CRS File (cont’d)
Course Grad
Related Related Requirement .
Course Status | Legal | Number Course Level Course Type | F=Arts Education FAS Diploma Category
— A ~ti Course _ . _ . .
A=Active Last of (Only Descriotion E=Equivalency | A=Applied Design,
W=Withdrawn | Name | Credits | (Onlyused | - % P C=Challenge Skills and
for IDS) IDS) Technology
B=Both
“F" - meets Arts Education
Req't only (must be at least 2 credits)
"A" - meets Applied Design, Skills and
Technology
A Thesen 4 ENGLISH 12 E Req't only (must be at least 2 credits)
"B" - meets Arts Education and Applied
Design, Skills and Technology Req't (must
be at least 4 credits)
“N’ — Course Grad Requirement is blank
COMPUTER
Thesen 4 ANIMATION B
Thesen 4 MATH 12
\ SOCIAL
A O'Hara 4 STUDIES 11
TRAX v.3.2
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9.0 TRAX Logic

The following information outlines the basic standard MyEducation BC TRAX Logic.

1. When a Provincially examinable course is added to a Student's Course Selections or
manually added to a student’s transcript, a Provincial Exam Record is not immediately
created. A procedure called the Course Exam Synchronize Procedure must be run. This
Procedure looks at the end date in Student Transcript Records first and then the
scheduled course end date. For DL and CE schools it will look to the Course
Completion date first if there is one. If there is no Course Completion Date it will look to
the course end date.

If there is no Transcript Record yet, the Course Exam Synchronize Procedure will look at
the Course Schedule’s end date to identify the test session date.

2. When a Provincially examinable course is dropped from a Student's Course Selections
the corresponding Provincial Exam Record is not dropped automatically. Again, the
Course Exam Synchronize Procedure must be run to update student assessment
records.

3. Credits are only adjusted when the “Calculate Credits...” procedure is run through the
School view > Grade top tab > Transcript side tab > Options menu. When this
procedure is run, credits will be adjusted for all courses with posted final marks (non-
examinable) and those with Blended marks (examinable).

TRAX Extracts can be created from the Options menu > Exports of the Student top tab of
MyEducation BC:

1. DEM File — This file contains demographic information.

2. XAM File — This file contains information on provincially examinable courses and
graduation assessments.

If there is NO blended mark and NO exam mark on the Student Assessment Record:

e The School Mark will be extracted and populated in this file, and

e The Ministry will use the highest School Mark it has on record to create a blended
mark.

If there are NO results on the Student Assessment record for the Graduation assessment
record:

e The Numeracy assessment code and session date will be extracted.

3. CRS File — This file contains information on non-examinable courses. Each time a
TRAX extract is run the School Mark is extracted and repopulates the value at the
Ministry. The Ministry does not retain information on non-examinable courses; they rely
on each TRAX extract to re-populate these values. This extract includes initial
registration, interim and final letter grades, and interim and final letter grades.
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10.0 Adding Transcript Definitions to Historical Course
Catalogues

Transcript definitions must be added to historical course catalogues in order for the course list to
appear for the appropriate year when manually entering historical course records to a student’s

transcript side tab.

1. Inthe School view, select the Schedule top tab.
2. Click the Courses side tab.

3. Use the A icon to select the Year = ? filter. In the pop-up window:

a. Setthe School year field to the year of the school course catalogue that needs

transcript definitions. For example, to search for the 2014-2015 course

catalogue, enter 2015, for the 2013-2014 course catalogue, enter 2014, etc.
b. Setthe Search based on field to All Records.

c. Click Submit. The course list will now display all courses in the course

catalogue for the year selected.

Search criteria

School year

Search based on

[2014 ]

All Records v

Submit || Close

e|Year|SchoolLevel GrdLy|
42014 pecondary |12
2014|Becondary 12

TransDef > Name

22014|Becondary |12
42014 pecondary |12

Transcript
Definitions
Required

22014|Becondary |12
22014|Becondary |12

22014|Becondary |12

4. If the TransDef > Name field is blank, assign transcript definitions to the courses. This
can be done using the mass update or modify list functions.
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11.0 Ministry of Education Resources

The Ministry of Education website at

requirements.

12.0 Troubleshooting
12.1 Common TRAX Data Errors

has several resources
related to Graduation Assessment write dates, requirements and graduation requirements. Of
particular note is the Handbook of Procedures, which outlines all of the requirements for student
graduation. This resource should be referred to and understood by all users who are
responsible for TRAX and who are tasked with ensuring students meet graduation

TRAX SSW Error Message

Record

Troubleshooting in MyEdBC Student

[07A] Invalid or Blank Grad Reqt Year Code - must
be 2018, 2004, 1950 (Adult), 1996 or 1986

Ensure the student has a Program of Study
with the Primary flag checked

School View>Student Top Tab>Transcript Side
Tab>Program of Study>Options - Add

[07B] Mismatch on grad year/ grade

details

Sub Level

Students with the Adult — Graduation Program of
study must have a Subgrade of AD or AN in student

School View>Student Top>Details Side Tab>Grade

[021] Invalid grade - must be
08,09,10,11,12,AD,AN,OT or HS

Level

Accepted Grade Levels are 08, 09, 10, 11 or 12 if
applicable the subgrade AD, AN or HS
Note: TRAX does not use the subgrades SU, GA or GR

School View>Student Top>Details Side Tab> Grade

12.1.1 Invalid Grade: Accepted Graduation Program and Grade Level

Combinations

Below are the Grade levels accepted by TRAX for each of the Graduation Programs (Primary
Program of Study) in MyEducation BC. The commonly used grade levels are in bold.

Graduation Program

Student Grade Levels

Student Sub Grade
Levels

2018 — Graduation Program

8,9,10,11,12

HS

2004 — Graduation Program

8,9,10,11,12

HS
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School Completion Certificate Program 8,9,10,11,12 HS

Adult — Graduation Program 8,9,10,11,12 AD, AN, HS

Note: requires a Subgrade

Adult — Graduation Program Subgrades:

e AD - Adult Graduating: Has the Primary Program of Study = Adult Graduation
Program and is expected to graduate in the current school year.

o AN - Adult Not Graduating: Has the Primary Program of Study = Adult Graduation
Program and is not expected to graduate in the current school year.

Note: Students that have already met Graduation Requirements on a given diploma will remain
on that diploma. E.g., a student that met the 1995 Graduation Program Requirements will not be
assigned the Adult Graduation Program when upgrading courses in a current yeatr.

12.1.2 Assessment Scores and Graduation Reports

MYyED (Transcript ST)+ DVR + School Student Transcript Student Transcript (SSW) (STS)
Transcript Report Services (SSW) and
Student Transcripts
Service (STs)

Individual Graduation
Assessment/Examinations

Report
Literacy 10 Proficiency Score Proficiency Score RM
Numeracy 10 Proficiency Score Proficiency Score Proficiency Score
Literacy 12 Proficiency Score Proficiency Score Proficiency Score
Literacy 10 Exemption E XMT XMT

12.2 Troubleshooting Resources

L1s have access to the Heat System for Self Services Resources. You can access Knowledge

Base Articles (KBAs). KBAs are living documents and updated regularly. The information below
is from KBA 10606, to see the most up to date information on any topic review the current KBA
Troubleshooting Articles.

12.2.1 No Primary Program of Study

Student > Filter = No Program of Study

e |dentify the Grade 10-12 students in the list Options > Show Selected
e Assign the students a Primary Program of Study using Options > Primary Program of
Study Creator or through the Transcript > Program of Study side tab Options > Add

12.2.2 Primary Program of Study missing data

Global > Favorite > Graduation Student Program > List
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Filter to Active Students or Grade Level = (10, 11 or 12)

Sort on Diploma Type column to identify any records with a blank Diploma Type

Return to Student > Transcript > Program of Study — delete the existing program record
and create a new one.

Sort on PrimProgram column to identify and records with PrimProgram set to = N

Click into the blue hyperlink student name and check the Primary program study
checkbox and Save

Or, Options > Mass Update > Field: Primary program study > Value: check the checkbox

12.2.3 Adult Program of Study Missing Sub Grade

Student > Details

Students with the Adult Diploma should have the AN (not expected to attain grad
requirements this school year) or AD (expected to graduate this school year) subgrade
entered to avoid a Grad year, grade level mismatch error from TRAX.

12.2.4 Transcript Record Errors

Creating a field set with the following fields can assist in identifying errors originating from
Student Transcript Records:

Table: School; Field: Name

Table: Equivalent School Course; Field: Number
Table: Equivalent School Course; Field: Description
Table: School Course; Field: Number

Table: Master Schedule; Field: Course

Details on how to identify and correct the errors are below.

12.2.5

Note: If the Transcript Record belongs to another school, contact the school
before making any changes to the Transcript Record.

MIDS Courses With Ineligible Related Course Codes

See the Handbook of Procedures for current eligible courses.
School > Grades > Transcripts
o Create and use a Field Set that includes:

o Table: Equivalent School Course, Field: Number
o Table: Equivalent School Course, Field: Description

Set Dictionary to All and Filter to Current Students
Sort on the CrsNo column to bring the records with an equivalent course code to the top
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e Scan the list of records and identify any records with an ineligible course code. Eligible
courses include courses leading to graduation (Grade 10-12); XSIEP and XSPBK are
not eligible. See the handbook of procedures for details.

e Correct the IDS Related Course in the Student Transcript Record from this screen or
from Student > Transcript

12.2.6 Transcript Records Missing a School Course Code

e School course codes are required for the TRAX extract to run.
e School > Grades > Transcripts
e Create and use a Field Set that includes:

o Table: School Course; Field: Number
o Table: Master Schedule; Field: Course

e Set Dictionary to All and Filter to Current Students

e Sort on the School Course > CrsNo column to bring the records without a school
course code to the top

e Select the correct school course code for the record from the Transcript details here or
in Student > Transcript.
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