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1.0 Traditional Gradebook  

The focus of this guide is to provide the necessary understanding and requirements for working 
in the Staff View and for setting up the traditional gradebook.  

1.1 Objectives 

• Gradebook Preferences 

• Linking classes 

• Create categories and assignments 

• Enter Marks  

• Posting Grades 

• Optional Tools 

1.2 Areas of Consideration for Gradebook 

Some areas to be considered as they relate to the setup and use of the teacher 
gradebook are worth noting here: 

• Will the course transcript definitions be calculated? 

• Will teachers be allowed to modify weights? 

• Does the district or school require a specific method of gradebook mark calculation? 

• Will the district or school be using the student/family portal during the school year? 

• Will the district and / or school be providing a comment bank (which teachers to add to)? 

1.3 Resources 

From the Staff View, under all tabs with the exception of the landing page, the Help menu 
provides a variety of resources which follow: 

• Online Help - this will scope to the area from which the help was accessed. 

• User Guides  

o Staff View Setup and Navigation 
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2.0 Save Functionality 

As with any software, users should ensure that they are saving often to avoid loss of 
work.  Save buttons are available at the top and bottom of screens throughout the application. 

 

2.1 Auto-Save 

In addition to the save buttons, many screens in MyEdBC have an Auto-Save feature.  While 
this is handy functionality, users should not rely on it as a means of saving their work. Regular 
use of the save buttons should ALWAYS be the primary method for saving.  See the separate 
Fundamentals Appendix: Auto-Save Statistics for a list of screens that provide the Auto-Save 
functionality as a back-up measure. 

Note: The auto-save interval (number of minutes before a screen is auto-saved) is determined 
by the user preference settings as outlined in the Preferences - General section above.   

 

2.2 Gradebook and Grade Input Scores Save Functionality 

Staff > Gradebook > Scores 

School > Grades > Grade Input > Input Grid 

The grade entry screens in School and Staff view have a save-as-you-go functionality.  When a 
score is entered and the user moves out of the cell, the message: Saving, Please Wait displays 
above the score grid and the cell will turn yellow. The mark column entry is saved when both the 
message and the yellow cell colour have cleared the screen.  To avoid loss of work, do not 
begin entering information into the next cell until both the message and the yellow colour are no 
longer displayed on the screen, indicating the save has completed.  

3.0 School Preferences 

Each school sets basic Gradebook preferences for all teachers in School view > School TT > 
Setup ST > Preferences SST > Grade (Category). These are discussed in detail in the School 
Setup Reference Guide.   
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4.0 User Preferences 

Basic User Preferences are covered in the Fundamentals guide, and these should be set prior 
to setting up gradebook settings. These can be found by clicking on the user’s name > Set 
Preferences. The Gradebook tab, see below, displays a non-categorized version of the 
Gradebook preferences detailed in section 4. 

 

• Enable gradebook features:  This MUST be checked or gradebook functions will not 

work. 
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5.0 Setting Gradebook Preferences 

Gradebook Preferences are specific to Gradebook use.  They allow teachers to define the 
behaviour, view and default mark calculations for their gradebook.   

From the Gradebook top tab, click on the gear icon:  

 

Five top tabs define the organizational grouping of the settings: General, Student Information, 
Add Assignments, Missing Assignments and Averages.   

5.1 General  

•  Shade alternate lines 

• Track administrator updates:  A blue exclamation mark appears next to any grades or 

comments changed by an administrator. 

• Tab direction:  Down or Across. Which direction should the cursor go when the tab key 

is pressed during grade entry? 

• Show studies:  Includes rosters for advisory or study periods - not used in BC at this 

time. 
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• Enable gradebook features:  This MUST be checked or gradebook functions will not 

work. 

•  

• Assignment column order:  Ascending displays oldest assignments at left.  

Descending displays most recent assignment at left.  Sequence number displays 

assignments in sequence assigned by the teacher. 

• Show points in header:  Displays total points for an assignment in the column header 

• Show category names in header:  Displays abbreviated category code in the 

assignment column header. 

• Publish assignment statistics:  Pertains to Student/Parent Portal.  If checked, displays 

highest, lowest, and mean scores next to assignments viewed in the portal.  Often 

determined at the district level. 

• Anchor averages:  Displays running average for the marking period in the column to 

the right of student’s names. 

• Grade change tracking days: not used in BC 

5.2 Student Information:  

 

• Show Student Alerts:  Displays alert icons next to student names. 

• Enable student details: An information icon  next to the student name in the scores 

page provides student contact information. 

• Enable student academics: An information icon  next to the student name in the 

scores page provides student academic information.  

• Show course selection recommendation:  Displays recommendation column.  

Recommendations pertain to teacher suggestions for course selections in the next year.  

Recommendations can only be made at times set at the school level. Teachers may 

want to leave this box unchecked when not in use. 
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5.3 Add Assignments 

       

• Add to all linked classes by default – When course sections are linked for categories 

and assignments, the add assignment screen will automatically check the box to add the 

assignment to all linked classes on any template where the option exists.  Course 

sections can be deselected if the assignment should not be added to that section. See 

the section Gradebook: Assignments for details. 

5.3.1 Set Assignments for Specific Students 

To apply an assignment to specific students: 

Staff View>Gradebook Top Tab>Assignments Side Tab>Options Add 

• Click the ‘Student’ sub top tab. 

• Select the student(s) that will not receive the assignment 

• Click Exclude. 

The student(s) will not see the assignment in their To Do widget or on the assignments list in the 
Student portal.  
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On your Scores page, the grading cell for the assignment is grayed out for students that have 
been excluded from the assignment. No mark can be entered. The assignment does not affect 
the student's average; it does not exist for that excluded student.  
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5.4 Missing Assignments 

 

• Show missing column - If you create special codes that you enter for missing 

assignments, select this checkbox to view the Missing column on the Scores page.  

For each student, the Missing column includes assignments entered using special 
codes (see section 5.0 Optional Tools below for further information on the use of 
special codes). 

Note: This column is for your eyes only. Students and family members do not see it 
in the portals, and office and administrative staff members do not see it in the 
School or Enterprise views. 

• Count empty as missing - If you selected the Show missing column checkbox, select 

this checkbox to count any assignments that were due before today and that you have 

not entered scores for, as missing. 

 

Note: You might want to select this checkbox at the end of a term when you have 

finished entering all assignment scores. Otherwise, the Missing column will include 

scores for assignments you have not graded yet. 

 

• Show unscored – Only used with courses that have a rubric definition assigned to it.  
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5.5 Averages 

 

Default weighting:  This setting is significant as it sets the default mark calculation for the 
gradebook. This setting can be overridden at the course detail level for individual courses.  A 
short explanation of each of the settings is provided below, detailed explanations can be found 
in Appendix A and from online resources. 

• Categories only (weighted categories) if you want to weight only the categories in your 

gradebook.   

Assignments are converted to a percentage then averaged within each category. The category 

average is multiplied by the assigned weight, and the weighted category averages are added 

together. 

• Category and assignments (weighted) if you want to weight both categories and 

weight the assignments within those categories.  

Assignments are converted to a percentage, multiplied by the assigned weight and a category 

average is calculated. The category average is then multiplied by the assigned weight, and the 

weighted category averages are added together. 

• Select Total points if you want the overall value of an assignment to be determined by 

the maximum points possible for the assignment.     

Assignments are not converted to a percentage. The total points a student earns is divided by 

the total number of points possible. 

• Select Category total points if you want a category weighted and the value of an 

assignment within a category to be based on the points possible for the assignment.  
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Assignments are not converted to a percentage. Within each category, total points earned are 

divided by total points possible to determine the category average. The category average is 

then multiplied by the assigned weight, and the weighted category averages are added 

together.    

Additional Resources:  

Help > Quick Reference Cards > Gradebook—Beginning-of-the-Year Setup 

Help > Videos > Teacher Gradebook > Setting up your Aspen Gradebook > QRG > 
Understanding Averaging Modes. 

• Decimals:  Determines how many decimal points to use in calculating grades.  Impacts 

averages in Gradebook only.  Grades posted to transcripts will conform to the district 

defined decimal rules. 

• Grade scale: Some districts have uniform grade scales. If not established by the district, 

participants can select a scale from the list viewed by clicking the magnifying glass.  

o Provincial Mark Scale Final assigns numeric value of 25% for letter grade – F, no 

numeric value for letter grade –I. 

o Provincial Mark Scale Interim assigns no numeric value for letter grade - F, 

numeric value of 25% for letter grade - I. 

o The IB Grade Scale is for use by authorized IB Schools only. 
o If the district or school permits, teachers can go to the Tools top tab > Grade 

scales side tab > Options > Add to create their own grade scales 

• Semester Cumulative Average: Select this checkbox to show semester running 

averages on your Scores page. MyEducation BC calculates semester running averages 

based on the assignment grades within each of the terms inside of it, not on the average 

for each term. 

 

Students and family can view this column in the Student and Family views. 

 

Note: Your school must enable the School Grade preferences (for Show semester 

averages in the gradebook) for this user preference to be activated. School View>School 

Top Tab>Category = Gradebook 

 

MyEducation BC uses the column header Semester # (for example, Semester 1) for 

semester running average columns. 

 

• Cumulative Average: Select this checkbox to show an overall course cumulative mark 

calculation when using Total Points averaging mode. Selecting this option along with a 

default weighting of Total Points or Category Total Points produces a total cumulative 

mark calculation. Note: this option is only available if the School > Preferences > 

Grades has Semester Cumulative Average and Overall Cumulative Average 

checked.  
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6.0 Gradebook > Details: Linking Classes, Grade 
Calculation Weights, Categories 

A teacher can link his/her classes allowing them to create categories and assignments for one 
class which automatically add them to other classes linked to it.  

6.1 Class Details 

The class details screen provides the means to link classes and determine settings.  At the 
bottom of the page are expandable sections for linked classes, categories, drop mode and 
grade calculation weights. 

 

• In the Average Mode dropdown, teachers can override the averaging method they 

selected in Preferences. 

• Averages Grade Scale can be changed from the default preference setting. 

• Portal Notes allows the teacher to enter a comment about the class that will appear in 

the Student and Family portals. 

• Expand the Drop mode at the bottom of the screen, do one of the following to determine 

if you want to drop the lowest scores for this class: 

Select Do not drop scores if you do not want the system to drop any scores for this class. 

Select Drop lowest overall score if you want the system to drop the lowest score(s) for a term.  

Select Drop lowest score by category if you want to determine how many scores to drop each 

term by assignment category. For example, you might drop the two lowest homework scores 

each term. To do so, type the number in the # to drop column for each category, for each term. 

Note: Error Message “This gradebook section is shared with other teachers”.  This error 
message will display when one or more teachers share a course section and the Averages user 
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preference is set to ‘Gradebook Default’.  When a course section is shared, both teachers must 
determine and select the same Averages settings in the course details.  

 

6.2 Classes Linked for Assignments and Categories 

• Go to Gradebook top tab > Select a class > Details side tab 

• Review the information on the Details screen for the class selected. 

• At the bottom of the screen, expand the section Classes linked for assignments and 

categories, click the Select button and select sections that are the same as the class 

you are viewing, and click OK.  

• If you create assignment categories on the Class Details page and you have linked 

sections, the field Also add to linked sections? is enabled by default. The new 

category will be applied to all of your linked sections, unless you deselect the field. If you 

do not have linked sections, the Add to all sections? field appears.  

• It is not enabled by default, but you can select it to apply the new category to other class 

sections.  
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• Staff view, Gradebook > Categories 

• If you create categories using the Categories side-tab and you have linked sections, the 

new Add category field is enabled by default. The new category will be applied to all 

linked sections. If you do not want the category to be applied to a section, deselect the 

checkbox next to it. If you do not have linked sections, click Add category to add the 

category to all of your sections, or just select the checkboxes next to the sections it will 

apply to.  

  

• Enter a name for the group of linked classes. Click Save.  

Linking classes enables the teacher to enter information for categories and assignments just 
once for each course.  MyEducation BC will duplicate the categories and assignments for 
each of the linked classes. 
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Note: Creating assignments for linked classes does not adjust dates or grade terms. Multi 
Add assignments creates assignments for one course section at a time, even when 
sections are linked. 
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6.3 Grade Calculation Weights 

If the Grade Category in School Preferences is set to Allow editing of term weights by staff, 
courses set up with calculated transcript definitions can be adjusted by teachers.  The 
system will not accept a “zero” value for a grade term weight. 

From the course details screen in the gradebook, in the lower block of the window teachers can 
change the calculation of the final mark by adjusting the weightings of the terms and/or exams. 

 

 

Note: School View > Grades > Grade Post Controls must have the dates for the final 
grade term “open” for weights to be adjusted.  

 

In summary, three conditions must be met in order for teachers to be able to adjust term 
weights: 

1. Grade preferences are set to “Allow editing of term weights by staff” in the School 

view. 

2. Grade Post Controls must be open for weights to be adjusted. 

3. The transcript definition associated with the course must be one of the ones which are 

set up to be calculated. 
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6.4 Create Categories 

Categories group the learning tasks that teachers will use in student assessment. The QRC 
Advanced Gradebook, in the online Help, is an excellent resource for step-by-step instructions. 
Defaults selected when creating categories can be overridden for individual assignments within 
the category.   

• Go to Gradebook top tab > Select a class > expand the Categories section, or use the 

Gradebook top tab > Select a class > Categories side tab 

• Any existing categories for the class are displayed on the screen. 

 

• Go to the Add button to create additional categories. Note that if the course is linked to 

another, this will also add categories to the linked course sections. 
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Enter the code, description and weight (if applicable), click the check mark. 

• Code – An abbreviated label for the category to fit in the column header in 

the Gradebook: Connecting 

**note: the Code must be 20 characters or less and cannot contain spaces. 

• Description – The complete name of the category: Connecting and 

Reflecting 

• Weight – Enter the weight of the category in terms of the value of its 

percentage when calculating the average.  For example, the category Test 

might be worth double what the Homework category is worth.  

Click into the Category header to enter the category details pop up:  

 

• Grade scale – Select from the dropdown 

• Entry mode – Select Numeric, Letter or Both 

• Total points – Number of points anticipated for each assignment.  Can be changed for 

individual assignments. 

• Assignment Default Weight: Anticipated weight for each assignment.  Can be changed 

for individual assignments.Extra credit points – Enter value if assignments in this 

category will routinely have extra credit points. 

• Score cannot be dropped – Check this box if you do not want the system to drop any 

lowest scores from this category. 

• Visibility type – Will the assignment be displayed for students and parents in the portal? 

o Private means that assignments in the category will not be seen in the portal or 

included in portal averages.    

o Public means that assignments in the category are displayed in the portal and will 

be included in portal averages.  
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o Public-no grades means that the assignment appears in the portal, but no grades 

entered by the teacher appear in the portal or are included in the portal averages. 

• Save – at the top of the details screen  

 

6.4.1 Delete Categories 

From Gradebook > Details > expand Categories section, Or, Gradebook > Categories side 
tab 

• Click into the hyperlink details of the category  

• In the pop up, click the Delete button 

• Save – at the top of the details screen  

 

6.4.2 Importing Categories 

Categories can be imported into an individual course section from another course section. 

From Gradebook > Details >  
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• Expand the Categories section 

• Click the Import button 

• In the pop up, select a course section, and Selected or All Categores 

o Selected:  a pop up displays and individual categories can be selected for import 

o All Categories: All of the categories from the selected course section will import  

From Gradebook > Categories  

• Options > Import Categories … 

• In the pop up, select a course section, and Selected or All Categores 

o Selected:  a pop up displays and individual categories can be selected for import 

o All Categories: All of the categories from the selected course section will import 

 

• Select the category to import 

 

• Click OK 
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• Edit any of the category details as needed by clicking into the hyperlink of the category 

• Save – at the top of the details screen if in section details 

6.4.3 Creating Exams as Categories 

Exams can be separate mark columns as they are associated with a variety of Transcript 
Definitions.  If the course being taught is not associated with an exam or if you would like to 
track a separately weighted project (e.g., a mid-term exam), you can use the Categories feature 
in the Gradebook to integrate it.   

In the example below, there is an assumption there is no mid-term or final exam being 
accounted for in the structure of the transcript definition.  The mid-term is being conducted in Q2 
and the final exam is in Q4.  As such, the “Adjust Weights By Term” checkbox is checked to 
allow the weightings to be adjusted for each term. 

 

 

 

 

 

Once your exam Category or Categories have been created, an individual assigment will need 
to be created in each of them to hold the associated marks. 
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As an extension of the Categories example above, only one assignment will need to be created 
for each category to hold the exam marks: one in Q2 to hold the mid-term exam and one in Q4 
to hold the final exam. 
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7.0 Gradebook: Assignments 

Assignments can be created in singles or multiples and from different areas within the Staff 
view.   

7.1 Create Single Assignments 

Single assignments can be created from Gradebook > Assignments, Gradebook > Scores, or 
from Planner using Options > Add.    

Gradebook top tab > Assignments > Side tab > Options > Add assignment.  Complete the 
New Assignment template. Fields with a red star are required fields.  The Classes field 
populates on save.  

 

• Category – Click the magnifying glass and select a category. 

• Gradebook column name – Enter an abbreviation for the name of the assignment. 

▪ Naming the gradebook assignment column “Final” pulls the mark into the Final 

column – recommendation to use a variation of the word e.g., FinalProject 

• Assignment name – Enter the full name of the assignment. 

• Date assigned – Date on which assignment will be given to the class. 

• Date due – Date on which assignment must be turned in. 

• Total points – Total points without extra credit; what the assignment will be out of. 

• Online submission – To enable online submission of assignments in the student portal; 

enter an Open date and a Close date and times.   

• Extra credit – Check the box ONLY if the ENTIRE ASSIGNMENT is extra credit. 

• Extra Credit Points – Enter points value for extra credit if the assignment includes a 

component for extra credit. 
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• Sequence number – Assign a number if the teacher preference uses sequence 

numbers to organize assignments in the Gradebook. Lower numbers are closer to the 

student name. 

• Score not droppable – Check the box if the score cannot be dropped when calculating 

averages. (Relates to field in Category definitions.) 

• Visibility type – Defaults to the visibility type set in the category selected above. The 

grade viewed in the portal will be different from the average in Gradebook based on 

these settings.  The grade viewed in the portal is based only on the assignment 

grades made public.  Private assignments are not used in the portal calculations. 

o Public means assignment and grade can be viewed in the Portal.   

o Private means neither the assignment nor the grade can be viewed in the 

Portal.  

o Public no grades means the assignment appears in the portal, however no 

assignment scores or grades appear in the Portal. 

• Entry mode – From the dropdown, Select Letter Only, Numeric Only, or Both. 

• Grade Scale – Select a grade scale from the picklist if desired. 

• Grade Term - Select the term in which the grade will be used in the calculated average. 

Important at the end of a term.   

• Exclude from averages – check this box to remove the assignment score from all 

average calculations.  When this box is checked, the column header name in the scores 

screen appears with a line through the name.  

 

• Recurring Options – Select Daily, Weekly, or Monthly to repeat the assignment at the 

designated frequency.  Selecting a recurring option prompts a popup in which parameters 

for the frequency are defined. Example:  a weekly learning log. 
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• Also add this assignment to linked classes – Check the box to duplicate the 

assignment in the Gradebook for linked classes. The box will automatically be checked if 

the preference Add to all linked classes by default is selected. This option does not 

appear if the class for which the assignment is being created is not linked to any other 

class. 

When you create an assignment, there is a  Linked or All drop-down that will associate 

the assignment with all of the sections you teach that contain the same transcript 

definition, term and grade level, or with some or all of your linked sections. If you do not 

link your class sections, you can select All from the drop-down, and then select the 

checkbox next to each class that gets the new assignment. 
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• Resources Provided by the Teacher – The teacher can add files and web links using:  

Add File, Add Weblink or Drag and Drop from My Resources.  To Drag and Drop, select 

the item from the My Resources pop-up window and drag into the Resources Provided 

by the Teacher box until the green checkmark appears, then let go of the item. The 

Student Portal must be open to enable students to access the links and files.   

• Save (or, Save and New to create another assignment) When using Save and New 

review all settings and Portal Descriptions to ensure they are accurate for the current 

assignment. 

 

If the Student/Family Portal is open and the assignment is public, click the Portal Description tab 
and enter the assignment description and details that will be visible in the portal.  

Go to Scores side tab to view the new assignment column created in the Gradebook.  If the 
column does not appear, change Grade columns dropdown to All.  In Set Preferences > 
Gradebook, Enable gradebook features must be checked in Preferences. 

7.1.1 Gradebook View> Scores Side Tab 

Hover text displays full assignment name in column header 
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Hover the cursor over the abbreviated assignment name in the column header. You will see the 
full name 

7.2 Create Multiple Assignments 

Multiple assignments can be created from Gradebook > Assignments > Options > Add Multiple 
Assignments.  

Go to Gradebook top tab > Assignments > Side tab > Options > Add Multiple Assignments.  In 
the pop-up window complete the Multi Add Assignment template.  In the Add Multiple 
Assignments screen there is no option to add these assignments to linked courses.  The 
assignments entered through Add Multiple Assignments will apply to this course section only.  

• Copies per category – Enter the number of assignments you would like to create for 

each of the categories selected in the next step. 

• Categories – From the pick list, select the category or categories.  

• Number of Assignments to create – a total number of assignments that will be created 

based on the selections made in the settings above.  In the example below, 2 copies x 4 

categories = 8 total assignments that will be created.   
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The settings in the second box are default for the block of assignments created, they can be 
adjusted by assignment in the next step.  For details on any of these settings see section 15.1 
Create Assignments.  

• GB column name – the default gradebook column name for each assignment 

• Assignment name – the default assignment name for each assignment 

• Date Assigned – the default date assigned for each assignment 

• Date Due – the default date due for each assignment 

• Grade Term – the default term the assignments will be created in 

• Points – the default point value for each assignment  

• Visibility type – Defaults to the visibility type set in the category selected. See note 

below. 

• Save 

After clicking Save, the group of assignments will be displayed for review and editing.   

Creating multiple assignments may be done using multiple categories, and categories can have 
different default assignment settings.  Particular attention should be paid to the Visibility Type field 
during the creation wizard and during the updating of the individual assignment fields. 
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• Go to Options > Modify List to display the individual items in an editable column format.  

• Options > Mass Update could be used if the entire column would be updated with the 

same value. 

• A pencil icon at the top of a column indicates the column is available to edit.   

• Click on the pencil to open the fields for editing, make the changes to the column and 

click the green checkbox to save the column. 

• Move to the next column to edit, click the pencil icon and repeat the process until it is 

complete.    

• Assignments can also be edited by clicking into the details of each assignment. 

7.3 Copy Assignments 

Gradebook > Assignments > select an assignment(s) to copy > Options > Copy Assignments.  
This will create a copy of each selected assignment.  Details for the assignment can be edited 
by clicking into the hyperlink assignment name. 

7.4 Import Assignments 

Import Assignments is really a copy function, accessing the user’s assignment setup for past or 
current course sections. It is very useful for moving assignments from class to class and year to 
year.  

Pathway: Gradebook > Assignments > Options > Import Assignments  

• In the pop up select the course section, then  

• Identify if you want to select individual assignments to import, import all assignments 

within a specific category, or all assignments in the course section. 

• Select the Assignments (selection) or Category (category)  

• Click the Import button 

• Review all settings and descriptions to ensure they are accurate for this course section. 
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Once assignments are moved into this class’ gradebook, some changes can be made using the 
Options > Modify List functionality.  Fields that can be modified this way include:  

• Assignment Name 

• Gradebook Column Name 

• Assign Date 

• Due Date 

• Visibility Type 

• Points 

• Assignment weight 

Changes to other fields such as Grade Term require the user to go into the details of each 
assignment. 

It is also very helpful to use the Options > Shift Assignments Dates functionality after an “import” 
to help align your dates in an expedient manner (section 5.5 below). 

7.5 Shift Assignment Dates  

This is a handy feature for adjusting assignment dates and or re-aligning terms following the 
use of Import Assignments. Be sure to choose assignments and use Show Selected before 
applying changes. 

   
To re-align terms following an import of assignments, select the assignments to be adjusted. 
Only check Update grade terms as needed, and set School days to shift as 1. In this way, 
no dates will actually be adjusted, but the terms will be re-aligned to the assignment dates. 

Assignments can only be shifted to the first / last day of the course section’s schedule at the 
most. 
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7.6 Create Ungraded Assignments 

An ungraded assignment will display in your planner and in the Family/Student Portal if visibility 
is set to public but will not display on the scores side tab.  

Gradebook > Assignments > Options > Add Ungraded Assignment or Planner > Options > Add 
Ungraded Assignment and enter the following fields in the pop up 

• Assignment name  

• Gradebook Column name (optional) 

• Date Assigned  

• Date Due  

• Grade Term  

• Visibility type (optional) 

• Description (optional)  

• Save 
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7.7 DL/CE Active Assignment Checkbox 

Distributed Learning and Continuing Education schools have options available for the auto 
population of Active Dates.   

If the school preference setting for Active date is: Enabled by multiple assignments, the Staff 
view > Gradebook > Assignments template will have a checkbox for Active Assignment under 
Options.   

 

Teachers can select one or several assignments to flag as an Active Assignment.  When all the 
flagged assignments are marked, the active date will auto populate into the Active Date column 
in the scores screen and can then be posted to the student transcript record.   

Date columns are created when Prepare Grade input for Course Dates is run at the school 
level.   

See the DL and CE Schools Setup and Processes guide for more details on the Active Date 
Preference Settings. 
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8.0 Gradebook > Scores 

In MyEducation BC student marks are entered in the Scores window by clicking in the 
appropriate cell and either manually entering the mark or by using the Ctrl-L option to select 
from the list of acceptable values. Data is automatically saved as the values are entered, a 
yellow cell indicates the save is in progress.  Wait for the yellow to clear before entering a score 
in the next cell. The view in this screen is determined in part by the preference settings outlined 
in Section 3.0 above.  

 

8.1 Entering Marks and Feedback for Students 

8.1.1 Scores Window for Mark and Feedback Entry 

Go to Gradebook > Select class from class list > Scores side tab. 

• Enter Assignment feedback for student by clicking on Speech Bubble. These notes will 

be visible to students and parents. 

• Teacher can enter as much Assignment feedback as they like prior to scoring 

assignment. 

• Students can resubmit assignment as many times as they like until a score is entered by 

the teacher 

• Enter students’ assignment scores in the Gradebook column. 

• Make use of the following shortcuts: 

Control + D – Fills all cells below with the same score. 

Control + K – To undo the last change. 

Control + E – To exempt a grade from the calculated average. 

Control + N – To add a footnote visible only to the teacher.  Footnotes are created 

on the Tools top tab.  Enter a score in the cell, press Control + N on the 

keyboard, and select the note from the pick list. 

Control + M – To add notes.  Notes can be visible to the teacher only or to the 

student and parents.  Note that a score must be entered in a cell prior to using 

this feature to add a note. 
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Note: Shortcut key combinations are shown within the Options menu when working in the 
Gradebook scores columns, as well as on the QRC. 

• If teacher requires student to resubmit assignment after grading the teacher will need to 

delete the mark. 

Note: Any Assignment feedback entered by teacher will be deleted when mark is deleted. 
However, feedback can be added back in after the mark is deleted, making the feedback 
visible to the student. 

• Special Codes - Special codes impact the grade entered in a cell.  Special codes are 

created from the Tools top tab.  To utilize special codes set up in Tools > Special Codes 

in the Gradebook, type the code into the cell or use Ctrl + L with your cursor in the cell 

and filter by special code.  

 

• Enter 0 (zero) for assignments not submitted (the zero will be included in the grade 

calculation).The system does not include blank cells in calculated averages (a blank 

mark will be ignored in the grade calculation). 

• MyEducation BC automatically saves each entry and updates the average when the 

user leaves a cell. 

• To view grades for a single student, click on the student’s name. 

• There are a number of icons with associated behaviours that appear in the Gradebook 
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.  Please note that the red pushpin can be overridden for reposting of grades depending on 
school settings. 

Scores can also be entered in single student view by Student using Gradebook > Scores > 
Student.  All assignments are visible for a selected student and mark changes or mark entry can 
be done in this view. 
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Scores can also be entered by single assignment view using Gradebook > Scores 
>Assignment.  All students are visible for a selected assignment and mark changes or mark 
entry can be done in this view. 

 

 

8.1.2 Accessing the Scores View From Pages 

The Scores window can be accessed quickly and easily from the Pages top tab start screen. In 

the Teacher Classes widget, click on the Grades  icon. 

 

8.1.3 Move Between Students When Entering Report Card Comments 

 

When entering Comments for a student   Click  or .  This saves your comment, 

and opens the Edit Text Comment box for the previous or next student. Continue to click the buttons and 
enter comments as needed. Then Click Save to close the pop-up. 
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9.0 Gradebook: Posting Grades 

There are two ways to enter grades for a report card: 

• Entering a term grade directly to term grade screen for report cards.  (Teacher manages 

daily assessment outside of MyEducation BC). 

• Updating Post Columns from teacher-created assignments in the Gradebook.  (Teacher 

uses MyEducation BC to manage daily assessment). 

9.1 Entering a Term Grade Directly to the Term Grade Screen.  

1. Log in as a teacher.  

2. From the Pages top tab, click on the  icon beside the class for grade entry.  This 

takes you to the Gradebook top tab and the Scores side tab.  

3. In the Grade Columns field, choose Post Columns – Term. 

4. In the Term field, choose the appropriate term for which grades are being entered.   

 

Black pushpins with no shape beside them appear in the column headers prior to the dates 

defined for mark entry and appear in the Grade Post Controls. 

Green pushpins with a triangle beside them appear during the dates defined for mark entry.  

This lets the teacher know that the grade post window is open and they can enter marks and 

post them.   

Red pushpins with a red square beside them appear when the Post button has been pushed.  

Please note that the red pushpin can be overridden for reposting of grades depending on school 

settings. 

Enter grades, work habits and comments as appropriate.  Data is automatically saved, a yellow 
cell indicates the save is in progress, wait for the yellow to clear before entering a score into the 
next cell.  
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Comments can be entered manually after clicking on the notepad icon. Clicking the black 
triangle at the top right of the comment box opens the comment bank selection box. 

Character count and limit display at the bottom of the comment entry box, providing teachers 

the opportunity to edit the comment before saving if it over the character limit. If the comment is 

over the character limit, the comment cell displays red and an error message shows at the top 

of the scores screen.  The comment will not be saved if it is over limit. 

 

 

Comments will not save if they are over the maximum charcters for the Transcript Definition. 
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Clicking on a comment places it in the comment field. Show My Codes displays the user’s 
comments only within the selected category. 

 

 

The Options menu provides the following: 

Quick Tips:  Use the Options menu for shortcuts available for entering data, or use the 
quick keys.   

Lookup (Ctrl+L):  shows the user the valid values that can be entered into that field, if 
defined in Tools. 

Fill-Down Values (Ctrl+D):  takes the value in the cell the user is in and copies it down 
to all students below that cell.  This works for comments as well as grades. 

Revert Current Cell (Ctrl+K):  returns the cell value to the previously entered value.   

 

For transcript definitions with a calculation, an “Update” button will appear in the Final column in 
the final reporting period for courses.  Clicking the Update button will populate the final grade 
according to the calculation in the transcript definition.   
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When data entry is complete, click the Post Grades button.  A pop up window will confirm 
the course section and present a dropdown selection for grade term. This process creates 
the grade record for the student which will appear on the report card.   
Use the Class dropdown menu to select the course section by nickname or the navigation 
bar to select the next class.   

 

Repeat the process until grades are entered and posted for all classes.   
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9.2 Update Post Columns (Enter Term Grades) From Teacher-
created Categories/Assignments in the Gradebook 

• Pages top tab, click on the  icon beside the class for grade entry.  Or Gradebook top 

tab > Scores side tab.  

• Click the Update Post Columns button. 

• In Step 1 of the Update Post Columns wizard, use the drop-down menu to select the 

appropriate Grade Term.   Leave the Grades to update at Term grades for all students. 

• Click Next. 

• In Step 2 of the wizard, use the drop-down menu to select the grade to populate the term 

report card grade for the students in this class.  Click Next. 

 
 

• In Step 3 of the wizard, confirm that you have selected the correct grade term and grade.  

Click Finish. Complete the entry of work habits and comments in the Post Columns 

Term for the appropriate term.   
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For transcript definitions with a calculation, an “Update” button will appear in the Final 
column in the final reporting period for courses.  Clicking the Update button will populate the 
final grade according to the calculation in the transcript definition.   

• Enter grades, work habits and comments as appropriate.  Data is automatically saved. 
Comments can be entered manually after clicking on the notepad icon. Clicking the 
black triangle at the top right of the comment box opens the comment bank selection 
box. 
 

 
 

Clicking on a comment places it in the comment field. Show My Codes displays the user’s 
comments only within the selected category. 

 

 

The Options menu provides the following: 

Quick Tips:  Use the Options menu for shortcuts available for entering data, or use the 
quick keys.   
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Lookup (Ctrl+L):  shows the user the valid values that can be entered into that field, if 
defined in Tools. 

Fill-Down Values (Ctrl+D):  takes the value in the cell the user is in and copies it down 
to all students below that cell.  This works for comments as well as grades. 

Revert Current Cell (Ctrl+K):  returns the cell value to the previously entered value.   

 

 
 

• When data entry is complete, click the Post Grades button.  A pop up window will 

confirm the course section and present a dropdown selection for grade term. This 

process creates the grade record for the student which will appear on the report card.   

 

• Use the Class dropdown menu or the navigation bar to select the next class.   

 
 

• Repeat the process until grades are entered for all classes.   
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10.0 Gradebook: Reports 

10.1 Gradebook > Class List Reports 

From the Gradebook top tab > Class List, choose Reports. If you don’t want reports run for all 
classes, check beside the classes to select, do an Options > Show Selected.  

Reports available are: 

• BC Class List Reports - BC Class List w. Desig - Includes parameters for aboriginal 

and designations. 

• BC Class List Reports - BC Class List w. Grid - Generates a class list with 10 

columns; headings can be typed or written in afterwards. 

• BC Class List Reports - Class Lists  - List students and YOG  

• BC Marks Verification with Comments – Generates a class list showing the marks 

and comments entered for the selected reporting term. BC Mark Verification with 

Comments report displays assignment mark as Final Term Mark. The report  pulls an 

assignment column value into the Final Term Mark field if the assignment column title is 

Final. 

• Blank Grading Sheet - a very handy report providing a class list and up to 10 columns 

• Grade Input Sheet - Report for entering or displaying term grade and work habits. 
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10.2 Gradebook > Scores Reports 

A number of analysis reports can be found from Gradebook > Scores > Reports. These reports 
include: 

-  

Progress reports can be run on a class of students or selected students. Teachers have a 
variety of parameters to choose from and the option to enter a message to display on the 
progress report.  
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11.0 Report Cards 

A class set of report cards can be printed from class rosters as described in Section 11.0. To 
print report cards for all students or for a select group of students, go to the Student top tab. For 
only a select group of students, select the students and go to Options > Show Selected. To run 
the report cards, begin from Reports > Report Cards and choose the appropriate report card 
from the Report Card Type drop down selection. 
 

 
 

Complete the parameter form and click Run. 

 

 



 

Traditional Gradebook v2.2 Page 51 

12.0 The Planner 

The Planner is a useful visual calendar of upcoming class related items and appointments. 
Class assignments and tests can be viewed from the Planner and filtered for a particular class 
and/or term.  

 

 

The Planner displays student assignment dates as set in Gradebook > Assignments. 
Assignments can also be added from the Planner either by clicking on a date and opening up an 
options menu including; Add Assignment, Add Ungraded Assignment or Add Appointment.  

When adding an assignment in the Planner view, the classes picklist will display the nickname if 
the teacher has given one to the class. Nicknames are defined in the Class details. 
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The Options menu includes these items as well as Edit Calendar Item, Delete A Calendar 
Item, Edit Lesson Plans, Copy Assignment and accessing Planner Settings.  Selecting My 
Resources will add a window with your saved resources for easy drag and drop access for 
assignments. 

 

If using Group > Events, these also will display within the Planner. 
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13.0 Tools 

Provided in the Staff View for teachers is the availability of Special Codes and Footnotes 
which offer further methods of notating information to student assignments. It is under the Tools 
top tab that teachers can also build their banked Comments. 

13.1 Special Codes 

Tools top tab > Special Codes side tab 

Teachers can create special gradebook codes to exempt an assignment score from a student’s 
average or to count as a zero (0). For example, you might create the MED (medical) code to 
explain why a student did not complete an assignment, and then determine that the score does 
not affect the student's average. 

 

13.2 Footnotes 

Tools top tab > Footnotes side tab 

Create footnotes to add special notes to scores on the Scores page. The notes do not add or 
subtract any points, or affect the student’s average. They simply offer you a place to record 
notes regarding an assignment grade. 

After you enter a footnote for a score, the code you select appears next to the score. To view 
the footnote, use your cursor to hover over the footnote code 

13.3 Teacher Comment Bank 

Teacher comment banks fit within the school bank which fits within a district bank, should there 
be one. The school should have a single comment bank created for the teacher to select and 
add their own comments. The comments of each teacher/user are visible only to the individual 
who created them even though they reside within the greater bank. It is important to understand 
that only a single comment bank can be associated to each course from the School View, 
Schedule > Courses > Details. It is for this reason that if a district wishes to create a bank then 
the schools should enter their comments within this one as should the teachers. Otherwise the 
school should create a bank within which the staff can enter their comments and then only one 
bank exists to be added to every course.  

• Staff > Tools tab > Comments side-tab. 

• A list of any comment banks already created appears. Select a comment bank, and 
click Comments side tab > Codes sub-side tab. 

• On the Options menu, click Add. The New Comment Bank Code page appears. 

• In the ID field, type an identifier for the comment, such as a number or short 
combination of letters and numbers to identify the comment for users. Users can use 
this ID to search for the comment. 

Note: Be careful not to create a code that is already represented in your 
grade scale. For example, you do not want to create a campus event 
code C if your grade scale contains a C grade. 
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• In the Preview field, type the text of the comment to let users know what will be inserted 
in the field if they select this comment. This does not have to match the value you enter 
in the comment field. For example, you might type (Student) shows innovative thinking 
so that users will know the student’s name is inserted once they select it. 

• In the Comment field, type the actual comment. You can include a variable, which is 
text enclosed in double curly braces {{xxx}} and a filter, which is pipe-delimited text 
after a variable (hold the Shift key while clicking the backspace key to create the | 
symbol). For example, {{studentName|capitalize}} prompts the system to insert Jon 
instead of jon. 

• In the Category 1-3 fields, you can enter specific names for the categories defined for 
the comment bank itself. For example, if the comment bank has Category 1 defined as 
Department, Category 2 defined as Course, and Category 3 defined as Level, the 
specific categories you might enter for a comment could be English, Creative Writing, 
and AP. 

 

See Appendix B for further details on comment banks and the use of variables.
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Appendix A – Understanding Average Modes 

A.1 Averaging Mode #1: Categories only (weighted categories)  

This mode requires you to define:  

• A weight for each category in Gradebook > Details > expand the Categories 

section. See section 14 for details.  

To calculate an average Aspen does the following in this order: 

1. Each assignment score is converted into a percentage.  

2. Assignment percentages are averaged within each category. (Assignment 

percentages are added together and multiplied by the total number of assignments in the 

category) 

Reasoning and Analyzing 

RA Category: 
(Weight: 25) 

Understanding and Solving  
US Category: 
(Weight: 25) 

Communicating and Representing  
CR Category: 
(Weight: 50) 

RA 1: 10 of 10 =100% US 1:  50 of 50=100% CR 1: 80 of 100 = 80% 

RA 2: 9 of 10 = 90% US 2: 42 of 50 = 84% CR 2: 94 of 100 = 94% 

RA 3: 15 of 20 = 75% US 3: 48 of 50 = 96% CR 3: 180 of 200 = 90% 

RA 4: 4 of 5 = 80%   

RA Average:  

(100+90+75+80)/4 = 86.25% 

US Average:  

(100+84+96)/3 = 93.33% 

CR Average:  

(80+94+90)/3 = 88% 

 

3. Category averages are weighted.  (The category average is multiplied by the weight 

given to the category.) 

4. Calculate Average. Calculated category averages are added together. 

 (86.25 x 25/100) + (93.33 x 25/100) + (88 x 50/100) = 88.89%  
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A.2 Averaging Mode #2: Categories and assignments (weighted)  

This mode requires you to define:  

• A weight for each category in Gradebook > Details > expand the Categories section. 

See section 14 for details.   

• A weight for each assignment in Gradebook > Assignment > Details.  See section 15 for 

details. 

To calculate an average Aspen does the following in this order: 

1. Each assignment score is converted into a percentage. 

2. Assignments are weighted.  Assignment percentages are multiplied by the 

weight given to the assignment. 

3. Categories are Averaged.   

HW: (100 x 2/5) + (90 x 1/5) + (75 x 1/5) + (80 x 1/5)  = 89% 

Quiz: (100 x 1/3) + (84 x 1/3) + (96 x 1/3) = 93.33% 

Test: (80 x 1/5) + (94 x 2/5) + (90 x 2/5) = 89.6% 

Reasoning and Analyzing 

RA Category: 
(Weight: 25) 

Understanding and Solving 
US Category: 
(Weight: 25) 

Communicating and Representing CR 
Category: 

(Weight: 50) 

RA 1 (wt=2): 

10 of 10 =100% 

US 1 (wt=1):   

50 of 50=100% 

CR 1 (wt=1):  

80 of 100 = 80% 

RA 2 (wt=1):  

9 of 10 = 90% 

US 2 (wt=1):  

42 of 50 = 84% 

CR 2 (wt=2):  

94 of 100 = 94% 

RA 3 (wt =1):  

15 of 20 = 75% 

US 3 (wt=1):  

48 of 50 = 96% 

CR 3 (wt=2):  

180 of 200 = 90% 

RA 4 (wt=1):  

4 of 5 = 80% 

  

RA Average:  

89.00% 

US Average:  

93.33% 

CR Average:  

89.60% 

4. Category averages are weighted.  (The category average is multiplied by 

the weight given to the category.) 

(89 x 1/4) + (93.33 x 1/4) + (89.60 x 1/2) = 90.38% 

5. Calculate Average. Calculated category averages are added together. 
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A.3 Averaging Mode #3: Total points 

This mode requires you to define:  

• A point value for each assignment in the Assignment Details (Required Field) 

To calculate an average Aspen does the following in this order: 

(Assignments are NOT converted to a percentage) 

1. Calculate Points Earned.   All points a student receives for each assignment 

are added together.  

2. Calculate Points Possible.  Total Points Possible for all assignments are 

added together. 

3. Calculate Average.  Total Points Earned is divided by Total Points Possible. 

 

Reasoning and Analyzing 
RA Category: 

Understanding and Solving US 
Category: 

Communicating and Representing CR 
Category: 

RA 1: 

10 of 10  

US 1: 

50 of 50 

CR 1: 

80 of 100  

RA 2: 

9 of 10  

US 2: 

42 of 50  

CR 2: 

94 of 100 

RA 3:  

15 of 20  

US 3: 

48 of 50 

CR 3: 

180 of 200 

RA 4: 

4 of 5  

  

RA  

Total points earned: 38 

Total points possible: 45 

US  

Total points earned: 140 

Total points possible: 150 

CR  

Total points earned: 354 

Total points possible: 400 

 

Total Points Earned:  38 + 140 + 354 =532 

Total Points Possible: 45 + 150 + 400 = 595 

532/595 = 89.41 % 
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A.4 Averaging Mode #4: Category total points  

This mode requires you to define:  

• A point value for each assignment in the Assignment Details (Required Field) 

To calculate an average Aspen does the following in this order: 

(Assignments are NOT converted to a percentage) 

1. Calculate Category Points Earned.   The points a student receives for each 

assignment in a category are added together.  

2. Calculate Points Possible.  The Total Points Possible for each assignment 

in a category are added together. 

3. Categories are Averaged.   

Homework: 38/45 = 84.44  Quiz: 140/150 = 93.33  Test: 354/400 = 85.5 

Reasoning and Analyzing 
RA Category: 
(Weight: 25) 

Understanding and Solving 
US Category: 
(Weight: 25) 

Communicating and Representing CR 
Category: 

(Weight:50 ) 

RA 1: 

10 of 10  

US 1: 

50 of 50 

CR 1: 

80 of 100  

RA 2: 

9 of 10  

US 2: 

42 of 50  

CR 2: 

94 of 100 

RA 3:  

15 of 20  

US 3: 

48 of 50 

CR 3: 

180 of 200 

RA 4: 

4 of 5  

  

RA Average: 38/45 

84.44% 

US Average: 140/150 

93.33% 

CR Average: 354/400 

88.5% 

 

4. Categories are Weighted.  Category Averages are multiplied by the weight 

given to the category. 

(84.44 x 25/100) + (93.33 x 25/100) + (88.5 x 50/100) = 88.69% 

5. Calculate Average. Calculated category averages are added together. 
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Appendix B – Comment Bank Variables and Setup 

Create Comments in a Comment Bank  

After you create a comment bank, define the comments that are available within the bank. 

When you create a comment, you can use variables to call information specific to the record or 
student the comment is being entered for. For example, if you use the variable 
{{person.firstName}}, the system inserts the student’s legal first name where the variable 
appears in the comment text: 

{{person.firstName}} is a creative and critical thinker. = Jane is a creative and critical thinker. 

To create comments in a comment bank: 

1. Do one of the following:  

• For a district: Log on to the District view. Click the Admin tab, then the Data Dictionary 

side-tab. On the Data Dictionary side-tab, click Comments. 

• For a school: Log on to the School view. Click the Admin tab and the Comments side-

tab. 

• For staff members: Log on to the Staff view. Click the Tools tab and the Comments side-

tab. 

2. A list of any comment banks already created appears. Select a comment bank, and click 
Codes on the Data Dictionary side-tab.  

3. On the Options menu, click Add. The New Comment Bank Code page appears. 

4. In the ID field, type an identifier for the comment, such as a number or short combination 
of letters and numbers to identify the comment for users. Users can use this ID to search 
for the comment. 

5. In the Preview field, type the text of the comment to let users know what will be inserted 
in the field if they select this comment. This does not have to match the value you enter 
in the comment field. For example, you might type (Student) is disruptive in class so that 
users will know the student’s name is inserted once they select it.  

6. In the Code field, type the actual comment. You can include a variable, which is text 
enclosed in double curly braces {{xxx}} and a filter, which is pipe-delimited text after a 
variable (hold the Shift key while clicking the backslash key to create the | symbol). For 
example, {{studentName|capitalize}} prompts the system to insert Jon instead of jon. 

Use the following table to enter the available filters in your variables: 

Note: The samples below use Legal Name formats.  If Usual Name is preferred, substitute 
person.fieldC001 for firstName and person.fieldC003 for lastName.  
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Filter 
Type 

Description If you type this: This 
appears in 
the 
comment: 

Count The number 
of elements 
in a 
collection. 

{{student.conductIncidents|count}} 2 (the 
student has 2 
conduct 
incidents on 
record) 

Capitalize The system 
capitalizes 
the first 
letter. 

{{person.firstName|capitalize}} Elizabeth 

Titlecase The system 
enters the 
text in 
titlecase 
format. 

{{"parents and caregivers"|titlecase}} Parents and 
Caregivers 

Titlecase The system 
enters the 
text in 
titlecase 
format. 

{{"parents and caregivers"|titlecase}} Parents and 
Caregivers 

Ordinal  The system 
enters a 
numerical 
value in 
ordinal 
format. 

{{person.firstName}}'s 
{{student.conductIncidents|count|ordinal}} 
incident was the last documented offense. 

Timothy's 
third incident 
was the last 
documented 
offense. 

Upper The system 
enters the 
text in all 
uppercase. 

{{person.firstName|upper}} JANE 

Lower The system 
enters the 
text in all 
lowercase. 

{{person.firstName|lower}} jane 
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Filter 
Type 

Description If you type this: This 
appears in 
the 
comment: 

Trim The system 
enters the 
text with all 
white space 
trimmed. 

{{person.physicalAddress.addressLine01|trim}}, 
such as xxx123 Main Streetxxx 

123 Main 
Street (the 
address 
without any 
spaces 
before or 
after the text) 

Gender The system 
enters the 
gender term 
based on 
"Male" or 
"Female". 

{{person.genderCode|gender: He, She}} 

Can also be used with: Him, Her or His, Hers 

Gender 

Length The number 
of characters 
in text. 

{{person.firstName|length}}, such as Jane 4 (number of 
characters in 
the student's 
name) 

 

Note: You can chain filters by adding more filters separated by pipe (|) characters. For 
example, if you wanted to lower a text and then immediately capitalize it, you could 
use {{variable|lower|capitalize}}. 

 

7. In the Category 1-3 fields, you can enter specific names for the categories defined for 
the comment bank itself. For example, if the comment bank has Category 1 defined as 
Department, Category 2 defined as Course, and Category 3 defined as Level, the 
specific categories you might enter for a comment could be English, Creative Writing, 
and AP. 

8. Select the Disabled indicator checkbox if you do not want this comment to appear in the 
pick list for any users. For example, this would let you remove it from view without 
deleting it permanently. 

9. Click Save. 

Note: Staff members who create comment bank codes for school-owned banks will 
lose the codes if they move to a different school. However, codes created for 
comment banks owned by the Enterprise or district will remain if the user who 
created them changes schools within the Enterprise or district. 

 


