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1.0 Overview 

This document provides instructions on how to use learning standards (curricular competencies) 
in the teacher gradebook in MyEducation BC.   

The competencies are assigned to each course by the school and prepared each year as a part 
of the Grade Management process.  Once prepared, the competencies are available in the Staff 
View for use with assignments. 

If the Curricular Competencies are not available for use, contact the school office or District 
Level 1 Support for assistance. 

2.0 Save Functionality 

As with any software, users should ensure that they are saving often to avoid loss of 
work.  Save buttons are available at the top and bottom of screens throughout the application. 

 

2.1 Auto-Save 

In addition to the Save buttons, many screens in MyEdBC have an Auto-Save feature.  While 
this is handy functionality, users should not rely on it as a means of saving their work. Regular 
use of the save buttons should ALWAYS be the primary method for saving. See the separate 
Fundamentals Appendix: Auto-Save Statistics for a list of screens that provide the Auto-Save 
functionality as a back-up measure. 

Note: The auto-save interval (number of minutes before a screen is auto-saved) is determined 
by the user preference settings as outlined in the Preferences — General section in the 
Fundamentals guide.   

2.2 Gradebook and Grade Input Scores Save Functionality 

Staff > Gradebook > Scores 

School > Grades > Grade Input > Input Grid 

The grade entry screens in School and Staff view have a save-as-you-go functionality.  When a 
score is entered and the user moves out of the cell, the message: Saving, Please Wait…. 
Displays above the score grid and the cell will turn yellow.  The mark column entry is saved 
when both the message and the yellow cell colour have cleared the screen.  To avoid loss of 
work, do not begin entering information into the next cell until both the message and the yellow 
colour are no longer displayed on the screen, indicating the save has completed.  

Comment character limit and count display in the bottom right of the comment entry text box, 
providing teachers the opportunity to edit the comment before saving if it is over the character 
limit.   
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If the comment is over the character limit, the comment cell displays red, and an error message 
shows at the top of the scores screen. The comment will not be saved if it is over limit. Edit the 
comment prior to leaving the scores screen to avoid duplicated efforts in recreating the 
comment. 
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3.0 Setup for Competency-based Gradebook  

Refer to the Grade Management guide at www.MyEducationBC.info > School User Resources 
for instructions on preparing curricular competencies in the School view.   

The Transcript Definition is required for each course and defines the Grade Scale for the 
marks/scores that are entered into the report card term columns.   

The Rubric Definition defines the Grade Scale for the marks/scores that are entered into the 
assignments.  

Both the Transcript Definition and Rubric Definition are applied at the school level. 

When the Transcript Definition and Rubrics match, the assignment scores and the report card 
scores will use the same Grade Scale and can be used in both assignments and in term marks 
for report cards.  

Example: Transcript Definition *05 Single Term EMG-DEV-PRF-EXT and *05 BC 
Applied Design, Skills and Technology use the same Grade Scale (EMG-DEV-PRF-EXT 
and Letter Grades). Teachers can use the same scores for both assignments and term 
marks.  

However, this is not always possible or preferable and Schools can use Transcript Definitions 
that use one Grade Scale for term columns on report cards and a Rubric that uses a different 
Grade Scale for assignment scores in the Competency Based gradebook assignments. This is 
not problematic, but may be confusing for users, and clear end user instructions will be helpful 
in this scenario. 

Example: Grade 10-12 courses reporting with percentages on report cards (and TRAX) 
can use the Competency Based gradebook assignments.   

Transcript Definition Quarterly No Calculated Final (Provincial Grade Scale % and Letter 
Grade in the term report card columns) and *05 Applied Design, Skills and Technology 
(EMG-DEV-PRF-EXT and Letter Grades in the Competency Based gradebook 
assignments).  

  

http://www.myeducationbc/
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4.0 Staff View 

Staff view > Gradebook top tab > Details side tab 

Teacher settings in the competency-based gradebook: 

 

4.1 Curricular Competencies in the Gradebook 

Staff view > Gradebook top tab > Curricular Competencies side tab 

The BC curricular competencies are available in the Curricular Competencies side tab once the 
school has run the Prepare Curricular Competencies procedure.  

The standards are nested by category.   

The standard called ALL provides a way to see all assignments in the gradebook. 
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4.1.1 Manually Adding a Reporting Standard 

Curricular Competencies can also be added manually for individual users. For example, a class 
may master a standard and begin working on the next level up.  

Note: Manually added curricular competencies do not copy to linked classes, nor will they still 
be attached to an assignment that is imported from a previous year.  

Select Options > Add and then click on the Multi-Add button at the bottom of the screen: 

 

The standards are categorized by area of learning and competency category. Grade levels are 
indicated. 

 

Recommendation: Create the standard called ALL, if it does not already exist, and apply it to all 
assignments. This creates a way to see all assignments in the gradebook later. 
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Enter the details about the standard: 
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4.2 Categories 

Staff view > Gradebook top tab > Details side tab 

One category is needed in the competency-based gradebook to group assignments. Example 
name: Evidence of Learning (EOL).    

Notes from the Student Learning Committee: Many learning opportunities cover more 
than one Big Idea or content area. The type of learning opportunity (project, discussion, 
assignment, etc.) is irrelevant when assessing competencies. Competencies are 
assessed in all types of learning opportunities. A single category is a good way to set up 
a gradebook.  

4.2.1 Category Defaults 

Defaults are set the way a teacher most commonly enters information about their assignments. 
The default settings can be overwritten for individual assignments.  

 

The recommended default Visibility type is Private. With the Private setting default all 
assignments are created with the visibility of Private, allowing the teacher to determine when 
(or if) each individual assignment is ready to be viewed in the Student and Family Portal.   
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4.3 Assignments 

Gradebook top tab > Assignments side tab 

4.3.1 General tab 

Add the assignments details on the General tab: 
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4.3.2 Portal Description tab 

If Portal is in use, add a Portal Description so details of the assignment will display there: 

 

 

4.3.3 Standards tab 

For each assignment, attach the standards that will be assessed, one or many. Choosing the 
standard called ALL provides a way to see all assignments in the gradebook. Clicking the plus 
sign expands the selection to display the individual standards. 
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4.3.4 Students tab 

To apply an assignment to specific students: 

• Click the ‘Student’ sub top tab. 

• Select the student(s) that will not receive the assignment 

• Click Exclude. 

 

The student(s) will not see the assignment in their To Do widget or on the assignments list in the 
Student portal.  
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On the Scores page, the grading cell for the assignment is grayed out for students that have 
been excluded from the assignment. No mark can be entered. The assignment does not affect 
the student’s average; it does not exist for that excluded student.  

 

4.4 Completed Date Field for Student Assignments 

Teachers can record the date a student completed an assignment. 

Staff View > Gradebook top tab > Scores side tab 

In the assignment grading cell, click  to type Assignment feedback or Teachers Notes, and a 

Completed Date field appears at the top of the pop-up (Staff view > Gradebook TT > Scores 

ST).  
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4.5 Entering Marks and Feedback for Student Assignments 

4.5.1 Scores Window for Mark and Feedback Entry 

Go to Gradebook > Select class from class list > Scores side tab. 

• Enter Assignment feedback for student by clicking on Speech Bubble. These notes will 

be visible to students and parents. 

• Teacher can enter as much Assignment feedback as they like prior to scoring 

assignment. 

• Students can resubmit assignment as many times as they like until a score is entered by 

the teacher 

• Enter students’ assignment scores in the Gradebook column. 

• Make use of the following shortcuts: 

o Control + D – Fills all cells below with the same score. 

o Control + K – To undo the last change. 

o Control + E – To exempt a grade from the calculated average. 

o Control + N – To add a footnote visible only to the teacher.  Footnotes are created 

on the Tools top tab.  Enter a score in the cell, press Control + N on the keyboard, 

and select the note from the pick list. 

o Control + M – To add notes.  Notes can be visible to the teacher only or to the 

student and parents.  Note that a score must be entered in a cell prior to using this 

feature to add a note. 

o  

• If teacher requires student to resubmit assignment after grading the teacher will need to 

delete the mark. 

 

 

 

• Special Codes — Special codes impact the grade entered in a cell.  Special codes are 

created from the Tools top tab.  To utilize special codes set up in Tools > Special Codes 

in the Gradebook, type the code into the cell or use Ctrl + L with your cursor in the cell 

and filter by special code.  

Note: Shortcut key combinations are shown within the Options menu when working 
in the Gradebook scores columns, as well as on the QRC. 

Note: Any Assignment feedback entered by teacher will be deleted when mark is 
deleted. However, feedback can be added back in after the mark is deleted, making 
the feedback visible to the student. 
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• Enter 0 (zero) for assignments not submitted (the zero will be included in the grade 

calculation). The system does not include blank cells in calculated averages (a blank 

mark will be ignored in the grade calculation). 

• MyEducation BC automatically saves each entry and updates the average when the 

user leaves a cell. 

• To view grades for a single student, click on the student’s name. 

• There are a number of icons with associated behaviours that appear in the Gradebook. 

  



 

Using the Competency Based Gradebook v.2.9 Page 17 

5.0 Enter Assessment Information 

In the competency-based gradebook, assessment information can be entered in three ways: 

1. By standard 

2. By student 

3. By assignment 

5.1 By Standard 

When you first enter the Scores Side Tab, you are in Standard View. In this view, you can enter 
all the assessment information from your assignments that relates to one standard only. As you 
change the standard, the assignments available on the page change. The assessment 
information entered is for that specific standard only. 

 

 
The standards-based view will now display buttons for “add Assignment” or Update Post 
columns” and “Post Grades, so that these actions can be taken during the Standards View.  
This can be changed for the viewer in Staff View and School View.  
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In addition to the existing drop-down menu containing standards, teachers can select Post 
column views, so that they do not need to switch to traditional view. Teachers can edit term 
grades if Post Columns- Term is selected in Standards drop down menu 
 

 

*If grades were posted during the posting window, the posted values are locked in the Staff 

View after the posting windows are closed. 
*If grades were not posted during the posting window, the post columns are editable in the Staff 
View 
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5.2 By Student 

Click on the “Student” leaf under the Scores side tab or on a student’s name. One student’s 
information is on the screen. Entering assessment information by student is also related to a 
specific standard. Attach the standard “ALL” to every assignment to see all assignments on the 
screen.  Hover over the column header, to see a short version of the competency. 

 

5.3 By Assignment 

Click on the “Assignment” leaf under the Scores side tab. This view allows data entry for all 
standards for one assignment.  Click on the magnifying glass icon next to the column header in 
other views to enter assignment view. 
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6.0 Reports 

6.1 Competency Summary Report  

The Competency Summary report provides teachers with the ability to print a summary by 
standard, listed alphabetically, for a student or all students in the course section. 

Navigation to report:  

• Staff view > Gradebook Top tab > Scores Side tab > Reports > Competency Summary 

• Staff view > Gradebook Top tab > Scores Side tab > Student Sub-side tab > Reports > 

Competency Summary 

The report runs for all the students in the course section if the student parameter is blank, or it 
can run for one student if selected from the pick list. You can also choose to not have 
assignment feedback displayed on the report by unchecking the Display Feedback checkbox. 
The user must have one of the Publish Add-on roles to see the “Publish” tab. 

 

The report output: 

• Shows the student’s proficiency for the standards defined for the course section. 

• Prints standard “All” on the report only if a proficiency is entered for that standard. 

• Displays the Proficiency Scale based on the Rubric Definition assigned to the course. 
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7.0 Other Features 

7.1 Special Codes 

Tools top tab > Special Codes side tab.  

Special codes offer additional methods of noting information to student assignments. Refer to 
the Traditional Gradebook reference guide for more information on entering special codes. 

 

 

7.2 Setting Colours to Proficiency Scales 

Gradebook top tab > Curricular Competencies side tab > Rubric Rating Scales > Ratings 

 

Showing colours in Gradebook 
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7.3 Report Card Comments 

7.3.1 Move Between Students When Entering Report Card Comments 

School View> Grades top tab > Grade Input side tab 

Staff View > Gradebook top tab > Scores side tab 

When entering comments for a student, click  or .  This saves the comment and 
opens the Edit Text Comment box for the previous or next student. Continue to click the buttons 
and enter comments as needed. Then click Save to close the pop-up. 

 

When logged on as a teacher > Staff View > Gradebook > Scores > Standard radio button > 
Standard — Post Columns Terms >  

The system allows a mark to be entered in the term column from the ‘Standards’ toggle, BUT 
the term comments either free form or saved, MUST be entered using the ‘Traditional’ toggle. 

 

7.3.2 Character Count for Post Column/Report Card Comments 

When teachers in Staff view, or school staff in School view, enter a post column/report card 
comment in the Gradebook, the character count and limit appear at the bottom right of the 
text comment box. This guide helps teachers stay within the report-defined text area. If the 
teacher enters a comment that exceeds the limit, the character count and limit are 
highlighted in red. This gives the teacher a chance to edit the comment and reduce its 
length. MyEducation BC will not save a comment if its length exceeds the limit. 

 


