Version History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Sep 1, 2017</td>
<td>Initial Document</td>
</tr>
<tr>
<td>1.1</td>
<td>Dec 14, 2018</td>
<td>Updated with Section 6.1.5 New Class Roster Side Tab</td>
</tr>
<tr>
<td>1.2</td>
<td>Apr 17, 2019</td>
<td>Added hyperlinks to Table of Contents</td>
</tr>
<tr>
<td>1.3</td>
<td>Jul 29, 2019</td>
<td>Update Daily attendance preferences with new 5.10 options 3.1, 4.1, 5.1</td>
</tr>
<tr>
<td>1.4</td>
<td>Oct 21, 2019</td>
<td>Section 3.3 updated to School Setup BC Default Template to support Student Portfolios</td>
</tr>
</tbody>
</table>

Confidentiality

This document contains information which is proprietary and confidential to Fujitsu Consulting (Canada) Inc. (including the information of third parties, including but not limited to, Follett of Canada Inc., submitted with their permission). In consideration of receipt of this document, the recipient agrees to treat this information as confidential and to not use or reproduce this information for any purpose other than its evaluation of this proposal or disclose this information to any other person for any purpose, without the express prior consent of Fujitsu Consulting (Canada) Inc. (and any applicable third party.)
Table of Contents

1.0 CLASS ATTENDANCE IN MYEDUCATION BC ................................................................. 4
2.0 CLASS ATTENDANCE OPTIONS .................................................................................. 4
3.0 NO DAILY ATTENDANCE VALUE CREATED FROM CLASS POSTING .................... 5
   3.1 Daily Attendance Preferences .................................................................................. 5
   3.2 Class Attendance Preferences ................................................................................ 6
   3.3 Class to Daily Procedure ........................................................................................ 7
   3.4 Staff View Attendance – No Daily Value Created From Class .............................. 8
4.0 DAILY ATTENDANCE VALUE CREATED FROM ONE CLASS POSTING ..................... 9
   4.1 Daily Attendance Preferences ................................................................................ 9
   4.2 Class Attendance Preferences .............................................................................. 10
   4.3 Staff View Attendance – Daily Value Created from One Class Posting ............... 11
5.0 DAILY ATTENDANCE VALUE CREATED FROM TWO CLASS POSTINGS ............... 12
   5.1 Daily Attendance Preferences .............................................................................. 12
   5.2 Class Attendance Preferences .............................................................................. 14
   5.3 Staff View Attendance – Daily Value Created from Two Class Postings .............. 15
6.0 TAKING ATTENDANCE – OFFICE .............................................................. 16
   6.1 Creating or Editing a Student Class Attendance Value ......................................... 16
7.0 APPENDIX 1: SECURITY ROLES FOR TAKING ATTENDANCE .............................. 23
8.0 APPENDIX 2: ATTENDANCE CODES ................................................................. 24
9.0 APPENDIX 3: ATTENDANCE REPORTS .................................................................. 25
   9.1 Class Attendance Reports ..................................................................................... 25
   9.2 Daily Attendance Reports ..................................................................................... 26
   9.3 Staff view Attendance Reports ............................................................................. 28
1.0 Class Attendance in MyEducation BC

Class attendance and Daily attendance are separate functions in MyEducation BC. An entry can be created for individual Classes, and one entry created for a Daily attendance value on a given day.

If a School creates Daily value for a student in addition to class values, school Preference settings will determine the way a Daily attendance value is created. A Daily value can be created by the posting of one or more Class values, or through the Class to Daily Attendance Procedure.

With Class based attendance, MyEducation BC is set up to record one attendance record per student per class.

- The class attendance record stores the date, the code and whether the late, dismissed, or excused checkboxes were selected.
- The arrival and departure times.

Class Attendance in MyEducation BC can be recorded through the School Office view or through the Teacher Staff view:

- School view > Attendance > Class Office
- Staff view > Class Attendance

The School Setup and Staff Class Attendance input vary slightly depending on the method of Class Attendance selected. Detailed instructions for Staff view attendance are found in the Staff View Setup and Navigation guide.

The School Class Office entry is done in the same way regardless of the method of class attendance selected.

Schools must be setup with an active schedule and days assigned if using course sections in the calendar. See the School Setup guide for details.

2.0 Class Attendance Options

Class attendance will track which individual classes or course sections your students attended.

Class attendance can be taken:

- Once a day by an identified course section
- Twice a day by identified course section(s)
- In each course section scheduled in a day
  - Can be taken twice in a course section that is scheduled twice on the same day

Class attendance can create a Daily attendance value for a student based on School Preference settings:

- The initial posting of *one selected period class attendance* creates a daily attendance value for the student. After the initial class posting, subsequent changes to the daily value can be adjusted by the office as needed.
- The initial posting of *two selected period class attendances* creates a daily attendance value. Each period accounts for a partial amount of the day. After the initial class
postings, subsequent changes to the daily value can be adjusted by the office as needed.

- **Class to Daily attendance procedure** creates a daily value for a student based on the class value entered in each scheduled class if one is not created through a class posting. The daily value for the student will be visible on the following day.
  - This procedure will increase the daily value based on class attendance, it will not reduce the daily value based on class attendance. Reduction to a daily value can be adjusted by the office as needed.

Attendance setup for your school is done from the **School top tab > Setup side tab > Preferences** leaf. Both the Daily Attendance and Period Attendance dropdowns will have preference settings for class attendance.

### 3.0 No Daily Attendance Value created from Class Posting

#### 3.1 Daily Attendance Preferences

**School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic**

These two settings must be set:

- **Classroom Input Type** to **Homeroom** - This setting prevents a daily value from being created by a period class attendance posting.
- **Show Daily Side tab in Staff view** to **unchecked** - Daily values and Class values are separate, this should only be checked in schools where the teacher is creating a daily value based on students in the homeroom. If the Daily side tab is visible in Staff view a Daily value can be posted for the students listed, overwriting any entry made by the office.

**School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Advanced**

For details on Weekend Attendance, see the **School Setup guide**

For Second Daily Attendance:

- **Second daily attendance** – **Unchecked**
- **AM portion absent** – **Blank**
- **Classroom input type** – **Homeroom**
- **Classroom input period** – **N/A**

Attendance Activity Tracking: District settings determine if a school can edit these fields

- **Attendance Activity Tracking** – **Unchecked** – not for use in BC
- **Restrict [edit] link in staff view (this setting applies to both class and daily attendance)**
  - **Checked**: Presents a view only popup in Staff > Attendance
  - **Unchecked**: Presents an editable popup in Staff > Attendance
If the School Office is entering a Daily attendance value the following Daily Attendance preferences can also be set. The Advanced Tab allows for the selection of Weekend Attendance if applicable (See School Setup guide for details) and Second Daily Attendance settings which are not applicable to this attendance type.

- Classroom Input Period: N/A
- Recent attendance history cutoff – the number of days of attendance history shown in the Recent Attendance filter.
- Allow daily attendance for past dates – N/A
- Previous day limit – N/A
- Daily Roster Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily Roster side tab if used.
- Daily Office Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily office side tab if used.
- Staff View Input Buttons – N/A

### 3.2 Class Attendance Preferences

*School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic*

- **Post mode** - determines if and how many times a teacher may post class attendance information to a student record
  - No Post – Attendance will be recorded in the Staff view but will NOT be recorded in a student record
  - Post – Attendance can be posted to a student Class attendance record multiple times, overwriting the last entry.
**Post Once** – Attendance can be posted to a student Class attendance record once, changes made after the initial post will not change the student Class attendance record.

- **Allow Date Change** – Controls the Date Navigation setting in the Staff view > Attendance
  - **Checked** – Allows date change and attendance adjustment in Staff view (based on post mode setting)
  - **Unchecked** – Changes to Class attendance for previous dates is done only in the office via School view

- **Track Class Attendance by Period** - Check if the school has double blocked periods and would like an attendance record posted for both periods.

**3.3 Class to Daily Procedure**

The Class to Daily Procedure can be run for schools taking Class based attendance and not creating a Daily value.

This procedure can be set up to run nightly and will create a Daily Attendance value based on the classes absent divided by the total classes scheduled for the day. The Daily Attendance value will be visible the following day. This procedure will increase the daily value based on class attendance, it will not reduce the daily value based on class attendance. Reduction to a daily value can be adjusted by the office as needed.

*School view > School top tab > Setup side tab > Details leaf*
3.4 Staff View Attendance – No Daily Value Created From Class

In Staff view attendance is accessed through the *Today’s Classes* widget or the *Attendance top tab.*

Class Attendance is taken for all course sections by selecting the corresponding button (A or L in the screenshot) on a given date and posted to the student record using the Post button. The Post button is active or greyed out depending on the school settings for Post Mode in the Class Attendance preferences screen. No Daily Attendance value is created by the Staff view class posting in any course section.
4.0 Daily Attendance Value created from one Class Posting

A Daily Attendance value is created from the initial posting of one selected period Class attendance. Changes to the Daily value after the initial posting can be made through School or Staff view depending on preference settings.

4.1 Daily Attendance Preferences

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic

These three settings must be set:

- **Classroom Input Type** to *Period* - This setting allows a daily value to be created by a period class attendance posting.
- **Classroom Input Period**: Select the period of the day that will create the Daily attendance value when the class attendance is posted.
- **Show Daily Side tab in Staff view** to *unchecked* – It is recommended that this only be checked in schools where the teacher is creating a daily value based on students in the homeroom, not a course section. If the Daily side tab is visible in Staff view a Daily value can be posted for the students listed in the staff homeroom, overwriting any entry made by the office.

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Advanced

For details on Weekend Attendance, see the School Setup guide

Second Daily Attendance:

- **Second daily attendance** – *Unchecked*
- **AM portion absent** – *Blank*
- **Classroom input type** – *Homeroom*
- **Classroom input period** – *N/A*

Attendance Activity Tracking: District settings determine if a school can edit these fields

- **Attendance Activity Tracking** – *Unchecked* – not for use in BC
- **Restrict [edit] link in staff view (this setting applies to both class and daily attendance)**
  - **Checked**: Presents a view only popup in Staff > Attendance
  - **Unchecked**: Presents an editable popup in Staff > Attendance
If the School Office is entering a Daily attendance value the following Daily Attendance preferences can also be set. The Advanced Tab allows for the selection of Weekend Attendance if applicable (See School Setup guide for details) and Second Daily Attendance settings which are not applicable to this attendance type.

- Recent attendance history cutoff – the number of days of attendance history shown in the Recent Attendance filter.
- Allow daily attendance for past dates – N/A
- Previous day limit – N/A
- Daily Roster Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily Roster side tab if used.
- Daily Office Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily office side tab if used.
- Staff View Input Buttons – N/A

### 4.2 Class Attendance Preferences

The first posting of the Class Attendance for the period selected as the Classroom Input Period in Daily Attendance preferences will create the Daily Attendance value for the student. Subsequent postings (if allowed by school Post Mode preferences below) will update the Class attendance value, any changes required to the student Daily Attendance value will be done through the office School view.

**School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic**

- **Post mode** - Determines if and how many times a teacher may post class attendance information to a student record.
  - **No Post** – Attendance will be recorded in the Staff view but will NOT be recorded in a student record
  - **Post** – Attendance can be posted to a student Class attendance record multiple times, overwriting the last entry.
Post Once – Attendance can be posted to a student Class attendance record once, changes made after the initial post will not change the student Class attendance record.

- Allow Date Change – Controls the Date Navigation setting in the Staff view > Attendance
  - Checked – Allows date change and attendance adjustment in Staff view (based on post mode setting)
  - Unchecked – Changes to Class attendance for previous dates is done only in the office via School view

- Track Class Attendance by Period - Check if the school has double blocked periods and would like an attendance record posted for both periods.

Class Attendance > Advanced tab – N/A

4.3 Staff View Attendance – Daily Value Created from One Class Posting

In Staff view attendance is accessed through the Today’s Classes widget or the Attendance top tab.
Class Attendance for all course sections is taken by selecting the corresponding button (A or L in the screenshot) on a given date and posted to the student record using the Post button. The Post button is active or greyed out depending on the school settings for Post Mode in the Class Attendance preferences screen.

The first posting by the teacher of the Class Attendance for the period creates the Daily Attendance value for the student. Subsequent Class Attendance postings for the section (if allowed by school Post Mode preferences) will update the Class attendance value, not the student Daily Attendance value. Any changes required to the student Daily Attendance value will be done through the office School view.

5.0 Daily Attendance Value Created from Two Class Postings

A Daily Attendance value is created from the posting of two selected period Class attendances, typically a morning and an afternoon class. Changes to the Daily value after the initial posting can be made through School or Staff view depending on preference settings.

5.1 Daily Attendance Preferences

School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Basic

These settings must be set:

- **Classroom Input Type** to *Period* - This setting allows a daily value to be created by a period class attendance posting.
- **Classroom Input Period**: Select the period of the day that will create the first or morning portion of the student Daily attendance value when the class attendance is posted.
- **Show Daily Side tab in Staff view** to unchecked – It is recommended that this only be checked in schools where the teacher is creating a daily value based on students in the homeroom, not a course section. If the Daily side tab is visible in Staff view a Daily value can be posted for the students listed in the staff homeroom, overwriting any entry made by the office.
School top tab > Setup side tab > Preferences > Category dropdown: Daily Attendance > Advanced

- **Second daily attendance**: checked – This setting allows a portion of the daily attendance to be created separately from the first posting
- **AM portion absent** – Enter the portion of the day that the morning absence counts for (.5 for half of the day)
- **Classroom input type** – Period - This setting allows a daily value to be created by a period class attendance posting
- **Classroom input period** - Select the period of the day that will create the second or afternoon portion of the student Daily attendance value when the class attendance is posted.

Attendance Activity Tracking: District settings determine if a school can edit these fields

- **Attendance Activity Tracking** – Unchecked – not for use in BC
- **Restrict [edit] link in staff view** (this setting applies to both class and daily attendance)
  - Checked: Presents a view only popup in Staff > Attendance
  - Unchecked: Presents an editable popup in Staff > Attendance
If the School Office is entering a Daily attendance value the following Daily Attendance preferences can also be set. The Advanced Tab allows for the selection of Weekend Attendance if applicable (See School Setup guide for details).

- Recent attendance history cutoff – the number of days of attendance history shown in the Recent Attendance filter.
- Allow daily attendance for past dates – N/A
- Previous day limit – N/A
- Daily Roster Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily Roster side tab if used.
- Daily Office Input Buttons – select the number and type of buttons visible in the School > Attendance > Daily office side tab if used.
- Staff View Input Buttons – N/A

### 5.2 Class Attendance Preferences

The first posting of Class Attendance for the periods set as the Classroom Input Periods together will create a single Daily Attendance value for the student. Subsequent postings (if allowed by school Post Mode preferences below) will update the Class attendance value, any changes required to the student Daily Attendance value will be done through the office School view.

*School top tab > Setup side tab > Preferences > Category dropdown: Class Attendance > Basic*

- **Post mode** - Determines if and how many times a teacher may post class attendance information to a student record.
  - **No Post** – Attendance will be recorded in the Staff view but will NOT be recorded in a student record.
  - **Post** – Attendance can be posted to a student Class attendance record multiple times, overwriting the last entry.
  - **Post Once** – Attendance can be posted to a student Class attendance record once, changes made after the initial post will not change the student Class attendance record.
• **Allow Date Change** – Controls the Date Navigation setting in the Staff view > Attendance
  
  o **Checked** – Allows date change and attendance adjustment in Staff view (based on post mode setting)
  
  o **Unchecked** – Changes to Class attendance for previous dates is done only in the office via School view

• **Track Class Attendance by Period** - Check if the school has double blocked periods and would like an attendance record posted for both periods.

Class Attendance > Advanced tab – N/A

### 5.3 Staff View Attendance – Daily Value Created from Two Class Postings

In Staff view attendance is accessed through the *Today’s Classes* widget or the *Attendance top tab*. 

Class Attendance for all course sections is taken by selecting the corresponding button (A or L in the screenshot) on a given date and posted to the student record using the Post button. The Post button is active or greyed out depending on the school settings for Post Mode in the Class Attendance preferences screen.

The first posting of Class Attendance by the teacher in the designated periods creates the Daily Attendance value for the student. The periods are defined by the preference setting in Daily Attendance Preferences > Basic and Advanced. Subsequent Class Attendance postings for the course section (if allowed by school Post Mode preferences) will update the Class attendance value, not the student Daily Attendance value. Any changes required to the student Daily Attendance value will be done through the office School view.

6.0 Taking Attendance – Office

Each side tab in the Attendance top tab has different action items under the Options menu and different reports available in the Reports menu.

6.1 Creating or Editing a Student Class Attendance Value

6.1.1 Class Office Side Tab

School > Attendance > Class Office

Student Daily Attendance values and Class or Period Attendance values are separate. This screen lists all of the students in the school and has one column for the Daily code and columns for any scheduled periods in your school on the date selected on the top right of the screen.

Records created for either the Daily or Class attendance values for a student will display in the appropriate columns.

Class attendance entered here will be visible in the Staff view, teachers can edit the record if necessary prior to posting the Staff view attendance.

Note: Rotating your schedule in the Build View as a part of the Schedule Build process will allow this screen to list the course sections in the order they occur on the date selected. Using the Bell Schedule to rotate the school schedule presents this screen in a flat schedule order and the user will need to determine which order the periods occur on the date selected. See Rotations, Pattern Library and Pattern Sets reference guide for further details.

System Filters on the Class Office side tab include:
- **All Records**: This contains every student in the school, regardless whether they have an existing attendance record or not.

Filters to narrow the scope of the list:

- **Attendance Activity**: Students with any attendance records assigned to them on the given date, regardless whether they are Daily Attendance or Class Attendance records
- **Truant List**: Students that have Absence records assigned in one or more classes during the day, but the student Daily Attendance value is empty
- **Course Section = ?**: Students scheduled into the selected course section
- **Attendance Discrepancy**: Students with a Daily Attendance value of Absent, but have no Absent records for any of their classes that day
- **Grade Level = ?**: Students in a selected grade
- **Group = ?**: Students in a specified group
- **Homeroom = ?**: Students in a selected homeroom
- **Program = ?**: Students in a specified program

### 6.1.2 Taking Class Attendance in the Class Office Side Tab

If a Daily Attendance record exists the values can be "pushed out" to all the classes. In the **Daily Code** column, there will be a Daily Attendance value, followed by two “greater than” symbols, like so: `>>`. Click that symbol and it will copy the A-E code to each of the student’s classes. This value will push out to all course sections scheduled that day. If the absence is for a portion of the day only, adjust the class attendance by period as needed.

When the teacher logs in, it will show that student has been marked absent for that section.

Class Attendance can also be entered for an individual by clicking on the ellipsis in the appropriate period column, bringing up a popup. An attendance code and reason can be entered for that class only.
Any changes you make in this screen will be visible to the teacher when they go to their Staff view > Attendance for this course section.

6.1.3 Entering Class Attendance for Multiple Students at the Same Time

School > Attendance > Class Office > Options > BC Multi-Add Class Attendance

- **Students to Include** – select the students
  - **Student IDs** – opens the Student IDs entry box for entry of pupil numbers
  - **Current Selection** – uses the Current Selection of students on the Class Office Screen. Filter to the group of students needed
- **Start and End Dates** – defaults to the current date, enter the correct date or range of dates for the attendance record entry
- **Select period(s)** – select a single or multiple periods from the picklist
- **Attendance code** – The code determines the type of Daily Attendance record created, select the appropriate code for
  - A – Absent
  - AE – Absent Excused
  - L – Late
  - LE – Late Excused
  - AUTH – Authorized
  - D – Early Dismissal
• **Time In** - available for entry when Attendance code of L - Late or LE - Late Excused is selected. Time can be entered as a numeric and will be automatically formatted on the student record - HH:MM AM/PM. (10:15 AM)

• **Time Out** – available for entry when Attendance code of D – Early Dismissal is selected. Time can be entered as a numeric and will be automatically formatted on the student record - HH:MM AM/PM. (10:15 AM)

• **Attendance Reason** – select the appropriate Attendance Reason from the picklist per school or district policy

• **Duplicated Records** - provides options for how the system handles a record if one already exists for a student on that date.
  - **Skip** – will not overwrite the existing class attendance record
  - **Replace** – will overwrite the existing class attendance record with the new information

Click **Run** to record these absences. A confirmation pop-up will appear indicating how many records were updated.

### 6.1.4 Modifying Class Attendance in the Class Office Side Tab

Select the date on the top right of the screen and click the blue, hyperlinked Daily Attendance record or Class Attendance record to be modified. Change, add or remove any information as required for accuracy, or delete the entire record using **Options > Delete**. The Arrivals and Departures section can be edited by clicking into the blue hyperlinked details of the entry or using the **Add** or **Delete** buttons.
6.1.5 New Class Roster Side Tab

This new side tab will allow the school user to post daily and class attendance based on the school settings.

If the school is set with classroom input type “Homeroom” in preferences, the class attendance will be posted from the Class Roster screen.

If the school is set with classroom input type “Period” in preferences, there will be an option to post both Daily and Class attendance from the Class Roster screen. Regardless of the option selected, class attendance will be posted respectively.

School View> Attendance (TT)> Class Roster (ST)> Select Course> Take Attendance> Click Post button

6.1.6 Secondary School Management

Secondary School Management handles how your school works with Cross-Enrolled students. These settings will allow students to show in your All Active Students and All Students filters. They also control which school has the ability to create or own a Daily Attendance record.

School > Setup > Preferences > Secondary School Management

- Secondary Students
  - Checked - will include students with secondary associations to your school in the Active Students and related filters along with the students primary to your school. This is the recommended setting in BC for full functionality.
6.1.7 Positive Attendance in individual sections

Positive Attendance is Class Attendance where a student is defaulted to Absent and is marked Present if in attendance.

School view > School top tab > Setup > Preferences > Class Attendance > Advanced

- **Positive attendance in all classes** – unchecked

Set the number and type of attendance input buttons available in the staff view

School > Schedule > Master > Sections

Add **Positive Attendance** to your field set:

---

**Note:** This pull-down menu ONLY affects Daily Attendance. Class attendance for any course section can be edited by any one of the students Primary or Secondary schools.
On the Manage Field Sets menu, highlight a field set you wish to use, and either edit that field set, or else make a copy and edit the copy.

In the Schedule Master table, highlight Positive Attendance and click the Add button.

Select the Field Set and Options > Modify List
Check the sections using Positive Attendance and check the green save checkbox at the top of the column.
7.0 Appendix 1: Security Roles for Taking Attendance

To take Attendance, the user will require a security role with Create, Read, Update and Delete permissions on the following tables:

- **Daily** attendance requires this access **Student Attendance** table
- **Class** Attendance requires this access to the **Student Class Attendance** table

School-level staff using the **Staff** view to take attendance will also require:

- *Create* permission on the **Gradebook Access Grant** table
- *Create permission*, and **Gradebook Administrator Access** permission on the **Organization** table

Attendance permissions have been already given to the following Baseline Security Roles:

- Clerical – School Admin Assistant
- Clerical – SIS Admin
- School Administrator
- District Support (Help Desk/Level 1)
- Teacher (**Staff** view for all school types)
8.0 APPENDIX 2: Attendance Codes

Student Attendance codes indicate what type of Attendance Record is created for the student. These six system codes, combined with optional additional settings define the type of attendance record. A Reason code may be assigned to indicate why a student was given the attendance record per school or district policy.

- **A (Absent)** – Absent Excused or Absent Unexcused
  - **Excused** – check the excused checkbox or use the A-E dropdown if available
  - **Unexcused** – leave the checkbox unchecked
- **L (Late)** – Late Excused or Late Unexcused
  - **Excused** – check the **Excused** checkbox
  - **Unexcused** – leave the **Excused** checkbox unchecked
  - **Time In** – place to record the time the student arrived (per school or district policy) defaults to the current time, edit as appropriate
- **D (Dismissal)** – Dismissal Excused and Dismissal Unexcused
  - **Excused** – check the *Excused* checkbox
  - **Unexcused** – leave the *Excused* checkbox unchecked
  - **Time Out** – place to record the time the student left (per school or district policy) defaults to the current time, edit as appropriate
- **AUTH (Authorized)** –
  - **Absent?** – determines if the AUTH code day is counted as an absence for the student in summary counts
    - **Checked** will count as an absence for the student
    - **Unchecked** will not count as an absence for the student
- **ISS (In School Suspension)** – can be applied as a standard attendance entry and is automatically assigned as **ISS – Excused** to a student given an In School Suspension with a date range in the Conduct module. The record can be edited to uncheck the Excused checkbox per school or district policy. See the Conduct Management guide for details.
- **OSS (Out of School Suspension)** can be applied as a standard attendance entry and is automatically assigned as **OSS – Excused** to a student given an Out of School Suspension with a date range in the Conduct module. The record can be edited to uncheck the Excused checkbox per school or district policy. See the Conduct Management guide for details.
9.0 APPENDIX 3: Attendance Reports

9.1 Class Attendance Reports

School > Attendance > Class Office side tabs

- **BC Class Attendance Call Sheet** – a BC report listing students with an Absent (unexcused) attendance record entered on that day, report includes: Name, Grade level, Homeroom, Gender, Attendance Code, and the Name and Phone numbers of the two student contacts with highest priority
  - *Date*
  - *Sort results by* – select Name, Grade Level or Homeroom from the dropdown list
  - *Format* – select the format to print

- **BC Class Attendance Post Verification** – a BC report advising when and if Class attendance was posted by a staff user on the selected date. The report can be run for a selected course section or for a selected teacher.
  - *Start and End Dates* - enter the range of dates to include on the report
  - *Select class* – select a course section from the picklist
  - *Select teacher* – select a teacher from the picklist
  - *Show non-posts only*
    - Check - to only show classes where attendance was not posted
    - Uncheck - to show all classes and if they were posted or not
  - *Sort results by* – Name or Time posted
  - *Format* – select the format to print

- **BC Class Attendance Post History** – a BC report providing a historical record of attendance postings by course section or by teacher
  - *Start and End Dates* - enter the range of dates to include on the report
  - *Select class* – select a course section from the picklist
  - *Select teacher* – select a teacher from the picklist
  - *Sort Results by* – Date, Post Count or Period
  - *Format* – select the format to print

- **BC Homeroom List w. Grid** – a BC report listing students in a course section with fillable column headers in a grid format
  - *Column Labels* – enter the information to print in the Column Headers
  - *Sections to include* – select All or select a Term Code, Course Number, Section, Schedule Expression or Teacher.
  - *Sort results by* - select Course or Teacher
  - *Format* – select the format to print

- **BC Principal’s Attendance Report by Class** – a BC reporting tool allowing schools to review and analyze student Class attendance using a parameter form with multiple criteria. The tool will return a list of students that meet the specified threshold. If the criteria is to include Absences greater than or equal to 3, the report will include students that have 3 or more absences per section, but will return a complete listing of the student’s attendance in their other sections.
Start and End Dates – enter the range of dates to include on the report
Students to include – select All, Current Selection or select a YOG, Snapshot, Course Section, Combined Classes ID, Grade or Student Program
Criteria – enter and combine different criteria to build the report
  • Absence Code – use pre filled values or select a code from the dropdown
  • Reasons – select from the dropdown
  • Operator – select from the dropdown
  • Exclude Excused – check to exclude for each criteria line
  • Connector – select And or Or to combine criteria lines
Sort results by – Name, YOG or Homeroom
Group results by – Homeroom, House Code, Team Code
Format – select the format to print

9.2 Daily Attendance Reports

School > Attendance > Daily side tabs > Reports

• Absence Letter – a core report which identifies students with five or more absences and prepares letters to send to parents. The report is not customizable by number of absences. Parameters that can be selected include:
  • Start and End Dates – enter the range of dates to include on the report
  • Exclude Excused Absences – check to exclude
  • Include students with previous letters home – check to include
  • Alternate mailings – check to send a letter to parent/guardian designated to receive attendance mailing in School > Student > Contacts
  • Sort results by – select Name, YOG or Homeroom from the dropdown list
  • Format – select the format to print

• Attendance Bulletin – a core report listing all students with an attendance record entered that day, report includes: Name, YOG, Homeroom, Absence Code and Time (if entered)
  • Date
  • Sort results by – select Name, YOG or Homeroom from the dropdown list
  • Include secondary students – check to include
  • Format – select the format to print

• BC Daily Attendance Call Sheet – a core report listing students with an attendance record entered on that day, report includes: Name, YOG, Homeroom, Gender, Attendance Code, and the Name and Phone numbers of the two student contacts with highest priority
  • Date
  • Sort results by – select Name, YOG or Homeroom from the dropdown list
  • Format – select the format to print

• Attendance Classroom Input – a core report listing the students in a course section with dates for the week selected as column headers
- **Attendance Homeroom Input** – a core report listing the students in a homeroom with dates for the week selected as column headers
  - **Week of** – select a date to define the date column headers
  - **Students to include** – select: All or select a Teacher or Homeroom
  - **Format** – select the format to print

- **BC Homeroom List w. Desig** – a BC report listing students in a homeroom, based on the parameters selected the report can include: Name, Pupil #, Gender, Grade, Age, Birthday, Student Services Designation and Aboriginal Ancestry indicator
  - **Students to include** – All or select a Homeroom or Grade
  - **Aboriginal Y/N** – check to include the Aboriginal Ancestry column in the report
  - **Include Exceptionality Type** – Defaults to all designations checked
    - **Checked** – an assigned 1701 primary designation program will print
    - **Unchecked** – will not print designations in the column
  - **Sort Results by** – select Name or Grade
  - **Format** – select the format to print

- **BC Homeroom List w. Grid** – a BC report listing students in a homeroom with fillable column headers in a grid format
  - **Column Labels** – enter the information to print in the Column Headers
  - **Students to include** – select All or select a Homeroom or Grade
  - **Sort results by** – select Name or Grade
  - **Format** – select the format to print

- **Consecutive Absence List** – a core report listing students absent for a selected number of days in a row during the specified date range
  - **Start and End Dates** – enter the range of dates to include on the report
  - **Count** – enter the minimum consecutive absence records needed to include the student on the report
  - **Exclude excused** – check to exclude
  - **Sort results by** – select Name, YOG, Homeroom or Count
  - **Include secondary students** – check to include
  - **Format** – select the format to print

- **Daily Attendance Post Verification** – a core report advising when and if Daily attendance was posted by a staff user on the selected date
  - **Date**
  - **Show non-posts only**
    - **Check** - to only show classes where attendance was not posted
    - **Uncheck** - to show all classes and if they were posted or not
  - **Sort results by** – Name or Time posted
  - **Format** – select the format to print

- **Principal’s Attendance** – a core report tool allowing schools to review and analyze student Daily attendance using a parameter form with multiple criteria
  - **Start and End Dates** – enter the range of dates to include on the report
Students to include – select All or select a YOG or Snapshot
Criteria – enter and combine different criteria to build the report
  - Absence Code – use pre filled values or select a code from the dropdown
  - Reasons – select from the dropdown
  - Operator – select from the dropdown
  - Exclude Excused – check to exclude for each criteria line
  - Connector – select And or Or to combine criteria lines

Sort results by – Name, YOG or Homeroom
Group results by – Homeroom, House Code, Team Code
Format – select the format to print

9.3 Staff view Attendance Reports

Staff > Attendance > Reports

- Attendance Bulletin – a core report listing all students with an attendance record entered that day, report includes: Name, YOG, Homeroom, Absence Code and Time (if entered)
  - Date
  - Sort results by – select Name, YOG or Homeroom from the dropdown list
  - Include secondary students – check to include
  - Format – select the format to print

- Attendance Classroom Input – a core report listing the students in a course section with dates for the week selected as column headers
  - Week of – select a date to define the date column headers
  - Students to include – select: All or select a Class, Teacher or Course number
  - Format – select the format to print

- Attendance Homeroom Input – a core report listing the students in a homeroom with dates for the week selected as column headers
  - Week of – select a date to define the date column headers
  - Students to include – select: All or select a Teacher or Homeroom
  - Format – select the format to print

- BC Homeroom List w. Grid – a BC report listing students in a course section with fillable column headers in a grid format
  - Column Labels – enter the information to print in the Column Headers
  - Sections to include – select All or select a Term Code, Course Number, Section, Schedule Expression or Teacher.
  - Sort results by - select Course or Teacher
  - Format – select the format to print

- BC Homeroom List w. Desig – a BC report listing students in a homeroom, based on the parameters selected the report can include: Name, Pupil #, Gender, Grade, Age, Birthday, Student Services Designation and Aboriginal Ancestry indicator
  - Students to include – All or select a Homeroom or Grade
• Aboriginal Y/N – check to include the Aboriginal Ancestry column in the report
• Include Exceptionality Type – Defaults to all designations checked
  ▪ Checked – an assigned 1701 primary designation program will print
  ▪ Unchecked – will not print designations in the column
• Sort Results by – select Name or Grade
• Format – select the format to print

• **Consecutive Absence List** – a core report listing students absent for a selected number of days in a row during the specified date range
  • Start and End Dates – enter the range of dates to include on the report
  • Count – enter the minimum consecutive absence records needed to include the student on the report
  • Exclude excused – check to exclude
  • Sort results by – select Name, YOG, Homeroom or Count
  • Include secondary students – check to include
  • Format – select the format to print

*Staff > Attendance > Class > Details > Input > Reports*

• **Class Attendance Summary** – a summary of the attendance statistics in a course section by student
  • Start and End Dates – enter the range of dates to include on the report
  • Format – select the format to print

• **Class Attendance History** – a listing of the attendance entries for a course section
  • Start and End Dates – enter the range of dates to include on the report
  • Print for – select Current Selection, or All
  • Sort Results by – Name or Date
  • Format – select the format to print

• **StrongStart Attendance Summary** – a BC report listing the students in the course section and the number of POS and Absent entries in the selected date range
  • Start and End Dates – enter the range of dates to include on the report
  • Format – select the format to print