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1.0 Traditional Gradebook  

The focus of this guide is to provide the necessary understanding and requirements for working 
in the Staff View and for setting up the traditional gradebook.  

1.1 Objectives 

¶ Gradebook Preferences 

¶ Linking classes 

¶ Create categories and assignments 

¶ Enter Marks  

¶ Posting Grades 

¶ Optional Tools 

1.2 Areas of Consideration for Gradebook 

Some areas to be considered as they relate to the setup and use of the teacher 
gradebook are worth noting here: 

¶ Will the course transcript definitions be calculated? 

¶ Will teachers be allowed to modify weights? 

¶ Does the district or school require a specific method of gradebook mark calculation? 

¶ Will the district or school be using the student/family portal during the school year? 

¶ Will the district and / or school be providing a comment bank (which teachers to add to)? 

1.3 Resources 

From the Staff View, under all tabs with the exception of the landing page, the Help menu 
provides a variety of resources which follow: 

¶ Online Help - this will scope to the area from which the help was accessed. 

¶ User Guides  

o Staff View Setup and Navigation 
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2.0 Save Functionality 

As with any software, users should ensure that they are saving often to avoid loss of 
work.  Save buttons are available at the top and bottom of screens throughout the application. 

 

2.1 Auto-Save 

In addition to the save buttons, many screens in MyEdBC have an Auto-Save feature.  While 
this is handy functionality, users should not rely on it as a means of saving their work. Regular 
use of the save buttons should ALWAYS be the primary method for saving.  See the separate 
Fundamentals Appendix: Auto-Save Statistics for a list of screens that provide the Auto-Save 
functionality as a back-up measure. 

Note: The auto-save interval (number of minutes before a screen is auto-saved) is determined 
by the user preference settings as outlined in the Preferences - General section above.   

 

2.2 Gradebook and Grade Input Scores Save Functionality 

Staff > Gradebook > Scores 

School > Grades > Grade Input > Input Grid 

The grade entry screens in School and Staff view have a save-as-you-go functionality.  When a 
score is entered and the user moves out of the cell, the message: Saving, Please Waité. 
displays above the score grid and the cell will turn yellow.  The mark column entry is saved 
when both the message and the yellow cell colour have cleared the screen.  To avoid loss of 
work, do not begin entering information into the next cell until both the message and the yellow 
colour are no longer displayed on the screen, indicating the save has completed.  

3.0 School Preferences 

Each school sets basic Gradebook preferences for all teachers in School view > School TT > 
Setup ST > Preferences SST > Grade (Category). These are discussed in detail in the School 
Setup Reference Guide.   
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4.0 User Preferences 

Basic User Preferences are covered in the Fundamentals guide and these should be set prior to 
setting up gradebook settings. These can be found by clicking on the users name > Set 
Preferences. The Gradebook tab, see below, displays a non-categorized version of the 
Gradebook preferences detailed in section 4. 

 

¶ Enable gradebook features:  This MUST be checked or gradebook functions will not 

work. 
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5.0 Setting Gradebook Preferences 

Gradebook Preferences are specific to Gradebook use.  They allow teachers to define the 
behaviour, view and default mark calculations for their gradebook.   

From the Gradebook top tab, click on the gear icon:  

 

Five top tabs define the organizational grouping of the settings: General, Student Information, 
Add Assignments, Missing Assignments and Averages.   

5.1 General  

¶  Shade alternate lines 

¶ Track administrator updates:  A blue exclamation mark appears next to any grades or 

comments changed by an administrator. 

¶ Tab direction:  Down or Across. Which direction should the cursor go when the tab key 

is pressed during grade entry? 

¶ Show studies:  Includes rosters for advisory or study periods - not used in BC at this 

time. 
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¶ Enable gradebook features:  This MUST be checked or gradebook functions will not 

work. 

¶  

¶ Assignment column order:  Ascending displays oldest assignments at left.  

Descending displays most recent assignment at left.  Sequence number displays 

assignments in sequence assigned by the teacher. 

¶ Show points in header:  Displays total points for an assignment in the column header 

¶ Show category names in header:  Displays abbreviated category code in the 

assignment column header. 

¶ Publish assignment statistics:  Pertains to Student/Parent Portal.  If checked, displays 

highest, lowest, and mean scores next to assignments viewed in the portal.  Often 

determined at the district level. 

¶ Anchor averages:  Displays running average for the marking period in the column to 

the right of studentôs names. 

¶ Grade change tracking days: not  used in BC 

5.2 Student Information:  

 

¶ Show Student Alerts:  Displays alert icons next to student names. 

¶ Enable student details: An information icon  next to the student name in the scores 

page provides student contact information. 

¶ Enable student academics: An information icon  next to the student name in the 

scores page provides student academic information.  

¶ Show course selection recommendation:  Displays recommendation column.  

Recommendations pertain to teacher suggestions for course selections in the next year.  

Recommendations can only be made at times set at the school level. Teachers may 

want to leave this box unchecked when not in use. 
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5.3 Add Assignments 

       

¶ Add to all linked classes by default ï When course sections are linked for categories 

and assignments, the add assignment screen will automatically check the box to add the 

assignment to all linked classes on any template where the option exists.  Course 

sections can be deselected if the assignment should not be added to that section. See 

the section Gradebook: Assignments for details. 

5.3.1 Set Assignments for Specific Students 

To apply an assignment to specific students: 

Staff View>Gradebook Top Tab>Assignments Side Tab>Options Add 

¶ Click the óStudentô sub top tab. 

¶ Select the student(s) that will not receive the assignment 

¶ Click Exclude. 

The student(s) will not see the assignment in their To Do widget or on the assignments list in the 
Student portal.  
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On your Scores page, the grading cell for the assignment is grayed out for students that have 
been excluded from the assignment. No mark can be entered. The assignment does not affect 
the student's average; it does not exist for that excluded student.  
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5.4 Missing Assignments 

 

¶ Show missing column - If you create special codes that you enter for missing 

assignments, select this checkbox to view the Missing column on the Scores page.  

For each student, the Missing column includes assignments entered using special 
codes (see section 5.0 Optional Tools below for further information on the use of 
special codes). 

Note: This column is for your eyes only. Students and family members do not see it 
in the portals, and office and administrative staff members do not see it in the 
School or Enterprise views. 

¶ Count empty as missing - If you selected the Show missing column checkbox, select 

this checkbox to count any assignments that were due before today and that you have 

not entered scores for, as missing. 

 

Note: You might want to select this checkbox at the end of a term when you have 

finished entering all assignment scores. Otherwise, the Missing column will include 

scores for assignments you have not graded yet. 

 

¶ Show unscored ï Only used with courses that have a rubric definition assigned to it.  
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5.5 Averages 

 

Default weighting:  This setting is significant as it sets the default mark calculation for the 
gradebook. This setting can be overridden at the course detail level for individual courses.  A 
short explanation of each of the settings is provided below, detailed explanations can be found 
in Appendix A and from online resources. 

¶ Categories only (weighted categories) if you want to weight only the categories in your 

gradebook.   

Assignments are converted to a percentage then averaged within each category. The category 

average is multiplied by the assigned weight, and the weighted category averages are added 

together. 

¶ Category and assignments (weighted) if you want to weight both categories and 

weight the assignments within those categories.  

Assignments are converted to a percentage, multiplied by the assigned weight and a category 

average is calculated. The category average is then multiplied by the assigned weight, and the 

weighted category averages are added together. 

¶ Select Total points if you want the overall value of an assignment to be determined by 

the maximum points possible for the assignment.     

Assignments are not converted to a percentage. The total points a student earns is divided by 

the total number of points possible. 

¶ Select Category total points if you want a category weighted and the value of an 

assignment within a category to be based on the points possible for the assignment.  
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Assignments are not converted to a percentage. Within each category, total points earned are 

divided by total points possible to determine the category average. The category average is 

then multiplied by the assigned weight, and the weighted category averages are added 

together.    

Additional Resources:  

Help > Quick Reference Cards > GradebookðBeginning-of-the-Year Setup 

Help > Videos > Teacher Gradebook > Setting up your Aspen Gradebook > QRG > 
Understanding Averaging Modes. 

¶ Decimals:  Determines how many decimal points to use in calculating grades.  Impacts 

averages in Gradebook only.  Grades posted to transcripts will conform to the district 

defined decimal rules. 

¶ Grade scale: Some districts have uniform grade scales. If not established by the district, 

participants can select a scale from the list viewed by clicking the magnifying glass.  

o Provincial Mark Scale Final assigns numeric value of 25% for letter grade ï F, no 

numeric value for letter grade ïI. 

o Provincial Mark Scale Interim assigns no numeric value for letter grade - F, 

numeric value of 25% for letter grade - I. 

o The IB Grade Scale is for use by authorized IB Schools only. 
o If the district or school permits, teachers can go to the Tools top tab > Grade 

scales side tab > Options > Add to create their own grade scales 

¶ Semester Cumulative Average: Select this checkbox to show semester running 

averages on your Scores page. MyEducation BC calculates semester running averages 

based on the assignment grades within each of the terms inside of it, not on the average 

for each term. 

 

Students and family can view this column in the Student and Family views. 

 

Note: Your school must enable the School Grade preferences (for Show semester 

averages in the gradebook) for this user preference to be activated. School View>School 

Top Tab>Category = Gradebook 

 

MyEducation BC uses the column header Semester # (for example, Semester 1) for 

semester running average columns. 

 

¶ Cumulative Average: Select this checkbox to show an overall course cumulative mark 

calculation when using Total Points averaging mode. Selecting this option along with a 

default weighting of Total Points or Category Total Points produces a total cumulative 

mark calculation. Note: this option is only available if the School > Preferences > 

Grades has Semester Cumulative Average and Overall Cumulative Average 

checked.  
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6.0 Gradebook > Details: Linking Classes, Grade 
Calculation Weights, Categories 

A teacher can link his/her classes allowing them to create categories and assignments for one 
class which automatically add them to other classes linked to it.  

6.1 Class Details 

The class details screen provides the means to link classes and determine settings.  At the 
bottom of the page are expandable sections for linked classes, categories, drop mode and 
grade calculation weights. 

 

¶ In the Average Mode dropdown, teachers can override the averaging method they 

selected in Preferences. 

¶ Averages Grade Scale can be changed from the default preference setting. 

¶ Portal Notes allows the teacher to enter a comment about the class that will appear in 

the Student and Family portals. 

¶ Expand the Drop mode at the bottom of the screen, do one of the following to determine 

if you want to drop the lowest scores for this class: 

Select Do not drop scores if you do not want the system to drop any scores for this class. 

Select Drop lowest overall score if you want the system to drop the lowest score(s) for a term.  

Select Drop lowest score by category if you want to determine how many scores to drop each 

term by assignment category. For example, you might drop the two lowest homework scores 

each term. To do so, type the number in the # to drop column for each category, for each term. 

Note: Error Message ñThis gradebook section is shared with other teachersò.  This error 
message will display when one or more teachers share a course section and the Averages user 
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preference is set to óGradebook Defaultô.  When a course section is shared, both teachers must 
determine and select the same Averages settings in the course details.  

 

6.2 Classes Linked for Assignments and Categories 

¶ Go to Gradebook top tab > Select a class > Details side tab 

¶ Review the information on the Details screen for the class selected. 

¶ At the bottom of the screen, expand the section Classes linked for assignments and 

categories, click the Select button and select sections that are the same as the class 

you are viewing, and click OK.  

¶ If you create assignment categories on the Class Details page and you have linked 

sections, the field Also add to linked sections? is enabled by default. The new 

category will be applied to all of your linked sections, unless you deselect the field. If you 

do not have linked sections, the Add to all sections? field appears.  

¶ It is not enabled by default, but you can select it to apply the new category to other class 

sections.  
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¶ Staff view, Gradebook > Categories 

¶ If you create categories using the Categories side-tab and you have linked sections, the 

new Add category field is enabled by default. The new category will be applied to all 

linked sections. If you do not want the category to be applied to a section, deselect the 

checkbox next to it. If you do not have linked sections, click Add category to add the 

category to all of your sections, or just select the checkboxes next to the sections it will 

apply to.  

  

¶ Enter a name for the group of linked classes. Click Save.  

Linking classes enables the teacher to enter information for categories and assignments just 
once for each course.  MyEducation BC will duplicate the categories and assignments for 
each of the linked classes. 
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Note: Creating assignments for linked classes does not adjust dates or grade terms. Multi 
Add assignments creates assignments for one course section at a time, even when 
sections are linked. 
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6.3 Grade Calculation Weights 

If the Grade Category in School Preferences is set to Allow editing of term weights by staff, 
courses set up with calculated transcript definitions can be adjusted by teachers. 

From the course details screen in the gradebook, in the lower block of the window teachers can 
change the calculation of the final mark by adjusting the weightings of the terms and/or exams. 

 

 

Note: School View > Grades > Grade Post Controls must have the dates for the final 
grade term ñopenò for weights to be adjusted.  

 

In summary, three conditions must be met in order for teachers to be able to adjust term 
weights: 

1. Grade preferences are set to ñAllow editing of term weights by staffò in the School 

view. 

2. Grade Post Controls must be open for weights to be adjusted. 

3. The transcript definition associated with the course must be one of the ones which are 

set up to be calculated. 
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6.4 Create Categories 

Categories group the learning tasks that teachers will use in student assessment. The QRC 
Advanced Gradebook, in the online Help, is an excellent resource for step-by-step instructions. 
Defaults selected when creating categories can be overridden for individual assignments within 
the category.   

¶ Go to Gradebook top tab > Select a class > expand the Categories section, or use the 

Gradebook top tab > Select a class > Categories side tab 

¶ Any existing categories for the class are displayed on the screen. 

 

¶ Go to the Add button to create additional categories. Note that if the course is linked to 

another, this will also add categories to the linked course sections. 

 

 


